efi-rpm-macros/0001-Add-riscv64-to-efi.patch

40 lines
997 B
Diff

From 3c38c71252d53ad29827b0b8700633b7d3c4e0c6 Mon Sep 17 00:00:00 2001
From: rpm-build <rpm-build>
Date: Thu, 21 Mar 2024 15:55:34 +0000
Subject: [PATCH] Add riscv64 to efi
---
Makefile | 2 +-
macros.efi-srpm.in | 2 ++
2 files changed, 3 insertions(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index 37e97a5..166ee97 100644
--- a/Makefile
+++ b/Makefile
@@ -14,7 +14,7 @@ override EFI_ESP_ROOT=/boot/efi
endif
EFI_ARCHES ?= $(call get-config,arches)
ifeq ($(EFI_ARCHES),)
-override EFI_ARCHES="x86_64 aarch64 %{arm} %{ix86}"
+override EFI_ARCHES="x86_64 aarch64 %{arm} %{ix86} riscv64"
endif
EFI_VENDOR ?= $(call get-config,vendor)
diff --git a/macros.efi-srpm.in b/macros.efi-srpm.in
index 00503f1..7f258c7 100644
--- a/macros.efi-srpm.in
+++ b/macros.efi-srpm.in
@@ -37,6 +37,8 @@
return("aa64")
elseif arch("%{arm}") then
return("arm")
+ elseif arch("riscv64") then
+ return("riscv64")
else
return("none")
end
--
2.44.0