Add riscv64 to EFI list

Signed-off-by: David Abdurachmanov <david.abdurachmanov@gmail.com>
This commit is contained in:
David Abdurachmanov 2018-05-05 19:08:47 +02:00
parent 4532585c24
commit fb28875ed5
2 changed files with 31 additions and 1 deletions

View File

@ -0,0 +1,26 @@
diff --git a/Makefile b/Makefile
index a3e20ec..39a1278 100644
--- a/Makefile
+++ b/Makefile
@@ -15,7 +15,7 @@ $(error rpm macro directory could not be found)
endif
EFI_ESP_ROOT ?= /boot/efi
-EFI_ARCHES ?= x86_64 aarch64 %{arm} %{ix86}
+EFI_ARCHES ?= x86_64 aarch64 %{arm} %{ix86} riscv64
EFI_VENDOR ?=
# TARGETS = macros.efi macros.efi-srpm efi-rpm-macros.spec
diff --git a/macros.efi-srpm.in b/macros.efi-srpm.in
index f3b4c68..fb2ccba 100644
--- a/macros.efi-srpm.in
+++ b/macros.efi-srpm.in
@@ -37,6 +37,8 @@
return("aa64")
elseif arch("%{arm}") then
return("arm")
+ elseif arch("riscv64") then
+ return("rv64")
else
return("none")
end

View File

@ -1,7 +1,7 @@
Summary: Common RPM Macros for building EFI-related packages
Name: efi-rpm-macros
Version: 3
Release: 2%{?dist}
Release: 2.0.riscv64%{?dist}
Group: Development/System
License: GPLv3+
URL: https://github.com/rhboot/%{name}/
@ -10,6 +10,7 @@ BuildArch: noarch
Source0: https://github.com/rhboot/%{name}/releases/download/%{version}/%{name}-%{version}.tar.bz2
Patch0001: 0001-macros.efi-srpm-make-all-of-our-macros-always-expand.patch
Patch0100: efi-rpm-macros-add-riscv64.patch
%global debug_package %{nil}
%global _efi_vendor_ %(eval sed -n -e 's/rhel/redhat/' -e 's/^ID=//p' /etc/os-release)
@ -65,6 +66,9 @@ machine bootloaders and tools.
%dir /boot/efi/EFI/%{_efi_vendor_}
%changelog
* Sat May 05 2018 David Abdurachmanov <david.abdurachmanov@gmail.com> - 3-2.0.riscv64
- Add riscv64
* Fri May 04 2018 Peter Jones <pjones@redhat.com> - 3-2
- Always provide macros for efi_arch and efi_alt_arch (and their _upper
variants), and make efi_has_arch and efi_has_alt_arch 0 when they will be