Add riscv64

Signed-off-by: David Abdurachmanov <davidlt@rivosinc.com>
This commit is contained in:
David Abdurachmanov 2022-11-23 15:53:23 +02:00
parent a22143a21e
commit b81850c468
Signed by: davidlt
GPG Key ID: 8B7F1DA0E2C9FDBB
2 changed files with 45 additions and 2 deletions

View File

@ -0,0 +1,39 @@
diff --git a/Makefile b/Makefile
index 7d56eae..221c46d 100644
--- a/Makefile
+++ b/Makefile
@@ -14,7 +14,7 @@ override EFI_ESP_ROOT=/boot/efi
endif
EFI_ARCHES ?= $(call get-config,arches)
ifeq ($(EFI_ARCHES),)
-override EFI_ARCHES="x86_64 aarch64 %{arm} %{ix86}"
+override EFI_ARCHES="x86_64 aarch64 %{arm} %{ix86} riscv64"
endif
EFI_VENDOR ?= $(call get-config,vendor)
diff --git a/efi-rpm-macros.spec.in b/efi-rpm-macros.spec.in
index a9aaf6d..d36a8d5 100644
--- a/efi-rpm-macros.spec.in
+++ b/efi-rpm-macros.spec.in
@@ -39,7 +39,7 @@ machine bootloaders and tools.
%autosetup -S git -n %{name}-@@EFI_SOURCE_VERSION@@
git config --local --add efi.vendor "%{_efi_vendor_}"
git config --local --add efi.esp-root /boot/efi
-git config --local --add efi.arches "x86_64 aarch64 %{arm} %{ix86}"
+git config --local --add efi.arches "x86_64 aarch64 %{arm} %{ix86} riscv64"
%build
%make_build clean all
diff --git a/macros.efi-srpm.in b/macros.efi-srpm.in
index 00503f1..7f258c7 100644
--- a/macros.efi-srpm.in
+++ b/macros.efi-srpm.in
@@ -37,6 +37,8 @@
return("aa64")
elseif arch("%{arm}") then
return("arm")
+ elseif arch("riscv64") then
+ return("riscv64")
else
return("none")
end

View File

@ -1,7 +1,7 @@
Summary: Common RPM Macros for building EFI-related packages
Name: efi-rpm-macros
Version: 5
Release: 6%{?dist}
Release: 6.0.riscv64%{?dist}
License: GPLv3+
URL: https://github.com/rhboot/%{name}/
BuildRequires: git sed
@ -11,6 +11,7 @@ BuildArch: noarch
Source0: https://github.com/rhboot/%{name}/releases/download/%{version}/%{name}-5.tar.bz2
Patch0001: 0001-Don-t-have-arm-as-an-alt-arch-of-aarch64.patch
Patch0002: efi-rpm-macros-4-riscv64.patch
%global debug_package %{nil}
%global _efi_vendor_ %(eval echo $(sed -n -e 's/rhel/redhat/' -e 's/^ID=//p' /etc/os-release))
@ -39,7 +40,7 @@ machine bootloaders and tools.
%autosetup -S git_am -n %{name}-5
git config --local --add efi.vendor "%{_efi_vendor_}"
git config --local --add efi.esp-root /boot/efi
git config --local --add efi.arches "x86_64 aarch64 %{arm} %{ix86}"
git config --local --add efi.arches "x86_64 aarch64 %{arm} %{ix86} riscv64"
%build
%make_build clean all
@ -68,6 +69,9 @@ git config --local --add efi.arches "x86_64 aarch64 %{arm} %{ix86}"
%dir /boot/efi/EFI/%{_efi_vendor_}
%changelog
* Wed Nov 23 2022 David Abdurachmanov <davidlt@rivosinc.com> - 5-6.0.riscv64
- Add riscv64
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 5-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild