Bump to release 4:

- macros.efi-srpm: make all of our macros always expandable, even if wrong
- Sort .gitignore better.
- Add %{efi_build_requires}
- Give it the get-config treatment.
- Add .spec gunk for pre-releases
- Add brp-boot-efi-times to make sure ESP files don't have odd timestamps.

Signed-off-by: Peter Jones <pjones@redhat.com>
This commit is contained in:
Peter Jones 2018-09-26 14:15:43 -04:00
parent 1afd76446e
commit 241577e3b8
3 changed files with 16 additions and 82 deletions

View File

@ -1,74 +0,0 @@
From 29e47cd8011b1569c4a73c8e395c7fb5192e6dc1 Mon Sep 17 00:00:00 2001
From: Peter Jones <pjones@redhat.com>
Date: Fri, 4 May 2018 15:02:14 -0400
Subject: [PATCH] macros.efi-srpm: make all of our macros always expandable,
even if wrong
In particular, arch and altarch give "none", and when they do efi_has_arch
and efi_has_alt_arch are 0 (respectively). if they're correct, they'll
be 1.
Signed-off-by: Peter Jones <pjones@redhat.com>
---
macros.efi-srpm.in | 17 ++++++++++++-----
1 file changed, 12 insertions(+), 5 deletions(-)
diff --git a/macros.efi-srpm.in b/macros.efi-srpm.in
index 5f8a784af8a..f3b4c68b2f9 100644
--- a/macros.efi-srpm.in
+++ b/macros.efi-srpm.in
@@ -38,7 +38,7 @@
elseif arch("%{arm}") then
return("arm")
else
- return("")
+ return("none")
end
end
-- alt arch
@@ -46,24 +46,30 @@
if arch("x86_64") then
return("ia32")
else
- return(nil)
+ return("none")
end
end
-- make some macros
local done = rpm.expand("%{?_efi}")
if done == nil or done == "" then
+ local arch = getarch()
local alt = getaltarch()
print("%global _efi @@EFI_ARCHES@@\\n")
print("%global _efi_vendor @@EFI_VENDOR@@\\n")
+ if arch == "none" then
+ print("%global _efi_has_arch 0\\n")
+ else
+ print("%global _efi_has_arch 1\\n")
+ end
print("%global _efi_arch " .. getarch() .. "\\n")
print("%global _efi_arch_upper " .. string.upper(getarch()) .. "\\n")
- if alt == nil then
+ if alt == "none" then
print("%global _efi_has_alt_arch 0\\n")
else
print("%global _efi_has_alt_arch 1\\n")
- print("%global _efi_alt_arch " .. alt .. "\\n")
- print("%global _efi_alt_arch_upper " .. string.upper(alt) .. "\\n")
end
+ print("%global _efi_alt_arch " .. alt .. "\\n")
+ print("%global _efi_alt_arch_upper " .. string.upper(alt) .. "\\n")
end
}}
@@ -79,6 +85,7 @@
%efi_arch %{expand:%{_efi_srpm_macros_setup}}%{_efi_arch}
%efi_arch_upper %{expand:%{_efi_srpm_macros_setup}}%{_efi_arch_upper}
+%efi_has_arch %{expand:%{_efi_srpm_macros_setup}}0%{_efi_has_arch}
%efi_has_alt_arch %{expand:%{_efi_srpm_macros_setup}}0%{_efi_has_alt_arch}
%efi_alt_arch %{expand:%{_efi_srpm_macros_setup}}%{?_efi_alt_arch}%{nil}
%efi_alt_arch_upper %{expand:%{_efi_srpm_macros_setup}}%{?_efi_alt_arch_upper}%{nil}
--
2.14.3

View File

@ -1,15 +1,14 @@
Summary: Common RPM Macros for building EFI-related packages
Name: efi-rpm-macros
Version: 3
Release: 3%{?dist}
Version: 4
Release: 1%{?dist}
Group: Development/System
License: GPLv3+
URL: https://github.com/rhboot/%{name}/
BuildRequires: git sed
BuildArch: noarch
Source0: https://github.com/rhboot/%{name}/releases/download/%{version}/%{name}-%{version}.tar.bz2
Patch0001: 0001-macros.efi-srpm-make-all-of-our-macros-always-expand.patch
Source0: https://github.com/rhboot/%{name}/releases/download/%{version}/%{name}-4.tar.bz2
%global debug_package %{nil}
%global _efi_vendor_ %(eval echo $(sed -n -e 's/rhel/redhat/' -e 's/^ID=//p' /etc/os-release))
@ -37,13 +36,16 @@ The efi-filesystem package contains the basic directory layout for EFI
machine bootloaders and tools.
%prep
%autosetup -S git
%autosetup -S git -n %{name}-4
git config --local --add efi.vendor "%{_efi_vendor_}"
git config --local --add efi.esp-root /boot/efi
git config --local --add efi.arches "x86_64 aarch64 %{arm} %{ix86}"
%build
%make_build EFI_VENDOR=%{_efi_vendor_} clean all
%make_build clean all
%install
%make_install EFI_VENDOR=%{_efi_vendor_}
%make_install
#%%files
#%%{!?_licensedir:%%global license %%%%doc}
@ -56,6 +58,7 @@ machine bootloaders and tools.
%license LICENSE
%doc README
%{_rpmmacrodir}/macros.efi-srpm
%{_rpmconfigdir}/brp-boot-efi-times
%files -n efi-filesystem
%defattr(0700,root,root,-)
@ -65,6 +68,9 @@ machine bootloaders and tools.
%dir /boot/efi/EFI/%{_efi_vendor_}
%changelog
* Wed Sep 26 2018 Peter Jones <pjones@redhat.com> - 4-1
- Provide %%{efi_build_requires} and brp-boot-efi-times
* Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
@ -93,6 +99,8 @@ machine bootloaders and tools.
* Tue May 01 2018 Peter Jones <pjones@redhat.com> - 2-2
- Fix the non-efi and non-efi-alt-arch cases, hopefully.
- Make efi-*-macros packages not be ExclusiveArch, because they need to work
in non-efi-arch packages.
* Tue May 01 2018 Peter Jones <pjones@redhat.com> - 2-1
- Lots of rpmlint fixups and the like.

View File

@ -1 +1 @@
SHA512 (efi-rpm-macros-3.tar.bz2) = 0fba0b2e9d08f4da28eb3305f82a02e5d1787800c9e5dee8e78add3572935f80bf823318495763b126e8d79c927913ae4e9087533011032cd13175ed09955ac6
SHA512 (efi-rpm-macros-4.tar.bz2) = 0c580902ec053d3bac167086a70fefd5785ddfd93873a48bb7801ab287b2b7af9db325a1f6e3609ad996656cfff713f741f911d012e89b48250ae108fedb789c