41 lines
2.1 KiB
Diff
41 lines
2.1 KiB
Diff
From 0af592dfa9a6d1a3379db1331344f411f7774bea Mon Sep 17 00:00:00 2001
|
|
From: Laszlo Ersek <lersek@redhat.com>
|
|
Date: Wed, 25 Jul 2018 22:40:09 +0200
|
|
Subject: [PATCH] BaseTools/header.makefile: remove "-c" from BUILD_CFLAGS
|
|
|
|
Option "-c" is a mode selection flag (choosing between compiling and
|
|
linking); it should not be in BUILD_CFLAGS, which applies only to
|
|
compiling anyway. The compilation rule for C source files, in
|
|
"footer.makefile", already includes "-c" -- currently we have double "-c"
|
|
options.
|
|
|
|
This patch doesn't change behavior.
|
|
|
|
Cc: Liming Gao <liming.gao@intel.com>
|
|
Cc: Yonghong Zhu <yonghong.zhu@intel.com>
|
|
Ref: https://bugzilla.redhat.com/show_bug.cgi?id=1540244
|
|
Contributed-under: TianoCore Contribution Agreement 1.1
|
|
Signed-off-by: Laszlo Ersek <lersek@redhat.com>
|
|
Reviewed-by: Liming Gao <liming.gao@intel.com>
|
|
(cherry picked from commit 03252ae287c4a61983b3793ff71baeabe2ff3df7)
|
|
---
|
|
BaseTools/Source/C/Makefiles/header.makefile | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/BaseTools/Source/C/Makefiles/header.makefile b/BaseTools/Source/C/Makefiles/header.makefile
|
|
index db436773cf..08421ba24c 100644
|
|
--- a/BaseTools/Source/C/Makefiles/header.makefile
|
|
+++ b/BaseTools/Source/C/Makefiles/header.makefile
|
|
@@ -71,9 +71,9 @@ INCLUDE = $(TOOL_INCLUDE) -I $(MAKEROOT) -I $(MAKEROOT)/Include/Common -I $(MAKE
|
|
BUILD_CPPFLAGS = $(INCLUDE) -O2
|
|
ifeq ($(DARWIN),Darwin)
|
|
# assume clang or clang compatible flags on OS X
|
|
-BUILD_CFLAGS = -MD -fshort-wchar -fno-strict-aliasing -Wall -Werror -Wno-deprecated-declarations -Wno-self-assign -Wno-unused-result -nostdlib -c -g
|
|
+BUILD_CFLAGS = -MD -fshort-wchar -fno-strict-aliasing -Wall -Werror -Wno-deprecated-declarations -Wno-self-assign -Wno-unused-result -nostdlib -g
|
|
else
|
|
-BUILD_CFLAGS = -MD -fshort-wchar -fno-strict-aliasing -Wall -Werror -Wno-deprecated-declarations -Wno-stringop-truncation -Wno-restrict -Wno-unused-result -nostdlib -c -g
|
|
+BUILD_CFLAGS = -MD -fshort-wchar -fno-strict-aliasing -Wall -Werror -Wno-deprecated-declarations -Wno-stringop-truncation -Wno-restrict -Wno-unused-result -nostdlib -g
|
|
endif
|
|
BUILD_LFLAGS =
|
|
BUILD_CXXFLAGS = -Wno-unused-result
|