diff --git a/eclipse-add-ppc64-sparc64-s390-s390x.patch b/eclipse-add-ppc64-sparc64-s390-s390x.patch
index eec19aa..e24cf2e 100644
--- a/eclipse-add-ppc64-sparc64-s390-s390x.patch
+++ b/eclipse-add-ppc64-sparc64-s390-s390x.patch
@@ -1,11 +1,99 @@
-Index: src/org/eclipse/core/runtime/Platform.java
-===================================================================
-RCS file: /cvsroot/eclipse/org.eclipse.core.runtime/src/org/eclipse/core/runtime/Platform.java,v
-retrieving revision 1.106
-diff -u -r1.106 Platform.java
---- plugins/org.eclipse.core.runtime/src/org/eclipse/core/runtime/Platform.java 13 Apr 2006 00:42:47 -0000 1.106
-+++ plugins/org.eclipse.core.runtime/src/org/eclipse/core/runtime/Platform.java 31 Jan 2007 21:33:51 -0000
-@@ -339,6 +339,11 @@
+diff -ru eclipse-3.3-src.orig/features/org.eclipse.platform.source/feature.xml eclipse-3.3-src/features/org.eclipse.platform.source/feature.xml
+--- eclipse-3.3-src.orig/features/org.eclipse.platform.source/feature.xml 2007-06-25 15:39:41.000000000 -0400
++++ eclipse-3.3-src/features/org.eclipse.platform.source/feature.xml 2007-07-16 16:08:02.000000000 -0400
+@@ -42,4 +42,7 @@
+
+
+
++
++
++
+
+diff -ru eclipse-3.3-src.orig/features/org.eclipse.rcp/feature.xml eclipse-3.3-src/features/org.eclipse.rcp/feature.xml
+--- eclipse-3.3-src.orig/features/org.eclipse.rcp/feature.xml 2007-06-25 15:57:06.000000000 -0400
++++ eclipse-3.3-src/features/org.eclipse.rcp/feature.xml 2007-07-16 16:10:09.000000000 -0400
+@@ -506,4 +506,48 @@
+ version="0.0.0"
+ fragment="true"
+ unpack="true"/>
++
++
++
++
++
++
++
++
+
+Only in eclipse-3.3-src/features/org.eclipse.rcp: feature.xml.orig
+diff -ru eclipse-3.3-src.orig/features/org.eclipse.rcp.source/feature.xml eclipse-3.3-src/features/org.eclipse.rcp.source/feature.xml
+--- eclipse-3.3-src.orig/features/org.eclipse.rcp.source/feature.xml 2007-06-25 15:39:41.000000000 -0400
++++ eclipse-3.3-src/features/org.eclipse.rcp.source/feature.xml 2007-07-16 16:08:02.000000000 -0400
+@@ -30,4 +30,8 @@
+
+
+
++
++
++
++
+
+diff -ru eclipse-3.3-src.orig/plugins/org.eclipse.core.runtime/src/org/eclipse/core/internal/runtime/InternalPlatform.java eclipse-3.3-src/plugins/org.eclipse.core.runtime/src/org/eclipse/core/internal/runtime/InternalPlatform.java
+--- eclipse-3.3-src.orig/plugins/org.eclipse.core.runtime/src/org/eclipse/core/internal/runtime/InternalPlatform.java 2007-06-25 15:57:02.000000000 -0400
++++ eclipse-3.3-src/plugins/org.eclipse.core.runtime/src/org/eclipse/core/internal/runtime/InternalPlatform.java 2007-07-16 16:08:02.000000000 -0400
+@@ -47,6 +47,11 @@
+ Platform.ARCH_X86, //
+ Platform.ARCH_AMD64, //
+ Platform.ARCH_IA64, //
++ Platform.ARCH_PPC64, //
++ Platform.ARCH_SPARC64, //
++ Platform.ARCH_S390, //
++ Platform.ARCH_S390X, //
++ Platform.ARCH_ALPHA, //
+ Platform.ARCH_IA64_32};
+
+ // debug support: set in loadOptions()
+Only in eclipse-3.3-src/plugins/org.eclipse.core.runtime/src/org/eclipse/core/internal/runtime: InternalPlatform.java.orig
+diff -ru eclipse-3.3-src.orig/plugins/org.eclipse.core.runtime/src/org/eclipse/core/runtime/Platform.java eclipse-3.3-src/plugins/org.eclipse.core.runtime/src/org/eclipse/core/runtime/Platform.java
+--- eclipse-3.3-src.orig/plugins/org.eclipse.core.runtime/src/org/eclipse/core/runtime/Platform.java 2007-06-25 15:57:18.000000000 -0400
++++ eclipse-3.3-src/plugins/org.eclipse.core.runtime/src/org/eclipse/core/runtime/Platform.java 2007-07-16 16:08:02.000000000 -0400
+@@ -346,6 +346,12 @@
* @since 3.1
*/
public static final String ARCH_IA64_32 = "ia64_32";//$NON-NLS-1$
@@ -14,51 +102,27 @@ diff -u -r1.106 Platform.java
+ public static final String ARCH_SPARC64 = "sparc64";//$NON-NLS-1$
+ public static final String ARCH_S390 = "s390";//$NON-NLS-1$
+ public static final String ARCH_S390X = "s390x";//$NON-NLS-1$
++ public static final String ARCH_ALPHA = "alpha";//$NON-NLS-1$
/**
* Constant string (value "win32") indicating the platform is running on a
-Index: src/org/eclipse/core/internal/runtime/InternalPlatform.java
-===================================================================
-RCS file: /cvsroot/eclipse/org.eclipse.core.runtime/src/org/eclipse/core/internal/runtime/InternalPlatform.java,v
-retrieving revision 1.253
-diff -u -r1.253 InternalPlatform.java
---- plugins/org.eclipse.core.runtime/src/org/eclipse/core/internal/runtime/InternalPlatform.java 21 Apr 2006 20:49:57 -0000 1.253
-+++ plugins/org.eclipse.core.runtime/src/org/eclipse/core/internal/runtime/InternalPlatform.java 31 Jan 2007 21:33:50 -0000
-@@ -52,6 +52,10 @@
- Platform.ARCH_X86, //
- Platform.ARCH_AMD64, //
- Platform.ARCH_IA64, //
-+ Platform.ARCH_PPC64, //
-+ Platform.ARCH_SPARC64, //
-+ Platform.ARCH_S390, //
-+ Platform.ARCH_S390X, //
- Platform.ARCH_IA64_32};
- private static final String BOOT = "-boot"; //$NON-NLS-1$
- private static final String CLASSLOADER_PROPERTIES = "-classloaderProperties"; //$NON-NLS-1$
-Index: eclipseAdaptor/src/org/eclipse/core/runtime/internal/adaptor/PluginConverterImpl.java
-===================================================================
-RCS file: /cvsroot/eclipse/org.eclipse.osgi/eclipseAdaptor/src/org/eclipse/core/runtime/internal/adaptor/PluginConverterImpl.java,v
-retrieving revision 1.13
-diff -u -r1.13 PluginConverterImpl.java
---- plugins/org.eclipse.osgi/eclipseAdaptor/src/org/eclipse/core/runtime/internal/adaptor/PluginConverterImpl.java 13 Apr 2006 16:10:27 -0000 1.13
-+++ plugins/org.eclipse.osgi/eclipseAdaptor/src/org/eclipse/core/runtime/internal/adaptor/PluginConverterImpl.java 31 Jan 2007 21:33:52 -0000
+Only in eclipse-3.3-src/plugins/org.eclipse.core.runtime/src/org/eclipse/core/runtime: Platform.java.orig
+diff -ru eclipse-3.3-src.orig/plugins/org.eclipse.osgi/eclipseAdaptor/src/org/eclipse/core/runtime/internal/adaptor/PluginConverterImpl.java eclipse-3.3-src/plugins/org.eclipse.osgi/eclipseAdaptor/src/org/eclipse/core/runtime/internal/adaptor/PluginConverterImpl.java
+--- eclipse-3.3-src.orig/plugins/org.eclipse.osgi/eclipseAdaptor/src/org/eclipse/core/runtime/internal/adaptor/PluginConverterImpl.java 2007-06-25 15:57:06.000000000 -0400
++++ eclipse-3.3-src/plugins/org.eclipse.osgi/eclipseAdaptor/src/org/eclipse/core/runtime/internal/adaptor/PluginConverterImpl.java 2007-07-16 16:08:02.000000000 -0400
@@ -64,7 +64,7 @@
private static final String MANIFEST_VERSION = "Manifest-Version"; //$NON-NLS-1$
private static final String PLUGIN_PROPERTIES_FILENAME = "plugin"; //$NON-NLS-1$
private static PluginConverterImpl instance;
- private static final String[] ARCH_LIST = {org.eclipse.osgi.service.environment.Constants.ARCH_PA_RISC, org.eclipse.osgi.service.environment.Constants.ARCH_PPC, org.eclipse.osgi.service.environment.Constants.ARCH_SPARC, org.eclipse.osgi.service.environment.Constants.ARCH_X86, org.eclipse.osgi.service.environment.Constants.ARCH_AMD64, org.eclipse.osgi.service.environment.Constants.ARCH_IA64};
-+ private static final String[] ARCH_LIST = {org.eclipse.osgi.service.environment.Constants.ARCH_PA_RISC, org.eclipse.osgi.service.environment.Constants.ARCH_PPC, org.eclipse.osgi.service.environment.Constants.ARCH_SPARC, org.eclipse.osgi.service.environment.Constants.ARCH_X86, org.eclipse.osgi.service.environment.Constants.ARCH_AMD64, org.eclipse.osgi.service.environment.Constants.ARCH_IA64, org.eclipse.osgi.service.environment.Constants.ARCH_PPC64, org.eclipse.osgi.service.environment.Constants.ARCH_SPARC64, org.eclipse.osgi.service.environment.Constants.ARCH_S390, org.eclipse.osgi.service.environment.Constants.ARCH_S390X};
++ private static final String[] ARCH_LIST = {org.eclipse.osgi.service.environment.Constants.ARCH_PA_RISC, org.eclipse.osgi.service.environment.Constants.ARCH_PPC, org.eclipse.osgi.service.environment.Constants.ARCH_SPARC, org.eclipse.osgi.service.environment.Constants.ARCH_X86, org.eclipse.osgi.service.environment.Constants.ARCH_AMD64, org.eclipse.osgi.service.environment.Constants.ARCH_IA64, org.eclipse.osgi.service.environment.Constants.ARCH_PPC64, org.eclipse.osgi.service.environment.Constants.ARCH_SPARC64, org.eclipse.osgi.service.environment.Constants.ARCH_S390, org.eclipse.osgi.service.environment.Constants.ARCH_S390X, org.eclipse.osgi.service.environment.Constants.ARCH_ALPHA};
static public final String FRAGMENT_MANIFEST = "fragment.xml"; //$NON-NLS-1$
static public final String GENERATED_FROM = "Generated-from"; //$NON-NLS-1$
static public final String MANIFEST_TYPE_ATTRIBUTE = "type"; //$NON-NLS-1$
-Index: eclipseAdaptor/src/org/eclipse/osgi/service/environment/Constants.java
-===================================================================
-RCS file: /cvsroot/eclipse/org.eclipse.osgi/eclipseAdaptor/src/org/eclipse/osgi/service/environment/Constants.java,v
-retrieving revision 1.9
-diff -u -r1.9 Constants.java
---- plugins/org.eclipse.osgi/eclipseAdaptor/src/org/eclipse/osgi/service/environment/Constants.java 13 Jun 2005 17:14:22 -0000 1.9
-+++ plugins/org.eclipse.osgi/eclipseAdaptor/src/org/eclipse/osgi/service/environment/Constants.java 31 Jan 2007 21:33:52 -0000
-@@ -119,6 +119,11 @@
+diff -ru eclipse-3.3-src.orig/plugins/org.eclipse.osgi/eclipseAdaptor/src/org/eclipse/osgi/service/environment/Constants.java eclipse-3.3-src/plugins/org.eclipse.osgi/eclipseAdaptor/src/org/eclipse/osgi/service/environment/Constants.java
+--- eclipse-3.3-src.orig/plugins/org.eclipse.osgi/eclipseAdaptor/src/org/eclipse/osgi/service/environment/Constants.java 2007-06-25 15:57:02.000000000 -0400
++++ eclipse-3.3-src/plugins/org.eclipse.osgi/eclipseAdaptor/src/org/eclipse/osgi/service/environment/Constants.java 2007-07-16 16:08:02.000000000 -0400
+@@ -119,6 +119,12 @@
*/
public static final String ARCH_IA64_32 = "ia64_32";//$NON-NLS-1$
@@ -66,74 +130,8 @@ diff -u -r1.9 Constants.java
+ public static final String ARCH_SPARC64 = "sparc64";//$NON-NLS-1$
+ public static final String ARCH_S390 = "s390";//$NON-NLS-1$
+ public static final String ARCH_S390X = "s390x";//$NON-NLS-1$
++ public static final String ARCH_ALPHA = "alpha";//$NON-NLS-1$
+
/**
* Constant string (value "win32") indicating the platform is running on a
* machine using the Windows windowing system.
-Index: feature.xml
-===================================================================
-RCS file: /cvsroot/eclipse/org.eclipse.sdk-feature/features/org.eclipse.rcp/feature.xml,v
-retrieving revision 1.40.2.1
-diff -u -r1.40.2.1 feature.xml
---- features/org.eclipse.rcp/feature.xml 1 Aug 2006 17:29:33 -0000 1.40.2.1
-+++ features/org.eclipse.rcp/feature.xml 6 Feb 2007 23:44:22 -0000
-@@ -308,5 +308,38 @@
- install-size="0"
- version="0.0.0"
- unpack="false"/>
-+
-+
-+
-+
-+
-+
-
-
-diff -ru features/org.eclipse.platform.source/feature.xml features/org.eclipse.platform.source/feature.xml
---- features/org.eclipse.platform.source/feature.xml 2007-02-06 19:04:05.000000000 -0500
-+++ features/org.eclipse.platform.source/feature.xml 2007-02-06 19:07:26.000000000 -0500
-@@ -42,4 +42,6 @@
-
-
-
-+
-+
-
-diff -ru features/org.eclipse.rcp.source/feature.xml features/org.eclipse.rcp.source/feature.xml
---- features/org.eclipse.rcp.source/feature.xml 2007-02-06 19:04:06.000000000 -0500
-+++ features/org.eclipse.rcp.source/feature.xml 2007-02-06 19:09:11.000000000 -0500
-@@ -30,4 +30,7 @@
-
-
-
-+
-+
-+
-
diff --git a/eclipse.spec b/eclipse.spec
index 1e9d759..faea171 100644
--- a/eclipse.spec
+++ b/eclipse.spec
@@ -562,9 +562,9 @@ sed --in-place "s|\(initialValue = request.getDefaultValue\)|// \1|" \
sed --in-place "s|\(value = fRequest.getDefaultValue\)|// \1|" \
plugins/org.eclipse.ant.ui/Remote\ Ant\ Support/org/eclipse/ant/internal/ui/antsupport/inputhandler/SWTInputHandler.java
-## Nasty hack to get suppport for ppc64, s390{,x} and sparc{,64}
-%patch24 -p0
-# there is only partial support for ppc64 in 3.2 so we have to remove this
+## Nasty hack to get suppport for ppc64, s390{,x}, sparc{,64} and alpha
+%patch24 -p1
+# there is only partial support for ppc64 so we have to remove this
# partial support to get the replacemnt hack to work
find -name \*ppc64\* | xargs rm -r
# remove ppc64 support from features/org.eclipse.platform.source/feature.xml
@@ -574,9 +574,9 @@ find -type f -name \*.xml -exec sed --in-place "s/\(rootFileslinux_gtk_\)ppc64/\
sed --in-place "s/,.\{38\}ppc64.*macosx/,org.eclipse.platform.source.macosx/g" features/org.eclipse.platform.source/build.xml
# replace final occurances with an existing arch
sed --in-place "s/ppc64/x86_64/g" features/org.eclipse.platform.source/build.xml
-# Move all of the ia64 directories to ppc64 or s390{,x} or sparc{,64} dirs and replace
+# Move all of the ia64 directories to ppc64 or s390{,x} or sparc{,64} or alpha dirs and replace
# the ia64 strings with ppc64 or s390(x)
-%ifarch ppc64 s390 s390x sparc sparc64
+%ifarch ppc64 s390 s390x sparc sparc64 alpha
for f in $(find -name \*ia64\* | grep -v motif | grep -v ia64_32); do
mv $f $(echo $f | sed "s/ia64/%{_arch}/")
done
@@ -608,8 +608,12 @@ rm plugins/com.ibm.icu_3.6.1.v20070417.jar
ln -s %{_datadir}/eclipse/plugins/com.ibm.icu_3.6.1.v20070417.jar plugins/com.ibm.icu_3.6.1.v20070417.jar
# link to lucene
-rm plugins/org.apache.lucene_1.9.1.v200706111724.jar
-ln -s %{_javadir}/lucene.jar plugins/org.apache.lucene_1.9.1.v200706111724.jar
+#rm plugins/org.apache.lucene_1.9.1.v200706111724.jar
+#ln -s %{_javadir}/lucene.jar plugins/org.apache.lucene_1.9.1.v200706111724.jar
+
+# link to commons-logging
+rm plugins/org.apache.commons.logging_1.0.4.v200706111724.jar
+ln -s %{_javadir}/commons-logging.jar plugins/org.apache.commons.logging_1.0.4.v200706111724.jar
# delete included jars
# https://bugs.eclipse.org/bugs/show_bug.cgi?id=170662
@@ -1057,8 +1061,12 @@ rm plugins/com.ibm.icu_3.6.1.v20070417.jar
ln -s %{_datadir}/eclipse/plugins/com.ibm.icu_3.6.1.v20070417.jar plugins/com.ibm.icu_3.6.1.v20070417.jar
# link to lucene
-rm plugins/org.apache.lucene_1.9.1.v200706111724.jar
-ln -s %{_javadir}/lucene.jar plugins/org.apache.lucene_1.9.1.v200706111724.jar
+#rm plugins/org.apache.lucene_1.9.1.v200706111724.jar
+#ln -s %{_javadir}/lucene.jar plugins/org.apache.lucene_1.9.1.v200706111724.jar
+
+# link to commons-logging
+rm plugins/org.apache.commons.logging_1.0.4.v200706111724.jar
+ln -s %{_javadir}/commons-logging.jar plugins/org.apache.commons.logging_1.0.4.v200706111724.jar
popd
@@ -1617,8 +1625,11 @@ fi
%{_libdir}/%{name}/plugins/org.eclipse.sdk_*
%changelog
-* Fri Jul 16 2007 Ben Konrath 3.3.0-2
+* Mon Jul 16 2007 Ben Konrath 3.3.0-2
- Fix dep in rcp sub-package.
+- Add Alpha support.
+- Link to commons-logging.jar
+- Resolves: #248359.
* Fri Jun 29 2007 Ben Konrath 3.3.0-1
- 3.3.