Update to Neon.3
Upstreamed some changes from RHSCL
This commit is contained in:
parent
3196467104
commit
e73c02762d
@ -395,3 +395,25 @@ index 88a8daa..382c5ee 100644
|
||||
<versionRange>0.0.0</versionRange>
|
||||
</requirement>
|
||||
<requirement>
|
||||
--- eclipse.platform.ui.tools/bundles/org.eclipse.e4.tools.emf.ui/META-INF/MANIFEST.MF.orig 2017-02-15 10:01:24.202436806 +0000
|
||||
+++ eclipse.platform.ui.tools/bundles/org.eclipse.e4.tools.emf.ui/META-INF/MANIFEST.MF 2017-02-15 10:01:35.454301845 +0000
|
||||
@@ -38,8 +38,7 @@
|
||||
org.eclipse.e4.core.commands;bundle-version="0.10.0",
|
||||
org.eclipse.e4.ui.dialogs;bundle-version="1.0.0"
|
||||
Bundle-ActivationPolicy: lazy
|
||||
-Import-Package: javax.annotation,
|
||||
- javax.inject;version="1.0.0",
|
||||
+Import-Package: javax.inject;version="1.0.0",
|
||||
org.osgi.framework;version="1.5.0",
|
||||
org.osgi.service.event;version="1.3.1"
|
||||
Export-Package: org.eclipse.e4.tools.emf.ui.common;version="0.12.0.qualifier";x-friends:="org.eclipse.e4.tools.emf.editor3x,org.eclipse.e4.tools.model.spy",
|
||||
--- eclipse.platform.ui.tools/bundles/org.eclipse.e4.tools.services/META-INF/MANIFEST.MF.orig 2017-02-15 10:00:56.352770853 +0000
|
||||
+++ eclipse.platform.ui.tools/bundles/org.eclipse.e4.tools.services/META-INF/MANIFEST.MF 2017-02-15 10:01:06.757646050 +0000
|
||||
@@ -14,6 +14,5 @@
|
||||
org.eclipse.e4.core.di;bundle-version="0.9.0"
|
||||
Service-Component: OSGI-INF/resourcepoolfunction.xml, OSGI-INF/resourceservice.xml
|
||||
Bundle-ActivationPolicy: lazy
|
||||
-Import-Package: javax.annotation,
|
||||
- javax.inject;version="1.0.0"
|
||||
+Import-Package: javax.inject;version="1.0.0"
|
||||
Bundle-Activator: org.eclipse.e4.tools.services.ToolsServicesActivator
|
||||
|
41
eclipse.spec
41
eclipse.spec
@ -6,7 +6,7 @@
|
||||
Epoch: 1
|
||||
|
||||
%global eb_commit d5db901519674ad1dd5823a62bb6cec7a0f73fa3
|
||||
%global eclipse_tag R4_6_2
|
||||
%global eclipse_tag S4_6_3_RC3
|
||||
|
||||
%if 0%{?fedora} >= 25
|
||||
%global _jetty_version 9.4.0
|
||||
@ -46,8 +46,8 @@ Epoch: 1
|
||||
|
||||
Summary: An open, extensible IDE
|
||||
Name: eclipse
|
||||
Version: 4.6.2
|
||||
Release: 4%{?dist}
|
||||
Version: 4.6.3
|
||||
Release: 1%{?dist}
|
||||
License: EPL
|
||||
URL: http://www.eclipse.org/
|
||||
|
||||
@ -129,9 +129,8 @@ Patch27: eclipse-disable-droplets-in-dropins.patch
|
||||
# Temporary measure until wayland improves
|
||||
Patch28: prefer_x11_backend.patch
|
||||
|
||||
# Hack: Need to set system classpaths by reflection due to API change in ant
|
||||
# A real solution should eventually come from https://bugs.eclipse.org/bugs/show_bug.cgi?id=499717
|
||||
Patch29: port_to_ant_1.10.patch
|
||||
# Fix errors when building ant launcher
|
||||
Patch29: fix_ant_build.patch
|
||||
|
||||
BuildRequires: tycho >= 0.25.0
|
||||
BuildRequires: tycho-extras >= 0.25.0
|
||||
@ -189,15 +188,15 @@ BuildRequires: sat4j >= 2.3.5-1
|
||||
BuildRequires: objectweb-asm >= 5.0.3-1
|
||||
BuildRequires: sac >= 1.3-12
|
||||
BuildRequires: batik-css
|
||||
BuildRequires: xml-commons-apis >= 1.4.01-12
|
||||
BuildRequires: xml-commons-apis
|
||||
BuildRequires: atinject
|
||||
BuildRequires: atinject-tck
|
||||
BuildRequires: eclipse-filesystem
|
||||
BuildRequires: eclipse-ecf-core >= 3.13.3-1
|
||||
BuildRequires: eclipse-emf-core >= 1:2.12.0-1
|
||||
BuildRequires: eclipse-license
|
||||
BuildRequires: glassfish-el-api
|
||||
BuildRequires: glassfish-el
|
||||
BuildRequires: glassfish-el-api >= 3.0.1
|
||||
BuildRequires: glassfish-el >= 3.0.1
|
||||
BuildRequires: glassfish-jsp-api >= 2.2.1-4
|
||||
BuildRequires: glassfish-jsp >= 2.2.5
|
||||
BuildRequires: glassfish-servlet-api >= 3.1.0
|
||||
@ -274,10 +273,12 @@ Requires: lucene-analyzers-smartcn >= %{_lucene_version}
|
||||
Requires: sat4j >= 2.3.5-1
|
||||
Requires: sac >= 1.3-12
|
||||
Requires: batik-css
|
||||
Requires: xml-commons-apis >= 1.4.01-12
|
||||
Requires: xml-commons-apis
|
||||
Requires: atinject
|
||||
Requires: eclipse-ecf-core >= 3.13.3-1
|
||||
Requires: eclipse-emf-core >= 1:2.12.0-1
|
||||
Requires: glassfish-el-api >= 3.0.1
|
||||
Requires: glassfish-el >= 3.0.1
|
||||
Requires: glassfish-jsp-api >= 2.2.1-4
|
||||
Requires: glassfish-jsp >= 2.2.5
|
||||
Requires: glassfish-servlet-api >= 3.1.0
|
||||
@ -287,7 +288,11 @@ Requires: %{name}-equinox-osgi = %{epoch}:%{version}-%{release}
|
||||
Requires: httpcomponents-core
|
||||
Requires: httpcomponents-client
|
||||
%if 0%{?fedora} >= 26
|
||||
Requires: ant >= 1.10.1
|
||||
Requires: osgi(org.tukaani.xz) >= 1.6
|
||||
%else
|
||||
Requires: ant >= 1.9.6
|
||||
Requires: osgi(org.tukaani.xz)
|
||||
%endif
|
||||
|
||||
%description platform
|
||||
@ -348,6 +353,9 @@ SWT tools, E4 tools, Rel-Eng tools and Eclipse Test frameworks.
|
||||
%package tests
|
||||
Summary: Eclipse Tests
|
||||
|
||||
Requires: %{name}-pde = %{epoch}:%{version}-%{release}
|
||||
Requires: %{name}-contributor-tools = %{epoch}:%{version}-%{release}
|
||||
|
||||
%description tests
|
||||
Eclipse Tests.
|
||||
|
||||
@ -572,6 +580,15 @@ for f in `find eclipse.platform.team/bundles/org.eclipse.core.net/fragments -nam
|
||||
echo -e "Eclipse-BundleShape: dir\n\n" >> $f;
|
||||
done
|
||||
|
||||
%if 0%{?rhel}
|
||||
# Manually place rhino at correction location in reactor cache
|
||||
mkdir rhino
|
||||
pushd rhino
|
||||
xmvn -o install:install-file -Dfile=%{_root_datadir}/java/rhino.jar -Dpackaging=jar \
|
||||
-DgroupId=org.mozilla -DartifactId=rhino -Dversion=1.7R4
|
||||
popd
|
||||
%endif
|
||||
|
||||
#fake dependencies that don't exist in fedora
|
||||
./dependencies/fake_ant_dependency.sh .m2/p2/repo-sdk/plugins/org.apache.ant_* -makejar
|
||||
|
||||
@ -1123,6 +1140,10 @@ fi
|
||||
%{_libdir}/eclipse/plugins/org.eclipse.osgi.compatibility.state_*
|
||||
|
||||
%changelog
|
||||
* Fri Feb 24 2017 Mat Booth <mat.booth@redhat.com> - 1:4.6.3-1
|
||||
- Update to Neon.3
|
||||
- Upstreamed some changes from RHSCL
|
||||
|
||||
* Mon Jan 16 2017 Mat Booth <mat.booth@redhat.com> - 1:4.6.2-4
|
||||
- Fix last javax.annotation reference
|
||||
|
||||
|
@ -1,61 +1,3 @@
|
||||
--- eclipse.platform/ant/org.eclipse.ant.core/src_ant/org/eclipse/ant/internal/core/ant/InternalAntRunner.java.orig 2017-01-04 10:48:22.000000000 +0000
|
||||
+++ eclipse.platform/ant/org.eclipse.ant.core/src_ant/org/eclipse/ant/internal/core/ant/InternalAntRunner.java 2017-01-09 11:57:43.930455256 +0000
|
||||
@@ -19,6 +19,8 @@
|
||||
import java.io.IOException;
|
||||
import java.io.InputStream;
|
||||
import java.io.PrintStream;
|
||||
+import java.lang.reflect.Field;
|
||||
+import java.lang.reflect.Modifier;
|
||||
import java.net.URL;
|
||||
import java.text.MessageFormat;
|
||||
import java.util.ArrayList;
|
||||
@@ -1481,7 +1483,16 @@
|
||||
}
|
||||
|
||||
org.apache.tools.ant.types.Path systemClasspath = new org.apache.tools.ant.types.Path(null, buff.substring(0, buff.length() - 2));
|
||||
- org.apache.tools.ant.types.Path.systemClasspath = systemClasspath;
|
||||
+ try {
|
||||
+ Field field = org.apache.tools.ant.types.Path.class.getDeclaredField("systemClasspath"); //$NON-NLS-1$
|
||||
+ Field modifiersField = Field.class.getDeclaredField("modifiers"); //$NON-NLS-1$
|
||||
+ modifiersField.setAccessible(true);
|
||||
+ modifiersField.setInt(field, field.getModifiers() & ~Modifier.FINAL);
|
||||
+ field.set(field, systemClasspath);
|
||||
+ }
|
||||
+ catch (NoSuchFieldException | IllegalArgumentException | IllegalAccessException | SecurityException e) {
|
||||
+ e.printStackTrace();
|
||||
+ }
|
||||
}
|
||||
|
||||
/**
|
||||
--- "eclipse.platform/ant/org.eclipse.ant.ui/Ant Tools Support/org/eclipse/ant/internal/ui/model/AntDefiningTaskNode.java.orig" 2017-01-09 10:40:37.663084636 +0000
|
||||
+++ "eclipse.platform/ant/org.eclipse.ant.ui/Ant Tools Support/org/eclipse/ant/internal/ui/model/AntDefiningTaskNode.java" 2017-01-09 10:41:11.452722811 +0000
|
||||
@@ -14,6 +14,8 @@
|
||||
|
||||
import java.io.File;
|
||||
import java.io.IOException;
|
||||
+import java.lang.reflect.Field;
|
||||
+import java.lang.reflect.Modifier;
|
||||
import java.net.URISyntaxException;
|
||||
import java.net.URL;
|
||||
import java.util.ArrayList;
|
||||
@@ -175,7 +177,16 @@
|
||||
}
|
||||
|
||||
org.apache.tools.ant.types.Path systemClasspath = new org.apache.tools.ant.types.Path(null, buff.substring(0, buff.length() - 2));
|
||||
- org.apache.tools.ant.types.Path.systemClasspath = systemClasspath;
|
||||
+ try {
|
||||
+ Field field = org.apache.tools.ant.types.Path.class.getDeclaredField("systemClasspath"); //$NON-NLS-1$
|
||||
+ Field modifiersField = Field.class.getDeclaredField("modifiers"); //$NON-NLS-1$
|
||||
+ modifiersField.setAccessible(true);
|
||||
+ modifiersField.setInt(field, field.getModifiers() & ~Modifier.FINAL);
|
||||
+ field.set(field, systemClasspath);
|
||||
+ }
|
||||
+ catch (NoSuchFieldException | IllegalArgumentException | IllegalAccessException | SecurityException e) {
|
||||
+ e.printStackTrace();
|
||||
+ }
|
||||
}
|
||||
|
||||
@Override
|
||||
--- eclipse.platform/ant/org.eclipse.ant.launching/build.properties.orig 2017-01-09 10:24:16.258243377 +0000
|
||||
+++ eclipse.platform/ant/org.eclipse.ant.launching/build.properties 2017-01-09 10:25:08.302620557 +0000
|
||||
@@ -20,18 +20,14 @@
|
||||
@ -85,15 +27,6 @@
|
||||
+output.lib/remote.jar = remote_bin/
|
||||
+src.includes = about.html
|
||||
javacWarnings..=-unavoidableGenericProblems
|
||||
--- eclipse.pde.build/org.eclipse.pde.build.tests/src/org/eclipse/pde/build/internal/tests/ant/AntUtils.java.orig 2017-01-09 10:47:27.168692489 +0000
|
||||
+++ eclipse.pde.build/org.eclipse.pde.build.tests/src/org/eclipse/pde/build/internal/tests/ant/AntUtils.java 2017-01-09 10:47:36.735589854 +0000
|
||||
@@ -115,6 +115,5 @@
|
||||
}
|
||||
|
||||
org.apache.tools.ant.types.Path systemClasspath = new org.apache.tools.ant.types.Path(null, buff.substring(0, buff.length() - 2));
|
||||
- org.apache.tools.ant.types.Path.systemClasspath = systemClasspath;
|
||||
}
|
||||
}
|
||||
--- eclipse.platform.common/bundles/org.eclipse.jdt.doc.user/build.xml.orig 2017-01-09 13:30:24.238066571 +0000
|
||||
+++ eclipse.platform.common/bundles/org.eclipse.jdt.doc.user/build.xml 2017-01-09 13:31:19.228456113 +0000
|
||||
@@ -1,106 +1,8 @@
|
@ -1,7 +1,7 @@
|
||||
#!/bin/bash
|
||||
set -e
|
||||
AGGREGATOR_PATH=git://git.eclipse.org/gitroot/platform/eclipse.platform.releng.aggregator.git
|
||||
TAG=R4_6_2
|
||||
TAG=S4_6_3_RC3
|
||||
|
||||
rm -rf R4_platform-aggregator-$TAG
|
||||
rm -rf R4_platform-aggregator-$TAG.tar.xz
|
||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (R4_platform-aggregator-R4_6_2.tar.xz) = dcbcf4dfc9b0c913470f8006f85dcde83692c42e86fda53a026619a5a1dee8b0859a29cd740e0bbd057219058eba3cdbcb1a2f3b02167ff64dcc905b9ee65ffd
|
||||
SHA512 (R4_platform-aggregator-S4_6_3_RC3.tar.xz) = 8bf5f5b3737050f1e9e041f1b0898308cde471db298de24a8d1f998c0b3fa51c1061f35ec69979c36177545fbbcd84baf3e0432e2bf76e6b00e08099108286e8
|
||||
SHA512 (org.eclipse.linuxtools.eclipse-build-d5db901519674ad1dd5823a62bb6cec7a0f73fa3.tar.xz) = e459e345d08a643bcc11bd524772bda10c6a3423e16297724c7c5e84f95de7d965011b50a3d020fc172648a8c0700b7c30103cf42bf080d80cb9b77db79ba62d
|
||||
|
Loading…
Reference in New Issue
Block a user