fix osgi service package generation + produces working build (not i
This commit is contained in:
parent
1a4d3ef118
commit
d12201287f
@ -1,6 +1,6 @@
|
|||||||
--- rt.equinox.framework/bundles/org.eclipse.osgi.services/pom.xml.bak 2012-07-25 17:42:07.000000000 +0200
|
--- rt.equinox.framework/bundles/org.eclipse.osgi.services/pom.xml.bak 2012-07-25 17:42:07.000000000 +0200
|
||||||
+++ rt.equinox.framework/bundles/org.eclipse.osgi.services/pom.xml 2012-07-30 12:05:54.525785334 +0200
|
+++ rt.equinox.framework/bundles/org.eclipse.osgi.services/pom.xml 2012-07-30 12:05:54.525785334 +0200
|
||||||
@@ -42,6 +42,68 @@
|
@@ -42,6 +42,84 @@
|
||||||
</dependency-resolution>
|
</dependency-resolution>
|
||||||
</configuration>
|
</configuration>
|
||||||
</plugin>
|
</plugin>
|
||||||
@ -29,11 +29,12 @@
|
|||||||
+ <version>1.7</version>
|
+ <version>1.7</version>
|
||||||
+ <executions>
|
+ <executions>
|
||||||
+ <execution>
|
+ <execution>
|
||||||
+ <id>natives</id>
|
+ <id>extract-sources</id>
|
||||||
+ <phase>process-resources</phase>
|
+ <phase>process-resources</phase>
|
||||||
+ <configuration>
|
+ <configuration>
|
||||||
+ <target>
|
+ <target>
|
||||||
+ <unzip src="src.zip" dest="." overwrite="false"/>
|
+ <mkdir dir="src" /><mkdir dir="bin" />
|
||||||
|
+ <unzip src="src.zip" dest="src" overwrite="false"/>
|
||||||
+ <mkdir dir="src2/javax" />
|
+ <mkdir dir="src2/javax" />
|
||||||
+ <copy todir="src2/javax/"><fileset dir="../../../rt.equinox.bundles/bundles/org.eclipse.equinox.io/src/javax"/></copy>
|
+ <copy todir="src2/javax/"><fileset dir="../../../rt.equinox.bundles/bundles/org.eclipse.equinox.io/src/javax"/></copy>
|
||||||
+ </target>
|
+ </target>
|
||||||
@ -42,6 +43,21 @@
|
|||||||
+ <goal>run</goal>
|
+ <goal>run</goal>
|
||||||
+ </goals>
|
+ </goals>
|
||||||
+ </execution>
|
+ </execution>
|
||||||
|
+ <execution>
|
||||||
|
+ <id>copy-classes-back</id>
|
||||||
|
+ <phase>process-classes</phase>
|
||||||
|
+ <configuration>
|
||||||
|
+ <target>
|
||||||
|
+ <copy todir="org/"><fileset dir="target/classes/org/"/></copy>
|
||||||
|
+ <!--unzip src="src.zip" dest="src" overwrite="false"/>
|
||||||
|
+ <mkdir dir="src2/javax" />
|
||||||
|
+ -->
|
||||||
|
+ </target>
|
||||||
|
+ </configuration>
|
||||||
|
+ <goals>
|
||||||
|
+ <goal>run</goal>
|
||||||
|
+ </goals>
|
||||||
|
+ </execution>
|
||||||
+ </executions>
|
+ </executions>
|
||||||
+ <dependencies>
|
+ <dependencies>
|
||||||
+ <dependency>
|
+ <dependency>
|
||||||
@ -69,3 +85,25 @@
|
|||||||
</plugins>
|
</plugins>
|
||||||
</build>
|
</build>
|
||||||
|
|
||||||
|
--- rt.equinox.framework/bundles/org.eclipse.osgi.services/build.properties.bak 2012-08-01 16:03:39.000000000 +0200
|
||||||
|
+++ rt.equinox.framework/bundles/org.eclipse.osgi.services/build.properties 2012-08-01 16:22:16.274724843 +0200
|
||||||
|
@@ -11,13 +11,16 @@
|
||||||
|
bin.includes = plugin.properties,\
|
||||||
|
about.html,\
|
||||||
|
META-INF/,\
|
||||||
|
- org/,\
|
||||||
|
+ org/,\
|
||||||
|
about_files/
|
||||||
|
src.includes = src.zip,\
|
||||||
|
about.html,\
|
||||||
|
about_files/
|
||||||
|
-source.. = .
|
||||||
|
-output.. = .
|
||||||
|
+source.. = src/
|
||||||
|
+output.. = bin/
|
||||||
|
customBuildCallbacks=customBuildCallbacks.xml
|
||||||
|
javacSource = 1.5
|
||||||
|
javacTarget = 1.5
|
||||||
|
+jars.compile.order = library.jar,\
|
||||||
|
+ src/
|
||||||
|
+source.library.jar = src2/
|
||||||
|
23
eclipse.spec
23
eclipse.spec
@ -340,22 +340,27 @@ sed -i -e "s/1500/1503/" rt.equinox.framework/bundles/org.eclipse.equinox.launch
|
|||||||
%build
|
%build
|
||||||
mvn-local -f eclipse-parent/pom.xml \
|
mvn-local -f eclipse-parent/pom.xml \
|
||||||
install \
|
install \
|
||||||
-Dmaven.local.mode=true \
|
-Dmaven.local.mode=true
|
||||||
-Dmaven.repo.local=/var/tmp/lts/R4_localrepo
|
#\
|
||||||
|
# -Dmaven.repo.local=/var/tmp/lts/R4_localrepo
|
||||||
|
|
||||||
mvn-local -f maven-cbi-plugin/pom.xml \
|
mvn-local -f maven-cbi-plugin/pom.xml \
|
||||||
install \
|
install \
|
||||||
-Dmaven.local.mode=true \
|
-Dmaven.local.mode=true
|
||||||
-Dmaven.repo.local=/var/tmp/lts/R4_localrepo
|
#\
|
||||||
|
# -Dmaven.repo.local=/var/tmp/lts/R4_localrepo
|
||||||
|
|
||||||
mvn-local install \
|
mvn-local install \
|
||||||
-Dmaven.test.skip=true -Dnative=linux.gtk.`uname -p` \
|
-Dmaven.test.skip=true -Dnative=linux.gtk.`uname -p` \
|
||||||
-Dmaven.local.mode=true \
|
-Dmaven.local.mode=true
|
||||||
-Dmaven.repo.local=/var/tmp/lts/R4_localrepo
|
#\
|
||||||
|
# -Dmaven.repo.local=/var/tmp/lts/R4_localrepo
|
||||||
|
|
||||||
#mvn-local clean install \
|
mvn-local clean install \
|
||||||
# -Dmaven.test.skip=true -Dnative=linux.gtk.`uname -p` \
|
-Dmaven.test.skip=true -Dnative=linux.gtk.`uname -p` \
|
||||||
# -Dmaven.local.mode=true \
|
-Dmaven.local.mode=true
|
||||||
|
|
||||||
|
#\
|
||||||
# -Dmaven.repo.local=/var/tmp/lts/R4_localrepo
|
# -Dmaven.repo.local=/var/tmp/lts/R4_localrepo
|
||||||
|
|
||||||
#export JAVA_HOME=%{java_home}
|
#export JAVA_HOME=%{java_home}
|
||||||
|
Loading…
Reference in New Issue
Block a user