diff --git a/eclipse-osgi-unpack-sources.patch b/eclipse-osgi-unpack-sources.patch
index be9f6bd..286d4e2 100644
--- a/eclipse-osgi-unpack-sources.patch
+++ b/eclipse-osgi-unpack-sources.patch
@@ -1,6 +1,6 @@
--- rt.equinox.framework/bundles/org.eclipse.osgi.services/pom.xml.bak 2012-07-25 17:42:07.000000000 +0200
+++ rt.equinox.framework/bundles/org.eclipse.osgi.services/pom.xml 2012-07-30 12:05:54.525785334 +0200
-@@ -42,6 +42,68 @@
+@@ -42,6 +42,84 @@
@@ -29,11 +29,12 @@
+ 1.7
+
+
-+ natives
++ extract-sources
+ process-resources
+
+
-+
++
++
+
+
+
@@ -42,6 +43,21 @@
+ run
+
+
++
++ copy-classes-back
++ process-classes
++
++
++
++
++
++
++
++ run
++
++
+
+
+
@@ -69,3 +85,25 @@
+--- rt.equinox.framework/bundles/org.eclipse.osgi.services/build.properties.bak 2012-08-01 16:03:39.000000000 +0200
++++ rt.equinox.framework/bundles/org.eclipse.osgi.services/build.properties 2012-08-01 16:22:16.274724843 +0200
+@@ -11,13 +11,16 @@
+ bin.includes = plugin.properties,\
+ about.html,\
+ META-INF/,\
+- org/,\
++ org/,\
+ about_files/
+ src.includes = src.zip,\
+ about.html,\
+ about_files/
+-source.. = .
+-output.. = .
++source.. = src/
++output.. = bin/
+ customBuildCallbacks=customBuildCallbacks.xml
+ javacSource = 1.5
+ javacTarget = 1.5
++jars.compile.order = library.jar,\
++ src/
++source.library.jar = src2/
diff --git a/eclipse.spec b/eclipse.spec
index 24f74f9..d3aab74 100644
--- a/eclipse.spec
+++ b/eclipse.spec
@@ -340,22 +340,27 @@ sed -i -e "s/1500/1503/" rt.equinox.framework/bundles/org.eclipse.equinox.launch
%build
mvn-local -f eclipse-parent/pom.xml \
install \
- -Dmaven.local.mode=true \
- -Dmaven.repo.local=/var/tmp/lts/R4_localrepo
+ -Dmaven.local.mode=true
+#\
+# -Dmaven.repo.local=/var/tmp/lts/R4_localrepo
mvn-local -f maven-cbi-plugin/pom.xml \
install \
- -Dmaven.local.mode=true \
- -Dmaven.repo.local=/var/tmp/lts/R4_localrepo
+ -Dmaven.local.mode=true
+#\
+# -Dmaven.repo.local=/var/tmp/lts/R4_localrepo
mvn-local install \
-Dmaven.test.skip=true -Dnative=linux.gtk.`uname -p` \
- -Dmaven.local.mode=true \
- -Dmaven.repo.local=/var/tmp/lts/R4_localrepo
+ -Dmaven.local.mode=true
+#\
+# -Dmaven.repo.local=/var/tmp/lts/R4_localrepo
-#mvn-local clean install \
-# -Dmaven.test.skip=true -Dnative=linux.gtk.`uname -p` \
-# -Dmaven.local.mode=true \
+mvn-local clean install \
+ -Dmaven.test.skip=true -Dnative=linux.gtk.`uname -p` \
+ -Dmaven.local.mode=true
+
+#\
# -Dmaven.repo.local=/var/tmp/lts/R4_localrepo
#export JAVA_HOME=%{java_home}