Update to Luna SR2 release
- Drop upstreamed patches - Fixes rhbz#1177906
This commit is contained in:
parent
98fd2d20f5
commit
d06642a92c
@ -1,11 +1,11 @@
|
||||
--- rt.equinox.framework/bundles/org.eclipse.equinox.launcher.gtk.linux.x86_64/pom.xml.orig 2014-04-15 14:32:03.000000000 +0100
|
||||
+++ rt.equinox.framework/bundles/org.eclipse.equinox.launcher.gtk.linux.x86_64/pom.xml 2014-04-16 15:53:08.145402094 +0100
|
||||
@@ -27,4 +27,59 @@
|
||||
@@ -27,4 +27,37 @@
|
||||
<ws>gtk</ws>
|
||||
<arch>x86_64</arch>
|
||||
</properties>
|
||||
+ <profiles>
|
||||
+ <profile>
|
||||
+ <profile>
|
||||
+ <id>build-native-launchers-gtk.linux.x86_64</id>
|
||||
+ <activation>
|
||||
+ <property>
|
||||
@ -17,7 +17,7 @@
|
||||
+ <plugins>
|
||||
+ <plugin>
|
||||
+ <artifactId>maven-antrun-plugin</artifactId>
|
||||
+ <version> 1.7 </version>
|
||||
+ <version>1.7</version>
|
||||
+ <executions>
|
||||
+ <execution>
|
||||
+ <id>compile-executable-natives</id>
|
||||
@ -32,28 +32,6 @@
|
||||
+ </goals>
|
||||
+ </execution>
|
||||
+ </executions>
|
||||
+ <dependencies>
|
||||
+ <dependency>
|
||||
+ <groupId>bsf</groupId>
|
||||
+ <artifactId>bsf</artifactId>
|
||||
+ <version>2.4.0</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>rhino</groupId>
|
||||
+ <artifactId>js</artifactId>
|
||||
+ <version>1.7R2</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.apache.ant</groupId>
|
||||
+ <artifactId>ant-apache-bsf</artifactId>
|
||||
+ <version>1.8.3</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.apache.ant</groupId>
|
||||
+ <artifactId>ant-nodeps</artifactId>
|
||||
+ <version>1.8.1</version>
|
||||
+ </dependency>
|
||||
+ </dependencies>
|
||||
+ </plugin>
|
||||
+ </plugins>
|
||||
+ </build>
|
||||
@ -62,13 +40,12 @@
|
||||
</project>
|
||||
--- rt.equinox.framework/bundles/org.eclipse.equinox.launcher.win32.win32.x86_64/pom.xml.orig 2014-04-15 14:32:03.000000000 +0100
|
||||
+++ rt.equinox.framework/bundles/org.eclipse.equinox.launcher.win32.win32.x86_64/pom.xml 2014-04-16 15:53:08.145402094 +0100
|
||||
@@ -27,4 +27,60 @@
|
||||
@@ -27,4 +27,37 @@
|
||||
<ws>win32</ws>
|
||||
<arch>x86_64</arch>
|
||||
</properties>
|
||||
+
|
||||
+ <profiles>
|
||||
+ <profile>
|
||||
+ <profile>
|
||||
+ <id>build-native-launchers-win32.win32.x86_64</id>
|
||||
+ <activation>
|
||||
+ <property>
|
||||
@ -80,7 +57,7 @@
|
||||
+ <plugins>
|
||||
+ <plugin>
|
||||
+ <artifactId>maven-antrun-plugin</artifactId>
|
||||
+ <version> 1.7 </version>
|
||||
+ <version>1.7</version>
|
||||
+ <executions>
|
||||
+ <execution>
|
||||
+ <id>compile-executable-natives</id>
|
||||
@ -95,28 +72,6 @@
|
||||
+ </goals>
|
||||
+ </execution>
|
||||
+ </executions>
|
||||
+ <dependencies>
|
||||
+ <dependency>
|
||||
+ <groupId>bsf</groupId>
|
||||
+ <artifactId>bsf</artifactId>
|
||||
+ <version>2.4.0</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>rhino</groupId>
|
||||
+ <artifactId>js</artifactId>
|
||||
+ <version>1.7R2</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.apache.ant</groupId>
|
||||
+ <artifactId>ant-apache-bsf</artifactId>
|
||||
+ <version>1.8.3</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.apache.ant</groupId>
|
||||
+ <artifactId>ant-nodeps</artifactId>
|
||||
+ <version>1.8.1</version>
|
||||
+ </dependency>
|
||||
+ </dependencies>
|
||||
+ </plugin>
|
||||
+ </plugins>
|
||||
+ </build>
|
||||
@ -125,13 +80,12 @@
|
||||
</project>
|
||||
--- rt.equinox.framework/bundles/org.eclipse.equinox.launcher.gtk.linux.ppc64le/pom.xml.orig 2014-04-16 15:57:02.805249103 +0100
|
||||
+++ rt.equinox.framework/bundles/org.eclipse.equinox.launcher.gtk.linux.ppc64le/pom.xml 2014-04-16 15:57:26.204834155 +0100
|
||||
@@ -27,4 +27,60 @@
|
||||
@@ -27,4 +27,37 @@
|
||||
<ws>gtk</ws>
|
||||
<arch>ppc64le</arch>
|
||||
</properties>
|
||||
+
|
||||
+ <profiles>
|
||||
+ <profile>
|
||||
+ <profile>
|
||||
+ <id>build-native-launchers-gtk.linux.ppc64le</id>
|
||||
+ <activation>
|
||||
+ <property>
|
||||
@ -143,7 +97,7 @@
|
||||
+ <plugins>
|
||||
+ <plugin>
|
||||
+ <artifactId>maven-antrun-plugin</artifactId>
|
||||
+ <version> 1.7 </version>
|
||||
+ <version>1.7</version>
|
||||
+ <executions>
|
||||
+ <execution>
|
||||
+ <id>compile-executable-natives</id>
|
||||
@ -158,28 +112,6 @@
|
||||
+ </goals>
|
||||
+ </execution>
|
||||
+ </executions>
|
||||
+ <dependencies>
|
||||
+ <dependency>
|
||||
+ <groupId>bsf</groupId>
|
||||
+ <artifactId>bsf</artifactId>
|
||||
+ <version>2.4.0</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>rhino</groupId>
|
||||
+ <artifactId>js</artifactId>
|
||||
+ <version>1.7R2</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.apache.ant</groupId>
|
||||
+ <artifactId>ant-apache-bsf</artifactId>
|
||||
+ <version>1.8.3</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.apache.ant</groupId>
|
||||
+ <artifactId>ant-nodeps</artifactId>
|
||||
+ <version>1.8.1</version>
|
||||
+ </dependency>
|
||||
+ </dependencies>
|
||||
+ </plugin>
|
||||
+ </plugins>
|
||||
+ </build>
|
||||
@ -188,12 +120,12 @@
|
||||
</project>
|
||||
--- rt.equinox.framework/bundles/org.eclipse.equinox.launcher.gtk.linux.x86/pom.xml.orig 2014-04-15 14:32:03.000000000 +0100
|
||||
+++ rt.equinox.framework/bundles/org.eclipse.equinox.launcher.gtk.linux.x86/pom.xml 2014-04-16 15:53:08.145402094 +0100
|
||||
@@ -27,4 +27,59 @@
|
||||
@@ -27,4 +27,37 @@
|
||||
<ws>gtk</ws>
|
||||
<arch>x86</arch>
|
||||
</properties>
|
||||
+ <profiles>
|
||||
+ <profile>
|
||||
+ <profile>
|
||||
+ <id>build-native-launchers-gtk.linux.x86</id>
|
||||
+ <activation>
|
||||
+ <property>
|
||||
@ -205,7 +137,7 @@
|
||||
+ <plugins>
|
||||
+ <plugin>
|
||||
+ <artifactId>maven-antrun-plugin</artifactId>
|
||||
+ <version> 1.7 </version>
|
||||
+ <version>1.7</version>
|
||||
+ <executions>
|
||||
+ <execution>
|
||||
+ <id>compile-executable-natives</id>
|
||||
@ -220,28 +152,6 @@
|
||||
+ </goals>
|
||||
+ </execution>
|
||||
+ </executions>
|
||||
+ <dependencies>
|
||||
+ <dependency>
|
||||
+ <groupId>bsf</groupId>
|
||||
+ <artifactId>bsf</artifactId>
|
||||
+ <version>2.4.0</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>rhino</groupId>
|
||||
+ <artifactId>js</artifactId>
|
||||
+ <version>1.7R2</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.apache.ant</groupId>
|
||||
+ <artifactId>ant-apache-bsf</artifactId>
|
||||
+ <version>1.8.3</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.apache.ant</groupId>
|
||||
+ <artifactId>ant-nodeps</artifactId>
|
||||
+ <version>1.8.1</version>
|
||||
+ </dependency>
|
||||
+ </dependencies>
|
||||
+ </plugin>
|
||||
+ </plugins>
|
||||
+ </build>
|
||||
@ -250,13 +160,12 @@
|
||||
</project>
|
||||
--- rt.equinox.framework/bundles/org.eclipse.equinox.launcher.win32.win32.x86/pom.xml.orig 2014-04-15 14:32:03.000000000 +0100
|
||||
+++ rt.equinox.framework/bundles/org.eclipse.equinox.launcher.win32.win32.x86/pom.xml 2014-04-16 15:53:08.145402094 +0100
|
||||
@@ -27,4 +27,60 @@
|
||||
@@ -27,4 +27,37 @@
|
||||
<ws>win32</ws>
|
||||
<arch>x86</arch>
|
||||
</properties>
|
||||
+
|
||||
+ <profiles>
|
||||
+ <profile>
|
||||
+ <profile>
|
||||
+ <id>build-native-launchers-win32.win32.x86</id>
|
||||
+ <activation>
|
||||
+ <property>
|
||||
@ -268,7 +177,7 @@
|
||||
+ <plugins>
|
||||
+ <plugin>
|
||||
+ <artifactId>maven-antrun-plugin</artifactId>
|
||||
+ <version> 1.7 </version>
|
||||
+ <version>1.7</version>
|
||||
+ <executions>
|
||||
+ <execution>
|
||||
+ <id>compile-executable-natives</id>
|
||||
@ -283,28 +192,6 @@
|
||||
+ </goals>
|
||||
+ </execution>
|
||||
+ </executions>
|
||||
+ <dependencies>
|
||||
+ <dependency>
|
||||
+ <groupId>bsf</groupId>
|
||||
+ <artifactId>bsf</artifactId>
|
||||
+ <version>2.4.0</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>rhino</groupId>
|
||||
+ <artifactId>js</artifactId>
|
||||
+ <version>1.7R2</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.apache.ant</groupId>
|
||||
+ <artifactId>ant-apache-bsf</artifactId>
|
||||
+ <version>1.8.3</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.apache.ant</groupId>
|
||||
+ <artifactId>ant-nodeps</artifactId>
|
||||
+ <version>1.8.1</version>
|
||||
+ </dependency>
|
||||
+ </dependencies>
|
||||
+ </plugin>
|
||||
+ </plugins>
|
||||
+ </build>
|
||||
@ -313,13 +200,12 @@
|
||||
</project>
|
||||
--- rt.equinox.framework/bundles/org.eclipse.equinox.launcher.gtk.linux.s390/pom.xml.orig 2014-04-15 14:32:03.000000000 +0100
|
||||
+++ rt.equinox.framework/bundles/org.eclipse.equinox.launcher.gtk.linux.s390/pom.xml 2014-04-16 15:53:08.145402094 +0100
|
||||
@@ -27,4 +27,60 @@
|
||||
@@ -27,4 +27,37 @@
|
||||
<ws>gtk</ws>
|
||||
<arch>s390</arch>
|
||||
</properties>
|
||||
+
|
||||
+ <profiles>
|
||||
+ <profile>
|
||||
+ <profile>
|
||||
+ <id>build-native-launchers-gtk.linux.s390</id>
|
||||
+ <activation>
|
||||
+ <property>
|
||||
@ -331,7 +217,7 @@
|
||||
+ <plugins>
|
||||
+ <plugin>
|
||||
+ <artifactId>maven-antrun-plugin</artifactId>
|
||||
+ <version> 1.7 </version>
|
||||
+ <version>1.7</version>
|
||||
+ <executions>
|
||||
+ <execution>
|
||||
+ <id>compile-executable-natives</id>
|
||||
@ -346,28 +232,6 @@
|
||||
+ </goals>
|
||||
+ </execution>
|
||||
+ </executions>
|
||||
+ <dependencies>
|
||||
+ <dependency>
|
||||
+ <groupId>bsf</groupId>
|
||||
+ <artifactId>bsf</artifactId>
|
||||
+ <version>2.4.0</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>rhino</groupId>
|
||||
+ <artifactId>js</artifactId>
|
||||
+ <version>1.7R2</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.apache.ant</groupId>
|
||||
+ <artifactId>ant-apache-bsf</artifactId>
|
||||
+ <version>1.8.3</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.apache.ant</groupId>
|
||||
+ <artifactId>ant-nodeps</artifactId>
|
||||
+ <version>1.8.1</version>
|
||||
+ </dependency>
|
||||
+ </dependencies>
|
||||
+ </plugin>
|
||||
+ </plugins>
|
||||
+ </build>
|
||||
@ -376,13 +240,12 @@
|
||||
</project>
|
||||
--- rt.equinox.framework/bundles/org.eclipse.equinox.launcher.gtk.linux.s390x/pom.xml.orig 2014-04-15 14:32:03.000000000 +0100
|
||||
+++ rt.equinox.framework/bundles/org.eclipse.equinox.launcher.gtk.linux.s390x/pom.xml 2014-04-16 15:53:08.146402075 +0100
|
||||
@@ -27,4 +27,60 @@
|
||||
@@ -27,4 +27,37 @@
|
||||
<ws>gtk</ws>
|
||||
<arch>s390x</arch>
|
||||
</properties>
|
||||
+
|
||||
+ <profiles>
|
||||
+ <profile>
|
||||
+ <profile>
|
||||
+ <id>build-native-launchers-gtk.linux.s390x</id>
|
||||
+ <activation>
|
||||
+ <property>
|
||||
@ -394,7 +257,7 @@
|
||||
+ <plugins>
|
||||
+ <plugin>
|
||||
+ <artifactId>maven-antrun-plugin</artifactId>
|
||||
+ <version> 1.7 </version>
|
||||
+ <version>1.7</version>
|
||||
+ <executions>
|
||||
+ <execution>
|
||||
+ <id>compile-executable-natives</id>
|
||||
@ -409,28 +272,6 @@
|
||||
+ </goals>
|
||||
+ </execution>
|
||||
+ </executions>
|
||||
+ <dependencies>
|
||||
+ <dependency>
|
||||
+ <groupId>bsf</groupId>
|
||||
+ <artifactId>bsf</artifactId>
|
||||
+ <version>2.4.0</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>rhino</groupId>
|
||||
+ <artifactId>js</artifactId>
|
||||
+ <version>1.7R2</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.apache.ant</groupId>
|
||||
+ <artifactId>ant-apache-bsf</artifactId>
|
||||
+ <version>1.8.3</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.apache.ant</groupId>
|
||||
+ <artifactId>ant-nodeps</artifactId>
|
||||
+ <version>1.8.1</version>
|
||||
+ </dependency>
|
||||
+ </dependencies>
|
||||
+ </plugin>
|
||||
+ </plugins>
|
||||
+ </build>
|
||||
@ -439,13 +280,12 @@
|
||||
</project>
|
||||
--- rt.equinox.framework/bundles/org.eclipse.equinox.launcher.gtk.linux.ppc64/pom.xml.orig 2014-04-15 14:32:03.000000000 +0100
|
||||
+++ rt.equinox.framework/bundles/org.eclipse.equinox.launcher.gtk.linux.ppc64/pom.xml 2014-04-16 15:57:28.315796703 +0100
|
||||
@@ -27,4 +27,60 @@
|
||||
@@ -27,4 +27,37 @@
|
||||
<ws>gtk</ws>
|
||||
<arch>ppc64</arch>
|
||||
</properties>
|
||||
+
|
||||
+ <profiles>
|
||||
+ <profile>
|
||||
+ <profile>
|
||||
+ <id>build-native-launchers-gtk.linux.ppc64</id>
|
||||
+ <activation>
|
||||
+ <property>
|
||||
@ -457,7 +297,7 @@
|
||||
+ <plugins>
|
||||
+ <plugin>
|
||||
+ <artifactId>maven-antrun-plugin</artifactId>
|
||||
+ <version> 1.7 </version>
|
||||
+ <version>1.7</version>
|
||||
+ <executions>
|
||||
+ <execution>
|
||||
+ <id>compile-executable-natives</id>
|
||||
@ -472,28 +312,6 @@
|
||||
+ </goals>
|
||||
+ </execution>
|
||||
+ </executions>
|
||||
+ <dependencies>
|
||||
+ <dependency>
|
||||
+ <groupId>bsf</groupId>
|
||||
+ <artifactId>bsf</artifactId>
|
||||
+ <version>2.4.0</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>rhino</groupId>
|
||||
+ <artifactId>js</artifactId>
|
||||
+ <version>1.7R2</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.apache.ant</groupId>
|
||||
+ <artifactId>ant-apache-bsf</artifactId>
|
||||
+ <version>1.8.3</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.apache.ant</groupId>
|
||||
+ <artifactId>ant-nodeps</artifactId>
|
||||
+ <version>1.8.1</version>
|
||||
+ </dependency>
|
||||
+ </dependencies>
|
||||
+ </plugin>
|
||||
+ </plugins>
|
||||
+ </build>
|
||||
@ -502,13 +320,12 @@
|
||||
</project>
|
||||
--- rt.equinox.framework/bundles/org.eclipse.equinox.launcher.gtk.linux.ppc/pom.xml.orig 2014-04-15 14:32:03.000000000 +0100
|
||||
+++ rt.equinox.framework/bundles/org.eclipse.equinox.launcher.gtk.linux.ppc/pom.xml 2014-04-16 15:53:08.146402075 +0100
|
||||
@@ -27,4 +27,60 @@
|
||||
@@ -27,4 +27,37 @@
|
||||
<ws>gtk</ws>
|
||||
<arch>ppc</arch>
|
||||
</properties>
|
||||
+
|
||||
+ <profiles>
|
||||
+ <profile>
|
||||
+ <profile>
|
||||
+ <id>build-native-launchers-gtk.linux.ppc</id>
|
||||
+ <activation>
|
||||
+ <property>
|
||||
@ -520,7 +337,7 @@
|
||||
+ <plugins>
|
||||
+ <plugin>
|
||||
+ <artifactId>maven-antrun-plugin</artifactId>
|
||||
+ <version> 1.7 </version>
|
||||
+ <version>1.7</version>
|
||||
+ <executions>
|
||||
+ <execution>
|
||||
+ <id>compile-executable-natives</id>
|
||||
@ -535,28 +352,6 @@
|
||||
+ </goals>
|
||||
+ </execution>
|
||||
+ </executions>
|
||||
+ <dependencies>
|
||||
+ <dependency>
|
||||
+ <groupId>bsf</groupId>
|
||||
+ <artifactId>bsf</artifactId>
|
||||
+ <version>2.4.0</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>rhino</groupId>
|
||||
+ <artifactId>js</artifactId>
|
||||
+ <version>1.7R2</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.apache.ant</groupId>
|
||||
+ <artifactId>ant-apache-bsf</artifactId>
|
||||
+ <version>1.8.3</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.apache.ant</groupId>
|
||||
+ <artifactId>ant-nodeps</artifactId>
|
||||
+ <version>1.8.1</version>
|
||||
+ </dependency>
|
||||
+ </dependencies>
|
||||
+ </plugin>
|
||||
+ </plugins>
|
||||
+ </build>
|
||||
|
@ -1,96 +0,0 @@
|
||||
From 716d35d30c1f639a04515188fedd89bb3aaf12bc Mon Sep 17 00:00:00 2001
|
||||
From: Sami Wagiaalla
|
||||
Date: Mon, 15 Sep 2014 11:51:44 -0400
|
||||
Subject: Bug 444143 - [GTK3] Reset selected background color in Table
|
||||
|
||||
When setBackgroundColor is called for Table it results in
|
||||
a call to gtk_widget_override_background_color with the flag
|
||||
GTK_STATE_FLAG_NORMAL which overrides the color for selected
|
||||
items' background despite the flag. Therefore the selected item
|
||||
color must be reset to the default.
|
||||
|
||||
Change-Id: Iab3cad4e01cf87cca04e536fdea8991c818d0336
|
||||
Signed-off-by: Sami Wagiaalla <swagiaal@redhat.com>
|
||||
|
||||
diff --git a/eclipse.platform.swt/bundles/org.eclipse.swt/Eclipse SWT/gtk/org/eclipse/swt/widgets/Table.java b/eclipse.platform.swt/bundles/org.eclipse.swt/Eclipse SWT/gtk/org/eclipse/swt/widgets/Table.java
|
||||
index 96493c6..2558fd1 100644
|
||||
--- a/eclipse.platform.swt/bundles/org.eclipse.swt/Eclipse SWT/gtk/org/eclipse/swt/widgets/Table.java
|
||||
+++ b/eclipse.platform.swt/bundles/org.eclipse.swt/Eclipse SWT/gtk/org/eclipse/swt/widgets/Table.java
|
||||
@@ -11,12 +11,28 @@
|
||||
package org.eclipse.swt.widgets;
|
||||
|
||||
|
||||
-import org.eclipse.swt.*;
|
||||
-import org.eclipse.swt.internal.*;
|
||||
-import org.eclipse.swt.internal.cairo.*;
|
||||
-import org.eclipse.swt.internal.gtk.*;
|
||||
-import org.eclipse.swt.graphics.*;
|
||||
-import org.eclipse.swt.events.*;
|
||||
+import org.eclipse.swt.SWT;
|
||||
+import org.eclipse.swt.SWTException;
|
||||
+import org.eclipse.swt.events.SelectionEvent;
|
||||
+import org.eclipse.swt.events.SelectionListener;
|
||||
+import org.eclipse.swt.graphics.Color;
|
||||
+import org.eclipse.swt.graphics.Font;
|
||||
+import org.eclipse.swt.graphics.GC;
|
||||
+import org.eclipse.swt.graphics.Image;
|
||||
+import org.eclipse.swt.graphics.Point;
|
||||
+import org.eclipse.swt.graphics.Rectangle;
|
||||
+import org.eclipse.swt.internal.Converter;
|
||||
+import org.eclipse.swt.internal.ImageList;
|
||||
+import org.eclipse.swt.internal.cairo.Cairo;
|
||||
+import org.eclipse.swt.internal.gtk.GdkColor;
|
||||
+import org.eclipse.swt.internal.gtk.GdkEventButton;
|
||||
+import org.eclipse.swt.internal.gtk.GdkEventExpose;
|
||||
+import org.eclipse.swt.internal.gtk.GdkRGBA;
|
||||
+import org.eclipse.swt.internal.gtk.GdkRectangle;
|
||||
+import org.eclipse.swt.internal.gtk.GtkAllocation;
|
||||
+import org.eclipse.swt.internal.gtk.GtkCellRendererClass;
|
||||
+import org.eclipse.swt.internal.gtk.GtkRequisition;
|
||||
+import org.eclipse.swt.internal.gtk.OS;
|
||||
|
||||
/**
|
||||
* Instances of this class implement a selectable user interface
|
||||
@@ -3006,6 +3022,17 @@ void setBackgroundColor (GdkColor color) {
|
||||
super.setBackgroundColor (color);
|
||||
if (!OS.GTK3) {
|
||||
OS.gtk_widget_modify_base (handle, 0, color);
|
||||
+ } else {
|
||||
+ // Setting the background color overrides the selected background color
|
||||
+ // so we have to reset it the default.
|
||||
+ GdkColor defaultColor = getDisplay().COLOR_LIST_SELECTION;
|
||||
+ GdkRGBA selectedBackground = new GdkRGBA ();
|
||||
+ selectedBackground.alpha = 1;
|
||||
+ selectedBackground.red = (defaultColor.red & 0xFFFF) / (float)0xFFFF;
|
||||
+ selectedBackground.green = (defaultColor.green & 0xFFFF) / (float)0xFFFF;
|
||||
+ selectedBackground.blue = (defaultColor.blue & 0xFFFF) / (float)0xFFFF;
|
||||
+
|
||||
+ OS.gtk_widget_override_background_color (handle, OS.GTK_STATE_FLAG_SELECTED, selectedBackground);
|
||||
}
|
||||
}
|
||||
|
||||
diff --git a/eclipse.platform.swt/bundles/org.eclipse.swt/Eclipse SWT/gtk/org/eclipse/swt/widgets/Tree.java b/eclipse.platform.swt/bundles/org.eclipse.swt/Eclipse SWT/gtk/org/eclipse/swt/widgets/Tree.java
|
||||
index 2a40869..4603cff 100644
|
||||
--- a/eclipse.platform.swt/bundles/org.eclipse.swt/Eclipse SWT/gtk/org/eclipse/swt/widgets/Tree.java
|
||||
+++ b/eclipse.platform.swt/bundles/org.eclipse.swt/Eclipse SWT/gtk/org/eclipse/swt/widgets/Tree.java
|
||||
@@ -3038,6 +3038,17 @@ void setBackgroundColor (GdkColor color) {
|
||||
super.setBackgroundColor (color);
|
||||
if (!OS.GTK3) {
|
||||
OS.gtk_widget_modify_base (handle, 0, color);
|
||||
+ } else {
|
||||
+ // Setting the background color overrides the selected background color
|
||||
+ // so we have to reset it the default.
|
||||
+ GdkColor defaultColor = getDisplay().COLOR_LIST_SELECTION;
|
||||
+ GdkRGBA selectedBackground = new GdkRGBA ();
|
||||
+ selectedBackground.alpha = 1;
|
||||
+ selectedBackground.red = (defaultColor.red & 0xFFFF) / (float)0xFFFF;
|
||||
+ selectedBackground.green = (defaultColor.green & 0xFFFF) / (float)0xFFFF;
|
||||
+ selectedBackground.blue = (defaultColor.blue & 0xFFFF) / (float)0xFFFF;
|
||||
+
|
||||
+ OS.gtk_widget_override_background_color (handle, OS.GTK_STATE_FLAG_SELECTED, selectedBackground);
|
||||
}
|
||||
}
|
||||
|
||||
--
|
||||
cgit v0.10.1-9-gd18e
|
||||
|
@ -412,18 +412,20 @@ index fac13bf..e487001 100644
|
||||
<profile>
|
||||
<id>build-native-launchers-win32.win32.x86_64</id>
|
||||
<activation>
|
||||
@@ -530,8 +530,6 @@
|
||||
@@ -530,8 +530,8 @@
|
||||
<include name="gtk/solaris/x86/**/*" />
|
||||
<include name="win32/win32/x86/**/*" />
|
||||
<include name="win32/win32/x86_64/**/*" />
|
||||
- </fileset>
|
||||
- <fileset dir="../../../rt.equinox.binaries/org.eclipse.equinox.executable/contributed/">
|
||||
+ <include name="gtk/linux/arm/**/*" />
|
||||
+ <include name="gtk/linux/aarch64/**/*" />
|
||||
<include name="gtk/linux/s390/**/*" />
|
||||
<include name="gtk/linux/s390x/**/*" />
|
||||
</fileset>
|
||||
--- a/eclipse.platform.releng.tychoeclipsebuilder/rcp.config/pom.xml 2014-05-26 19:20:28.958177815 +0300
|
||||
+++ b/eclipse.platform.releng.tychoeclipsebuilder/rcp.config/pom.xml 2014-05-26 19:33:42.942025740 +0300
|
||||
@@ -30,6 +30,64 @@
|
||||
@@ -30,6 +30,44 @@
|
||||
<version>2.6</version>
|
||||
<executions>
|
||||
<execution>
|
||||
@ -464,26 +466,6 @@ index fac13bf..e487001 100644
|
||||
+ </resources>
|
||||
+ </configuration>
|
||||
+ </execution>
|
||||
+ <execution>
|
||||
+ <id>copy-resources-gtk.linux.ppc64le</id>
|
||||
+ <phase>validate</phase>
|
||||
+ <goals>
|
||||
+ <goal>copy-resources</goal>
|
||||
+ </goals>
|
||||
+ <configuration>
|
||||
+ <outputDirectory>${basedir}/rootfiles/linux.gtk.ppc64le</outputDirectory>
|
||||
+ <resources>
|
||||
+ <resource>
|
||||
+ <directory>../../eclipse.platform.swt.binaries/bundles/org.eclipse.swt.gtk.linux.ppc64le
|
||||
+ </directory>
|
||||
+ <includes>
|
||||
+ <include>about_files/*</include>
|
||||
+ <include>about.html</include>
|
||||
+ </includes>
|
||||
+ </resource>
|
||||
+ </resources>
|
||||
+ </configuration>
|
||||
+ </execution>
|
||||
+ <execution>
|
||||
<id>copy-resources-gtk.linux.x86</id>
|
||||
<phase>validate</phase>
|
||||
|
@ -1,28 +0,0 @@
|
||||
From ba6d6b9708a06fa267240471407c239d02484821 Mon Sep 17 00:00:00 2001
|
||||
From: Timo Kinnunen
|
||||
Date: Fri, 7 Nov 2014 15:28:21 +0100
|
||||
Subject: Fixed bug 429308: Make workspace selection dialog visible in the task
|
||||
manager of the OS
|
||||
|
||||
Signed-off-by: Timo Kinnunen <timo.kinnunen@gmail.com>
|
||||
diff --git a/eclipse.platform.ui/bundles/org.eclipse.ui.ide.application/src/org/eclipse/ui/internal/ide/application/IDEApplication.java b/bundles/org.eclipse.ui.ide.application/src/org/eclipse/ui/internal/ide/application/IDEApplication.java
|
||||
index 4797d2d..d88f57f 100644
|
||||
--- a/eclipse.platform.ui/bundles/org.eclipse.ui.ide.application/src/org/eclipse/ui/internal/ide/application/IDEApplication.java
|
||||
+++ b/eclipse.platform.ui/bundles/org.eclipse.ui.ide.application/src/org/eclipse/ui/internal/ide/application/IDEApplication.java
|
||||
@@ -314,7 +314,12 @@ public class IDEApplication implements IApplication, IExecutableExtension {
|
||||
URL url = null;
|
||||
do {
|
||||
// okay to use the shell now - this is the splash shell
|
||||
- new ChooseWorkspaceDialog(shell, launchData, false, true).prompt(force);
|
||||
+ new ChooseWorkspaceDialog(shell, launchData, false, true) {
|
||||
+ @Override
|
||||
+ protected Shell getParentShell() {
|
||||
+ return null;
|
||||
+ }
|
||||
+ }.prompt(force);
|
||||
String instancePath = launchData.getSelection();
|
||||
if (instancePath == null) {
|
||||
return null;
|
||||
--
|
||||
cgit v0.10.1-9-gd18e
|
||||
|
42
eclipse.spec
42
eclipse.spec
@ -11,11 +11,11 @@ Epoch: 1
|
||||
|
||||
%global eclipse_major 4
|
||||
%global eclipse_minor 4
|
||||
%global eclipse_micro 1
|
||||
%global eb_commit 2135919f7f0f11f3c43901b8e70819c9a4911ac3
|
||||
%global eclipse_tag R4_4_1
|
||||
%global eclipse_micro 2
|
||||
%global eb_commit 2775b93d3d9f147f5711c91bb3aa623f2582019d
|
||||
%global eclipse_tag R4_4_2
|
||||
%global eclipse_version %{eclipse_major}.%{eclipse_minor}.%{eclipse_micro}
|
||||
%global _jetty_version 9.2.3
|
||||
%global _jetty_version 9.2.9
|
||||
|
||||
%ifarch %{ix86}
|
||||
%define eclipse_arch x86
|
||||
@ -38,7 +38,7 @@ Epoch: 1
|
||||
Summary: An open, extensible IDE
|
||||
Name: %{?scl_prefix}eclipse
|
||||
Version: %{eclipse_version}
|
||||
Release: 17%{?dist}
|
||||
Release: 1%{?dist}
|
||||
License: EPL
|
||||
Group: Development/Tools
|
||||
URL: http://www.eclipse.org/
|
||||
@ -112,7 +112,6 @@ Patch21: %{pkg_name}-mockito.patch
|
||||
Patch22: %{pkg_name}-policy-comparators.patch
|
||||
|
||||
Patch23: %{pkg_name}-webkit2-support.patch
|
||||
Patch24: %{pkg_name}-bug-444143.patch
|
||||
|
||||
Patch25: %{pkg_name}-support-symlink-bundles.patch
|
||||
|
||||
@ -122,9 +121,6 @@ Patch25: %{pkg_name}-support-symlink-bundles.patch
|
||||
# the plugin in the top-level category so it still gets bundled.
|
||||
Patch26: %{pkg_name}-feature-plugins-to-category-ius.patch
|
||||
|
||||
# Make workspace selection dialog visible in the task manager of the OS
|
||||
Patch27: eclipse-workspace-chooser.patch
|
||||
|
||||
# Require hamcrest when using directly (cannot rely on junit reexporting it)
|
||||
Patch28: eclipse-direct-hamcrest-use.patch
|
||||
|
||||
@ -144,7 +140,6 @@ BuildRequires: desktop-file-utils
|
||||
BuildRequires: java-1.8.0-openjdk-devel
|
||||
BuildRequires: libXt-devel
|
||||
BuildRequires: webkitgtk-devel
|
||||
BuildRequires: webkitgtk4
|
||||
BuildRequires: webkitgtk4-devel
|
||||
BuildRequires: geronimo-annotation >= 1.0-7
|
||||
BuildRequires: %{?scl_prefix}icu4j >= 1:54.1.1-2
|
||||
@ -176,15 +171,15 @@ BuildRequires: xml-commons-apis >= 1.4.01-12
|
||||
BuildRequires: atinject >= 1-6
|
||||
BuildRequires: tycho >= 0.22
|
||||
BuildRequires: tycho-extras >= 0.22
|
||||
BuildRequires: eclipse-ecf-core >= 3.9.2-1
|
||||
BuildRequires: eclipse-ecf-core >= 3.9.2-2
|
||||
BuildRequires: eclipse-emf-core >= 1:2.10.1-3
|
||||
BuildRequires: glassfish-jsp-api >= 2.2.1-4
|
||||
BuildRequires: glassfish-jsp >= 2.2.5
|
||||
BuildRequires: glassfish-servlet-api >= 3.1.0
|
||||
BuildRequires: cbi-plugins
|
||||
BuildRequires: xml-maven-plugin
|
||||
BuildRequires: httpcomponents-core
|
||||
BuildRequires: httpcomponents-client
|
||||
BuildRequires: httpcomponents-core >= 4.4-1
|
||||
BuildRequires: httpcomponents-client >= 4.4-1
|
||||
BuildRequires: mockito
|
||||
%if ! %{bootstrap}
|
||||
BuildRequires: eclipse-pde
|
||||
@ -204,7 +199,7 @@ Requires: jpackage-utils
|
||||
Requires: gtk2
|
||||
Requires: gtk3
|
||||
Requires: webkitgtk
|
||||
Requires: webkitgtk3
|
||||
Requires: webkitgtk4
|
||||
|
||||
%description swt
|
||||
SWT Library for GTK+.
|
||||
@ -244,7 +239,7 @@ Requires: batik-css >= 1.8-0.17
|
||||
Requires: xml-commons-apis >= 1.4.01-12
|
||||
Requires: atinject >= 1-6
|
||||
Requires: geronimo-annotation >= 1.0-7
|
||||
Requires: eclipse-ecf-core >= 3.9.2-1
|
||||
Requires: eclipse-ecf-core >= 3.9.2-2
|
||||
Requires: eclipse-emf-core >= 1:2.10.1-3
|
||||
Requires: glassfish-jsp-api >= 2.2.1-4
|
||||
Requires: glassfish-jsp >= 2.2.5
|
||||
@ -252,8 +247,8 @@ Requires: glassfish-servlet-api >= 3.1.0
|
||||
Requires: %{?scl_prefix}icu4j >= 1:54.1.1-2
|
||||
Requires: %{name}-swt = %{epoch}:%{eclipse_version}-%{release}
|
||||
Requires: %{name}-equinox-osgi = %{epoch}:%{eclipse_version}-%{release}
|
||||
Requires: httpcomponents-core
|
||||
Requires: httpcomponents-client
|
||||
Requires: httpcomponents-core >= 4.4-1
|
||||
Requires: httpcomponents-client >= 4.4-1
|
||||
%{?scl:Requires: %scl_runtime}
|
||||
Obsoletes: %{name}-rcp < 1:4.3.0
|
||||
Provides: %{name}-rcp = 1:%{eclipse_version}-%{release}
|
||||
@ -339,10 +334,8 @@ tar --strip-components=1 -xf %{SOURCE1}
|
||||
%patch21
|
||||
%patch22
|
||||
%patch23
|
||||
%patch24 -p1
|
||||
%patch25
|
||||
%patch26
|
||||
%patch27 -p1
|
||||
%patch28
|
||||
|
||||
#Disable as many things as possible to make the build faster. We care only for Eclipse.
|
||||
@ -743,13 +736,13 @@ rm $RPM_BUILD_ROOT/%{_javadir}/eclipse-testing/runtests.bat
|
||||
|
||||
pushd $RPM_BUILD_ROOT/%{_javadir}/eclipse-testing/plugins
|
||||
f=`ls | grep -e "^org.easymock_"`
|
||||
rm -rf $f
|
||||
rm -rf $f
|
||||
ln -s %{_javadir}/easymock.jar ${f%.jar}.jar
|
||||
f=`ls | grep -e "^org.mockito.mockito-core_"`
|
||||
rm -rf $f
|
||||
rm -rf $f
|
||||
ln -s %{_javadir}/mockito.jar ${f%.jar}.jar
|
||||
f=`ls | grep -e "^org.objenesis_"`
|
||||
rm -rf $f
|
||||
rm -rf $f
|
||||
ln -s %{_javadir}/objenesis/objenesis.jar ${f%.jar}.jar
|
||||
# These are already present in the platform
|
||||
rm -rf org.hamcrest.core_*
|
||||
@ -1030,6 +1023,11 @@ fi
|
||||
%{_libdir}/%{pkg_name}/plugins/org.eclipse.osgi.compatibility.state_*
|
||||
|
||||
%changelog
|
||||
* Fri Feb 27 2015 Mat Booth <mat.booth@redhat.com> - 1:4.4.2-1
|
||||
- Update to Luna SR2 release
|
||||
- Drop upstreamed patches
|
||||
- Fixes rhbz#1177906
|
||||
|
||||
* Fri Jan 23 2015 Michael Simacek <msimacek@redhat.com> - 1:4.4.1-17
|
||||
- Rebuild against new jetty
|
||||
|
||||
|
@ -1,7 +1,7 @@
|
||||
#!/bin/bash
|
||||
set -e
|
||||
AGGREGATOR_PATH=git://git.eclipse.org/gitroot/platform/eclipse.platform.releng.aggregator.git
|
||||
TAG=R4_4_1
|
||||
TAG=R4_4_2
|
||||
|
||||
rm -rf R4_platform-aggregator-$TAG
|
||||
rm -rf R4_platform-aggregator-$TAG.tar.xz
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
0d857f3b64931672dca62142d7fbdbd0 R4_platform-aggregator-R4_4_1.tar.xz
|
||||
4c99218a93f07f77d356c9bf06ee1cce org.eclipse.linuxtools.eclipse-build-2135919f7f0f11f3c43901b8e70819c9a4911ac3.tar.bz2
|
||||
a5eea41345c311a3c6668eed12e27d42 R4_platform-aggregator-R4_4_2.tar.xz
|
||||
1497147a427b98a00a87263880063294 org.eclipse.linuxtools.eclipse-build-2775b93d3d9f147f5711c91bb3aa623f2582019d.tar.bz2
|
||||
|
Loading…
Reference in New Issue
Block a user