Update to last RC of Photon
This commit is contained in:
parent
05065b62ed
commit
be2a7ad2e8
4
.gitignore
vendored
4
.gitignore
vendored
@ -1,10 +1,7 @@
|
||||
eclipse-*-src.tar.bz2
|
||||
*.rpm
|
||||
eclipse-build-*.tar.gz
|
||||
eclipse-build-*.tar.xz
|
||||
eclipse-3.8.0-*-src.tar.bz2
|
||||
/R4_platform-aggregator-*
|
||||
/eclipse-source.tar.bz2
|
||||
/eclipse-jdtpdeupdatesite.tar.bz2
|
||||
/x86_64
|
||||
/results_eclipse
|
||||
@ -14,3 +11,4 @@ eclipse-3.8.0-*-src.tar.bz2
|
||||
/org.eclipse.linuxtools.eclipse-build-*.tar.bz2
|
||||
/org.eclipse.linuxtools.eclipse-build-*.tar.xz
|
||||
/org.eclipse.linuxtools.eclipse-build-*/
|
||||
/eclipse-platform-sources-*.tar.xz
|
||||
|
@ -14,7 +14,7 @@
|
||||
org.eclipse.ui.tests.menus
|
||||
--- eclipse.platform.ui/tests/org.eclipse.e4.ui.tests/META-INF/MANIFEST.MF.orig 2014-03-26 11:44:04.400306048 +0000
|
||||
+++ eclipse.platform.ui/tests/org.eclipse.e4.ui.tests/META-INF/MANIFEST.MF 2014-03-26 12:58:07.608331033 +0000
|
||||
@@ -32,8 +32,8 @@
|
||||
@@ -31,8 +31,8 @@
|
||||
org.eclipse.core.expressions;bundle-version="3.4.200",
|
||||
org.eclipse.e4.ui.workbench.addons.swt;bundle-version="0.9.0",
|
||||
org.eclipse.e4.ui.css.swt;bundle-version="0.11.0",
|
||||
|
@ -214,18 +214,15 @@ index 7e1f520..734dd10 100644
|
||||
+requires.11.filter = (&(osgi.os=linux)(osgi.ws=gtk)(osgi.arch=s390x)(!(org.eclipse.swt.buildtime=true)))
|
||||
--- a/rt.equinox.framework/features/org.eclipse.equinox.executable.feature/library/gtk/build.sh 2017-04-19 13:31:15.000000000 +0100
|
||||
+++ b/rt.equinox.framework/features/org.eclipse.equinox.executable.feature/library/gtk/build.sh 2017-04-23 16:58:34.022207885 +0100
|
||||
@@ -119,9 +119,9 @@
|
||||
@@ -119,7 +119,7 @@
|
||||
"s390x")
|
||||
defaultOSArch="s390x"
|
||||
defaultJava=DEFAULT_JAVA_EXEC
|
||||
- OUTPUT_DIR="$EXEC_DIR/contributed/$defaultWS/$defaultOS/$defaultOSArch"
|
||||
+ OUTPUT_DIR="$EXEC_DIR/bin/$defaultWS/$defaultOS/$defaultOSArch"
|
||||
;;
|
||||
- "arm*")
|
||||
+ arm*)
|
||||
arm*)
|
||||
defaultOSArch="arm"
|
||||
defaultJava=DEFAULT_JAVA_EXEC
|
||||
OUTPUT_DIR="$EXEC_DIR/bin/$defaultWS/$defaultOS/$defaultOSArch"
|
||||
--- a/rt.equinox.framework/pom.xml 2017-04-26 22:19:15.548461372 +0100
|
||||
+++ b/rt.equinox.framework/pom.xml 2017-04-26 22:20:41.348571492 +0100
|
||||
@@ -73,6 +73,18 @@
|
||||
|
49
eclipse.spec
49
eclipse.spec
@ -6,7 +6,7 @@
|
||||
Epoch: 1
|
||||
|
||||
%global eb_commit 81122c55c72d9e308302c878f642f93c39507436
|
||||
%global eclipse_tag I20180515-0950
|
||||
%global eclipse_tag I20180531-0700
|
||||
|
||||
%if 0%{?fedora} >= 28 || 0%{?rhel} > 7
|
||||
%global _jetty_version 9.4.9
|
||||
@ -35,7 +35,7 @@ Epoch: 1
|
||||
# Eclipse is arch-specific, but multilib agnostic
|
||||
%global _eclipsedir %{_prefix}/lib/eclipse
|
||||
|
||||
%if 0%{?fedora} >= 27 || 0%{?rhel} > 7
|
||||
%if 0%{?fedora} || 0%{?rhel} > 7
|
||||
%global use_wayland 1
|
||||
%else
|
||||
%global use_wayland 0
|
||||
@ -44,12 +44,12 @@ Epoch: 1
|
||||
Summary: An open, extensible IDE
|
||||
Name: eclipse
|
||||
Version: 4.8.0
|
||||
Release: 0.6%{?dist}
|
||||
Release: 0.8%{?dist}
|
||||
License: EPL
|
||||
URL: http://www.eclipse.org/
|
||||
|
||||
# Tarball generated by calling ./get-eclipse.sh
|
||||
Source0: R4_platform-aggregator-%{eclipse_tag}.tar.xz
|
||||
Source0: http://download.eclipse.org/eclipse/downloads/drops4/%{eclipse_tag}/eclipse-platform-sources-%{eclipse_tag}.tar.xz
|
||||
|
||||
# Can generate locally with:
|
||||
# git archive --format=tar --prefix=org.eclipse.linuxtools.eclipse-build-%%{eb_commit}/ \
|
||||
# %%{eb_commit} | xz > org.eclipse.linuxtools.eclipse-build-%%{eb_commit}.tar.xz
|
||||
@ -197,7 +197,6 @@ BuildRequires: batik-css >= 1.9-7
|
||||
BuildRequires: xmlgraphics-commons >= 2.2
|
||||
BuildRequires: xml-commons-apis
|
||||
BuildRequires: atinject
|
||||
BuildRequires: atinject-tck
|
||||
BuildRequires: eclipse-ecf-core >= 3.14.0-1
|
||||
BuildRequires: eclipse-emf-core >= 1:2.14.0-1
|
||||
BuildRequires: eclipse-license
|
||||
@ -368,10 +367,22 @@ Requires: %{name}-contributor-tools = %{epoch}:%{version}-%{release}
|
||||
Eclipse Tests.
|
||||
|
||||
%prep
|
||||
%setup -q %{SOURCE0} -n R4_platform-aggregator-%{eclipse_tag}
|
||||
%setup -q %{SOURCE0} -n eclipse-platform-sources-%{eclipse_tag}
|
||||
|
||||
# Extract linuxtools/eclipse-build sources
|
||||
tar --strip-components=1 -xf %{SOURCE1}
|
||||
|
||||
# Delete pre-built binary artifacts except some test data that cannot be generated
|
||||
find . ! -path "*/JCL/*" ! -name "rtstubs*.jar" ! -name "java10api.jar" \
|
||||
-type f -name *.jar -delete
|
||||
find . -type f -name *.class -delete
|
||||
find . -type f -name *.so -delete
|
||||
find . -type f -name *.dll -delete
|
||||
find . -type f -name *.jnilib -delete
|
||||
|
||||
# Remove pre-compiled native launchers
|
||||
rm -rf rt.equinox.binaries/org.eclipse.equinox.executable/{bin,contributed}/
|
||||
|
||||
%patch0
|
||||
%patch1
|
||||
%patch4
|
||||
@ -438,7 +449,14 @@ sed -i -e 's/groupId>org.eclipse.jdt</groupId>org.eclipse.tycho</' eclipse-platf
|
||||
%pom_disable_module bundles/org.eclipse.equinox.p2.artifact.processors rt.equinox.p2
|
||||
%pom_disable_module bundles/ie.wombat.jbdiff rt.equinox.p2
|
||||
%pom_disable_module bundles/ie.wombat.jbdiff.test rt.equinox.p2
|
||||
%pom_disable_module com.google.code.atinject.tck eclipse.platform.runtime/tests
|
||||
|
||||
# Don't need annotations for obsolete JDKs
|
||||
%pom_disable_module org.eclipse.jdt.annotation_v1 eclipse.jdt.core
|
||||
%pom_xpath_remove "plugin[@version='1.1.200.qualifier']" eclipse.jdt/org.eclipse.jdt-feature/feature.xml
|
||||
sed -i -e '/org\.eclipse\.jdt\.annotation;bundle-version="\[1\.1\.0,2\.0\.0)"/d' \
|
||||
eclipse.jdt.core/org.eclipse.jdt.core.tests.{model,builder,compiler}/META-INF/MANIFEST.MF \
|
||||
eclipse.jdt.core/org.eclipse.jdt.apt.pluggable.tests/META-INF/MANIFEST.MF \
|
||||
eclipse.jdt.ui/org.eclipse.jdt.ui.tests/META-INF/MANIFEST.MF
|
||||
|
||||
# Disable examples
|
||||
%pom_disable_module bundles/org.eclipse.sdk.examples eclipse.platform.releng
|
||||
@ -578,13 +596,6 @@ for f in rt.equinox.bundles/bundles/org.eclipse.equinox.security.linux.*/META-IN
|
||||
echo -e "Eclipse-BundleShape: dir\n\n" >> $f;
|
||||
done
|
||||
|
||||
# Java API stubs must be available at build time
|
||||
mkdir java10api
|
||||
pushd java10api
|
||||
xmvn -B -o install:install-file -Dfile=../eclipse.jdt.core/org.eclipse.jdt.compiler.apt/lib/java10api.jar \
|
||||
-Dpackaging=jar -DgroupId=org.eclipse -DartifactId=java10api -Dversion=10
|
||||
popd
|
||||
|
||||
# Add dep on Java API stubs when compiling with JDT
|
||||
%pom_xpath_inject "pom:pluginManagement/pom:plugins/pom:plugin[pom:artifactId='tycho-compiler-plugin']/pom:dependencies" \
|
||||
"<dependency><groupId>org.eclipse</groupId><artifactId>java10api</artifactId><version>10</version></dependency>" eclipse-platform-parent
|
||||
@ -1079,6 +1090,14 @@ fi
|
||||
%{_eclipsedir}/plugins/org.eclipse.osgi.util_*
|
||||
|
||||
%changelog
|
||||
* Thu Jun 07 2018 Mat Booth <mat.booth@redhat.com> - 1:4.8.0-0.8
|
||||
- Update to last RC of Photon
|
||||
|
||||
* Mon May 21 2018 Mat Booth <mat.booth@redhat.com> - 1:4.8.0-0.7
|
||||
- Updated I-build
|
||||
- Switch to using upstream tarball
|
||||
- Disable unused annotation bundle
|
||||
|
||||
* Mon May 21 2018 Mat Booth <mat.booth@redhat.com> - 1:4.8.0-0.6
|
||||
- Rebuild to correct permissions
|
||||
|
||||
|
@ -1,30 +0,0 @@
|
||||
#!/bin/bash
|
||||
set -e
|
||||
AGGREGATOR_PATH=git://git.eclipse.org/gitroot/platform/eclipse.platform.releng.aggregator.git
|
||||
TAG=I20180515-0950
|
||||
|
||||
rm -rf R4_platform-aggregator-$TAG
|
||||
rm -rf R4_platform-aggregator-$TAG.tar.xz
|
||||
|
||||
git clone --recursive -j2 --branch $TAG $AGGREGATOR_PATH R4_platform-aggregator-$TAG
|
||||
|
||||
pushd R4_platform-aggregator-$TAG
|
||||
|
||||
rm -rf production
|
||||
|
||||
# Comment this line to get a shallow clone.
|
||||
find . -type d -name ".git" | xargs rm -rf
|
||||
|
||||
# Delete pre-built binary artifacts except some test data that cannot be generated
|
||||
find . ! -path "*/JCL/*" ! -name "rtstubs*.jar" ! -name "java10api.jar" \
|
||||
-type f -name *.jar -delete
|
||||
find . -type f -name *.class -delete
|
||||
find . -type f -name *.so -delete
|
||||
find . -type f -name *.dll -delete
|
||||
find . -type f -name *.jnilib -delete
|
||||
# Remove pre-compiled native launchers
|
||||
rm -rf rt.equinox.binaries/org.eclipse.equinox.executable/{bin,contributed}/
|
||||
|
||||
popd
|
||||
|
||||
tar cJf R4_platform-aggregator-$TAG.tar.xz R4_platform-aggregator-$TAG
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (eclipse-platform-sources-I20180531-0700.tar.xz) = a34e3eb772a12d970a1b1bae1d063d337e3a9e581aa2576cd94af0c5563555558e68e395a337f47aefcf8375314be683ac87a270046fd2fc1d9d2cbd712515d5
|
||||
SHA512 (org.eclipse.linuxtools.eclipse-build-81122c55c72d9e308302c878f642f93c39507436.tar.xz) = 170d6801fd2c2f5f95c4d79cb14e36bb5db63142a52cafea81656f63dd132cf1a5b52b945fa0f85d4eed21ed660d22f46d2cdf9cde86e08fed06b16e9a22ed51
|
||||
SHA512 (R4_platform-aggregator-I20180515-0950.tar.xz) = 41f9b6022a0486e81f5e24eca44a6f98f1db7ec98a913dd469c938eeb6a3e47a05f30db01a1ecfadaa0c9924b930204a95993f8ebb2d5b94238f2eb92465a8ad
|
||||
|
Loading…
Reference in New Issue
Block a user