- Remove patches for the ecj package and others already applied upstream.

- Rediff some ppc64 patches.
This commit is contained in:
Alexander Kurtakov 2009-04-13 13:56:20 +00:00
parent 69c0ea0e48
commit bd30f33ad4
8 changed files with 21 additions and 324 deletions

View File

@ -1,4 +0,0 @@
#!/bin/sh
CLASSPATH=@JAVADIR@/eclipse-ecj.jar${CLASSPATH:+:}$CLASSPATH \
java org.eclipse.jdt.internal.compiler.batch.Main "$@"

View File

@ -53,16 +53,18 @@ diff -up ./features/org.eclipse.rcp/feature.xml.arches ./features/org.eclipse.rc
os="solaris"
ws="gtk"
diff -up ./features/org.eclipse.rcp.source/feature.xml.arches ./features/org.eclipse.rcp.source/feature.xml
--- ./features/org.eclipse.rcp.source/feature.xml.arches 2008-10-03 09:05:08.000000000 -0400
+++ ./features/org.eclipse.rcp.source/feature.xml 2008-10-03 09:07:51.000000000 -0400
@@ -45,6 +45,10 @@
<plugin id="org.eclipse.swt.motif.hpux.ia64_32.source" version="3.4.1.v3452b" os="hpux" arch="ia64_32" ws="motif" unpack="false"/>
<plugin id="org.eclipse.swt.motif.linux.x86.source" version="3.4.1.v3452b" os="linux" arch="x86" ws="motif" unpack="false"/>
<plugin id="org.eclipse.swt.gtk.linux.ia64.source" version="3.4.0.HEAD" os="linux" arch="ia64" ws="gtk" unpack="false"/>
+ <plugin id="org.eclipse.swt.gtk.linux.ppc64.source" version="3.4.1.v3452b" os="linux" arch="ppc64" ws="gtk" unpack="false"/>
+ <plugin id="org.eclipse.swt.gtk.linux.sparc.source" version="3.4.1.v3452b" os="linux" arch="sparc" ws="gtk" unpack="false"/>
+ <plugin id="org.eclipse.swt.gtk.linux.sparc64.source" version="3.4.1.v3452b" os="linux" arch="sparc64" ws="gtk" unpack="false"/>
+ <plugin id="org.eclipse.swt.gtk.linux.alpha.source" version="3.4.1.v3452b" os="linux" arch="alpha" ws="gtk" unpack="false"/>
<plugin id="org.eclipse.swt.motif.solaris.sparc.source" version="3.4.1.v3452b" os="solaris" arch="sparc" ws="motif" unpack="false"/>
<plugin id="org.eclipse.swt.photon.qnx.x86.source" version="3.4.1.v3452b" os="qnx" arch="x86" ws="photon" unpack="false"/>
<plugin id="org.eclipse.rcp.source" version="3.4.1.R342_v20090205" unpack="false"/>
--- ./features/org.eclipse.rcp.source/feature.xml.orig 2009-04-13 15:04:47.000000000 +0200
+++ ./features/org.eclipse.rcp.source/feature.xml 2009-04-13 15:07:51.000000000 +0200
@@ -49,7 +49,11 @@
<plugin id="org.eclipse.swt.motif.hpux.ia64_32.source" version="3.5.0.v3539" os="hpux" arch="ia64_32" ws="motif" unpack="false"/>
<plugin id="org.eclipse.swt.motif.linux.x86.source" version="3.5.0.v3539" os="linux" arch="x86" ws="motif" unpack="false"/>
<plugin id="org.eclipse.swt.gtk.linux.ia64.source" version="3.5.0.HEAD" os="linux" arch="ia64" ws="gtk" unpack="false"/>
- <plugin id="org.eclipse.swt.motif.solaris.sparc.source" version="3.5.0.v3539" os="solaris" arch="sparc" ws="motif" unpack="false"/>
+ <plugin id="org.eclipse.swt.gtk.linux.ppc64.source" version="3.5.0.v3539" os="linux" arch="ppc64" ws="gtk" unpack="false"/>
+ <plugin id="org.eclipse.swt.gtk.linux.sparc.source" version="3.5.0.v3539" os="linux" arch="sparc" ws="gtk" unpack="false"/>
+ <plugin id="org.eclipse.swt.gtk.linux.sparc64.source" version="3.5.0.v3539" os="linux" arch="sparc64" ws="gtk" unpack="false"/>
+ <plugin id="org.eclipse.swt.gtk.linux.alpha.source" version="3.5.0.v3539" os="linux" arch="alpha" ws="gtk" unpack="false"/>
+ <plugin id="org.eclipse.swt.motif.solaris.sparc.source" version="3.5.0.v3539" os="solaris" arch="sparc" ws="motif" unpack="false"/>
<plugin id="org.eclipse.swt.photon.qnx.x86.source" version="3.5.0.v3539" os="qnx" arch="x86" ws="photon" unpack="false"/>
<plugin id="org.eclipse.rcp.source" version="3.4.0.v20080507" unpack="false"/>
<plugin id="org.eclipse.core.contenttype.source" version="3.4.0.v20090302" unpack="false"/>

View File

@ -53,18 +53,6 @@
<available property="@dot" file="${build.result.folder}/@dot" />
--- ./plugins/org.eclipse.swt.gtk.linux.s390x/build.xml.orig 2009-03-24 18:54:29.000000000 +0100
+++ ./plugins/org.eclipse.swt.gtk.linux.s390x/build.xml 2009-03-25 10:08:51.000000000 +0100
@@ -276,6 +276,11 @@
</target>
<target name="build.cfiles" depends="build.jars">
+ <!-- delete swttools.jar so that it will be compiled in the build.jars target -->
+ <ant antfile="build.xml" dir="${toolsplugindir}" inheritAll="false" target="clean"/>
+ <!--compile swtools.jar in org.eclipse.swt.tools-->
+ <ant antfile="build.xml" dir="${toolsplugindir}" inheritAll="false" target="build.jars" />
+
<!-- generate the C code from the (64 bit) SWT PI java classes -->
<!-- assumes the swt.jar has already been built -->
<java classname="org.eclipse.swt.tools.internal.JNIGeneratorApp" classpath="${toolsplugindir}/bin:${toolsplugindir}/swttools.jar:${basedir}/swt.jar">
@@ -330,6 +335,7 @@
<fileset dir="${basedir}/src/Eclipse SWT Mozilla/common/library" />
<fileset dir="${basedir}/src/Eclipse SWT OpenGL/glx/library" />

View File

@ -1,44 +0,0 @@
### Eclipse Workspace Patch 1.0
#P org.eclipse.jdt.core
Index: compiler/org/eclipse/jdt/internal/compiler/impl/CompilerOptions.java
===================================================================
RCS file: /cvsroot/eclipse/org.eclipse.jdt.core/compiler/org/eclipse/jdt/internal/compiler/impl/CompilerOptions.java,v
retrieving revision 1.203
diff -u -r1.203 CompilerOptions.java
--- compiler/org/eclipse/jdt/internal/compiler/impl/CompilerOptions.java 14 Apr 2008 19:41:33 -0000 1.203
+++ compiler/org/eclipse/jdt/internal/compiler/impl/CompilerOptions.java 15 Dec 2008 19:50:02 -0000
@@ -253,9 +253,9 @@
// By default only lines and source attributes are generated.
public int produceDebugAttributes = ClassFileConstants.ATTR_SOURCE | ClassFileConstants.ATTR_LINES;
- public long complianceLevel = ClassFileConstants.JDK1_4; // by default be compliant with 1.4
- public long sourceLevel = ClassFileConstants.JDK1_3; //1.3 source behavior by default
- public long targetJDK = ClassFileConstants.JDK1_2; // default generates for JVM1.2
+ public long complianceLevel = ClassFileConstants.JDK1_5; // by default be compliant with 1.4
+ public long sourceLevel = ClassFileConstants.JDK1_5; //1.3 source behavior by default
+ public long targetJDK = ClassFileConstants.JDK1_5; // default generates for JVM1.2
// source encoding format
public String defaultEncoding = null; // will use the platform default encoding
@@ -757,7 +757,7 @@
} else if (DISABLED.equals(optionValue)) {
this.reportUnusedParameterIncludeDocCommentReference = false;
}
- }
+ }
if ((optionValue = optionsMap.get(OPTION_ReportSpecialParameterHidingField)) != null) {
if (ENABLED.equals(optionValue)) {
this.reportSpecialParameterHidingField = true;
@@ -944,10 +944,10 @@
}
if ((optionValue = optionsMap.get(OPTION_ReportMissingJavadocComments)) != null) {
updateSeverity(MissingJavadocComments, optionValue);
- }
+ }
if ((optionValue = optionsMap.get(OPTION_ReportMissingJavadocTagDescription)) != null) {
this.reportMissingJavadocTagDescription = (String) optionValue;
- }
+ }
if ((optionValue = optionsMap.get(OPTION_ReportMissingJavadocCommentsVisibility)) != null) {
if (PUBLIC.equals(optionValue)) {
this.reportMissingJavadocCommentsVisibility = ClassFileConstants.AccPublic;

View File

@ -1,196 +0,0 @@
### Eclipse Workspace Patch 1.0
#P org.eclipse.jdt.core
Index: batch/org/eclipse/jdt/internal/compiler/batch/Main.java
===================================================================
RCS file: /cvsroot/eclipse/org.eclipse.jdt.core/batch/org/eclipse/jdt/internal/compiler/batch/Main.java,v
retrieving revision 1.327
diff -u -r1.327 Main.java
--- batch/org/eclipse/jdt/internal/compiler/batch/Main.java 21 Apr 2008 15:00:59 -0000 1.327
+++ batch/org/eclipse/jdt/internal/compiler/batch/Main.java 20 Nov 2008 19:26:57 -0000
@@ -268,22 +268,22 @@
if ((startPosition > endPosition)
|| ((startPosition < 0) && (endPosition < 0))
|| length == 0)
- return Messages.problem_noSourceInformation;
+ return Messages.problem_noSourceInformation;
StringBuffer errorBuffer = new StringBuffer();
if ((bits & Main.Logger.EMACS) == 0) {
- errorBuffer.append(' ').append(Messages.bind(Messages.problem_atLine, String.valueOf(problem.getSourceLineNumber())));
+ errorBuffer.append(' ').append(Messages.bind(Messages.problem_atLine, String.valueOf(problem.getSourceLineNumber())));
errorBuffer.append(Util.LINE_SEPARATOR);
}
errorBuffer.append('\t');
-
+
char c;
final char SPACE = '\u0020';
final char MARK = '^';
final char TAB = '\t';
//the next code tries to underline the token.....
//it assumes (for a good display) that token source does not
- //contain any \r \n. This is false on statements !
+ //contain any \r \n. This is false on statements !
//(the code still works but the display is not optimal !)
// expand to line limits
@@ -295,11 +295,11 @@
for (end = endPosition >= length ? length - 1 : endPosition ; end+1 < length; end++) {
if ((c = unitSource[end + 1]) == '\r' || c == '\n') break;
}
-
+
// trim left and right spaces/tabs
while ((c = unitSource[begin]) == ' ' || c == '\t') begin++;
//while ((c = unitSource[end]) == ' ' || c == '\t') end--; TODO (philippe) should also trim right, but all tests are to be updated
-
+
// copy source
errorBuffer.append(unitSource, begin, end-begin+1);
errorBuffer.append(Util.LINE_SEPARATOR).append("\t"); //$NON-NLS-1$
@@ -424,7 +424,7 @@
String.valueOf(generateTime),
String.valueOf(((int) (generateTime * 1000.0 / time)) / 10.0),
}));
- }
+ }
}
public void logClassFile(boolean generatePackagesStructure, String outputPath, String relativeFileName) {
if ((this.tagBits & Logger.XML) != 0) {
@@ -916,7 +916,7 @@
this.main.bind("compile.totalTime", //$NON-NLS-1$
new String[] {
String.valueOf(time),
- }));
+ }));
}
if ((this.main.timing & Main.TIMING_DETAILED) != 0) {
this.printlnOut(
@@ -1119,7 +1119,7 @@
this.endTag(Logger.STATS);
}
}
-
+
private void printTag(String name, HashMap params, boolean insertNewLine, boolean closeTag) {
if (this.log != null) {
((GenericXMLWriter) this.log).printTag(name, parameters, true, insertNewLine, closeTag);
@@ -1245,12 +1245,12 @@
boolean warnJavadocOn;
boolean warnAllJavadocOn;
-
+
public Compiler batchCompiler;
/* Bundle containing messages */
public ResourceBundle bundle;
protected FileSystem.Classpath[] checkedClasspaths;
-
+
public Locale compilerLocale;
public CompilerOptions compilerOptions; // read-only
public CompilationProgress progress;
@@ -1299,7 +1299,7 @@
public static final int TIMING_DISABLED = 0;
public static final int TIMING_ENABLED = 1;
public static final int TIMING_DETAILED = 2;
-
+
public int timing = TIMING_DISABLED;
public CompilerStats[] compilerStats;
public boolean verbose = false;
@@ -1312,7 +1312,7 @@
// two uses: recognize 'none' in options; code the singleton none
// for the '-d none' option (wherever it may be found)
public static final int DEFAULT_SIZE_CLASSPATH = 4;
-
+
public static final String NONE = "none"; //$NON-NLS-1$
/**
@@ -1562,7 +1562,7 @@
}
/**
* Return true if and only if the running VM supports the given minimal version.
- *
+ *
* <p>This only checks the major version, since the minor version is always 0 (at least for the useful cases).</p>
* <p>The given minimalSupportedVersion is one of the constants:</p>
* <ul>
@@ -2536,8 +2536,8 @@
mode = DEFAULT;
continue;
}
-
- // set DocCommentSupport, with appropriate side effects on defaults if
+
+ // set DocCommentSupport, with appropriate side effects on defaults if
// javadoc is not enabled
if (this.enableJavadocOn) {
this.options.put(
@@ -2601,7 +2601,7 @@
this.logger.logVersion(printVersionRequired);
validateOptions(didSpecifyCompliance);
-
+
// Enable annotation processing by default in batch mode when compliance is at least 1.6
// see bug https://bugs.eclipse.org/bugs/show_bug.cgi?id=185768
if (!didSpecifyDisabledAnnotationProcessing
@@ -2609,6 +2609,29 @@
this.options.put(CompilerOptions.OPTION_Process_Annotations, CompilerOptions.ENABLED);
}
+ {
+ // If we're building an RPM, force full debugging info to
+ // be generated, no matter what options have been passed
+ // by Ant. This is something of a kludge, but it is far
+ // better than the alternative, which is having class
+ // files with debug info mysteriously missing.
+
+ String RpmPackageName = System.getenv("RPM_PACKAGE_NAME");
+ String RpmArch = System.getenv("RPM_ARCH");
+ String RpmBuildRoot = System.getenv("RPM_BUILD_ROOT");
+ if (RpmPackageName != null && RpmArch != null && RpmBuildRoot != null) {
+ this.options.put(
+ CompilerOptions.OPTION_LocalVariableAttribute,
+ CompilerOptions.GENERATE);
+ this.options.put(
+ CompilerOptions.OPTION_LineNumberAttribute,
+ CompilerOptions.GENERATE);
+ this.options.put(
+ CompilerOptions.OPTION_SourceFileAttribute,
+ CompilerOptions.GENERATE);
+ }
+ }
+
this.logger.logCommandLineArguments(newCommandLineArgs);
this.logger.logOptions(this.options);
@@ -2636,7 +2659,7 @@
0,
classCount);
}
-
+
setPaths(bootclasspaths,
sourcepathClasspathArg,
sourcepathClasspaths,
@@ -2644,7 +2667,7 @@
extdirsClasspaths,
endorsedDirClasspaths,
customEncoding);
-
+
if (this.pendingErrors != null) {
for (Iterator iterator = this.pendingErrors.iterator(); iterator.hasNext(); ) {
String message = (String) iterator.next();
@@ -3376,7 +3399,7 @@
} else if (token.equals("unusedTypeArgs")) { //$NON-NLS-1$
this.options.put(
CompilerOptions.OPTION_ReportUnusedTypeArgumentsForMethodInvocation,
- isEnabling ? CompilerOptions.WARNING : CompilerOptions.IGNORE);
+ isEnabling ? CompilerOptions.WARNING : CompilerOptions.IGNORE);
} else {
addPendingErrors(this.bind("configure.invalidWarning", token)); //$NON-NLS-1$
}

View File

@ -1,18 +0,0 @@
### Eclipse Workspace Patch 1.0
#P org.eclipse.pde.api.tools.ui
Index: src/org/eclipse/pde/api/tools/ui/internal/wizards/ApiProfileWizardPage.java
===================================================================
RCS file: /cvsroot/eclipse/org.eclipse.pde.api.tools.ui/src/org/eclipse/pde/api/tools/ui/internal/wizards/ApiProfileWizardPage.java,v
retrieving revision 1.25
diff -u -r1.25 ApiProfileWizardPage.java
--- src/org/eclipse/pde/api/tools/ui/internal/wizards/ApiProfileWizardPage.java 22 May 2008 15:36:51 -0000 1.25
+++ src/org/eclipse/pde/api/tools/ui/internal/wizards/ApiProfileWizardPage.java 26 Jun 2008 14:12:52 -0000
@@ -309,7 +309,7 @@
}
Collections.sort(items, new Comparator() {
public int compare(Object o1, Object o2) {
- return ((String)o1).compareTo(o2);
+ return ((String)o1).compareTo((String) o2);
}
});

View File

@ -1,34 +0,0 @@
### Eclipse Workspace Patch 1.0
#P org.eclipse.pde.api.tools
Index: src_ant/org/eclipse/pde/api/tools/internal/tasks/DeltaReportConversionTask.java
===================================================================
RCS file: /cvsroot/eclipse/org.eclipse.pde.api.tools/src_ant/org/eclipse/pde/api/tools/internal/tasks/DeltaReportConversionTask.java,v
retrieving revision 1.3
diff -u -r1.3 DeltaReportConversionTask.java
--- src_ant/org/eclipse/pde/api/tools/internal/tasks/DeltaReportConversionTask.java 14 May 2008 15:02:51 -0000 1.3
+++ src_ant/org/eclipse/pde/api/tools/internal/tasks/DeltaReportConversionTask.java 26 Jun 2008 13:56:12 -0000
@@ -288,7 +288,7 @@
public int compare(Object o1, Object o2) {
Map.Entry entry1 = (Map.Entry) o1;
Map.Entry entry2 = (Map.Entry) o2;
- return ((String) entry1.getKey()).compareTo(entry2.getKey());
+ return ((String) entry1.getKey()).compareTo((String) entry2.getKey());
}
});
for (Iterator iterator = allEntries.iterator(); iterator.hasNext(); ) {
Index: src_ant/org/eclipse/pde/api/tools/internal/tasks/APIToolsVerificationTask.java
===================================================================
RCS file: /cvsroot/eclipse/org.eclipse.pde.api.tools/src_ant/org/eclipse/pde/api/tools/internal/tasks/APIToolsVerificationTask.java,v
retrieving revision 1.8
diff -u -r1.8 APIToolsVerificationTask.java
--- src_ant/org/eclipse/pde/api/tools/internal/tasks/APIToolsVerificationTask.java 26 May 2008 19:59:29 -0000 1.8
+++ src_ant/org/eclipse/pde/api/tools/internal/tasks/APIToolsVerificationTask.java 26 Jun 2008 13:56:12 -0000
@@ -656,7 +656,7 @@
public int compare(Object o1, Object o2) {
Map.Entry entry1 = (Map.Entry) o1;
Map.Entry entry2 = (Map.Entry) o2;
- return ((String) entry1.getKey()).compareTo(entry2.getKey());
+ return ((String) entry1.getKey()).compareTo((String) entry2.getKey());
}
});
Summary[] summaries = new Summary[size];

View File

@ -29,7 +29,7 @@ Epoch: 1
Summary: An open, extensible IDE
Name: eclipse
Version: %{eclipse_majmin}.%{eclipse_micro}
Release: 0.1.12%{?dist}
Release: 0.2%{?dist}
License: EPL
Group: Text Editors/Integrated Development Environments (IDE)
URL: http://www.eclipse.org/
@ -409,8 +409,7 @@ sed --in-place "s|$swt_frag_ver_s390x|$swt_frag_ver|g" plugins/org.eclipse.swt.g
# Nasty hack to get suppport for ppc64, sparc{,64} and alpha
%patch24 -p1
# TODO check this patch
#%patch28
%patch28
# TODO and this one
#%patch30
%patch31 -p1
@ -1593,6 +1592,10 @@ fi
#%{_libdir}/%{name}/configuration/org.eclipse.equinox.source
%changelog
* Mon Apr 13 2009 Alexander Kurtakov <akurtako@redhat.com> 1:3.5.0-0.2
- Remove patches for the ecj package and others already applied upstream.
- Rediff some ppc64 patches.
* Mon Apr 13 2009 Alexander Kurtakov <akurtako@redhat.com> 1:3.5.0-0.1.12
- o.e.update.core.linux is x86 only.