- Remove all testframework sources, patches, build and etc.
This commit is contained in:
parent
1de46433dd
commit
b1b2bbce7c
11
.cvsignore
11
.cvsignore
@ -1,15 +1,4 @@
|
||||
ecf-filetransfer-v20080611-1715.tar.bz2
|
||||
eclipse-ecj-gcj.tar.bz2
|
||||
eclipse-fileinitializerapp.tar.bz2
|
||||
eclipse-sourceBuild-srcIncluded-3.4.1.zip
|
||||
eclipse-3.4.1-testframework.tar.bz2
|
||||
pre320changelog.txt
|
||||
eclipse-sourceBuild-srcIncluded-3.4.2.zip
|
||||
eclipse-3.4.2-testframework.tar.bz2
|
||||
eclipse-sourceBuild-srcIncluded-I20090401-1325.zip
|
||||
eclipse-sourceBuild-srcIncluded-I20090416-1053.zip
|
||||
eclipse-I20090611-1540-fetched-src.tar.bz2
|
||||
eclipse-3.5.0-testframework.tar.bz2
|
||||
eclipse-build-generatedScripts.tar.bz2
|
||||
eclipse-build-R0_0_2_1.tar.gz
|
||||
eclipse-build-R0_3_0.tar.gz
|
||||
|
@ -1,18 +0,0 @@
|
||||
diff -up ./org.eclipse.test-feature/feature.xml.nowin32 ./org.eclipse.test-feature/feature.xml
|
||||
--- ./org.eclipse.test-feature/feature.xml.nowin32 2008-08-27 10:14:56.000000000 -0400
|
||||
+++ ./org.eclipse.test-feature/feature.xml 2008-08-27 10:15:04.000000000 -0400
|
||||
@@ -58,14 +58,6 @@
|
||||
unpack="false"/>
|
||||
|
||||
<plugin
|
||||
- id="org.eclipse.test.performance.win32"
|
||||
- download-size="0"
|
||||
- install-size="0"
|
||||
- version="0.0.0"
|
||||
- fragment="true"
|
||||
- unpack="false"/>
|
||||
-
|
||||
- <plugin
|
||||
id="org.junit"
|
||||
download-size="0"
|
||||
install-size="0"
|
@ -1,192 +0,0 @@
|
||||
### Eclipse Workspace Patch 1.0
|
||||
#P org.eclipse.test
|
||||
Index: library.xml
|
||||
===================================================================
|
||||
RCS file: /cvsroot/eclipse/org.eclipse.test/library.xml,v
|
||||
retrieving revision 1.33
|
||||
diff -u -r1.33 library.xml
|
||||
--- library.xml 13 Mar 2008 14:00:36 -0000 1.33
|
||||
+++ library.xml 7 May 2009 18:49:56 -0000
|
||||
@@ -6,13 +6,13 @@
|
||||
</target>
|
||||
|
||||
<target name="init">
|
||||
- <!--
|
||||
+ <!--
|
||||
Parameters:
|
||||
(Mandatory)
|
||||
data-dir - the directory for Eclipse to write its data
|
||||
plugin-name - the name of the plugin to test
|
||||
classname - the name of the test class
|
||||
-
|
||||
+
|
||||
(Optional - overrides defaults set in script)
|
||||
vmargs - a string containing arguments to pass to the VM.
|
||||
extraVMargs - allows separate setting of VM args from separate caller.
|
||||
@@ -22,7 +22,7 @@
|
||||
useEclipseExe - property setting forces test to launch via eclipse executable.
|
||||
junit-report-output - output directory for junit reports produced for specified classname.
|
||||
-->
|
||||
-
|
||||
+
|
||||
<tstamp>
|
||||
<format property="TIMENOW" pattern="HHmmssSSSS"/>
|
||||
</tstamp>
|
||||
@@ -33,25 +33,30 @@
|
||||
<!--default launch target for launching tests-->
|
||||
<property name="launchTarget" value="java-test" />
|
||||
<property name="formatter" value="org.apache.tools.ant.taskdefs.optional.junit.XMLJUnitResultFormatter"/>
|
||||
-
|
||||
+
|
||||
<!--default heap sizes when running performance tests-->
|
||||
<condition property="vmargs" value=" -Xms256M -Xmx256M">
|
||||
<equals arg1="${test.target}" arg2="performance" />
|
||||
</condition>
|
||||
+ <condition property="extraVMargs" value=" -Xdebug -Xrunjdwp:transport=dt_socket,server=y,suspend=y,address=40000">
|
||||
+ <equals arg1="${debugTests}" arg2="true" />
|
||||
+ </condition>
|
||||
<property name="extraVMargs" value=""/>
|
||||
<property name="plugin-path" value="" />
|
||||
+ <property name="tmpresults" value="${eclipse-home}/tmpresults/" />
|
||||
+ <property name="testhome" value="${eclipse-home}/testhome" />
|
||||
<property name="timeout" value="7200000" />
|
||||
- <property name="test-output" value="${eclipse-home}/${classname}.xml" />
|
||||
+ <property name="test-output" value="${tmpresults}/${classname}.xml" />
|
||||
<property name="junit-report-output" value="${eclipse-home}/results" />
|
||||
<mkdir dir="${junit-report-output}"/>
|
||||
</target>
|
||||
-
|
||||
+
|
||||
<target name="core-test" description="Eclipse application used to launch HEADLESS plugin tests." depends="init">
|
||||
<antcall target="${launchTarget}">
|
||||
<param name="application" value="org.eclipse.test.coretestapplication"/>
|
||||
</antcall>
|
||||
</target>
|
||||
-
|
||||
+
|
||||
<target name="ui-test" description="Eclipse application used to launch UI plugin tests." depends="init">
|
||||
<antcall target="${launchTarget}">
|
||||
<param name="application" value="org.eclipse.test.uitestapplication"/>
|
||||
@@ -60,13 +65,17 @@
|
||||
|
||||
<target name="java-test">
|
||||
<!--default vm args-->
|
||||
- <property name="vmargs" value=" -Xms40m -Xmx256m"/>
|
||||
-
|
||||
+ <property name="vmargs" value=" -Xms256m -Xmx1024m -XX:MaxPermSize=512m"/>
|
||||
+ <delete failonerror="false" includeEmptyDirs="true">
|
||||
+ <fileset dir="${testhome}" includes="**/*"/>
|
||||
+ </delete>
|
||||
+ <mkdir dir="${testhome}"/>
|
||||
+
|
||||
<!--set default jvm to use for testing-->
|
||||
- <property name="jvm" value="${java.home}/bin/java" />
|
||||
-
|
||||
+ <property name="jvm" value="${java.home}/bin/java" />
|
||||
+
|
||||
<echo message="Running ${classname}. Result file: ${junit-report-output}/${classname}.xml."/>
|
||||
-
|
||||
+
|
||||
<java fork="true" dir="." timeout="${timeout}" jvm="${jvm}" logError="true"
|
||||
classname="org.eclipse.core.launcher.Main" output="${junit-report-output}/${classname}.txt">
|
||||
<classpath>
|
||||
@@ -75,7 +84,7 @@
|
||||
</fileset>
|
||||
</classpath>
|
||||
<arg line="-application ${application}"/>
|
||||
- <arg line="-data ${data-dir}"/>
|
||||
+ <arg line="-data ${test-data-dir}"/>
|
||||
<arg line="formatter=${formatter},${test-output}"/>
|
||||
<arg line="-testPluginName ${plugin-name}"/>
|
||||
<arg line="-className ${classname}"/>
|
||||
@@ -83,15 +92,31 @@
|
||||
<arg line="-ws ${ws}"/>
|
||||
<arg line="-arch ${arch}"/>
|
||||
<arg line="-consolelog"/>
|
||||
+ <arg line="-clean"/>
|
||||
+ <arg line="-Dswt.library.path=/usr/lib/eclipse"/>
|
||||
+ <arg line="-Dsetup.override.vmArgs=Xms256m;Xmx1024m"/>
|
||||
+ <arg line="-Dsetup.override.systemProperties=PLUGIN_PATH=${plugin-path};user.home=${testhome}"/>
|
||||
<jvmarg line="${vmargs} ${extraVMargs}"/>
|
||||
- <sysproperty key="PLUGIN_PATH" value="${plugin-path}"/>
|
||||
+ <sysproperty key="PLUGIN_PATH" value="${plugin-path}"/>
|
||||
+ <sysproperty key="user.home" value="${testhome}"/>
|
||||
+ <sysproperty key="swt.library.path" value="/usr/lib/eclipse"/>
|
||||
+ <sysproperty key="setup.override.vmArgs" value="Xms256m;Xmx1024m"/>
|
||||
+ <sysproperty key="setup.override.systemProperties" value="PLUGIN_PATH=${plugin-path};user.home=${testhome}"/>
|
||||
+ <sysproperty key="sdk.tests.data.dir" value="${data-dir}"/>
|
||||
+ <sysproperty key="org.eclipse.equinox.p2.reconciler.tests.platform.archive" value="${tmpresults}/eclipse-platform-archive.tar.gz"/>
|
||||
+ <sysproperty key="osgi.configuration.area" value="${data-dir}"/>
|
||||
</java>
|
||||
<antcall target="collect-results" />
|
||||
</target>
|
||||
-
|
||||
- <target name="eclipse-test" description="Runs the specified classname as a plug-in test.">
|
||||
+
|
||||
+ <target name="eclipse-test" description="Runs the specified classname as a plug-in test.">
|
||||
<property name="vmargs" value="-Xms256m -Xmx512m"/>
|
||||
-
|
||||
+
|
||||
+ <delete failonerror="false" includeEmptyDirs="true">
|
||||
+ <fileset dir="${testhome}" includes="**/*"/>
|
||||
+ </delete>
|
||||
+ <mkdir dir="${testhome}"/>
|
||||
+
|
||||
<!--use -consolelog if launching a headless test-->
|
||||
<condition property="consolelog" value="-consolelog">
|
||||
<equals arg1="${application}" arg2="org.eclipse.test.coretestapplication"/>
|
||||
@@ -107,11 +132,11 @@
|
||||
<isset property="jvm" />
|
||||
</condition>
|
||||
<property name="test-vm" value="" />
|
||||
-
|
||||
+
|
||||
<!--ensure executable has execute permission-->
|
||||
<chmod file="${eclipse-home}/eclipse" perm="ugo+rx"/>
|
||||
-
|
||||
-
|
||||
+
|
||||
+
|
||||
<echo message="Running ${classname}. Result file: ${junit-report-output}/${classname}.xml."/>
|
||||
|
||||
<exec executable="${eclipse-home}/eclipse" dir="${eclipse-home}" timeout="${timeout}" logError="true" failonerror="false" output="${junit-report-output}/${classname}.txt">
|
||||
@@ -125,10 +150,12 @@
|
||||
<arg line="--launcher.suppressErrors"/>
|
||||
<arg line="${consolelog}"/>
|
||||
<arg line="-vmargs ${vmargs} ${extraVMargs} -DPLUGIN_PATH=${plugin-path}"/>
|
||||
+ <arg line="-Duser.home=${testhome}"/>
|
||||
+ <arg line="-Dsetup.override.systemProperties=PLUGIN_PATH=${plugin-path};user.home=${testhome}"/>
|
||||
</exec>
|
||||
<antcall target="collect-results" />
|
||||
</target>
|
||||
-
|
||||
+
|
||||
<target name="collect-results">
|
||||
<dirname property="output-dir" file="${test-output}"/>
|
||||
<basename property="output-file-name" file="${test-output}"/>
|
||||
@@ -138,7 +165,7 @@
|
||||
</fileset>
|
||||
</junitreport>
|
||||
|
||||
- <style style="${eclipse-home}/dropins/eclipse/plugins/org.eclipse.test/JUNIT.XSL"
|
||||
+ <style style="${eclipse-home}/dropins/sdk/plugins/org.eclipse.test/JUNIT.XSL"
|
||||
basedir="${junit-report-output}"
|
||||
includes="${classname}.result.xml"
|
||||
destdir="${junit-report-output}" />
|
||||
@@ -153,13 +180,13 @@
|
||||
<target name="collect">
|
||||
<!--
|
||||
This target can be used to aggragate test runs from multiple test suites into a single report.
|
||||
-
|
||||
+
|
||||
Parameters to this target:
|
||||
includes - the names of the files to include
|
||||
output-file - the name of the output file to produce
|
||||
-->
|
||||
- <junitreport todir="." tofile="${output-file}">
|
||||
- <fileset dir=".">
|
||||
+ <junitreport todir="${results}" tofile="${output-file}">
|
||||
+ <fileset dir="${tmpresults}">
|
||||
<include name="${includes}"/>
|
||||
</fileset>
|
||||
</junitreport>
|
68
eclipse.spec
68
eclipse.spec
@ -30,7 +30,7 @@ Epoch: 1
|
||||
Summary: An open, extensible IDE
|
||||
Name: eclipse
|
||||
Version: %{eclipse_majmin}.%{eclipse_micro}
|
||||
Release: 0.8%{?dist}
|
||||
Release: 0.9%{?dist}
|
||||
License: EPL
|
||||
Group: Text Editors/Integrated Development Environments (IDE)
|
||||
URL: http://www.eclipse.org/
|
||||
@ -58,18 +58,6 @@ Source26: ecf-filetransfer-feature.xml
|
||||
Source27: ecf-filetransfer-build.properties
|
||||
# This script copies the platform sub-set of the SDK for generating metadata
|
||||
Source28: %{name}-mv-Platform.sh
|
||||
# Test feature and plugins
|
||||
# cvs -d :pserver:anonymous@dev.eclipse.org:/cvsroot/eclipse co equinox-incubator/org.eclipse.equinox.initializer
|
||||
# mkdir %{name}-%{version}-testframework; cd %{name}-%{version}-testframework
|
||||
# cvs -d :pserver:anonymous@dev.eclipse.org:/cvsroot/eclipse export -r R3_4 \
|
||||
# org.eclipse.test \
|
||||
# org.eclipse.test.performance \
|
||||
# org.eclipse.test-feature \
|
||||
# org.eclipse.ant.optional.junit
|
||||
# tar cjf %{name}-%{version}-testframework.tar.bz2 \
|
||||
# %{name}-%{version}-testframework
|
||||
# (generated 2009-07-23)
|
||||
Source30: %{name}-%{version}-testframework.tar.bz2
|
||||
|
||||
# Build swttools.jar before generation on 64-bit platforms.
|
||||
# Build SWT native libraries
|
||||
@ -122,13 +110,6 @@ Patch37: %{name}-nojarsignatures.patch
|
||||
#Patch39: %{name}-profilesync-e.o242632.patch
|
||||
#Patch40: %{name}-profilesync-e.o242632-2.patch
|
||||
|
||||
# Remove win32 fragment from test feature
|
||||
Patch41: %{name}-nowin32testfragment.patch
|
||||
|
||||
# Some fixes for library.xml
|
||||
# FIXME: submit upstream
|
||||
Patch42: %{name}-tests-libraryXml.patch
|
||||
|
||||
Patch43: %{name}-osgi-classpath.patch
|
||||
Patch44: %{name}-fix-javahome64.patch
|
||||
|
||||
@ -648,16 +629,6 @@ fi
|
||||
#popd
|
||||
#popd
|
||||
|
||||
# Test framework
|
||||
tar jxf %{SOURCE30}
|
||||
pushd %{name}-%{version}-testframework
|
||||
%patch41
|
||||
pushd org.eclipse.test
|
||||
%patch42
|
||||
popd
|
||||
sed -i "s:/usr/lib/eclipse:%{_libdir}/%{name}:" org.eclipse.test/library.xml
|
||||
popd
|
||||
|
||||
%patch43
|
||||
%patch44
|
||||
%patch47
|
||||
@ -706,35 +677,6 @@ popd
|
||||
#
|
||||
#popd
|
||||
|
||||
# Build the test framework
|
||||
#pushd %{name}-%{version}-testframework
|
||||
#mkdir -p build
|
||||
|
||||
# The qualifier is what is in upstream's release:
|
||||
# http://download.eclipse.org/eclipse/downloads/drops/R-3.4-200806172000/eclipse-test-framework-3.4.zip
|
||||
#java -cp $SDK/plugins/org.eclipse.equinox.launcher_$LAUNCHERVERSION \
|
||||
# -Duser.home=$homedir \
|
||||
# org.eclipse.core.launcher.Main \
|
||||
# -application org.eclipse.ant.core.antRunner \
|
||||
# -Dtype=feature \
|
||||
# -Did=org.eclipse.test \
|
||||
# -DsourceDirectory=$(pwd) \
|
||||
# -DbaseLocation=$SDK \
|
||||
# -DforceContextQualifier=v20080507 \
|
||||
# -Dbuilder=$SDK/plugins/org.eclipse.pde.build_$PDEPLUGINVERSION/templates/package-build \
|
||||
# -f $SDK/plugins/org.eclipse.pde.build_$PDEPLUGINVERSION/scripts/build.xml
|
||||
#popd
|
||||
|
||||
#TODO verify this is the correct place
|
||||
#pushd %{name}-%{version}-testframework
|
||||
#unzip build/rpmBuild/org.eclipse.test.zip
|
||||
## These are already in the SDK
|
||||
#rm eclipse/epl-v10.html eclipse/notice.html
|
||||
#rm -rf eclipse/plugins/org.junit*
|
||||
#rm build/rpmBuild/org.eclipse.test.zip
|
||||
#zip -r build/rpmBuild/org.eclipse.test.zip eclipse
|
||||
#popd
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
# Get swt version
|
||||
@ -771,11 +713,6 @@ rm -fr $RPM_BUILD_ROOT%{_libdir}/eclipse/p2
|
||||
#rm -rf \
|
||||
# $sdkDir/features/org.eclipse.ecf.filetransfer_feature_*
|
||||
|
||||
# Test framework
|
||||
#unzip -d $RPM_BUILD_ROOT%{_libdir} \
|
||||
# %{name}-%{version}-testframework/build/rpmBuild/org.eclipse.test.zip
|
||||
#mv $RPM_BUILD_ROOT%{_libdir}/eclipse/plugins/org.eclipse.test{_3.2.0,}
|
||||
|
||||
LAUNCHERVERSION=$(ls $sdkDir/plugins | grep equinox.launcher_ | sed 's/org.eclipse.equinox.launcher_//')
|
||||
|
||||
installDir=$sdkDir-Platform
|
||||
@ -1468,6 +1405,9 @@ fi
|
||||
#%{_libdir}/%{name}/configuration/org.eclipse.equinox.source
|
||||
|
||||
%changelog
|
||||
* Mon Aug 31 2009 Alexander Kurtakov <akurtako@redhat.com> 1:3.5.0-0.9
|
||||
- Remove all testframework sources, patches, build and etc.
|
||||
|
||||
* Tue Aug 18 2009 Alexander Kurtakov <akurtako@redhat.com> 1:3.5.0-0.8
|
||||
- Use system hamcrest.
|
||||
|
||||
|
1
sources
1
sources
@ -1,4 +1,3 @@
|
||||
611d3dc63e9e4246e325848d32773132 ecf-filetransfer-v20080611-1715.tar.bz2
|
||||
72a590190a4fea7a4f8885bfe26a3e18 eclipse-I20090611-1540-fetched-src.tar.bz2
|
||||
67c8679981ee3020ec2709d85cfaf4b1 eclipse-3.5.0-testframework.tar.bz2
|
||||
a3504fedff088a6e58a39d43fff4d47e eclipse-build-R0_3_0.tar.gz
|
||||
|
Loading…
Reference in New Issue
Block a user