diff --git a/eclipse-remove-weaving.patch b/eclipse-remove-weaving.patch
new file mode 100644
index 0000000..6db9844
--- /dev/null
+++ b/eclipse-remove-weaving.patch
@@ -0,0 +1,13 @@
+--- rt.equinox.bundles/features/org.eclipse.equinox.sdk/feature.xml.bak 2012-07-25 17:41:27.000000000 +0200
++++ rt.equinox.bundles/features/org.eclipse.equinox.sdk/feature.xml 2012-07-27 12:52:29.414656054 +0200
+@@ -40,10 +40,6 @@
+ version="0.0.0"/>
+
+
+-
+-
+
diff --git a/eclipse-set-1.6-bree.patch b/eclipse-set-1.6-bree.patch
index 4efcf4f..49f91a4 100644
--- a/eclipse-set-1.6-bree.patch
+++ b/eclipse-set-1.6-bree.patch
@@ -20,3 +20,25 @@
+--- rt.equinox.framework/features/org.eclipse.equinox.core.sdk/pom.xml.bak 2012-07-25 17:42:07.000000000 +0200
++++ rt.equinox.framework/features/org.eclipse.equinox.core.sdk/pom.xml 2012-07-27 13:04:13.392040773 +0200
+@@ -32,7 +32,7 @@
+ target-platform-configuration
+
+
+- J2SE-1.5
++ JavaSE-1.6
+
+
+
+--- eclipse.platform.releng/features/master/pom.xml.bak 2012-07-25 17:26:52.000000000 +0200
++++ eclipse.platform.releng/features/master/pom.xml 2012-07-27 13:13:35.876618847 +0200
+@@ -33,7 +33,7 @@
+ org.eclipse.tycho
+ target-platform-configuration
+
+- J2SE-1.5
++ JavaSE-1.6
+
+
+ wce_ppc
diff --git a/eclipse.spec b/eclipse.spec
index c21f0e6..aa5656e 100644
--- a/eclipse.spec
+++ b/eclipse.spec
@@ -66,6 +66,7 @@ Patch4: %{name}-no-source-for-dependencies.patch
Patch5: %{name}-osgi-serverside-patch-additional-imports.patch
Patch6: %{name}-fix-sshd-id.patch
Patch7: %{name}-fix-equinox-ip-imports.patch
+Patch8: %{name}-remove-weaving.patch
BuildRequires: ant >= 1.8.3
BuildRequires: rsync
@@ -248,6 +249,7 @@ developing Eclipse plugins.
%patch5
%patch6
%patch7
+%patch8
#https://bugs.eclipse.org/bugs/show_bug.cgi?id=386040
%pom_disable_module bundles/org.eclipse.equinox.http.jetty5 rt.equinox.bundles .
@@ -255,6 +257,8 @@ developing Eclipse plugins.
#we do not have dependencies for those tests
%pom_disable_module bundles/org.eclipse.equinox.region.tests rt.equinox.bundles
+%pom_disable_module bundles/org.eclipse.equinox.weaving.aspectj rt.equinox.bundles
+%pom_disable_module features/org.eclipse.equinox.weaving.sdk rt.equinox.bundles
#export JAVA_HOME=%{java_home}
#%setup -q -n eclipse-build-%{eb_sha1}