diff --git a/eclipse.spec b/eclipse.spec
index 8627622..192ac23 100644
--- a/eclipse.spec
+++ b/eclipse.spec
@@ -912,7 +912,8 @@ homedir=$(cd home && pwd)
echo "" > build/assemble.org.eclipse.equinox.initializer.all.xml
echo "" > build/package.org.eclipse.equinox.initializer.all.xml
-$SDK/eclipse \
+java -cp $SDK/startup.jar \
+ org.eclipse.core.launcher.Main \
-Duser.home=$homedir \
-application org.eclipse.ant.core.antRunner \
-Dtype=plugin \
@@ -923,7 +924,8 @@ $SDK/eclipse \
-f $SDK/plugins/org.eclipse.pde.build_$PDEPLUGINVERSION/scripts/build.xml
pushd build/plugins/org.eclipse.equinox.initializer
-$SDK/eclipse \
+java -cp $SDK/startup.jar \
+ org.eclipse.core.launcher.Main \
-Duser.home=$homedir \
-application org.eclipse.ant.core.antRunner \
-f build.xml build.update.jar