Packaging improvements after review.

Removed unnecessary dependencies, changed installation group, used osgi
style dependencies for jetty, excluded console.jaas from build since
it;s not used anyway.

Conflicts:
	eclipse.spec
This commit is contained in:
Krzysztof Daniel 2012-09-10 10:42:56 +02:00
parent a97837256b
commit a80ea2fc73
4 changed files with 516 additions and 48 deletions

View File

@ -1,16 +0,0 @@
--- rt.equinox.incubator/console/org.eclipse.equinox.console.jaas.fragment/META-INF/MANIFEST.MF.bak 2012-07-26 16:40:00.000000000 +0200
+++ rt.equinox.incubator/console/org.eclipse.equinox.console.jaas.fragment/META-INF/MANIFEST.MF 2012-07-26 16:40:17.896441807 +0200
@@ -5,4 +5,4 @@
Bundle-Version: 1.0.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
DynamicImport-Package: org.eclipse.equinox.console.jaas
-Fragment-Host: org.apache.sshd.core;bundle-version="0.5.0"
+Fragment-Host: org.apache.sshd.core
--- rt.equinox.bundles/bundles/org.eclipse.equinox.console.jaas.fragment/META-INF/MANIFEST.MF.bak 2012-07-25 17:41:27.000000000 +0200
+++ rt.equinox.bundles/bundles/org.eclipse.equinox.console.jaas.fragment/META-INF/MANIFEST.MF 2012-07-27 09:17:27.641681636 +0200
@@ -7,4 +7,4 @@
Bundle-Version: 1.0.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
DynamicImport-Package: org.eclipse.equinox.console.jaas
-Fragment-Host: org.apache.sshd.core;bundle-version="0.5.0"
+Fragment-Host: org.apache.sshd.core

72
eclipse-remove-jaas.patch Normal file
View File

@ -0,0 +1,72 @@
--- rt.equinox.incubator/console/org.eclipse.equinox.console.jaas.fragment/META-INF/MANIFEST.MF.bak 2012-07-26 16:40:00.000000000 +0200
+++ rt.equinox.incubator/console/org.eclipse.equinox.console.jaas.fragment/META-INF/MANIFEST.MF 2012-07-26 16:40:17.896441807 +0200
@@ -5,4 +5,4 @@
Bundle-Version: 1.0.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
DynamicImport-Package: org.eclipse.equinox.console.jaas
-Fragment-Host: org.apache.sshd.core;bundle-version="0.5.0"
+Fragment-Host: org.apache.sshd.core
--- rt.equinox.bundles/bundles/org.eclipse.equinox.console.jaas.fragment/META-INF/MANIFEST.MF.bak 2012-07-25 17:41:27.000000000 +0200
+++ rt.equinox.bundles/bundles/org.eclipse.equinox.console.jaas.fragment/META-INF/MANIFEST.MF 2012-07-27 09:17:27.641681636 +0200
@@ -7,4 +7,4 @@
Bundle-Version: 1.0.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
DynamicImport-Package: org.eclipse.equinox.console.jaas
-Fragment-Host: org.apache.sshd.core;bundle-version="0.5.0"
+Fragment-Host: org.apache.sshd.core
--- rt.equinox.framework/features/org.eclipse.equinox.core.sdk/feature.xml.bak 2012-09-07 14:34:00.000000000 +0200
+++ rt.equinox.framework/features/org.eclipse.equinox.core.sdk/feature.xml 2012-09-07 14:42:44.111687873 +0200
@@ -340,13 +340,13 @@
version="0.0.0"
unpack="false"/>
- <plugin
+ <!--plugin
id="org.eclipse.equinox.console.jaas.fragment"
download-size="0"
install-size="0"
version="0.0.0"
fragment="true"
- unpack="false"/>
+ unpack="false"/-->
<plugin
id="org.apache.felix.gogo.command"
@@ -369,7 +369,7 @@
version="0.0.0"
unpack="false"/>
- <plugin
+ <!--plugin
id="org.apache.mina.core"
download-size="0"
install-size="0"
@@ -381,7 +381,7 @@
download-size="0"
install-size="0"
version="0.0.0"
- unpack="false"/>
+ unpack="false"/-->
<plugin
id="org.eclipse.equinox.bidi"
--- rt.equinox.framework/features/org.eclipse.equinox.core.sdk/feature.xml.bak 2012-09-07 17:38:22.000000000 +0200
+++ rt.equinox.framework/features/org.eclipse.equinox.core.sdk/feature.xml 2012-09-07 17:46:04.368180213 +0200
@@ -326,7 +326,7 @@
version="0.0.0"
unpack="false"/>
- <plugin
+ <!--plugin
id="org.eclipse.equinox.console.ssh"
download-size="0"
install-size="0"
@@ -338,7 +338,7 @@
download-size="0"
install-size="0"
version="0.0.0"
- unpack="false"/>
+ unpack="false"/-->
<!--plugin
id="org.eclipse.equinox.console.jaas.fragment"

View File

@ -0,0 +1,391 @@
--- rt.equinox.bundles/bundles/org.eclipse.equinox.http/pom.xml.bak 2012-09-06 16:02:03.000000000 +0200
+++ rt.equinox.bundles/bundles/org.eclipse.equinox.http/pom.xml 2012-09-07 11:37:32.943823238 +0200
@@ -41,19 +41,6 @@
<removeAll />
</filter>
</filters>
- <dependency-resolution>
- <extraRequirements>
- <!--
- new methods were introduced in ServletContext and possibly other interfaces implemented by this bundle
- in javax.servlet 3.0. Because of this we need to make sure to compile against earlier version.
- -->
- <requirement>
- <type>eclipse-plugin</type>
- <id>javax.servlet</id>
- <versionRange>[2.4.0,2.6.0)</versionRange>
- </requirement>
- </extraRequirements>
- </dependency-resolution>
</configuration>
</plugin>
</plugins>
diff --git rt.equinox.bundles/bundles/org.eclipse.equinox.http/META-INF/MANIFEST.MF rt.equinox.bundles/bundles/org.eclipse.equinox.http/META-INF/MANIFEST.MF
index 8b76fdc..b730678 100644
--- rt.equinox.bundles/bundles/org.eclipse.equinox.http/META-INF/MANIFEST.MF
+++ rt.equinox.bundles/bundles/org.eclipse.equinox.http/META-INF/MANIFEST.MF
@@ -1,18 +1,19 @@
Bundle-ManifestVersion: 2
Bundle-Vendor: %bundleVendor
-Bundle-Version: 1.0.500.qualifier
+Bundle-Version: 1.0.500.qualifier
Bundle-Activator: org.eclipse.equinox.http.Activator
Bundle-SymbolicName: org.eclipse.equinox.http
Bundle-Name: %bundleName
-Import-Package: javax.servlet,
+Import-Package: javax.net;resolution:=optional,
+ javax.servlet,
+ javax.servlet.descriptor,
javax.servlet.http,
- javax.net; resolution:="optional",
+ org.eclipse.osgi.util,
org.osgi.framework;version="1.0",
org.osgi.service.cm;version="1.0",
org.osgi.service.http;version="[1.2,1.3)",
org.osgi.service.log;version="1.0",
- org.osgi.util.tracker;version="1.1",
- org.eclipse.osgi.util
+ org.osgi.util.tracker;version="1.1"
Export-Package: org.eclipse.equinox.http;x-internal:=true,
org.eclipse.equinox.http.servlet;x-internal:=true,
org.eclipse.equinox.socket;x-internal:=true,
diff --git rt.equinox.bundles/bundles/org.eclipse.equinox.http/src/org/eclipse/equinox/http/servlet/HttpServletRequestImpl.java rt.equinox.bundles/bundles/org.eclipse.equinox.http/src/org/eclipse/equinox/http/servlet/HttpServletRequestImpl.java
index d1520e0..3b5788c 100644
--- rt.equinox.bundles/bundles/org.eclipse.equinox.http/src/org/eclipse/equinox/http/servlet/HttpServletRequestImpl.java
+++ rt.equinox.bundles/bundles/org.eclipse.equinox.http/src/org/eclipse/equinox/http/servlet/HttpServletRequestImpl.java
@@ -1,5 +1,5 @@
/*******************************************************************************
- * Copyright (c) 1999, 2009 IBM Corporation and others.
+ * Copyright (c) 1999, 2012 IBM Corporation and others.
* All rights reserved. This program and the accompanying materials
* are made available under the terms of the Eclipse Public License v1.0
* which accompanies this distribution, and is available at
@@ -7,14 +7,14 @@
*
* Contributors:
* IBM Corporation - initial API and implementation
+ * Red Hat, Inc. - Bug 389033 - get rid off javax.servlet < 2.6 dependency
*******************************************************************************/
package org.eclipse.equinox.http.servlet;
import java.io.*;
import java.security.Principal;
import java.util.*;
-import javax.servlet.RequestDispatcher;
-import javax.servlet.ServletInputStream;
+import javax.servlet.*;
import javax.servlet.http.*;
import org.eclipse.equinox.http.*;
import org.eclipse.equinox.socket.SocketInterface;
@@ -1435,4 +1435,64 @@ public class HttpServletRequestImpl implements HttpServletRequest {
public int getRemotePort() {
throw new UnsupportedOperationException(HttpMsg.HTTP_ONLY_SUPPORTS_2_1);
}
+
+ public AsyncContext getAsyncContext() {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ public DispatcherType getDispatcherType() {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ public ServletContext getServletContext() {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ public boolean isAsyncStarted() {
+ // TODO Auto-generated method stub
+ return false;
+ }
+
+ public boolean isAsyncSupported() {
+ // TODO Auto-generated method stub
+ return false;
+ }
+
+ public AsyncContext startAsync() {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ public AsyncContext startAsync(ServletRequest arg0, ServletResponse arg1) {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ public boolean authenticate(HttpServletResponse arg0) throws IOException, ServletException {
+ // TODO Auto-generated method stub
+ return false;
+ }
+
+ public Part getPart(String arg0) throws IOException, IllegalStateException, ServletException {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ public Collection getParts() throws IOException, IllegalStateException, ServletException {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ public void login(String arg0, String arg1) throws ServletException {
+ // TODO Auto-generated method stub
+
+ }
+
+ public void logout() throws ServletException {
+ // TODO Auto-generated method stub
+
+ }
}
diff --git rt.equinox.bundles/bundles/org.eclipse.equinox.http/src/org/eclipse/equinox/http/servlet/HttpServletResponseImpl.java rt.equinox.bundles/bundles/org.eclipse.equinox.http/src/org/eclipse/equinox/http/servlet/HttpServletResponseImpl.java
index 12020c0..8bb68ee 100644
--- rt.equinox.bundles/bundles/org.eclipse.equinox.http/src/org/eclipse/equinox/http/servlet/HttpServletResponseImpl.java
+++ rt.equinox.bundles/bundles/org.eclipse.equinox.http/src/org/eclipse/equinox/http/servlet/HttpServletResponseImpl.java
@@ -858,4 +858,24 @@ public class HttpServletResponseImpl implements HttpServletResponse {
throw new UnsupportedOperationException(HttpMsg.HTTP_ONLY_SUPPORTS_2_1);
}
+
+ public String getHeader(String arg0) {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ public Collection getHeaderNames() {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ public Collection getHeaders(String arg0) {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ public int getStatus() {
+ // TODO Auto-generated method stub
+ return 0;
+ }
}
diff --git rt.equinox.bundles/bundles/org.eclipse.equinox.http/src/org/eclipse/equinox/http/servlet/RequestDispatcherImpl.java rt.equinox.bundles/bundles/org.eclipse.equinox.http/src/org/eclipse/equinox/http/servlet/RequestDispatcherImpl.java
index 09fca65..d75e450 100644
--- rt.equinox.bundles/bundles/org.eclipse.equinox.http/src/org/eclipse/equinox/http/servlet/RequestDispatcherImpl.java
+++ rt.equinox.bundles/bundles/org.eclipse.equinox.http/src/org/eclipse/equinox/http/servlet/RequestDispatcherImpl.java
@@ -1,5 +1,5 @@
/*******************************************************************************
- * Copyright (c) 1999, 2009 IBM Corporation and others.
+ * Copyright (c) 1999, 2012 IBM Corporation and others.
* All rights reserved. This program and the accompanying materials
* are made available under the terms of the Eclipse Public License v1.0
* which accompanies this distribution, and is available at
@@ -7,11 +7,13 @@
*
* Contributors:
* IBM Corporation - initial API and implementation
+ * Red Hat, Inc. - Bug 389033 - get rid off javax.servlet < 2.6 dependency
*******************************************************************************/
package org.eclipse.equinox.http.servlet;
import java.io.IOException;
import java.io.PrintWriter;
+import java.util.Collection;
import java.util.Locale;
import javax.servlet.*;
import javax.servlet.http.Cookie;
@@ -198,6 +200,26 @@ public class RequestDispatcherImpl implements RequestDispatcher {
}
+ public String getHeader(String arg0) {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ public Collection getHeaderNames() {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ public Collection getHeaders(String arg0) {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ public int getStatus() {
+ // TODO Auto-generated method stub
+ return 0;
+ }
+
}
public RequestDispatcherImpl(Registration reg, String requestURI) {
diff --git rt.equinox.bundles/bundles/org.eclipse.equinox.http/src/org/eclipse/equinox/http/servlet/ServletContextImpl.java rt.equinox.bundles/bundles/org.eclipse.equinox.http/src/org/eclipse/equinox/http/servlet/ServletContextImpl.java
index 015e488..02ef245 100644
--- rt.equinox.bundles/bundles/org.eclipse.equinox.http/src/org/eclipse/equinox/http/servlet/ServletContextImpl.java
+++ rt.equinox.bundles/bundles/org.eclipse.equinox.http/src/org/eclipse/equinox/http/servlet/ServletContextImpl.java
@@ -1,5 +1,5 @@
/*******************************************************************************
- * Copyright (c) 1999, 2009 IBM Corporation and others.
+ * Copyright (c) 1999, 2012 IBM Corporation and others.
* All rights reserved. This program and the accompanying materials
* are made available under the terms of the Eclipse Public License v1.0
* which accompanies this distribution, and is available at
@@ -7,6 +7,7 @@
*
* Contributors:
* IBM Corporation - initial API and implementation
+ * Red Hat, Inc. - Bug 389033 - get rid off javax.servlet < 2.6 dependency
*******************************************************************************/
package org.eclipse.equinox.http.servlet;
@@ -16,7 +17,11 @@ import java.net.MalformedURLException;
import java.net.URL;
import java.util.*;
import javax.servlet.*;
+import javax.servlet.FilterRegistration.Dynamic;
+import javax.servlet.ServletRegistration;
+import javax.servlet.descriptor.JspConfigDescriptor;
import org.eclipse.equinox.http.*;
+import org.eclipse.equinox.http.Registration;
import org.osgi.service.http.HttpContext;
public class ServletContextImpl implements ServletContext {
@@ -447,4 +452,134 @@ public class ServletContextImpl implements ServletContext {
throw new UnsupportedOperationException(HttpMsg.HTTP_ONLY_SUPPORTS_2_1);
}
+ public Dynamic addFilter(String arg0, String arg1) {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ public Dynamic addFilter(String arg0, Filter arg1) {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ public Dynamic addFilter(String arg0, Class arg1) {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ public void addListener(Class arg0) {
+ // TODO Auto-generated method stub
+
+ }
+
+ public void addListener(String arg0) {
+ // TODO Auto-generated method stub
+
+ }
+
+ public void addListener(EventListener arg0) {
+ // TODO Auto-generated method stub
+
+ }
+
+ public javax.servlet.ServletRegistration.Dynamic addServlet(String arg0, String arg1) {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ public javax.servlet.ServletRegistration.Dynamic addServlet(String arg0, Servlet arg1) {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ public javax.servlet.ServletRegistration.Dynamic addServlet(String arg0, Class arg1) {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ public Filter createFilter(Class arg0) throws ServletException {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ public EventListener createListener(Class arg0) throws ServletException {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ public Servlet createServlet(Class arg0) throws ServletException {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ public void declareRoles(String[] arg0) {
+ // TODO Auto-generated method stub
+
+ }
+
+ public ClassLoader getClassLoader() {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ public Set getDefaultSessionTrackingModes() {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ public int getEffectiveMajorVersion() {
+ // TODO Auto-generated method stub
+ return 0;
+ }
+
+ public int getEffectiveMinorVersion() {
+ // TODO Auto-generated method stub
+ return 0;
+ }
+
+ public Set getEffectiveSessionTrackingModes() {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ public FilterRegistration getFilterRegistration(String arg0) {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ public Map getFilterRegistrations() {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ public JspConfigDescriptor getJspConfigDescriptor() {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ public ServletRegistration getServletRegistration(String arg0) {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ public Map getServletRegistrations() {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ public SessionCookieConfig getSessionCookieConfig() {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ public boolean setInitParameter(String arg0, String arg1) {
+ // TODO Auto-generated method stub
+ return false;
+ }
+
+ public void setSessionTrackingModes(Set arg0) throws IllegalStateException, IllegalArgumentException {
+ // TODO Auto-generated method stub
+
+ }
+
}

View File

@ -1,4 +1,4 @@
Epoch: 1
Epoch: 1
%global eclipse_major 4
%global eclipse_minor 2
@ -33,9 +33,9 @@ ln -s %{_javadir}/%{2} ${_f}
Summary: An open, extensible IDE
Name: eclipse
Version: %{eclipse_version}
Release: 14%{?dist}
Release: 15%{?dist}
License: EPL
Group: Text Editors/Integrated Development Environments (IDE)
Group: Development/Tools
URL: http://www.eclipse.org/
#get-eclipse.sh
Source0: eclipse-source.tar.bz2
@ -73,9 +73,8 @@ Patch4: %{name}-no-source-for-dependencies.patch
Patch5: %{name}-osgi-serverside-patch-additional-imports.patch
# org.eclipse.equinox.console.jaas.fragment has too tight requirement
# https://bugs.eclipse.org/bugs/show_bug.cgi?id=388100
Patch6: %{name}-fix-sshd-id.patch
# We don't need it
Patch6: %{name}-remove-jaas.patch
# javax.servlet 2.1 -> javax.servlet 3.0
@ -178,12 +177,13 @@ Patch28: %{name}-build-help-contents.patch
Patch29: %{name}-test-support.patch
Patch30: %{name}-remove-tomcat6.patch
BuildRequires: ant >= 1.8.3
BuildRequires: rsync
BuildRequires: jpackage-utils >= 0:1.5, make, gcc
BuildRequires: gtk2-devel
BuildRequires: glib2-devel
BuildRequires: GConf2-devel
BuildRequires: gcc-c++
BuildRequires: nspr-devel
BuildRequires: libXtst-devel
@ -199,7 +199,6 @@ BuildRequires: libXt-devel
BuildRequires: webkitgtk-devel
BuildRequires: geronimo-annotation >= 1.0-7
BuildRequires: icu4j-eclipse >= 1:4.4.2.2-11
BuildRequires: tomcat-lib >= 7.0.25-3
BuildRequires: ant-antlr ant-apache-bcel ant-apache-log4j ant-apache-oro ant-apache-regexp ant-apache-resolver ant-commons-logging ant-apache-bsf ant-commons-net
BuildRequires: ant-javamail ant-jdepend ant-junit ant-swing ant-jsch ant-testutil ant-apache-xalan2 ant-jmf
BuildRequires: ant-scripts
@ -207,11 +206,16 @@ BuildRequires: jsch >= 0:0.1.46-2
BuildRequires: apache-commons-el >= 1.0-22
BuildRequires: apache-commons-logging
BuildRequires: apache-commons-codec >= 1.6-2
BuildRequires: apache-sshd >= 0.7.0
BuildRequires: jakarta-commons-httpclient >= 1:3.1-7
BuildRequires: felix-gogo-command >= 0.12
BuildRequires: felix-gogo-shell >= 0.10.0-3
BuildRequires: jetty >= 8.1.0-1
BuildRequires: osgi(org.eclipse.jetty.util) >= 8.1.0-1
BuildRequires: osgi(org.eclipse.jetty.server) >= 8.1.0-1
BuildRequires: osgi(org.eclipse.jetty.http) >= 8.1.0-1
BuildRequires: osgi(org.eclipse.jetty.continuation) >= 8.1.0-1
BuildRequires: osgi(org.eclipse.jetty.io) >= 8.1.0-1
BuildRequires: osgi(org.eclipse.jetty.security) >= 8.1.0-1
BuildRequires: osgi(org.eclipse.jetty.servlet) >= 8.1.0-1
BuildRequires: lucene >= 2.9.4-8
BuildRequires: lucene-contrib >= 2.9.4-8
BuildRequires: junit >= 4.10-5
@ -228,10 +232,9 @@ BuildRequires: tycho-extras >= 0.16
BuildRequires: eclipse-emf-core >= 1:2.8.0-13
BuildRequires: eclipse-ecf-core
BuildRequires: tomcat-servlet-3.0-api
BuildRequires: tomcat6-servlet-2.5-api
BuildRequires: cglib
BuildRequires: glassfish-jsp >= 2.2.5
BuildRequires: glassfish-jsp >= 2.2.6
BuildRequires: eclipse-pde
%if 0%{?rhel} >= 6
ExclusiveArch: %{ix86} x86_64
%endif
@ -244,8 +247,8 @@ everything in between.
%package swt
Version: %{eclipse_version}
Summary: SWT Library for GTK+-2.0
Group: Text Editors/Integrated Development Environments (IDE)
# %{_libdir}/java directory owned by jpackage-utils
Group: Development/Tools
# %%{_libdir}/java directory owned by jpackage-utils
Requires: java >= 1:1.7.0
Requires: jpackage-utils
Requires: gtk2
@ -266,7 +269,7 @@ Eclipse OSGi - Equinox
%package platform
Version: %{eclipse_version}
Summary: Eclipse platform common files
Group: Text Editors/Integrated Development Environments (IDE)
Group: Development/Tools
Requires: %{name}-rcp = %{epoch}:%{eclipse_version}-%{release}
Requires: ant-antlr ant-apache-bcel ant-apache-log4j ant-apache-oro ant-apache-regexp ant-apache-resolver ant-commons-logging ant-apache-bsf ant-commons-net
Requires: ant-javamail ant-jdepend ant-junit ant-swing ant-jsch ant-testutil ant-apache-xalan2 ant-jmf
@ -275,10 +278,15 @@ Requires: apache-commons-el >= 1.0-23
Requires: apache-commons-logging
Requires: apache-commons-codec >= 1.6-2
Requires: jakarta-commons-httpclient >= 1:3.1-7
Requires: tomcat-lib >= 7.0.25-3
Requires: felix-gogo-command >= 0.12
Requires: felix-gogo-shell >= 0.10.0-3
Requires: jetty >= 8.1.0-1
Requires: osgi(org.eclipse.jetty.util) >= 8.1.0-1
Requires: osgi(org.eclipse.jetty.server) >= 8.1.0-1
Requires: osgi(org.eclipse.jetty.http) >= 8.1.0-1
Requires: osgi(org.eclipse.jetty.continuation) >= 8.1.0-1
Requires: osgi(org.eclipse.jetty.io) >= 8.1.0-1
Requires: osgi(org.eclipse.jetty.security) >= 8.1.0-1
Requires: osgi(org.eclipse.jetty.servlet) >= 8.1.0-1
Requires: jsch >= 0.1.46-2
Requires: lucene >= 2.9.4-8
Requires: lucene-contrib >= 2.9.4-8
@ -309,7 +317,7 @@ Java Development Tools or the Plugin Development Environment.
%package jdt
Version: %{eclipse_version}
Summary: Eclipse Java Development Tools
Group: Text Editors/Integrated Development Environments (IDE)
Group: Development/Tools
Requires: %{name}-platform = %{epoch}:%{eclipse_version}-%{release}
Requires: %{name}-cvs-client = %{epoch}:%{eclipse_version}-%{release}
Requires: junit >= 4.10-5
@ -325,7 +333,7 @@ developing software written in the Java programming language.
%package pde
Version: %{eclipse_version}
Summary: Eclipse Plugin Development Environment
Group: Text Editors/Integrated Development Environments (IDE)
Group: Development/Tools
Provides: eclipse = %{epoch}:%{eclipse_version}-%{release}
Provides: eclipse-sdk = %{epoch}:%{eclipse_version}-%{release}
Requires: %{name}-platform = %{epoch}:%{eclipse_version}-%{release}
@ -344,7 +352,7 @@ developing Eclipse plugins.
%package tests
Version: %{eclipse_version}
Summary: Eclipse Tests
Group: Text Editors/Integrated Development Environments (IDE)
Group: Development/Tools
Requires: %{name}-sdk = %{epoch}:%{eclipse_version}-%{release}
Provides: %{name}-pde-runtime = 1:%{eclipse_version}-%{release}
Obsoletes: %{name}-pde-runtime < 1:3.3.2-20
@ -357,7 +365,7 @@ Eclipse Tests.
ARCH=%{_arch}
ARCH=${ARCH/i386/x86}
%setup %{SOURCE0} -n R4_platform-aggregator
%setup -q %{SOURCE0} -n R4_platform-aggregator
tar --strip-components=1 -xf %{SOURCE1}
@ -390,6 +398,7 @@ tar --strip-components=1 -xf %{SOURCE1}
%patch27
%patch28
%patch29
%patch30
#https://bugs.eclipse.org/bugs/show_bug.cgi?id=386040
%pom_disable_module bundles/org.eclipse.equinox.http.jetty5 rt.equinox.bundles .
@ -401,8 +410,10 @@ tar --strip-components=1 -xf %{SOURCE1}
%pom_disable_module features/org.eclipse.equinox.weaving.sdk rt.equinox.bundles
%pom_disable_module features/master-equinox-weaving eclipse.platform.releng
%pom_disable_module bundles/org.eclipse.equinox.console.jaas.fragment rt.equinox.bundles
%pom_disable_module bundles/org.eclipse.equinox.cm.test rt.equinox.bundles
%pom_disable_module bundles/org.eclipse.equinox.console.ssh rt.equinox.bundles
#no idea what's that. Maybe later - sources seem to be hidden inside this additonal jar.
%pom_disable_module bundles/org.eclipse.equinox.weaving.caching.j9 rt.equinox.bundles/
@ -493,19 +504,19 @@ mvn-rpmbuild clean install \
# popd
pushd eclipse.platform.common/bundles/org.eclipse.platform.doc.user
mvn-rpmbuild install -Dmaven.test.skip=true -Dmaven.local.mode=true
mvn-rpmbuild install -Dmaven.test.skip=true -Dmaven.local.mode=true
popd
pushd eclipse.platform.common/bundles/org.eclipse.platform.doc.isv
mvn-rpmbuild install -Dmaven.test.skip=true -Dmaven.local.mode=true
mvn-rpmbuild install -Dmaven.test.skip=true -Dmaven.local.mode=true
popd
pushd eclipse.platform.common/bundles/org.eclipse.jdt.doc.user
mvn-rpmbuild install -Dmaven.test.skip=true -Dmaven.local.mode=true
mvn-rpmbuild install -Dmaven.test.skip=true -Dmaven.local.mode=true
popd
pushd eclipse.platform.common/bundles/org.eclipse.jdt.doc.isv
mvn-rpmbuild install -Dmaven.test.skip=true -Dmaven.local.mode=true
mvn-rpmbuild install -Dmaven.test.skip=true -Dmaven.local.mode=true
popd
pushd eclipse.platform.common/bundles/org.eclipse.pde.doc.user
mvn-rpmbuild install -Dmaven.test.skip=true -Dmaven.local.mode=true
mvn-rpmbuild install -Dmaven.test.skip=true -Dmaven.local.mode=true
popd
mvn-rpmbuild clean install \
-Dmaven.test.skip=true -Dnative=linux.gtk.${ARCH} \
@ -749,11 +760,11 @@ LOCAL_PWD=`pwd`
#change the installation p2 files
pushd TMP/org.eclipse.sdk.epp/target/products/org.fedoraproject.eclipse.platform/linux/gtk/${ARCH}/eclipse/p2/org.eclipse.equinox.p2.engine/profileRegistry/SDKProfile.profile/
for i in `ls | grep "profile.gz"` ; do \
echo $i ; \
gunzip $i ; \
sed -i -e "s@${LOCAL_PWD}/TMP/org.eclipse.sdk.epp/target/products/org.fedoraproject.eclipse.platform/linux/gtk/${ARCH}/eclipse@%{_libdir}/eclipse@g" *.profile ; \
gzip *.profile ; \
done
echo $i ; \
gunzip $i ; \
sed -i -e "s@${LOCAL_PWD}/TMP/org.eclipse.sdk.epp/target/products/org.fedoraproject.eclipse.platform/linux/gtk/${ARCH}/eclipse@%{_libdir}/eclipse@g" *.profile ; \
gzip *.profile ; \
done
# TODO: some other paths
popd
@ -1213,6 +1224,16 @@ rm -rf %{_bindir}/efj/
%{_mavendepmapfragdir}/%{name}-equinox-osgi
%changelog
* Fri Sep 7 2012 Krzysztof Daniel <kdaniel@redhat.com> 1:4.2.0-15
- Use existing software group.
- Add BR to eclipse-pde
- Removed dependency on tomcat6
- Removed BR GConf2-devel.
- Removed BR apache-sshd.
- Removed BR/R tomcat-lib.
- jetty BR/R transformed to osgi() style.
- Excluded org.eclipse.equinox.console.jaas from builds.
* Wed Sep 5 2012 Krzysztof Daniel <kdaniel@redhat.com> 1:4.2.0-14
- Native network support added.
- Native filesystem support added.