Add profiles in the equinox executable for ppc and arm.
Conflicts: eclipse.spec
This commit is contained in:
parent
b6e1e8e24c
commit
a4d7865ece
@ -220,3 +220,176 @@
|
||||
<plugin
|
||||
id="org.eclipse.core.filesystem.linux.x86_64"
|
||||
os="linux"
|
||||
--- rt.equinox.framework/bundles/org.eclipse.equinox.executable/pom.xml.bak 2012-10-22 20:39:19.000000000 +0200
|
||||
+++ rt.equinox.framework/bundles/org.eclipse.equinox.executable/pom.xml 2012-10-23 09:40:57.205750700 +0200
|
||||
@@ -132,6 +132,170 @@
|
||||
</plugins>
|
||||
</build>
|
||||
</profile>
|
||||
+
|
||||
+ <profile>
|
||||
+ <id>build-native-launchers-gtk.linux.ppc</id>
|
||||
+ <activation>
|
||||
+ <property>
|
||||
+ <name>native</name>
|
||||
+ <value>gtk.linux.ppc</value>
|
||||
+ </property>
|
||||
+ </activation>
|
||||
+ <build>
|
||||
+ <plugins>
|
||||
+ <plugin>
|
||||
+ <artifactId>maven-antrun-plugin</artifactId>
|
||||
+ <version> 1.7 </version>
|
||||
+ <executions>
|
||||
+ <execution>
|
||||
+ <id>compile-executable-natives</id>
|
||||
+ <phase>generate-resources</phase>
|
||||
+ <configuration>
|
||||
+ <target>
|
||||
+ <ant antfile="build.xml" dir="library/gtk/" target="build_eclipse_cbi" />
|
||||
+ </target>
|
||||
+ </configuration>
|
||||
+ <goals>
|
||||
+ <goal>run</goal>
|
||||
+ </goals>
|
||||
+ </execution>
|
||||
+ </executions>
|
||||
+ <dependencies>
|
||||
+ <dependency>
|
||||
+ <groupId>bsf</groupId>
|
||||
+ <artifactId>bsf</artifactId>
|
||||
+ <version>2.4.0</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>rhino</groupId>
|
||||
+ <artifactId>js</artifactId>
|
||||
+ <version>1.7R2</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.apache.ant</groupId>
|
||||
+ <artifactId>ant-apache-bsf</artifactId>
|
||||
+ <version>1.8.3</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.apache.ant</groupId>
|
||||
+ <artifactId>ant-nodeps</artifactId>
|
||||
+ <version>1.8.1</version>
|
||||
+ </dependency>
|
||||
+ </dependencies>
|
||||
+ </plugin>
|
||||
+ </plugins>
|
||||
+ </build>
|
||||
+ </profile>
|
||||
+
|
||||
+ <profile>
|
||||
+ <id>build-native-launchers-gtk.linux.ppc64</id>
|
||||
+ <activation>
|
||||
+ <property>
|
||||
+ <name>native</name>
|
||||
+ <value>gtk.linux.ppc64</value>
|
||||
+ </property>
|
||||
+ </activation>
|
||||
+ <build>
|
||||
+ <plugins>
|
||||
+ <plugin>
|
||||
+ <artifactId>maven-antrun-plugin</artifactId>
|
||||
+ <version> 1.7 </version>
|
||||
+ <executions>
|
||||
+ <execution>
|
||||
+ <id>compile-executable-natives</id>
|
||||
+ <phase>generate-resources</phase>
|
||||
+ <configuration>
|
||||
+ <target>
|
||||
+ <ant antfile="build.xml" dir="library/gtk/" target="build_eclipse_cbi" />
|
||||
+ </target>
|
||||
+ </configuration>
|
||||
+ <goals>
|
||||
+ <goal>run</goal>
|
||||
+ </goals>
|
||||
+ </execution>
|
||||
+ </executions>
|
||||
+ <dependencies>
|
||||
+ <dependency>
|
||||
+ <groupId>bsf</groupId>
|
||||
+ <artifactId>bsf</artifactId>
|
||||
+ <version>2.4.0</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>rhino</groupId>
|
||||
+ <artifactId>js</artifactId>
|
||||
+ <version>1.7R2</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.apache.ant</groupId>
|
||||
+ <artifactId>ant-apache-bsf</artifactId>
|
||||
+ <version>1.8.3</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.apache.ant</groupId>
|
||||
+ <artifactId>ant-nodeps</artifactId>
|
||||
+ <version>1.8.1</version>
|
||||
+ </dependency>
|
||||
+ </dependencies>
|
||||
+ </plugin>
|
||||
+ </plugins>
|
||||
+ </build>
|
||||
+ </profile>
|
||||
+
|
||||
+
|
||||
+ <profile>
|
||||
+ <id>build-native-launchers-gtk.linux.arm</id>
|
||||
+ <activation>
|
||||
+ <property>
|
||||
+ <name>native</name>
|
||||
+ <value>gtk.linux.arm</value>
|
||||
+ </property>
|
||||
+ </activation>
|
||||
+ <build>
|
||||
+ <plugins>
|
||||
+ <plugin>
|
||||
+ <artifactId>maven-antrun-plugin</artifactId>
|
||||
+ <version> 1.7 </version>
|
||||
+ <executions>
|
||||
+ <execution>
|
||||
+ <id>compile-executable-natives</id>
|
||||
+ <phase>generate-resources</phase>
|
||||
+ <configuration>
|
||||
+ <target>
|
||||
+ <ant antfile="build.xml" dir="library/gtk/" target="build_eclipse_cbi" />
|
||||
+ </target>
|
||||
+ </configuration>
|
||||
+ <goals>
|
||||
+ <goal>run</goal>
|
||||
+ </goals>
|
||||
+ </execution>
|
||||
+ </executions>
|
||||
+ <dependencies>
|
||||
+ <dependency>
|
||||
+ <groupId>bsf</groupId>
|
||||
+ <artifactId>bsf</artifactId>
|
||||
+ <version>2.4.0</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>rhino</groupId>
|
||||
+ <artifactId>js</artifactId>
|
||||
+ <version>1.7R2</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.apache.ant</groupId>
|
||||
+ <artifactId>ant-apache-bsf</artifactId>
|
||||
+ <version>1.8.3</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.apache.ant</groupId>
|
||||
+ <artifactId>ant-nodeps</artifactId>
|
||||
+ <version>1.8.1</version>
|
||||
+ </dependency>
|
||||
+ </dependencies>
|
||||
+ </plugin>
|
||||
+ </plugins>
|
||||
+ </build>
|
||||
+ </profile>
|
||||
+
|
||||
<profile>
|
||||
<id>build-native-launchers-win32.win32.x86_64</id>
|
||||
<activation>
|
||||
|
@ -78,7 +78,7 @@ fi;
|
||||
Summary: An open, extensible IDE
|
||||
Name: eclipse
|
||||
Version: %{eclipse_version}
|
||||
Release: 7%{?dist}
|
||||
Release: 8%{?dist}
|
||||
License: EPL
|
||||
Group: Development/Tools
|
||||
URL: http://www.eclipse.org/
|
||||
@ -1409,6 +1409,9 @@ rm -rf %{_bindir}/efj/
|
||||
%{_mavendepmapfragdir}/%{name}-equinox-osgi
|
||||
|
||||
%changelog
|
||||
* Tue Oct 23 2012 Krzysztof Daniel <kdaniel@redhat.com> 1:4.2.1-8
|
||||
- Add profiles in the equinox executable for ppc and arm.
|
||||
|
||||
* Mon Oct 22 2012 Krzysztof Daniel <kdaniel@redhat.com> 1:4.2.1-7
|
||||
- Moved launcher version change after secondary fragments creation.
|
||||
- Created some directories when creating secondary fragments.
|
||||
|
Loading…
Reference in New Issue
Block a user