- Revise gre64 patch to just do ppc64 addition and not ordering change.
This commit is contained in:
parent
ce958e2280
commit
a3a491615f
16
eclipse-ppc64gre64.patch
Normal file
16
eclipse-ppc64gre64.patch
Normal file
@ -0,0 +1,16 @@
|
||||
Index: library/eclipseMozilla.c
|
||||
===================================================================
|
||||
RCS file: /cvsroot/eclipse/platform-launcher/library/eclipseMozilla.c,v
|
||||
retrieving revision 1.2
|
||||
diff -u -r1.2 eclipseMozilla.c
|
||||
--- library/eclipseMozilla.c 10 Aug 2006 21:21:26 -0000 1.2
|
||||
+++ library/eclipseMozilla.c 17 Nov 2006 18:39:08 -0000
|
||||
@@ -102,7 +102,7 @@
|
||||
{
|
||||
struct stat buf;
|
||||
FILE *file = NULL;
|
||||
-#if defined(__amd64__) || defined(__x86_64__)
|
||||
+#if defined(__amd64__) || defined(__x86_64__) || defined(__powerpc64__)
|
||||
if (stat("/etc/gre64.conf", &buf) == 0)
|
||||
{
|
||||
file = fopen("/etc/gre64.conf", "r");
|
11
eclipse.spec
11
eclipse.spec
@ -26,7 +26,7 @@ Epoch: 1
|
||||
Summary: An open, extensible IDE
|
||||
Name: eclipse
|
||||
Version: %{eclipse_majmin}.%{eclipse_micro}
|
||||
Release: 19%{?dist}
|
||||
Release: 20%{?dist}
|
||||
License: EPL
|
||||
Group: Text Editors/Integrated Development Environments (IDE)
|
||||
URL: http://www.eclipse.org/
|
||||
@ -112,11 +112,9 @@ Patch57: %{name}-ecj-gcj.patch
|
||||
Patch59: %{name}-swt-firefox.patch
|
||||
Patch60: %{name}-swt-firefox.2.patch
|
||||
Patch100: customBuildCallbacks.xml-add-pre.gather.bin.parts.patch
|
||||
# Look at gre64.conf *after* gre.conf on x86_64. Add ppc64 to the list of
|
||||
# arches on which to do this.
|
||||
# Add ppc64 to the list of arches with gre64.conf
|
||||
# part of https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=207016
|
||||
# FIXME: file the ordering issue upstream
|
||||
Patch101: %{name}-lookatgre64aftergre.patch
|
||||
Patch101: %{name}-ppc64gre64.patch
|
||||
|
||||
|
||||
%if %{gcj_support}
|
||||
@ -1737,6 +1735,9 @@ rm -f %{_datadir}/%{name}/configuration/org.eclipse.update/platform.xml*
|
||||
%{_libdir}/%{name}/plugins/org.eclipse.sdk_*
|
||||
|
||||
%changelog
|
||||
* Fri Nov 17 2006 Andrew Overholt <overholt@redhat.com> 3.2.1-20
|
||||
- Revise gre64 patch to just do ppc64 addition and not ordering change.
|
||||
|
||||
* Thu Nov 16 2006 Andrew Overholt <overholt@redhat.com> 3.2.1-19
|
||||
- Add patch to look at gre64.conf on ppc64.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user