- Take ownerhsip of /usr/share/eclipse dir (RHBZ#986160).

- Include fix for Eclipse bug 408505.
- Added rpmlint builder to the fedora package.

Conflicts:
	eclipse.spec
This commit is contained in:
Krzysztof Daniel 2013-07-23 14:09:33 +02:00
parent f0ef328957
commit 976ff40c72
4 changed files with 48 additions and 2 deletions

1
.gitignore vendored
View File

@ -16,7 +16,6 @@ eclipse-3.8.0-I20120314-1800-src.tar.bz2
eclipse-build-2c0f2ac34e3aee110187aa1dea28430bec724bdb.tar.xz
eclipse-4.2.0-I20120405-1114-src.tar.bz2
eclipse-build-5b8ee4c44320ee145596a3ce98fef1aa199055dd.tar.xz
/.project
eclipse-build-6df9efbd645d64284c969e9775d51be63fec7627.tar.xz
eclipse-build-bbaaeebc6916cc28848e3f7f8f2ae5b8390c2ee3.tar.xz
/R4_platform-aggregator-*

17
.project Normal file
View File

@ -0,0 +1,17 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
<name>eclipse</name>
<comment></comment>
<projects>
</projects>
<buildSpec>
<buildCommand>
<name>org.eclipse.linuxtools.rpm.rpmlint.rpmlintBuilder</name>
<arguments>
</arguments>
</buildCommand>
</buildSpec>
<natures>
<nature>org.eclipse.linuxtools.rpm.rpmlint.rpmlintNature</nature>
</natures>
</projectDescription>

21
eclipse-bug-408505.patch Normal file
View File

@ -0,0 +1,21 @@
--- eclipse.platform.swt/bundles/org.eclipse.swt/Eclipse SWT/gtk/org/eclipse/swt/widgets/Control.java.bak 2013-01-28 12:16:08.000000000 +0100
+++ eclipse.platform.swt/bundles/org.eclipse.swt/Eclipse SWT/gtk/org/eclipse/swt/widgets/Control.java 2013-02-19 13:22:29.529926456 +0100
@@ -987,7 +987,17 @@ int setBounds (int x, int y, int width, int height, boolean move, boolean resize
allocation.width = width;
allocation.height = height;
}
- OS.gtk_widget_size_allocate (topHandle, allocation);
+ /*
+ * The widget needs to be shown before its size is allocated
+ * in GTK 3.8 otherwise its allocation return 0
+ */
+ if (OS.GTK_VERSION >= OS.VERSION (3, 8, 0) && !OS.gtk_widget_get_visible(handle)) {
+ OS.gtk_widget_show(handle);
+ OS.gtk_widget_size_allocate (topHandle, allocation);
+ OS.gtk_widget_hide(handle);
+ } else {
+ OS.gtk_widget_size_allocate (topHandle, allocation);
+ }
}
/*
* Bug in GTK. Widgets cannot be sized smaller than 1x1.

View File

@ -51,7 +51,7 @@ fi;
Summary: An open, extensible IDE
Name: %{?scl_prefix}eclipse
Version: %{eclipse_version}
Release: 2%{?dist}
Release: 3%{?dist}
License: EPL
Group: Development/Tools
URL: http://www.eclipse.org/
@ -121,6 +121,8 @@ Patch25: %{pkg_name}-fix-startup-class-refresh.patch
Patch26: %{pkg_name}-fix-dropins.patch
Patch27: %{pkg_name}-bug-408505.patch
BuildRequires: ant >= 1.8.3
BuildRequires: rsync
BuildRequires: jpackage-utils >= 0:1.5, make, gcc
@ -342,6 +344,7 @@ tar --strip-components=1 -xf %{SOURCE1}
%{!?scl:%patch23}
%patch25
%patch26
%patch27
#Disable as many things as possible to make the build faster. We care only for Eclipse.
%pom_disable_module platform.sdk eclipse.platform.releng.tychoeclipsebuilder
@ -777,6 +780,7 @@ fi
/usr/share/icons/*/*/apps/*
%{_libdir}/%{pkg_name}/eclipse
%dir %{_libdir}/%{pkg_name}/dropins
%dir %{_datadir}/%{pkg_name}/
%dir %{_datadir}/%{pkg_name}/dropins
%dir %{_libdir}/%{pkg_name}/configuration/
%{_libdir}/%{pkg_name}/configuration/config.ini
@ -1001,6 +1005,11 @@ fi
%{_libdir}/%{pkg_name}/plugins/org.eclipse.osgi.util_*
%changelog
* Tue Jul 23 2013 Krzysztof Daniel <kdaniel@redhat.com> 1:4.3.0-3
- Take ownerhsip of /usr/share/eclipse dir (RHBZ#986160).
- Include fix for Eclipse bug 408505.
- Added rpmlint builder to the fedora package.
* Mon Jun 24 2013 Krzysztof Daniel <kdaniel@redhat.com> 1:4.3.0-2
- Consume Kepler EMF.