- New eclipse-build snapshot. Remove parts included in it.
This commit is contained in:
parent
9a4cec5501
commit
8cf5b9bb14
@ -1,218 +0,0 @@
|
||||
### Eclipse Workspace Patch 1.0
|
||||
#P org.eclipse.swt
|
||||
Index: Eclipse SWT/gtk/org/eclipse/swt/widgets/Control.java
|
||||
===================================================================
|
||||
RCS file: /cvsroot/eclipse/org.eclipse.swt/Eclipse SWT/gtk/org/eclipse/swt/widgets/Control.java,v
|
||||
retrieving revision 1.380.2.1
|
||||
diff -u -r1.380.2.1 Control.java
|
||||
--- Eclipse SWT/gtk/org/eclipse/swt/widgets/Control.java 7 Aug 2009 18:50:38 -0000 1.380.2.1
|
||||
+++ Eclipse SWT/gtk/org/eclipse/swt/widgets/Control.java 30 Sep 2009 16:19:55 -0000
|
||||
@@ -3332,6 +3332,30 @@
|
||||
region = null;
|
||||
}
|
||||
|
||||
+void restackWindow (int /*long*/ window, int /*long*/ sibling, boolean above) {
|
||||
+ if (OS.GTK_VERSION >= OS.VERSION (2, 17, 11)) {
|
||||
+ OS.gdk_window_restack (window, sibling, above);
|
||||
+ } else {
|
||||
+ /*
|
||||
+ * Feature in X. If the receiver is a top level, XConfigureWindow ()
|
||||
+ * will fail (with a BadMatch error) for top level shells because top
|
||||
+ * level shells are reparented by the window manager and do not share
|
||||
+ * the same X window parent. This is the correct behavior but it is
|
||||
+ * unexpected. The fix is to use XReconfigureWMWindow () instead.
|
||||
+ * When the receiver is not a top level shell, XReconfigureWMWindow ()
|
||||
+ * behaves the same as XConfigureWindow ().
|
||||
+ */
|
||||
+ int /*long*/ xDisplay = OS.gdk_x11_drawable_get_xdisplay (window);
|
||||
+ int /*long*/ xWindow = OS.gdk_x11_drawable_get_xid (window);
|
||||
+ int xScreen = OS.XDefaultScreen (xDisplay);
|
||||
+ int flags = OS.CWStackMode | OS.CWSibling;
|
||||
+ XWindowChanges changes = new XWindowChanges ();
|
||||
+ changes.sibling = OS.gdk_x11_drawable_get_xid (sibling);
|
||||
+ changes.stack_mode = above ? OS.Above : OS.Below;
|
||||
+ OS.XReconfigureWMWindow (xDisplay, xWindow, xScreen, flags, changes);
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
boolean sendDragEvent (int button, int stateMask, int x, int y, boolean isStateMask) {
|
||||
Event event = new Event ();
|
||||
event.button = button;
|
||||
@@ -3682,15 +3706,7 @@
|
||||
if (!OS.GDK_WINDOWING_X11 ()) {
|
||||
OS.gdk_window_raise (enableWindow);
|
||||
} else {
|
||||
- int /*long*/ topWindow = OS.GTK_WIDGET_WINDOW (topHandle);
|
||||
- int /*long*/ xDisplay = OS.gdk_x11_drawable_get_xdisplay (topWindow);
|
||||
- int /*long*/ xWindow = OS.gdk_x11_drawable_get_xid (enableWindow);
|
||||
- int xScreen = OS.XDefaultScreen (xDisplay);
|
||||
- int flags = OS.CWStackMode | OS.CWSibling;
|
||||
- XWindowChanges changes = new XWindowChanges ();
|
||||
- changes.sibling = OS.gdk_x11_drawable_get_xid (topWindow);
|
||||
- changes.stack_mode = OS.Above;
|
||||
- OS.XReconfigureWMWindow (xDisplay, xWindow, xScreen, flags, changes);
|
||||
+ restackWindow (enableWindow, OS.GTK_WIDGET_WINDOW (topHandle), true);
|
||||
}
|
||||
if (OS.GTK_WIDGET_VISIBLE (topHandle)) OS.gdk_window_show_unraised (enableWindow);
|
||||
}
|
||||
@@ -4170,29 +4186,12 @@
|
||||
OS.gdk_window_lower (window);
|
||||
}
|
||||
} else {
|
||||
- XWindowChanges changes = new XWindowChanges ();
|
||||
- changes.sibling = OS.gdk_x11_drawable_get_xid (siblingWindow != 0 ? siblingWindow : redrawWindow);
|
||||
- changes.stack_mode = above ? OS.Above : OS.Below;
|
||||
- if (redrawWindow != 0 && siblingWindow == 0) changes.stack_mode = OS.Below;
|
||||
- int /*long*/ xDisplay = OS.gdk_x11_drawable_get_xdisplay (window);
|
||||
- int /*long*/ xWindow = OS.gdk_x11_drawable_get_xid (window);
|
||||
- int xScreen = OS.XDefaultScreen (xDisplay);
|
||||
- int flags = OS.CWStackMode | OS.CWSibling;
|
||||
- /*
|
||||
- * Feature in X. If the receiver is a top level, XConfigureWindow ()
|
||||
- * will fail (with a BadMatch error) for top level shells because top
|
||||
- * level shells are reparented by the window manager and do not share
|
||||
- * the same X window parent. This is the correct behavior but it is
|
||||
- * unexpected. The fix is to use XReconfigureWMWindow () instead.
|
||||
- * When the receiver is not a top level shell, XReconfigureWMWindow ()
|
||||
- * behaves the same as XConfigureWindow ().
|
||||
- */
|
||||
- OS.XReconfigureWMWindow (xDisplay, xWindow, xScreen, flags, changes);
|
||||
+ int /*long*/ siblingW = siblingWindow != 0 ? siblingWindow : redrawWindow;
|
||||
+ boolean stack_mode = above;
|
||||
+ if (redrawWindow != 0 && siblingWindow == 0) stack_mode = false;
|
||||
+ restackWindow (window, siblingW, stack_mode);
|
||||
if (enableWindow != 0) {
|
||||
- changes.sibling = OS.gdk_x11_drawable_get_xid (window);
|
||||
- changes.stack_mode = OS.Above;
|
||||
- xWindow = OS.gdk_x11_drawable_get_xid (enableWindow);
|
||||
- OS.XReconfigureWMWindow (xDisplay, xWindow, xScreen, flags, changes);
|
||||
+ restackWindow (enableWindow, window, true);
|
||||
}
|
||||
}
|
||||
}
|
||||
Index: Eclipse SWT PI/gtk/library/os_stats.h
|
||||
===================================================================
|
||||
RCS file: /cvsroot/eclipse/org.eclipse.swt/Eclipse SWT PI/gtk/library/os_stats.h,v
|
||||
retrieving revision 1.180
|
||||
diff -u -r1.180 os_stats.h
|
||||
--- Eclipse SWT PI/gtk/library/os_stats.h 29 May 2009 21:30:13 -0000 1.180
|
||||
+++ Eclipse SWT PI/gtk/library/os_stats.h 30 Sep 2009 16:19:54 -0000
|
||||
@@ -511,6 +511,7 @@
|
||||
_1gdk_1window_1raise_FUNC,
|
||||
_1gdk_1window_1remove_1filter_FUNC,
|
||||
_1gdk_1window_1resize_FUNC,
|
||||
+ _1gdk_1window_1restack_FUNC,
|
||||
_1gdk_1window_1scroll_FUNC,
|
||||
_1gdk_1window_1set_1accept_1focus_FUNC,
|
||||
_1gdk_1window_1set_1back_1pixmap_FUNC,
|
||||
Index: Eclipse SWT PI/gtk/library/os_custom.h
|
||||
===================================================================
|
||||
RCS file: /cvsroot/eclipse/org.eclipse.swt/Eclipse SWT PI/gtk/library/os_custom.h,v
|
||||
retrieving revision 1.80
|
||||
diff -u -r1.80 os_custom.h
|
||||
--- Eclipse SWT PI/gtk/library/os_custom.h 29 May 2009 21:30:14 -0000 1.80
|
||||
+++ Eclipse SWT PI/gtk/library/os_custom.h 30 Sep 2009 16:19:54 -0000
|
||||
@@ -112,6 +112,7 @@
|
||||
#define gtk_status_icon_set_tooltip_LIB "libgtk-x11-2.0.so.0"
|
||||
#define gtk_window_get_group_LIB "libgtk-x11-2.0.so.0"
|
||||
#define gtk_window_get_opacity_LIB "libgtk-x11-2.0.so.0"
|
||||
+#define gdk_window_restack_LIB "libgdk-x11-2.0.so.0"
|
||||
#define gdk_window_set_keep_above_LIB "libgdk-x11-2.0.so.0"
|
||||
#define gdk_window_set_accept_focus_LIB "libgdk-x11-2.0.so.0"
|
||||
#define gtk_window_set_opacity_LIB "libgtk-x11-2.0.so.0"
|
||||
Index: Eclipse SWT PI/gtk/library/os_stats.c
|
||||
===================================================================
|
||||
RCS file: /cvsroot/eclipse/org.eclipse.swt/Eclipse SWT PI/gtk/library/os_stats.c,v
|
||||
retrieving revision 1.180
|
||||
diff -u -r1.180 os_stats.c
|
||||
--- Eclipse SWT PI/gtk/library/os_stats.c 29 May 2009 21:30:13 -0000 1.180
|
||||
+++ Eclipse SWT PI/gtk/library/os_stats.c 30 Sep 2009 16:19:54 -0000
|
||||
@@ -8,7 +8,7 @@
|
||||
* the LGPL accompanying this distribution and there is any conflict
|
||||
* between the two license versions, the terms of the LGPL accompanying
|
||||
* this distribution shall govern.
|
||||
- *
|
||||
+ *
|
||||
* Contributors:
|
||||
* IBM Corporation - initial API and implementation
|
||||
*******************************************************************************/
|
||||
@@ -18,8 +18,8 @@
|
||||
|
||||
#ifdef NATIVE_STATS
|
||||
|
||||
-int OS_nativeFunctionCount = 1291;
|
||||
-int OS_nativeFunctionCallCount[1291];
|
||||
+int OS_nativeFunctionCount = 1292;
|
||||
+int OS_nativeFunctionCallCount[1292];
|
||||
char * OS_nativeFunctionNames[] = {
|
||||
#ifndef JNI64
|
||||
"Call__IIII",
|
||||
@@ -503,6 +503,7 @@
|
||||
"_1gdk_1window_1raise",
|
||||
"_1gdk_1window_1remove_1filter",
|
||||
"_1gdk_1window_1resize",
|
||||
+ "_1gdk_1window_1restack",
|
||||
"_1gdk_1window_1scroll",
|
||||
"_1gdk_1window_1set_1accept_1focus",
|
||||
"_1gdk_1window_1set_1back_1pixmap",
|
||||
Index: Eclipse SWT PI/gtk/library/os.c
|
||||
===================================================================
|
||||
RCS file: /cvsroot/eclipse/org.eclipse.swt/Eclipse SWT PI/gtk/library/os.c,v
|
||||
retrieving revision 1.272
|
||||
diff -u -r1.272 os.c
|
||||
--- Eclipse SWT PI/gtk/library/os.c 29 May 2009 21:30:14 -0000 1.272
|
||||
+++ Eclipse SWT PI/gtk/library/os.c 30 Sep 2009 16:19:54 -0000
|
||||
@@ -5944,6 +5944,24 @@
|
||||
}
|
||||
#endif
|
||||
|
||||
+#ifndef NO__1gdk_1window_1restack
|
||||
+JNIEXPORT void JNICALL OS_NATIVE(_1gdk_1window_1restack)
|
||||
+ (JNIEnv *env, jclass that, jintLong arg0, jintLong arg1, jboolean arg2)
|
||||
+{
|
||||
+ OS_NATIVE_ENTER(env, that, _1gdk_1window_1restack_FUNC);
|
||||
+/*
|
||||
+ gdk_window_restack((GdkWindow *)arg0, (GdkWindow *)arg1, (gboolean)arg2);
|
||||
+*/
|
||||
+ {
|
||||
+ LOAD_FUNCTION(fp, gdk_window_restack)
|
||||
+ if (fp) {
|
||||
+ ((void (CALLING_CONVENTION*)(GdkWindow *, GdkWindow *, gboolean))fp)((GdkWindow *)arg0, (GdkWindow *)arg1, (gboolean)arg2);
|
||||
+ }
|
||||
+ }
|
||||
+ OS_NATIVE_EXIT(env, that, _1gdk_1window_1restack_FUNC);
|
||||
+}
|
||||
+#endif
|
||||
+
|
||||
#ifndef NO__1gdk_1window_1scroll
|
||||
JNIEXPORT void JNICALL OS_NATIVE(_1gdk_1window_1scroll)
|
||||
(JNIEnv *env, jclass that, jintLong arg0, jint arg1, jint arg2)
|
||||
Index: Eclipse SWT PI/gtk/org/eclipse/swt/internal/gtk/OS.java
|
||||
===================================================================
|
||||
RCS file: /cvsroot/eclipse/org.eclipse.swt/Eclipse SWT PI/gtk/org/eclipse/swt/internal/gtk/OS.java,v
|
||||
retrieving revision 1.525.2.1
|
||||
diff -u -r1.525.2.1 OS.java
|
||||
--- Eclipse SWT PI/gtk/org/eclipse/swt/internal/gtk/OS.java 20 Aug 2009 19:16:37 -0000 1.525.2.1
|
||||
+++ Eclipse SWT PI/gtk/org/eclipse/swt/internal/gtk/OS.java 30 Sep 2009 16:19:55 -0000
|
||||
@@ -4887,6 +4887,21 @@
|
||||
lock.unlock();
|
||||
}
|
||||
}
|
||||
+/**
|
||||
+ * @method flags=dynamic
|
||||
+ * @param window cast=(GdkWindow *)
|
||||
+ * @param sibling cast=(GdkWindow *)
|
||||
+ * @param above cast=(gboolean)
|
||||
+ */
|
||||
+public static final native void _gdk_window_restack(int /*long*/ window, int /*long*/ sibling, boolean above);
|
||||
+public static final void gdk_window_restack(int /*long*/ window, int /*long*/ sibling, boolean above) {
|
||||
+ lock.lock();
|
||||
+ try {
|
||||
+ _gdk_window_restack(window, sibling, above);
|
||||
+ } finally {
|
||||
+ lock.unlock();
|
||||
+ }
|
||||
+}
|
||||
/** @param window cast=(GdkWindow *) */
|
||||
public static final native void _gdk_window_scroll(int /*long*/ window, int dx, int dy);
|
||||
public static final void gdk_window_scroll(int /*long*/ window, int dx, int dy) {
|
@ -1,17 +0,0 @@
|
||||
--- plugins/org.eclipse.osgi/build.xml.sav 2009-03-04 16:14:31.000000000 +0100
|
||||
+++ plugins/org.eclipse.osgi/build.xml 2009-03-04 16:23:41.000000000 +0100
|
||||
@@ -16,7 +16,13 @@
|
||||
<property name="compilerArg" value=""/>
|
||||
<property name="bundleJavacSource" value="1.3"/>
|
||||
<property name="bundleJavacTarget" value="1.2"/>
|
||||
- <property name="bundleBootClasspath" value="osgi/exceptions.jar;osgi/xmlParserAPIs.jar;${CDC-1.1/Foundation-1.1}"/>
|
||||
+ <property name="dir_bootclasspath" value="${java.home}/lib"/>
|
||||
+ <path id="path_bootclasspath">
|
||||
+ <fileset dir="${dir_bootclasspath}">
|
||||
+ <include name="*.jar"/>
|
||||
+ </fileset>
|
||||
+ </path>
|
||||
+ <property name="bundleBootClasspath" refid="path_bootclasspath"/>
|
||||
|
||||
<target name="init" depends="properties">
|
||||
<condition property="pluginTemp" value="${buildTempFolder}/plugins" >
|
@ -1,339 +0,0 @@
|
||||
### Eclipse Workspace Patch 1.0
|
||||
#P org.eclipse.pde.build
|
||||
Index: templates/package-build/prepare-build-dir.sh
|
||||
===================================================================
|
||||
RCS file: templates/package-build/prepare-build-dir.sh
|
||||
diff -N templates/package-build/prepare-build-dir.sh
|
||||
--- /dev/null 1 Jan 1970 00:00:00 -0000
|
||||
+++ templates/package-build/prepare-build-dir.sh 1 Jan 1970 00:00:00 -0000
|
||||
@@ -0,0 +1,105 @@
|
||||
+#!/bin/sh
|
||||
+
|
||||
+if [ $# -lt 2 ]; then
|
||||
+ echo "usage: $0 <path to source dir> <path to build dir>"
|
||||
+ exit 1
|
||||
+fi
|
||||
+
|
||||
+if [ ! -d $1 ]; then
|
||||
+ echo "usage: $0 <path to source dir> <path to build dir>"
|
||||
+ exit 1
|
||||
+fi
|
||||
+
|
||||
+SOURCEDIR=$1
|
||||
+BUILDDIR=$2
|
||||
+TESTING=$3
|
||||
+
|
||||
+echo "preparing files in $1 for buildfile generation ..."
|
||||
+mkdir -p $BUILDDIR
|
||||
+
|
||||
+# make some ant build files to extract the id from the feature.xml, plugin.xml or the fragment.xml
|
||||
+mkdir -p $BUILDDIR/tmp
|
||||
+BUILDFILE=$BUILDDIR/tmp/build.xml
|
||||
+
|
||||
+echo "<project default=\"main\">
|
||||
+ <target name=\"main\">
|
||||
+ <xmlproperty file=\"@type@.xml\" collapseAttributes=\"true\"/>
|
||||
+ <fail unless=\"@type@.id\" message=\"feature.id not set\"/>
|
||||
+ <echo message=\"\${@type@.id}\" />
|
||||
+ </target>
|
||||
+</project>" > $BUILDFILE
|
||||
+
|
||||
+for type in feature plugin fragment; do
|
||||
+ CURBUILDFILE=$BUILDDIR/tmp/$type-build.xml
|
||||
+ cat $BUILDFILE | sed "s|@type@|$type|" > $CURBUILDFILE
|
||||
+done
|
||||
+
|
||||
+# make the directories eclipse is expecting
|
||||
+echo " making the 'features' and 'plugins' directories"
|
||||
+mkdir -p $BUILDDIR/features $BUILDDIR/plugins
|
||||
+
|
||||
+# make symlinks for the features
|
||||
+FEATURES=$(find $SOURCEDIR -name feature.xml)
|
||||
+find $SOURCEDIR -name feature.xml | while read f; do
|
||||
+ PROJECTDIR=$(dirname "$f")
|
||||
+ inSDK=1
|
||||
+ inSDK=$(echo $PROJECTDIR | grep -c $BUILDDIR)
|
||||
+ if [ $inSDK == 0 ]; then
|
||||
+ PROJECTNAME=$(ant -Dbasedir="$PROJECTDIR" -f $BUILDDIR/tmp/feature-build.xml 2>&1 | grep echo | cut --delimiter=' ' -f 7)
|
||||
+ ERROR=""
|
||||
+ if [ -z "$PROJECTNAME" ]; then
|
||||
+ echo "ERROR: could not determine the feature id for $PROJECTDIR"
|
||||
+ if [ $TESTING != true ]; then
|
||||
+ exit 1
|
||||
+ else
|
||||
+ ERROR="yes"
|
||||
+ fi
|
||||
+ fi
|
||||
+
|
||||
+ if [ "x$ERROR" != "xyes" ]; then
|
||||
+ if [[ $TESTING != true || `echo $PROJECTNAME | grep "org.eclipse"` ]]; then
|
||||
+ echo " making symlink: $BUILDDIR/features/$PROJECTNAME -> $PROJECTDIR"
|
||||
+ ln -sfT "$PROJECTDIR" $BUILDDIR/features/"$PROJECTNAME"
|
||||
+ fi
|
||||
+ fi
|
||||
+ fi
|
||||
+done
|
||||
+
|
||||
+# make symlinks for plugins and fragments
|
||||
+PLUGINDIRS=$(find $SOURCEDIR -name plugin.xml -o -name fragment.xml -o -name MANIFEST.MF | sed "s/plugin.xml//g" | sed "s/fragment.xml//g" | sed "s/META-INF\/MANIFEST.MF//" | sort | uniq)
|
||||
+find $SOURCEDIR -name plugin.xml -o -name fragment.xml -o -name MANIFEST.MF | sed "s/plugin.xml//g" | sed "s/fragment.xml//g" | sed "s/META-INF\/MANIFEST.MF//" | sort | uniq | while read dir; do
|
||||
+ PROJECTNAME=""
|
||||
+ ERROR=""
|
||||
+ inSDK=1
|
||||
+ inSDK=$(echo $dir | grep -c $BUILDDIR)
|
||||
+ if [ $inSDK == 0 ]; then
|
||||
+ if [ -e "$dir/META-INF/MANIFEST.MF" ]; then
|
||||
+ PROJECTNAME=$(grep Bundle-SymbolicName $dir/META-INF/MANIFEST.MF | cut --delimiter=';' -f 1 | cut --delimiter=' ' -f 2)
|
||||
+ elif [ -e "$dir/plugin.xml" ]; then
|
||||
+ PROJECTNAME=$(ant -Dbasedir=$dir -f $BUILDDIR/tmp/plugin-build.xml 2>&1 | grep echo | cut --delimiter=' ' -f 7)
|
||||
+ elif [ -e "$dir/fragment.xml" ]; then
|
||||
+ PROJECTNAME=$(ant -Dbasedir=$dir -f $BUILDDIR/tmp/fragment-build.xml 2>&1 | grep echo | cut --delimiter=' ' -f 7)
|
||||
+ fi
|
||||
+
|
||||
+ if [ -z "$PROJECTNAME" ]; then
|
||||
+ echo "ERROR: could not determine the plugin or fragment id for $dir"
|
||||
+ if [ $TESTING != true ]; then
|
||||
+ exit 1
|
||||
+ else
|
||||
+ ERROR="yes"
|
||||
+ fi
|
||||
+ fi
|
||||
+
|
||||
+ if [ "x$ERROR" != "xyes" ]; then
|
||||
+ if [[ $TESTING != true || `echo $PROJECTNAME | grep "org.eclipse"` ]]; then
|
||||
+ echo " making symlink: $BUILDDIR/plugins/$PROJECTNAME -> $dir"
|
||||
+ ln -sfT "$dir" $BUILDDIR/plugins/"$PROJECTNAME"
|
||||
+ fi
|
||||
+ fi;
|
||||
+
|
||||
+ fi
|
||||
+
|
||||
+done
|
||||
+
|
||||
+rm -rf $BUILDDIR/tmp
|
||||
+echo done
|
||||
Index: templates/package-build/customTargets-assemble-target.xml
|
||||
===================================================================
|
||||
RCS file: templates/package-build/customTargets-assemble-target.xml
|
||||
diff -N templates/package-build/customTargets-assemble-target.xml
|
||||
--- /dev/null 1 Jan 1970 00:00:00 -0000
|
||||
+++ templates/package-build/customTargets-assemble-target.xml 1 Jan 1970 00:00:00 -0000
|
||||
@@ -0,0 +1,15 @@
|
||||
+<project>
|
||||
+ <!-- ===================================================================== -->
|
||||
+ <!-- Targets to assemble the built elements for particular configurations -->
|
||||
+ <!-- These generally call the generated assemble scripts (named in -->
|
||||
+ <!-- ${assembleScriptName}) but may also add pre and post processing -->
|
||||
+ <!-- Add one target for each root element and each configuration -->
|
||||
+ <!-- ===================================================================== -->
|
||||
+
|
||||
+ <target name="assemble.@id@">
|
||||
+ <ant antfile="${assembleScriptName}" dir="${buildDirectory}"/>
|
||||
+ </target>
|
||||
+ <target name="assemble.@id@.@configs@">
|
||||
+ <ant antfile="${assembleScriptName}" dir="${buildDirectory}" />
|
||||
+ </target>
|
||||
+</project>
|
||||
Index: templates/package-build/customTargets.xml
|
||||
===================================================================
|
||||
RCS file: templates/package-build/customTargets.xml
|
||||
diff -N templates/package-build/customTargets.xml
|
||||
--- /dev/null 1 Jan 1970 00:00:00 -0000
|
||||
+++ templates/package-build/customTargets.xml 1 Jan 1970 00:00:00 -0000
|
||||
@@ -0,0 +1,149 @@
|
||||
+<project name="Build specific targets and properties" default="noDefault">
|
||||
+
|
||||
+ <fail unless="type" message="Please set the ${type} property to 'feature', 'plugin' or 'fragment'." />
|
||||
+ <fail unless="id" message="Please set the ${id} property to the feature, plugin or fragment id of the plugin you are building." />
|
||||
+ <fail unless="sourceDirectory" message="Please set the ${sourceDirectory} property to the directory that has the source plugins." />
|
||||
+
|
||||
+ <!-- we need to do this because you can't expand variables in target names -->
|
||||
+ <copy file="${builder}/customTargets-assemble-target.xml" tofile="${buildDirectory}/customTargets-${id}-assemble-target.xml" />
|
||||
+ <replace file="${buildDirectory}/customTargets-${id}-assemble-target.xml" token="@id@" value="${id}" />
|
||||
+ <replace file="${buildDirectory}/customTargets-${id}-assemble-target.xml" token="@configs@" value="${configs}" />
|
||||
+ <replace file="${buildDirectory}/customTargets-${id}-assemble-target.xml" token="," value="." />
|
||||
+ <import file="${buildDirectory}/customTargets-${id}-assemble-target.xml" />
|
||||
+
|
||||
+ <!-- ===================================================================== -->
|
||||
+ <!-- Run a given ${target} on all elements being built -->
|
||||
+ <!-- Add on <ant> task for each top level element being built. -->
|
||||
+ <!-- ===================================================================== -->
|
||||
+ <target name="allElements">
|
||||
+ <ant antfile="${genericTargets}" target="${target}">
|
||||
+ <property name="type" value="${type}" />
|
||||
+ <property name="id" value="${id}" />
|
||||
+ </ant>
|
||||
+ </target>
|
||||
+
|
||||
+
|
||||
+ <!-- ===================================================================== -->
|
||||
+ <!-- Check out map files from correct repository -->
|
||||
+ <!-- ===================================================================== -->
|
||||
+ <target name="getMapFiles">
|
||||
+ </target>
|
||||
+
|
||||
+ <!-- ===================================================================== -->
|
||||
+
|
||||
+ <target name="clean" unless="noclean">
|
||||
+ <antcall target="allElements">
|
||||
+ <param name="target" value="cleanElement" />
|
||||
+ </antcall>
|
||||
+ </target>
|
||||
+
|
||||
+ <!-- ===================================================================== -->
|
||||
+ <!-- Steps to do before setup -->
|
||||
+ <!-- ===================================================================== -->
|
||||
+ <target name="preSetup">
|
||||
+ </target>
|
||||
+
|
||||
+ <!-- ===================================================================== -->
|
||||
+ <!-- Steps to do after setup but before starting the build proper -->
|
||||
+ <!-- ===================================================================== -->
|
||||
+ <target name="postSetup">
|
||||
+ </target>
|
||||
+
|
||||
+ <!-- ===================================================================== -->
|
||||
+ <!-- Steps to do before fetching the build elements -->
|
||||
+ <!-- ===================================================================== -->
|
||||
+ <target name="preFetch">
|
||||
+ </target>
|
||||
+
|
||||
+ <!-- ===================================================================== -->
|
||||
+ <!-- Steps to do after fetching the build elements -->
|
||||
+ <!-- ===================================================================== -->
|
||||
+ <target name="postFetch">
|
||||
+ </target>
|
||||
+
|
||||
+ <!-- ===================================================================== -->
|
||||
+ <!-- Steps to do before generating the build scripts. -->
|
||||
+ <!-- ===================================================================== -->
|
||||
+ <target name="preGenerate">
|
||||
+ <!-- Eclipse expects the feature projects to be in the 'features' directory and
|
||||
+ plugin projects to be in the 'plugins' directory. The build infrastructure
|
||||
+ normally arranges the projects during the fetch stage. Since we aren't doing
|
||||
+ the fetch stage, we have to manually arrange the files -->
|
||||
+ <exec dir="${builder}" executable="/bin/sh">
|
||||
+ <arg line="prepare-build-dir.sh ${sourceDirectory} ${buildDirectory} ${testing}" />
|
||||
+ </exec>
|
||||
+ <exec dir="${builder}" executable="/bin/sh">
|
||||
+ <arg line="symlink-deps.sh ${buildDirectory} ${orbitDepsDir}" />
|
||||
+ </exec>
|
||||
+
|
||||
+ </target>
|
||||
+
|
||||
+ <!-- ===================================================================== -->
|
||||
+ <!-- Steps to do after generating the build scripts. -->
|
||||
+ <!-- ===================================================================== -->
|
||||
+ <target name="postGenerate">
|
||||
+ <antcall target="clean" />
|
||||
+ </target>
|
||||
+
|
||||
+ <!-- ===================================================================== -->
|
||||
+ <!-- Steps to do before running the build.xmls for the elements being built. -->
|
||||
+ <!-- ===================================================================== -->
|
||||
+ <target name="preProcess">
|
||||
+ </target>
|
||||
+
|
||||
+ <!-- ===================================================================== -->
|
||||
+ <!-- Steps to do after running the build.xmls for the elements being built. -->
|
||||
+ <!-- ===================================================================== -->
|
||||
+ <target name="postProcess">
|
||||
+ </target>
|
||||
+
|
||||
+ <!-- ===================================================================== -->
|
||||
+ <!-- Steps to do before running assemble. -->
|
||||
+ <!-- ===================================================================== -->
|
||||
+ <target name="preAssemble">
|
||||
+ </target>
|
||||
+
|
||||
+ <!-- ===================================================================== -->
|
||||
+ <!-- Steps to do after running assemble. -->
|
||||
+ <!-- ===================================================================== -->
|
||||
+ <target name="postAssemble">
|
||||
+ </target>
|
||||
+
|
||||
+ <!-- ===================================================================== -->
|
||||
+ <!-- Steps to do before running package. -->
|
||||
+ <!-- ===================================================================== -->
|
||||
+ <target name="prePackage">
|
||||
+ </target>
|
||||
+
|
||||
+ <!-- ===================================================================== -->
|
||||
+ <!-- Steps to do after running package. -->
|
||||
+ <!-- ===================================================================== -->
|
||||
+ <target name="postPackage">
|
||||
+ </target>
|
||||
+
|
||||
+ <!-- ===================================================================== -->
|
||||
+ <!-- Steps to do after the build is done. -->
|
||||
+ <!-- ===================================================================== -->
|
||||
+ <target name="postBuild">
|
||||
+ </target>
|
||||
+
|
||||
+ <!-- ===================================================================== -->
|
||||
+ <!-- Steps to do to test the build results -->
|
||||
+ <!-- ===================================================================== -->
|
||||
+ <target name="test">
|
||||
+ </target>
|
||||
+
|
||||
+ <!-- ===================================================================== -->
|
||||
+ <!-- Steps to do to publish the build results -->
|
||||
+ <!-- ===================================================================== -->
|
||||
+ <target name="publish">
|
||||
+ </target>
|
||||
+
|
||||
+ <!-- ===================================================================== -->
|
||||
+ <!-- Default target -->
|
||||
+ <!-- ===================================================================== -->
|
||||
+ <target name="noDefault">
|
||||
+ <echo message="You must specify a target when invoking this file" />
|
||||
+ </target>
|
||||
+
|
||||
+</project>
|
||||
Index: templates/package-build/build.properties
|
||||
===================================================================
|
||||
RCS file: templates/package-build/build.properties
|
||||
diff -N templates/package-build/build.properties
|
||||
--- /dev/null 1 Jan 1970 00:00:00 -0000
|
||||
+++ templates/package-build/build.properties 1 Jan 1970 00:00:00 -0000
|
||||
@@ -0,0 +1,12 @@
|
||||
+buildDirectory=${sourceDirectory}/build
|
||||
+buildLabel=rpmBuild
|
||||
+archivePrefix=eclipse
|
||||
+skipFetch=true
|
||||
+javacFailOnError=true
|
||||
+collectingFolder=eclipse
|
||||
+archivesFormat=*,*,*-zip
|
||||
+zipargs=-y
|
||||
+javacDebugInfo=true
|
||||
+archiveName=${id}.zip
|
||||
+runPackager=false
|
||||
+baseLocation=/usr/share/eclipse
|
||||
Index: templates/package-build/symlink-deps.sh
|
||||
===================================================================
|
||||
RCS file: templates/package-build/symlink-deps.sh
|
||||
diff -N templates/package-build/symlink-deps.sh
|
||||
--- /dev/null 1 Jan 1970 00:00:00 -0000
|
||||
+++ templates/package-build/symlink-deps.sh 1 Jan 1970 00:00:00 -0000
|
||||
@@ -0,0 +1,21 @@
|
||||
+#!/bin/sh -x
|
||||
+
|
||||
+if [ $# -ne 2 ]; then
|
||||
+ echo "usage: $0 <path to build dir> <dependencies>"
|
||||
+ exit 1
|
||||
+fi
|
||||
+
|
||||
+if [ ! -d $1 ]; then
|
||||
+ echo "usage: $0 <path to build dir> <dependencies>"
|
||||
+ exit 1
|
||||
+fi
|
||||
+
|
||||
+BUILDDIR=$1
|
||||
+DEPENDENCIESDIR=$2
|
||||
+
|
||||
+pushd $BUILDDIR/plugins
|
||||
+ for dep in `ls $DEPENDENCIESDIR`; do
|
||||
+ echo "ln -s $DEPENDENCIESDIR/$dep"
|
||||
+ ln -s $DEPENDENCIESDIR/$dep
|
||||
+ done
|
||||
+popd
|
89
eclipse.spec
89
eclipse.spec
@ -30,7 +30,7 @@ Epoch: 1
|
||||
Summary: An open, extensible IDE
|
||||
Name: eclipse
|
||||
Version: %{eclipse_majmin}.%{eclipse_micro}
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
License: EPL
|
||||
Group: Text Editors/Integrated Development Environments (IDE)
|
||||
URL: http://www.eclipse.org/
|
||||
@ -49,16 +49,6 @@ Source27: ecf-filetransfer-build.properties
|
||||
# This script copies the platform sub-set of the SDK for generating metadata
|
||||
Source28: %{name}-mv-Platform.sh
|
||||
|
||||
# This does two things:
|
||||
# 1. allows the launcher to be in /usr/bin and
|
||||
# 2. ensures that the OSGi configuration directory
|
||||
# (which contains the JNI .sos) is in %{_libdir}
|
||||
# We should investigate whether or not this can go upstream
|
||||
#Patch12: %{name}-launcher-set-install-dir-and-shared-config.patch
|
||||
# generic releng plugins that can be used to build plugins
|
||||
# see this thread for details:
|
||||
# https://www.redhat.com/archives/fedora-devel-java-list/2006-April/msg00048.html
|
||||
Patch0: %{name}-pde.build-add-package-build.patch
|
||||
Patch1: %{name}-add-ppc64-sparc64-s390-s390x.patch
|
||||
Patch2: %{name}-add-ppc64-sparc64-s390-s390x-2.patch
|
||||
|
||||
@ -69,14 +59,6 @@ Patch5: %{name}-add-ppc64-filesystem.patch
|
||||
# need to go upstream.
|
||||
Patch6: %{name}-target-platform-template.patch
|
||||
|
||||
# Add /usr/share/eclipse/dropins to list of dropins locations
|
||||
# Already applied in eclipse-build upstream rev. #23023
|
||||
Patch7: %{name}-addusrsharedropins.patch
|
||||
|
||||
# https://bugs.eclipse.org/bugs/show_bug.cgi?id=287307
|
||||
# Already applied in eclipse-build upstream
|
||||
Patch8: %{name}-gtk2.18zorder.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: ant
|
||||
BuildRequires: jpackage-utils >= 0:1.5, make, gcc
|
||||
@ -222,14 +204,9 @@ developing Eclipse plugins.
|
||||
%prep
|
||||
%setup -q -n eclipse-build-0.4.0RC0
|
||||
cp %{SOURCE1} .
|
||||
sed --in-place "s/<target name=\"build\" depends=\"applyPatches,bootstrap,compilelibs\">/<target name=\"build\" depends=\"bootstrap,compilelibs\">/" build.xml
|
||||
ant applyPatches
|
||||
pushd build/eclipse-R3_5_1-fetched-src
|
||||
|
||||
# liblocalfile fixes
|
||||
sed --in-place "s/JAVA_HOME =/#JAVA_HOME =/" plugins/org.eclipse.core.filesystem/natives/unix/linux/Makefile
|
||||
sed --in-place "s/OPT_FLAGS=-O/OPT_FLAGS=-O2 -g/" plugins/org.eclipse.core.filesystem/natives/unix/linux/Makefile
|
||||
|
||||
# Use our system-installed javadocs, reference only what we built, and
|
||||
# don't like to osgi.org docs (FIXME: maybe we should package them?)
|
||||
sed -i -e "s|http://java.sun.com/j2se/1.4.2/docs/api|%{_datadir}/javadoc/java|" \
|
||||
@ -245,19 +222,10 @@ sed -i -e "s|http://java.sun.com/j2se/1.4/docs/api|%{_datadir}/javadoc/java|" \
|
||||
plugins/org.eclipse.pde.doc.user/pdeOptions.txt \
|
||||
plugins/org.eclipse.pde.doc.user/pdeOptions.txt
|
||||
|
||||
pushd plugins/org.eclipse.pde.build
|
||||
%patch0
|
||||
sed --in-place "s:/usr/share/eclipse:%{_libdir}/%{name}:" templates/package-build/build.properties
|
||||
popd
|
||||
|
||||
# Remove signatures for JARs
|
||||
find -iname \*.sf | xargs rm
|
||||
find -iname \*.rsa | xargs rm
|
||||
|
||||
# all output should be directed to stdout
|
||||
# https://bugs.eclipse.org/bugs/show_bug.cgi?id=144942
|
||||
find -type f -name \*.xml -exec sed --in-place -r "s/output=\".*(txt|log).*\"//g" "{}" \;
|
||||
|
||||
# Remove existing .sos and binary launcher
|
||||
find -name \*.so | xargs rm
|
||||
find features/org.eclipse.equinox.executable -type f -name eclipse | xargs rm
|
||||
@ -497,11 +465,6 @@ rm plugins/org.eclipse.swt/extra_jars/exceptions.jar \
|
||||
plugins/org.eclipse.osgi/osgi/osgi.cmpn.jar \
|
||||
plugins/org.eclipse.osgi/osgi/osgi.core.jar
|
||||
|
||||
# FIXME: figure out a way to symlink to something. Alternatively,
|
||||
# patch out of package.org.eclipse.sdk*.xml.
|
||||
# Delete unnecessary-for-build source JARs
|
||||
#rm plugins/*.source_*.jar
|
||||
|
||||
# make sure there are no jars left
|
||||
JARS=""
|
||||
for j in $(find -name \*.jar); do
|
||||
@ -527,11 +490,6 @@ popd
|
||||
|
||||
# target platform template patch
|
||||
%patch6 -p0
|
||||
%patch7 -p0
|
||||
popd
|
||||
|
||||
pushd build/eclipse-R3_5_1-fetched-src/plugins/org.eclipse.swt
|
||||
%patch8 -p0
|
||||
popd
|
||||
|
||||
%build
|
||||
@ -576,17 +534,15 @@ SWT_MAJ_VER=$(grep maj_ver build/eclipse-R3_5_1-fetched-src/plugins/org.eclipse.
|
||||
SWT_MIN_VER=$(grep min_ver build/eclipse-R3_5_1-fetched-src/plugins/org.eclipse.swt/Eclipse\ SWT/common/library/make_common.mak | cut -f 2 -d =)
|
||||
SWT_VERSION=$SWT_MAJ_VER$SWT_MIN_VER
|
||||
|
||||
ant -DdestDir=$RPM_BUILD_ROOT -Dprefix=/usr -DbuildArch=%{eclipse_arch} install
|
||||
|
||||
cp $RPM_BUILD_ROOT%{_libdir}/eclipse/eclipse.ini eclipse.ini-real
|
||||
# Some directories we need
|
||||
sdkDir=$RPM_BUILD_ROOT%{_libdir}/%{name}
|
||||
install -d -m 755 $sdkDir
|
||||
install -d -m 755 $sdkDir/plugins
|
||||
install -d -m 755 $sdkDir/features
|
||||
# FIXME: We can probably get rid of the links directory (for the
|
||||
# datadir.link file) when we ensure all plugins are installing into
|
||||
# dropins (either in libdir or datadir).
|
||||
install -d -m 755 $RPM_BUILD_ROOT%{_libdir}/java
|
||||
install -d -m 755 $RPM_BUILD_ROOT%{_datadir}/%{name}
|
||||
install -d -m 755 $RPM_BUILD_ROOT%{_datadir}/%{name}/dropins
|
||||
|
||||
# FIXME: Please don't install stuff to these directories. They're only
|
||||
# still here for legacy plugins (which probably won't function in 3.4).
|
||||
@ -813,24 +769,10 @@ done
|
||||
popd
|
||||
%endif
|
||||
|
||||
cp -p build/eclipse-R3_5_1-fetched-src/installation/eclipse.ini \
|
||||
cp -p eclipse.ini-real \
|
||||
$sdkDir/eclipse.ini
|
||||
# We have /usr/share/eclipse/dropins in eclipse.ini
|
||||
sed -i "s|/usr/share|%{_datadir}|" $sdkDir/eclipse.ini
|
||||
|
||||
sed --in-place "s/osgi.ws=gtk/osgi.ws=gtk\norg.eclipse.update.reconcile=false/" \
|
||||
$RPM_BUILD_ROOT%{_libdir}/%{name}/configuration/config.ini
|
||||
sed --in-place "s|org.eclipse.core.runtime,3.5.0.v20090316,file:plugins/org.eclipse.core.runtime_3.5.0.v20090316.jar,4,false|org.eclipse.core.runtime,3.5.0.v20090316,file:plugins/org.eclipse.core.runtime_3.5.0.v20090316.jar,4,true|" \
|
||||
$RPM_BUILD_ROOT%{_libdir}/%{name}/configuration/org.eclipse.equinox.simpleconfigurator/bundles.info
|
||||
|
||||
# Install the Eclipse binary wrapper
|
||||
install -d -m 755 $RPM_BUILD_ROOT%{_bindir}
|
||||
ln -s %{_libdir}/%{name}/%{name} $RPM_BUILD_ROOT%{_bindir}/%{name}
|
||||
install -d -m 755 $RPM_BUILD_ROOT%{_bindir}
|
||||
#cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/eclipse
|
||||
#sed --in-place "s|@LIBDIR@|%{_libdir}|g" $RPM_BUILD_ROOT%{_bindir}/eclipse
|
||||
#ECLIPSELIBSUFFIX=$(ls $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/org.eclipse.equinox.launcher.gtk.linux*/*.so | sed "s/.*.launcher.gtk.linux.//")
|
||||
#sed --in-place "s|@ECLIPSELIBSUFFIX@|$ECLIPSELIBSUFFIX|" $RPM_BUILD_ROOT%{_bindir}/eclipse
|
||||
sed -i "s|$RPM_BUILD_ROOT||g" $sdkDir/eclipse.ini
|
||||
|
||||
mkdir -p $RPM_BUILD_ROOT%{_libdir}/%{name}/links
|
||||
# FIXME: We can probably get rid of the links file when we ensure all
|
||||
@ -851,20 +793,6 @@ ln -s swt-gtk-%{eclipse_majmin}.%{eclipse_micro}.jar swt.jar
|
||||
ln -s ../%{name}/swt-gtk-%{eclipse_majmin}.%{eclipse_micro}.jar ../java/swt.jar
|
||||
popd
|
||||
|
||||
# Icons
|
||||
PLATFORMVERSION=$(ls $sdkDir/plugins | grep org.eclipse.platform_ | sed 's/org.eclipse.platform_//')
|
||||
install -d -m 755 $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
|
||||
ln -s %{_libdir}/%{name}/plugins/org.eclipse.platform_$PLATFORMVERSION/eclipse48.png \
|
||||
$RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/%{name}.png
|
||||
install -d -m 755 $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
|
||||
ln -s %{_libdir}/%{name}/plugins/org.eclipse.platform_$PLATFORMVERSION/eclipse32.png \
|
||||
$RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/%{name}.png
|
||||
install -d -m 755 $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps
|
||||
ln -s %{_libdir}/%{name}/plugins/org.eclipse.platform_$PLATFORMVERSION/eclipse.png \
|
||||
$RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/%{name}.png
|
||||
install -d -m 755 $RPM_BUILD_ROOT%{_datadir}/pixmaps
|
||||
ln -s %{_datadir}/icons/hicolor/48x48/apps/%{name}.png $RPM_BUILD_ROOT%{_datadir}/pixmaps
|
||||
|
||||
# Install the efj wrapper script
|
||||
install -p -D -m0755 %{SOURCE17} $RPM_BUILD_ROOT%{_bindir}/efj
|
||||
sed --in-place "s:startup.jar:%{_libdir}/%{name}/startup.jar:" \
|
||||
@ -1147,8 +1075,6 @@ fi
|
||||
%defattr(-,root,root)
|
||||
%attr(0755,root,root) %{_bindir}/%{name}
|
||||
%config %{_libdir}/%{name}/eclipse.ini
|
||||
#%{_libdir}/%{name}/.eclipseproduct
|
||||
%{_libdir}/%{name}/configuration/config.ini
|
||||
%ifnarch ppc
|
||||
%{_libdir}/%{name}/about_files
|
||||
%endif
|
||||
@ -1302,6 +1228,9 @@ fi
|
||||
#%{_libdir}/%{name}/configuration/org.eclipse.equinox.source
|
||||
|
||||
%changelog
|
||||
* Thu Oct 8 2009 Alexander Kurtakov <akurtako@redhat.com> 1:3.5.1-4
|
||||
- New eclipse-build snapshot. Remove parts included in it.
|
||||
|
||||
* Wed Oct 07 2009 Andrew Overholt <overholt@redhat.com> 1:3.5.1-3
|
||||
- Add patch for bugs.eclipse.org/287307
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user