Lucene issue fixed by changing lucene to lucene.core in pom.xml
This commit is contained in:
parent
1654f952e0
commit
6d46f95da5
@ -92,3 +92,14 @@ diff -r -Nu eclipse-3.8.0-M1-src/plugins/org.eclipse.help.base/META-INF/MANIFEST
|
||||
org.eclipse.ant.core;bundle-version="3.2.200";resolution:=optional,
|
||||
org.eclipse.core.runtime;bundle-version="3.6.0",
|
||||
org.eclipse.help;bundle-version="[3.5.0,4.0.0)";visibility:=reexport,
|
||||
--- eclipse.platform.ua/org.eclipse.help.base/pom.xml.bak 2012-07-25 17:39:10.000000000 +0200
|
||||
+++ eclipse.platform.ua/org.eclipse.help.base/pom.xml 2012-07-26 14:34:22.971863419 +0200
|
||||
@@ -33,7 +33,7 @@
|
||||
<extraRequirements>
|
||||
<requirement>
|
||||
<type>eclipse-plugin</type>
|
||||
- <id>org.apache.lucene</id>
|
||||
+ <id>org.apache.lucene.core</id>
|
||||
<versionRange>[2.9,3.0)</versionRange>
|
||||
</requirement>
|
||||
<requirement>
|
||||
|
14
eclipse.spec
14
eclipse.spec
@ -46,6 +46,8 @@ Source4: macros.%{name}
|
||||
# +org.apache.jasper
|
||||
# +org.apache.juli
|
||||
# -org.apache.lucene
|
||||
# -org.apache.lucene
|
||||
# +org.apache.lucene.core
|
||||
Patch0: %{name}-help-feature-adjust-dependencies.patch
|
||||
|
||||
|
||||
@ -283,19 +285,17 @@ find . -name *.so -exec rm -f {} \;
|
||||
#popd
|
||||
|
||||
%build
|
||||
mvn-rpmbuild -o -f eclipse-parent/pom.xml \
|
||||
mvn-rpmbuild -f eclipse-parent/pom.xml \
|
||||
clean install \
|
||||
-Dmaven.repo.local=R4_localrepo \
|
||||
-Dmaven.local.mode=true
|
||||
|
||||
mvn-rpmbuild -o -f maven-cbi-plugin/pom.xml \
|
||||
mvn-rpmbuild -f maven-cbi-plugin/pom.xml \
|
||||
clean install \
|
||||
-Dmaven.repo.local=R4_localrepo \
|
||||
-Dmaven.local.mode=true
|
||||
|
||||
mvn-rpmbuild -o clean install \
|
||||
-Dmaven.repo.local=R4_localrepo -Dmaven.test.skip=true -Dnative=gtk.linux.%{arch} \
|
||||
-Dmaven.local.mode=true
|
||||
mvn-rpmbuild clean install \
|
||||
-Dmaven.test.skip=true -Dnative=gtk.linux.%{arch} \
|
||||
-Dmaven.local.mode=true
|
||||
|
||||
#export JAVA_HOME=%{java_home}
|
||||
#ant provision.cvs
|
||||
|
Loading…
Reference in New Issue
Block a user