diff --git a/3.3-TODO.txt b/3.3-TODO.txt
new file mode 100644
index 0000000..18d31d2
--- /dev/null
+++ b/3.3-TODO.txt
@@ -0,0 +1,21 @@
+* check for correct files listings -- may need to add another sub-package
+* re-enable timestamp squashing
+* enable ecj on ppc64, s390{,x}, sparc{,64}
+* icu4j 3.6.0
+* update package build
+* splashscreen
+* junit 4.1
+* ant 1.7
+* deal with these:
+
+com.ibm.icu_3.6.1.v20070417.jar
+com.jcraft.jsch_0.1.28.jar
+javax.servlet_2.4.0.v200704241052.jar
+javax.servlet.jsp_2.0.0.v200703221034.jar
+org.apache.commons.el_1.0.0.v200704241052.jar
+org.apache.commons.logging_1.0.4.v200701082340.jar
+org.apache.jasper_5.5.17.v200704241052.jar
+org.apache.lucene_1.9.1.v200703221049.jar
+org.apache.lucene.analysis_1.9.1.v200703221049.jar
+org.mortbay.jetty_5.1.11.v200701082340.jar
+
diff --git a/eclipse-add-ppc64-sparc64-s390-s390x.patch b/eclipse-add-ppc64-sparc64-s390-s390x.patch
deleted file mode 100644
index c3808eb..0000000
--- a/eclipse-add-ppc64-sparc64-s390-s390x.patch
+++ /dev/null
@@ -1,165 +0,0 @@
-Index: src/org/eclipse/core/runtime/Platform.java
-===================================================================
-RCS file: /cvsroot/eclipse/org.eclipse.core.runtime/src/org/eclipse/core/runtime/Platform.java,v
-retrieving revision 1.106
-diff -u -r1.106 Platform.java
---- plugins/org.eclipse.core.runtime/src/org/eclipse/core/runtime/Platform.java 13 Apr 2006 00:42:47 -0000 1.106
-+++ plugins/org.eclipse.core.runtime/src/org/eclipse/core/runtime/Platform.java 31 Jan 2007 21:33:51 -0000
-@@ -339,6 +339,11 @@
- * @since 3.1
- */
- public static final String ARCH_IA64_32 = "ia64_32";//$NON-NLS-1$
-+
-+ public static final String ARCH_PPC64 = "ppc64";//$NON-NLS-1$
-+ public static final String ARCH_SPARC64 = "sparc64";//$NON-NLS-1$
-+ public static final String ARCH_S390 = "s390";//$NON-NLS-1$
-+ public static final String ARCH_S390X = "s390x";//$NON-NLS-1$
-
- /**
- * Constant string (value "win32") indicating the platform is running on a
-Index: src/org/eclipse/core/internal/runtime/InternalPlatform.java
-===================================================================
-RCS file: /cvsroot/eclipse/org.eclipse.core.runtime/src/org/eclipse/core/internal/runtime/InternalPlatform.java,v
-retrieving revision 1.253
-diff -u -r1.253 InternalPlatform.java
---- plugins/org.eclipse.core.runtime/src/org/eclipse/core/internal/runtime/InternalPlatform.java 21 Apr 2006 20:49:57 -0000 1.253
-+++ plugins/org.eclipse.core.runtime/src/org/eclipse/core/internal/runtime/InternalPlatform.java 31 Jan 2007 21:33:50 -0000
-@@ -52,6 +52,10 @@
- Platform.ARCH_X86, //
- Platform.ARCH_AMD64, //
- Platform.ARCH_IA64, //
-+ Platform.ARCH_PPC64, //
-+ Platform.ARCH_SPARC64, //
-+ Platform.ARCH_S390, //
-+ Platform.ARCH_S390X, //
- Platform.ARCH_IA64_32};
- private static final String BOOT = "-boot"; //$NON-NLS-1$
- private static final String CLASSLOADER_PROPERTIES = "-classloaderProperties"; //$NON-NLS-1$
-Index: eclipseAdaptor/src/org/eclipse/core/runtime/internal/adaptor/PluginConverterImpl.java
-===================================================================
-RCS file: /cvsroot/eclipse/org.eclipse.osgi/eclipseAdaptor/src/org/eclipse/core/runtime/internal/adaptor/PluginConverterImpl.java,v
-retrieving revision 1.13
-diff -u -r1.13 PluginConverterImpl.java
---- plugins/org.eclipse.osgi/eclipseAdaptor/src/org/eclipse/core/runtime/internal/adaptor/PluginConverterImpl.java 13 Apr 2006 16:10:27 -0000 1.13
-+++ plugins/org.eclipse.osgi/eclipseAdaptor/src/org/eclipse/core/runtime/internal/adaptor/PluginConverterImpl.java 31 Jan 2007 21:33:52 -0000
-@@ -64,7 +64,7 @@
- private static final String MANIFEST_VERSION = "Manifest-Version"; //$NON-NLS-1$
- private static final String PLUGIN_PROPERTIES_FILENAME = "plugin"; //$NON-NLS-1$
- private static PluginConverterImpl instance;
-- private static final String[] ARCH_LIST = {org.eclipse.osgi.service.environment.Constants.ARCH_PA_RISC, org.eclipse.osgi.service.environment.Constants.ARCH_PPC, org.eclipse.osgi.service.environment.Constants.ARCH_SPARC, org.eclipse.osgi.service.environment.Constants.ARCH_X86, org.eclipse.osgi.service.environment.Constants.ARCH_AMD64, org.eclipse.osgi.service.environment.Constants.ARCH_IA64};
-+ private static final String[] ARCH_LIST = {org.eclipse.osgi.service.environment.Constants.ARCH_PA_RISC, org.eclipse.osgi.service.environment.Constants.ARCH_PPC, org.eclipse.osgi.service.environment.Constants.ARCH_SPARC, org.eclipse.osgi.service.environment.Constants.ARCH_X86, org.eclipse.osgi.service.environment.Constants.ARCH_AMD64, org.eclipse.osgi.service.environment.Constants.ARCH_IA64, org.eclipse.osgi.service.environment.Constants.ARCH_PPC64, org.eclipse.osgi.service.environment.Constants.ARCH_SPARC64, org.eclipse.osgi.service.environment.Constants.ARCH_S390, org.eclipse.osgi.service.environment.Constants.ARCH_S390X};
- static public final String FRAGMENT_MANIFEST = "fragment.xml"; //$NON-NLS-1$
- static public final String GENERATED_FROM = "Generated-from"; //$NON-NLS-1$
- static public final String MANIFEST_TYPE_ATTRIBUTE = "type"; //$NON-NLS-1$
-Index: eclipseAdaptor/src/org/eclipse/osgi/service/environment/Constants.java
-===================================================================
-RCS file: /cvsroot/eclipse/org.eclipse.osgi/eclipseAdaptor/src/org/eclipse/osgi/service/environment/Constants.java,v
-retrieving revision 1.9
-diff -u -r1.9 Constants.java
---- plugins/org.eclipse.osgi/eclipseAdaptor/src/org/eclipse/osgi/service/environment/Constants.java 13 Jun 2005 17:14:22 -0000 1.9
-+++ plugins/org.eclipse.osgi/eclipseAdaptor/src/org/eclipse/osgi/service/environment/Constants.java 31 Jan 2007 21:33:52 -0000
-@@ -119,6 +119,11 @@
- */
- public static final String ARCH_IA64_32 = "ia64_32";//$NON-NLS-1$
-
-+ public static final String ARCH_PPC64 = "ppc64";//$NON-NLS-1$
-+ public static final String ARCH_SPARC64 = "sparc64";//$NON-NLS-1$
-+ public static final String ARCH_S390 = "s390";//$NON-NLS-1$
-+ public static final String ARCH_S390X = "s390x";//$NON-NLS-1$
-+
- /**
- * Constant string (value "win32") indicating the platform is running on a
- * machine using the Windows windowing system.
-Index: feature.xml
-===================================================================
-RCS file: /cvsroot/eclipse/org.eclipse.sdk-feature/features/org.eclipse.rcp/feature.xml,v
-retrieving revision 1.40.2.1
-diff -u -r1.40.2.1 feature.xml
---- features/org.eclipse.rcp/feature.xml 1 Aug 2006 17:29:33 -0000 1.40.2.1
-+++ features/org.eclipse.rcp/feature.xml 6 Feb 2007 23:44:22 -0000
-@@ -308,5 +308,60 @@
- install-size="0"
- version="0.0.0"
- unpack="false"/>
-+
-+
-+
-+
-+
-+
-+
-+
-+
-+
-
-
-diff -ru features/org.eclipse.platform.source/feature.xml features/org.eclipse.platform.source/feature.xml
---- features/org.eclipse.platform.source/feature.xml 2007-02-06 19:04:05.000000000 -0500
-+++ features/org.eclipse.platform.source/feature.xml 2007-02-06 19:07:26.000000000 -0500
-@@ -28,4 +28,8 @@
-
-
-
-+
-+
-+
-+
-
-diff -ru features/org.eclipse.rcp.source/feature.xml features/org.eclipse.rcp.source/feature.xml
---- features/org.eclipse.rcp.source/feature.xml 2007-02-06 19:04:06.000000000 -0500
-+++ features/org.eclipse.rcp.source/feature.xml 2007-02-06 19:09:11.000000000 -0500
-@@ -28,4 +28,9 @@
-
-
-
-+
-+
-+
-+
-+
-
diff --git a/eclipse-libupdatebuild.patch b/eclipse-libupdatebuild.patch
deleted file mode 100644
index 7995cb9..0000000
--- a/eclipse-libupdatebuild.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- plugins/org.eclipse.update.core.linux/src/build.xml.orig 2005-02-07 14:16:05.353485675 -0500
-+++ plugins/org.eclipse.update.core.linux/src/build.xml 2005-02-07 14:17:04.365259400 -0500
-@@ -47,7 +47,7 @@
-
-
-
--
-+
-
-
-
-@@ -56,9 +56,8 @@
-
-
-
-+
-
--
--
-
-
-
-@@ -67,4 +66,4 @@
-
-
-
--
-\ No newline at end of file
-+
diff --git a/eclipse.spec b/eclipse.spec
index 40a67fe..6cf32b7 100644
--- a/eclipse.spec
+++ b/eclipse.spec
@@ -55,9 +55,6 @@ Patch4: %{name}-swttools.patch
# (which contains the JNI .sos) is in %{_libdir}
# We should investigate whether or not this can go upstream
Patch12: %{name}-launcher-set-install-dir-and-shared-config.patch
-# Don't attempt to link to Sun's javadocs
-# FIXME: could use sed instead
-Patch13: %{name}-javadoclinks.patch
# Always generate debug info when building RPMs (Andrew Haley)
# This needs to be investigated for getEnv changes
Patch14: %{name}-ecj-rpmdebuginfo.patch
@@ -373,13 +370,16 @@ sed --in-place "s:/usr/share/eclipse:%{_datadir}/%{name}:" library/eclipse.c
zip -q -9 -r ../../plugins/org.eclipse.platform/launchersrc.zip library
popd
-# Link against our system-installed javadocs
-%patch13 -p0
-sed --in-place "s:/usr/share/:%{_datadir}/:g" \
- plugins/org.eclipse.jdt.doc.isv/jdtOptions.txt \
- plugins/org.eclipse.pde.doc.user/pdeOptions.txt \
- plugins/org.eclipse.pde.doc.user/pdeOptions \
- plugins/org.eclipse.platform.doc.isv/platformOptions.txt
+# use our system-installed javadocs
+sed --in-place "s|http://java.sun.com/j2se/1.4.2/docs/api|%{_datadir}/javadocs/java|" \
+ plugins/org.eclipse.platform.doc.isv/platformOptions.txt
+sed --in-place "s|http://java.sun.com/j2se/1.5/docs/api|%{_datadir}/javadocs/java|" \
+ plugins/org.eclipse.jdt.doc.isv/jdtaptOptions.txt \
+ plugins/org.eclipse.jdt.doc.isv/jdtOptions.txt
+sed --in-place "s|http://java.sun.com/j2se/1.4/docs/api|%{_datadir}/javadocs/java|" \
+ plugins/org.eclipse.pde.doc.user/pdeOptions.txt \
+ plugins/org.eclipse.pde.doc.user/pdeOptions
+
%patch14 -p0
pushd plugins/org.eclipse.pde.build