- Add shell script portability patch for prepare-build-dir.sh
This commit is contained in:
parent
2ad15f711d
commit
5775fe0b78
13
eclipse.spec
13
eclipse.spec
@ -27,7 +27,7 @@ Epoch: 1
|
||||
Summary: An open, extensible IDE
|
||||
Name: eclipse
|
||||
Version: %{eclipse_majmin}.%{eclipse_micro}
|
||||
Release: 14%{?dist}
|
||||
Release: 15%{?dist}
|
||||
License: EPL
|
||||
Group: Text Editors/Integrated Development Environments (IDE)
|
||||
URL: http://www.eclipse.org/
|
||||
@ -42,6 +42,8 @@ Patch0: remove-ant-trax.patch
|
||||
# a particular API and a type it depends on so we don't want to compile that
|
||||
# API
|
||||
Patch1: eclipse-xpcom-h.patch
|
||||
# Shell script portability patch: prepare-build-dir.sh
|
||||
Patch2: prepare-build-dir.sh.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: ant ant-nodeps
|
||||
@ -201,6 +203,10 @@ pushd Eclipse\ SWT\ Mozilla/common/library/
|
||||
popd
|
||||
popd
|
||||
|
||||
# Apply shell script portability
|
||||
# patch to upstream prepare-build-dir.sh
|
||||
%patch2
|
||||
|
||||
# Use our system-installed javadocs, reference only what we built, and
|
||||
# don't like to osgi.org docs (FIXME: maybe we should package them?)
|
||||
sed -i -e "s|http://java.sun.com/j2se/1.4.2/docs/api|%{_datadir}/javadoc/java|" \
|
||||
@ -318,7 +324,7 @@ desktop-file-validate %{buildroot}/%{_datadir}/applications/%{name}.desktop
|
||||
cp -p pdebuild/eclipse-copy-platform.sh copy-platform
|
||||
(
|
||||
cd $RPM_BUILD_ROOT%{_libdir}/%{name}
|
||||
ls -d * | egrep -v '^(plugins|features|about_files|dropins)$'
|
||||
ls -d * | grep -E -v '^(plugins|features|about_files|dropins)$'
|
||||
ls -d plugins/* features/*
|
||||
) |
|
||||
sed -e's,^\(.*\),[ ! -e \1 ] \&\& ln -s $eclipse/\1 \1,' >> copy-platform
|
||||
@ -599,6 +605,9 @@ fi
|
||||
%{_libdir}/%{name}/configuration/org.eclipse.equinox.source
|
||||
|
||||
%changelog
|
||||
* Mon Sep 27 2010 Severin Gehwolf <sgehwolf@redhat.com> 1:3.6.0-15
|
||||
- Add shell script portability patch for prepare-build-dir.sh
|
||||
|
||||
* Tue Sep 21 2010 Alexander Kurtakov <akurtako@redhat.com> 1:3.6.0-14
|
||||
- Really reenable webkit.
|
||||
|
||||
|
20
prepare-build-dir.sh.patch
Normal file
20
prepare-build-dir.sh.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- plugins/org.eclipse.pde.build/templates/package-build/prepare-build-dir.sh.orig 2010-09-22 18:11:55.546685423 -0400
|
||||
+++ plugins/org.eclipse.pde.build/templates/package-build/prepare-build-dir.sh 2010-09-22 17:58:40.763674792 -0400
|
||||
@@ -57,7 +57,7 @@
|
||||
fi
|
||||
|
||||
if [ "x$ERROR" != "xyes" ]; then
|
||||
- if [ $TESTING != true -o `echo $PROJECTNAME | grep "org.eclipse"` ]; then
|
||||
+ if [ $TESTING != true ] || `echo "$PROJECTNAME" | grep "org.eclipse"`; then
|
||||
echo " making symlink: $BUILDDIR/features/$PROJECTNAME -> $PROJECTDIR"
|
||||
ln -sfT "$PROJECTDIR" $BUILDDIR/features/"$PROJECTNAME"
|
||||
fi
|
||||
@@ -91,7 +91,7 @@
|
||||
fi
|
||||
|
||||
if [ "x$ERROR" != "xyes" ]; then
|
||||
- if [ $TESTING != true -o `echo $PROJECTNAME | grep "org.eclipse"` ]; then
|
||||
+ if [ $TESTING != true ] || `echo $PROJECTNAME | grep "org.eclipse"`; then
|
||||
echo " making symlink: $BUILDDIR/plugins/$PROJECTNAME -> $dir"
|
||||
ln -sfT "$dir" $BUILDDIR/plugins/"$PROJECTNAME"
|
||||
fi
|
Loading…
Reference in New Issue
Block a user