- Re-add updated use-ecj-for-gcj patch

This commit is contained in:
Andrew Overholt 2008-07-18 16:47:12 +00:00
parent 9827f389ce
commit 2698b10846
2 changed files with 9 additions and 9 deletions

View File

@ -5,10 +5,10 @@ retrieving revision 1.546.2.23
diff -u -r1.546.2.23 messages.properties
--- batch/org/eclipse/jdt/internal/compiler/batch/messages.properties 8 Feb 2007 15:04:43 -0000 1.546.2.23
+++ batch/org/eclipse/jdt/internal/compiler/batch/messages.properties 26 Feb 2007 18:21:06 -0000
@@ -249,3 +249,8 @@
template.restrictedAccess.constructor = The constructor {0} is not accessible due to restriction on classpath entry {1}
template.restrictedAccess.field = The field {0} from the type {1} is not accessible due to restriction on classpath entry {2}
template.restrictedAccess.method = The method {0} from the type {1} is not accessible due to restriction on classpath entry {2}
@@ -298,3 +298,8 @@ misc.usage.warn = {1} {2}\n\
\ \n\
\ Advanced options:\n\
\ -? -help print the help message\n
+
+# GCCMain messages.
+gcc.zipArg=-fzip-target requires argument

View File

@ -89,7 +89,7 @@ Patch4: %{name}-swttools.patch
# https://www.redhat.com/archives/fedora-devel-java-list/2006-April/msg00048.html
Patch15: %{name}-pde.build-add-package-build.patch
# Use ecj for gcj
#Patch17: %{name}-ecj-gcj.patch
Patch17: %{name}-ecj-gcj.patch
#Patch24: %{name}-add-ppc64-sparc64-s390-s390x.patch
#Patch28: %{name}-add-ppc64-sparc64-s390-s390x-2.patch
#Patch30: %{name}-addfragmentsforotherplatforms.patch
@ -309,10 +309,9 @@ pushd plugins/org.eclipse.swt.gtk.linux.x86_64
%patch4 -p0
popd
## FIXME: update
#pushd plugins/org.eclipse.jdt.core
#%patch17 -p0
#popd
pushd plugins/org.eclipse.jdt.core
%patch17 -p0
popd
# liblocalfile fixes
sed --in-place "s/JAVA_HOME =/#JAVA_HOME =/" plugins/org.eclipse.core.filesystem/natives/unix/linux/Makefile
@ -1340,6 +1339,7 @@ fi
- Un-do crazy config.ini, bundles.info, etc. shuffling
- Update patch for building native libraries
- Re-add missing BR on tomcat5-jasper-eclipse
- Re-add updated use-ecj-for-gcj patch
* Thu Jul 17 2008 Andrew Overholt <overholt@redhat.com> 3.4.0-3
- Generate metadata and provision each sub-package