Update to pre - SR2.
This commit is contained in:
parent
ebb857413e
commit
135a65f240
1
.gitignore
vendored
1
.gitignore
vendored
@ -29,3 +29,4 @@ eclipse-build-bbaaeebc6916cc28848e3f7f8f2ae5b8390c2ee3.tar.xz
|
||||
/eclipse-build-06227d455145aad68156ca408ce96a26beae4714.tar.xz
|
||||
/eclipse-build-264db10bec789532541d16baaa8889e4db52298d.tar.xz
|
||||
/eclipse-build-094a56b8b1222d3535f5dada20290dc91f14d102.tar.xz
|
||||
/eclipse-build-7a327b17de5f606f47cba6b74e64619520186b7a.tar.xz
|
||||
|
@ -236,7 +236,7 @@
|
||||
# This file should never exist or be needed for production machine,
|
||||
# but allows an easy way for a "local user" to provide this file
|
||||
# somewhere on the search path ($HOME/bin is common),
|
||||
@@ -92,11 +161,18 @@
|
||||
@@ -92,11 +161,17 @@
|
||||
#necessary when invoking this script through rsh
|
||||
cd $dir
|
||||
|
||||
@ -251,28 +251,80 @@
|
||||
- # note, the file pattern to match, must not start with */plugins because there is no leading '/' in the zip file, since they are repos.
|
||||
- unzip -qq -o -C eclipse-junit-tests-*.zip plugins/org.eclipse.test* -d eclipse/dropins/
|
||||
+ pushd @libdir@
|
||||
+ tar czf /tmp/eclipse-tests-directory/eclipse-SDK-v20120903-1347-linux-gtk-x86_64.tar.gz eclipse
|
||||
+ tar czf /tmp/eclipse-tests-directory/eclipse-SDK-temp-linux-gtk-x86_64.tar.gz eclipse
|
||||
+ popd
|
||||
+ cp -rf @libdir@/eclipse eclipse
|
||||
+ unzip -o -C /usr/share/java/eclipse-tests/eclipse-junit-tests-*.zip */plugins/org.eclipse.test* -d eclipse/dropins/
|
||||
fi
|
||||
|
||||
# run tests
|
||||
@@ -139,9 +215,15 @@
|
||||
echo "extdirproperty in runtest: ${extdirproperty}"
|
||||
--- eclipse.platform.releng.tychoeclipsebuilder/eclipse-junit-tests/src/main/scripts/runtests.sh.bak 2012-12-21 14:20:27.000000000 +0100
|
||||
+++ eclipse.platform.releng.tychoeclipsebuilder/eclipse-junit-tests/src/main/scripts/runtests.sh 2012-12-21 14:24:27.800161644 +0100
|
||||
@@ -178,45 +178,16 @@
|
||||
launcher=`ls eclipse/plugins/org.eclipse.equinox.launcher_*.jar`
|
||||
|
||||
# -Dtimeout=300000 "${ANT_OPTS}"
|
||||
+
|
||||
+ if [[ ! -z "${testslocation}" ]]
|
||||
+ then
|
||||
+ testslocation="/usr/share/java/eclipse-tests/"
|
||||
+fi
|
||||
+
|
||||
if [[ ! -z "${extdirproperty}" ]]
|
||||
then
|
||||
|
||||
- # make sure there is a window manager running. See bug 379026
|
||||
- # we should not have to, but may be a quirk/bug of hudson setup
|
||||
- # assuming metacity attaches to "current" display by default (which should have
|
||||
- # already been set by Hudson). We echo its value here just for extra reference/cross-checks.
|
||||
+ findXvncAndSetDisplay
|
||||
+ setArch
|
||||
+
|
||||
+ ant \
|
||||
+-file "/usr/share/java/eclipse-testing/test.xml" $tests \
|
||||
+-Dws=$ws -Dos=$os -Darch=$arch -Dos.arch=$arch \
|
||||
+-DbuildId=v20120903-1347 -Dbasedir="/tmp/eclipse-tests-directory" \
|
||||
+-DruntimeArchive="eclipse-SDK-temp-linux-gtk-x86_64.tar.gz" \
|
||||
+-DrepoLocation="/usr/share/java/eclipse-testing/" \
|
||||
+-Dorg.eclipse.test="3.3.100" \
|
||||
+-D$installmode=true $properties
|
||||
|
||||
- echo "Check if any window managers are running (xfwm|twm|metacity|beryl|fluxbox|compiz):"
|
||||
- wmpss=$(ps -ef | egrep -i "xfwm|twm|metacity|beryl|fluxbox|compiz" | grep -v egrep)
|
||||
- echo "Window Manager processes: $wmpss"
|
||||
- echo
|
||||
-
|
||||
- if [[ -z $wmpss ]]
|
||||
- then
|
||||
- echo "No window managers processes found running, so will start metacity"
|
||||
- metacity --replace --sm-disable &
|
||||
- METACITYPID=$!
|
||||
- echo $METACITYPID > epmetacity.pid
|
||||
- else
|
||||
- echo "Existing window manager found running, so did not force start of metacity"
|
||||
- fi
|
||||
-
|
||||
- echo
|
||||
-
|
||||
- # list out metacity processes so overtime we can see if they accumulate, or if killed automatically
|
||||
- # when our process exits. If not automatic, should use epmetacity.pid to kill it when we are done.
|
||||
- echo "Current metacity processes running (check for accumulation):"
|
||||
- ps -ef | grep "metacity" | grep -v grep
|
||||
- echo
|
||||
-
|
||||
- echo "Triple check if any window managers are running (at least metacity should be!):"
|
||||
- wmpss=$(ps -ef | egrep -i "xfwm|twm|metacity|beryl|fluxbox|compiz" | grep -v egrep)
|
||||
- echo "Window Manager processes: $wmpss"
|
||||
- echo
|
||||
- echo "extdirprop in runtest: ${extdirprop}"
|
||||
- echo "extdirproperty in runtest: ${extdirproperty}"
|
||||
-
|
||||
- # -Dtimeout=300000 "${ANT_OPTS}"
|
||||
- if [[ ! -z "${extdirproperty}" ]]
|
||||
- then
|
||||
- $vmcmd "${extdirproperty}" -Dosgi.os=$os -Dosgi.ws=$ws -Dosgi.arch=$arch -jar $launcher -data workspace -application org.eclipse.ant.core.antRunner -file ${PWD}/test.xml $tests -Dws=$ws -Dos=$os -Darch=$arch -D$installmode=true $properties -logger org.apache.tools.ant.DefaultLogger
|
||||
+ $vmcmd "${extdirproperty}" -Dosgi.os=$os -Dosgi.ws=$ws -Dosgi.arch=$arch -jar $launcher -data workspace -application org.eclipse.ant.core.antRunner -file ${testslocation}/test.xml $tests -Dws=$ws -Dos=$os -Darch=$arch -D$installmode=true $properties -logger org.apache.tools.ant.DefaultLogger
|
||||
else
|
||||
- else
|
||||
- $vmcmd -Dosgi.os=$os -Dosgi.ws=$ws -Dosgi.arch=$arch -jar $launcher -data workspace -application org.eclipse.ant.core.antRunner -file ${PWD}/test.xml $tests -Dws=$ws -Dos=$os -Darch=$arch -D$installmode=true $properties -logger org.apache.tools.ant.DefaultLogger
|
||||
+ $vmcmd -Dosgi.os=$os -Dosgi.ws=$ws -Dosgi.arch=$arch -jar $launcher -data workspace -application org.eclipse.ant.core.antRunner -file ${testslocation}/test.xml $tests -Dws=$ws -Dos=$os -Darch=$arch -D$installmode=true $properties -logger org.apache.tools.ant.DefaultLogger
|
||||
fi
|
||||
- fi
|
||||
+cleanupXvnc
|
||||
--- eclipse.platform.releng.tychoeclipsebuilder/eclipse-junit-tests/src/main/scripts/test.xml.bak 2012-12-21 19:31:12.000000000 +0100
|
||||
+++ eclipse.platform.releng.tychoeclipsebuilder/eclipse-junit-tests/src/main/scripts/test.xml 2012-12-27 08:26:23.767346326 +0100
|
||||
@@ -1291,7 +1291,7 @@
|
||||
<antcall target="debug" />
|
||||
<antcall target="ui" />
|
||||
<antcall target="equinoxds" />
|
||||
- <antcall target="equinoxp2discovery" />
|
||||
+ <!-- antcall target="equinoxp2discovery" /-->
|
||||
<antcall target="bidi" />
|
||||
<antcall target="ltkuirefactoringtests" />
|
||||
<antcall target="ltkcorerefactoringtests" />
|
||||
|
54
eclipse.spec
54
eclipse.spec
@ -3,7 +3,7 @@ Epoch: 1
|
||||
%global eclipse_major 4
|
||||
%global eclipse_minor 2
|
||||
%global eclipse_majmin %{eclipse_major}.%{eclipse_minor}
|
||||
%global eclipse_micro 1
|
||||
%global eclipse_micro 2
|
||||
%global initialize 1
|
||||
%global eb_commit 7a327b17de5f606f47cba6b74e64619520186b7a
|
||||
%global build_id I20120608-1400
|
||||
@ -65,7 +65,7 @@ fi;
|
||||
Summary: An open, extensible IDE
|
||||
Name: eclipse
|
||||
Version: %{eclipse_version}
|
||||
Release: 22%{?dist}
|
||||
Release: 0.1.git20121217%{?dist}
|
||||
License: EPL
|
||||
Group: Development/Tools
|
||||
URL: http://www.eclipse.org/
|
||||
@ -445,6 +445,23 @@ tar --strip-components=1 -xf %{SOURCE1}
|
||||
#no idea what's that. Maybe later - sources seem to be hidden inside this additonal jar.
|
||||
%pom_disable_module bundles/org.eclipse.equinox.weaving.caching.j9 rt.equinox.bundles/
|
||||
|
||||
%pom_disable_module bundles/org.eclipse.swt.carbon.macosx eclipse.platform.swt.binaries
|
||||
%pom_disable_module bundles/org.eclipse.swt.gtk.aix.ppc eclipse.platform.swt.binaries
|
||||
%pom_disable_module bundles/org.eclipse.swt.gtk.aix.ppc64 eclipse.platform.swt.binaries
|
||||
%pom_disable_module bundles/org.eclipse.swt.gtk.hpux.ia64 eclipse.platform.swt.binaries
|
||||
%pom_disable_module bundles/org.eclipse.swt.gtk.hpux.ia64_32 eclipse.platform.swt.binaries
|
||||
%pom_disable_module bundles/org.eclipse.swt.gtk.linux.ia64 eclipse.platform.swt.binaries
|
||||
%pom_disable_module bundles/org.eclipse.swt.gtk.solaris.sparc eclipse.platform.swt.binaries
|
||||
%pom_disable_module bundles/org.eclipse.swt.gtk.solaris.x86 eclipse.platform.swt.binaries
|
||||
%pom_disable_module bundles/org.eclipse.swt.motif.aix.ppc eclipse.platform.swt.binaries
|
||||
%pom_disable_module bundles/org.eclipse.swt.motif.hpux.ia64_32 eclipse.platform.swt.binaries
|
||||
%pom_disable_module bundles/org.eclipse.swt.motif.hpux.PA_RISC eclipse.platform.swt.binaries
|
||||
%pom_disable_module bundles/org.eclipse.swt.motif.solaris.sparc eclipse.platform.swt.binaries
|
||||
%pom_disable_module bundles/org.eclipse.swt.photon.qnx.x86 eclipse.platform.swt.binaries
|
||||
%pom_disable_module bundles/org.eclipse.swt.win32.wce_ppc.arm eclipse.platform.swt.binaries
|
||||
%pom_disable_module bundles/org.eclipse.swt.win32.win32.ia64 eclipse.platform.swt.binaries
|
||||
%pom_disable_module bundles/org.eclipse.swt.wpf.win32.x86 eclipse.platform.swt.binaries
|
||||
|
||||
# Use our system-installed javadocs, reference only what we built, and
|
||||
# don't like to osgi.org docs (FIXME: maybe we should package them?)
|
||||
sed -i -e "s|http://download.oracle.com/javase/6/docs/api|%{_datadir}/javadoc/java|" \
|
||||
@ -535,7 +552,7 @@ sed -i -e "s/javax.annotation/org.apache.geronimo.specs.geronimo-annotation_1.1_
|
||||
|
||||
%build
|
||||
#This is the lowest value where the build succeeds. 512m is not enough.
|
||||
export MAVEN_OPTS="-Xmx640m -XX:CompileCommand=exclude,org/eclipse/tycho/core/osgitools/EquinoxResolver,newState"
|
||||
export MAVEN_OPTS="-Xmx700m -XX:CompileCommand=exclude,org/eclipse/tycho/core/osgitools/EquinoxResolver,newState"
|
||||
|
||||
pushd .m2/p2/repo-sdk/features
|
||||
ln -s /usr/share/java/emf/eclipse/features/* -t .
|
||||
@ -1018,26 +1035,28 @@ install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/
|
||||
# Tests
|
||||
##############
|
||||
|
||||
unzip eclipse.platform.releng.tychoeclipsebuilder/eclipse-junit-tests/target/eclipse-junit-tests-bundle.zip -d $RPM_BUILD_ROOT/%{_javadir}/eclipse-tests
|
||||
unzip $RPM_BUILD_ROOT/%{_javadir}/eclipse-tests/eclipse-junit-tests-*.zip -d $RPM_BUILD_ROOT/%{_javadir}/eclipse-tests/
|
||||
rm $RPM_BUILD_ROOT/%{_javadir}/eclipse-tests/eclipse-junit-tests-*.zip
|
||||
rm $RPM_BUILD_ROOT/%{_javadir}/eclipse-tests/runtests.bat
|
||||
unzip eclipse.platform.releng.tychoeclipsebuilder/eclipse-junit-tests/target/eclipse-junit-tests-bundle.zip -d $RPM_BUILD_ROOT/%{_javadir}/
|
||||
unzip $RPM_BUILD_ROOT/%{_javadir}/eclipse-testing/eclipse-junit-tests-*.zip -d $RPM_BUILD_ROOT/%{_javadir}/eclipse-testing
|
||||
rm $RPM_BUILD_ROOT/%{_javadir}/eclipse-testing/eclipse-junit-tests-*.zip
|
||||
rm $RPM_BUILD_ROOT/%{_javadir}/eclipse-testing/runtests.bat
|
||||
|
||||
pushd $RPM_BUILD_ROOT/%{_javadir}/eclipse-tests/plugins
|
||||
rm -rf org.easymock_*.jar
|
||||
rm -rf org.hamcrest.core_*.jar
|
||||
rm -rf org.junit_*.jar
|
||||
rm -rf org.junit4_*.jar
|
||||
pushd $RPM_BUILD_ROOT/%{_javadir}/eclipse-testing/plugins
|
||||
%_symlink org.easymock_ easymock.jar
|
||||
|
||||
rm -rf org.hamcrest.core_*
|
||||
rm -rf com.junit_*
|
||||
rm -rf org.junit4_*
|
||||
popd
|
||||
|
||||
|
||||
sed -i -e "s#@libdir@#%{_libdir}#" $RPM_BUILD_ROOT/%{_javadir}/eclipse-tests/runtests.sh
|
||||
sed -i -e "s#@libdir@#%{_libdir}#" $RPM_BUILD_ROOT/%{_javadir}/eclipse-testing/runtests.sh
|
||||
|
||||
touch $RPM_BUILD_ROOT%{_bindir}/%{name}-runEclipsePackageTests
|
||||
chmod a+x $RPM_BUILD_ROOT/%{_bindir}/%{name}-runEclipsePackageTests
|
||||
echo '#!/bin/sh' >> $RPM_BUILD_ROOT/%{_bindir}/%{name}-runEclipsePackageTests
|
||||
echo 'echo "results in /tmp/eclipse-tests-directory/results/"' >> $RPM_BUILD_ROOT/%{_bindir}/%{name}-runEclipsePackageTests
|
||||
echo "pushd %{_javadir}/eclipse-tests;./runtests.sh -os linux -ws gtk -arch %{eclipse_arch} ; popd;" >> $RPM_BUILD_ROOT/%{_bindir}/%{name}-runEclipsePackageTests
|
||||
echo 'export testslocation="%{_javadir}/eclipse-testing/"' >> $RPM_BUILD_ROOT/%{_bindir}/%{name}-runEclipsePackageTests
|
||||
echo "pushd %{_javadir}/eclipse-testing;./runtests.sh -os linux -ws gtk -arch %{eclipse_arch} ; popd;" >> $RPM_BUILD_ROOT/%{_bindir}/%{name}-runEclipsePackageTests
|
||||
|
||||
|
||||
%post platform
|
||||
@ -1296,6 +1315,8 @@ rm -rf %{_bindir}/efj/
|
||||
# FIXME: should we ship content.xml for the platform?
|
||||
#%%{_libdir}/%%{name}/metadata
|
||||
%{_libdir}/%{name}/p2
|
||||
%{_libdir}/%{name}/about.html
|
||||
%{_libdir}/%{name}/about_files/
|
||||
%{_javadir}/%{name}/equinox.http.servlet.jar
|
||||
%{_mavenpomdir}/JPP.%{name}-equinox.http.servlet.pom
|
||||
%{_mavendepmapfragdir}/%{name}-platform
|
||||
@ -1314,7 +1335,7 @@ rm -rf %{_bindir}/efj/
|
||||
|
||||
%files tests
|
||||
%{_bindir}/%{name}-runEclipsePackageTests
|
||||
%{_javadir}/%{name}-tests
|
||||
%{_javadir}/%{name}-testing
|
||||
|
||||
%files equinox-osgi
|
||||
%dir %{_javadir}/%{name}
|
||||
@ -1328,6 +1349,9 @@ rm -rf %{_bindir}/efj/
|
||||
%{_mavendepmapfragdir}/%{name}-equinox-osgi
|
||||
|
||||
%changelog
|
||||
* Fri Dec 21 2012 Krzysztof Daniel <kdaniel@redhat.com> 1:4.2.2-0.1.git20121217
|
||||
- Update to pre SR2.
|
||||
|
||||
* Fri Dec 14 2012 Krzysztof Daniel <kdaniel@redhat.com> 1:4.2.1-22
|
||||
- Enable javadoc build.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user