- RHBZ#912664 - eclipse-swt should put swt.jar into /usr/lib/java even
on 64 bit systems. - RHBZ#903537 - [abrt] java-1.7.0-openjdk-1.7.0.9-2.3.4.fc18: gtk_widget_real_map (SIGABRT) Conflicts: eclipse.spec
This commit is contained in:
parent
ef924f4106
commit
12661d4bfe
15
eclipse-bug-903537.patch
Normal file
15
eclipse-bug-903537.patch
Normal file
@ -0,0 +1,15 @@
|
||||
--- eclipse.platform.swt/bundles/org.eclipse.swt/Eclipse SWT/gtk/org/eclipse/swt/widgets/Control.java
|
||||
+++ eclipse.platform.swt/bundles/org.eclipse.swt/Eclipse SWT/gtk/org/eclipse/swt/widgets/Control.java
|
||||
@@ -4232,7 +4232,11 @@ public boolean setParent (Composite parent) {
|
||||
oldDecorations.fixAccelGroup ();
|
||||
}
|
||||
int /*long*/ newParent = parent.parentingHandle();
|
||||
- OS.gtk_widget_reparent (topHandle, newParent);
|
||||
+// OS.gtk_widget_reparent (topHandle, newParent);
|
||||
+ OS.g_object_ref(topHandle);
|
||||
+ OS.gtk_container_remove(OS.gtk_widget_get_parent(topHandle), topHandle);
|
||||
+ OS.gtk_container_add(newParent, topHandle);
|
||||
+ OS.g_object_unref(topHandle);
|
||||
OS.gtk_fixed_move (newParent, topHandle, x, y);
|
||||
/*
|
||||
* Restore the original widget size since GTK does not keep it.
|
15
eclipse.spec
15
eclipse.spec
@ -65,7 +65,7 @@ fi;
|
||||
Summary: An open, extensible IDE
|
||||
Name: eclipse
|
||||
Version: %{eclipse_version}
|
||||
Release: 0.7.git20121217%{?dist}
|
||||
Release: 0.8.git20121217%{?dist}
|
||||
License: EPL
|
||||
Group: Development/Tools
|
||||
URL: http://www.eclipse.org/
|
||||
@ -197,6 +197,8 @@ Patch36: %{name}-improve-core-net-makefile.patch
|
||||
|
||||
Patch37: %{name}-debug-symbols.patch
|
||||
|
||||
Patch38: %{name}-bug-903537.patch
|
||||
|
||||
BuildRequires: ant >= 1.8.3
|
||||
BuildRequires: rsync
|
||||
BuildRequires: jpackage-utils >= 0:1.5, make, gcc
|
||||
@ -420,6 +422,7 @@ tar --strip-components=1 -xf %{SOURCE1}
|
||||
%patch35
|
||||
%patch36
|
||||
%patch37
|
||||
%patch38
|
||||
|
||||
#To save build hdd space (it took more than 10GB to build everything)
|
||||
%pom_disable_module platform.sdk eclipse.platform.releng.tychoeclipsebuilder
|
||||
@ -908,6 +911,8 @@ zip -r "../${SWT_JAR}.jar" *
|
||||
popd
|
||||
ln -s %{_libdir}/%{name}/plugins/"${SWT_JAR}.jar" swt.jar
|
||||
ln -s %{_libdir}/%{name}/plugins/"${SWT_JAR}.jar" swt-gtk.jar
|
||||
mkdir -p ../../lib/java
|
||||
ln -s ../%{name}/swt.jar ../../lib/java/swt.jar
|
||||
popd
|
||||
|
||||
#eclipse ini
|
||||
@ -1059,6 +1064,7 @@ rm -rf %{_bindir}/efj/
|
||||
|
||||
|
||||
%files swt
|
||||
<<<<<<< f18
|
||||
%dir %{_libdir}/%{name}
|
||||
%dir %{_libdir}/%{name}/plugins
|
||||
%{_libdir}/%{name}/notice.html
|
||||
@ -1069,8 +1075,7 @@ rm -rf %{_bindir}/efj/
|
||||
%{_libdir}/%{name}/plugins/org.eclipse.swt.gtk.linux.*
|
||||
%{_libdir}/%{name}/swt-gtk*.jar
|
||||
%{_libdir}/%{name}/swt.jar
|
||||
%{_libdir}/java/swt.jar
|
||||
|
||||
%{_usr}/lib/java/swt.jar
|
||||
|
||||
%files platform
|
||||
%attr(0755,root,root) %{_bindir}/%{name}
|
||||
@ -1317,6 +1322,10 @@ rm -rf %{_bindir}/efj/
|
||||
%{_mavendepmapfragdir}/%{name}-equinox-osgi
|
||||
|
||||
%changelog
|
||||
* Tue Feb 19 2013 Krzysztof Daniel <kdaniel@redhat.com> 1:4.2.2-0.8.git20121217
|
||||
- RHBZ#912664 - eclipse-swt should put swt.jar into /usr/lib/java even on 64 bit systems.
|
||||
- RHBZ#903537 - [abrt] java-1.7.0-openjdk-1.7.0.9-2.3.4.fc18: gtk_widget_real_map (SIGABRT)
|
||||
|
||||
* Wed Feb 6 2013 Krzysztof Daniel <kdaniel@redhat.com> 1:4.2.2-0.7.git20121217
|
||||
- Do really fix the swt.jar (RHBZ#908112)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user