Fix build against new felix-gogo
Update to latest I-build
This commit is contained in:
parent
a0f3cd3bfe
commit
0c31782d18
@ -24,7 +24,7 @@ index 8d08101..59567c0 100644
|
||||
import org.eclipse.core.runtime.*;
|
||||
import org.eclipse.equinox.internal.p2.ui.*;
|
||||
import org.eclipse.equinox.internal.p2.ui.query.IUViewQueryContext;
|
||||
@@ -325,6 +326,19 @@ public class RepositorySelectionGroup {
|
||||
@@ -322,6 +323,19 @@ public class RepositorySelectionGroup {
|
||||
void fillRepoCombo(final String selection) {
|
||||
RepositoryTracker tracker = ui.getRepositoryTracker();
|
||||
URI[] sites = tracker.getKnownRepositories(ui.getSession());
|
||||
@ -51,7 +51,7 @@ index c0f2ca1..03515c7 100644
|
||||
@@ -132,9 +132,22 @@ public class RepositoryManipulationPage extends PreferencePage implements IWorkb
|
||||
if (cachedElements == null) {
|
||||
Object[] children = super.fetchChildren(o, monitor);
|
||||
cachedElements = new Hashtable<String, MetadataRepositoryElement>(children.length);
|
||||
cachedElements = new Hashtable<>(children.length);
|
||||
+ String fragments = System.getProperty("p2.fragments");
|
||||
for (int i = 0; i < children.length; i++) {
|
||||
if (children[i] instanceof MetadataRepositoryElement) {
|
||||
|
@ -2,7 +2,7 @@ diff --git a/eclipse.platform.ui/features/org.eclipse.e4.rcp/feature.xml b/eclip
|
||||
index 7e1f520..734dd10 100644
|
||||
--- a/eclipse.platform.ui/features/org.eclipse.e4.rcp/feature.xml
|
||||
+++ b/eclipse.platform.ui/features/org.eclipse.e4.rcp/feature.xml
|
||||
@@ -410,6 +410,36 @@
|
||||
@@ -400,6 +400,36 @@
|
||||
install-size="0"
|
||||
version="0.0.0"
|
||||
fragment="true"/>
|
||||
@ -39,7 +39,7 @@ index 7e1f520..734dd10 100644
|
||||
|
||||
<plugin
|
||||
id="org.eclipse.equinox.launcher.gtk.linux.x86"
|
||||
@@ -488,6 +518,39 @@
|
||||
@@ -478,6 +508,39 @@
|
||||
download-size="0"
|
||||
install-size="0"
|
||||
version="0.0.0"
|
||||
@ -150,13 +150,12 @@ index 7e1f520..734dd10 100644
|
||||
<profile>
|
||||
<id>build-native-launchers-win32.win32.x86_64</id>
|
||||
<activation>
|
||||
@@ -563,9 +563,12 @@
|
||||
@@ -563,8 +563,11 @@
|
||||
<copy todir="bin" verbose="true" includeEmptyDirs="false" failonerror="true">
|
||||
<fileset dir="../../../rt.equinox.binaries/org.eclipse.equinox.executable/bin/">
|
||||
<include name="cocoa/macosx/x86_64/**/*"/>
|
||||
+ <include name="gtk/linux/arm/**/*"/>
|
||||
+ <include name="gtk/linux/aarch64/**/*"/>
|
||||
<include name="gtk/linux/ppc/**/*"/>
|
||||
<include name="gtk/linux/ppc64/**/*"/>
|
||||
<include name="gtk/linux/ppc64le/**/*"/>
|
||||
+ <include name="gtk/linux/s390x/**/*"/>
|
||||
@ -165,7 +164,7 @@ index 7e1f520..734dd10 100644
|
||||
<include name="win32/win32/x86/**/*"/>
|
||||
--- a/rt.equinox.framework/features/org.eclipse.equinox.executable.feature/build.properties 2015-01-30 14:44:03.436891441 +0000
|
||||
+++ b/rt.equinox.framework/features/org.eclipse.equinox.executable.feature/build.properties 2015-01-30 14:45:25.232480509 +0000
|
||||
@@ -40,3 +40,12 @@
|
||||
@@ -37,3 +37,12 @@
|
||||
|
||||
root.linux.gtk.x86_64=bin/gtk/linux/x86_64,gtk_root
|
||||
root.linux.gtk.x86_64.permissions.755=libcairo-swt.so
|
||||
@ -180,13 +179,12 @@ index 7e1f520..734dd10 100644
|
||||
+root.linux.gtk.s390x.permissions.755=launcher
|
||||
--- a/eclipse.platform.swt.binaries/pom.xml 2017-04-05 01:57:59.142576722 +0100
|
||||
+++ b/eclipse.platform.swt.binaries/pom.xml 2017-04-05 02:00:00.153247342 +0100
|
||||
@@ -55,9 +55,12 @@
|
||||
@@ -55,8 +55,11 @@
|
||||
|
||||
<modules>
|
||||
<module>bundles/org.eclipse.swt.cocoa.macosx.x86_64</module>
|
||||
+ <module>bundles/org.eclipse.swt.gtk.linux.arm</module>
|
||||
+ <module>bundles/org.eclipse.swt.gtk.linux.aarch64</module>
|
||||
<module>bundles/org.eclipse.swt.gtk.linux.ppc</module>
|
||||
<module>bundles/org.eclipse.swt.gtk.linux.ppc64</module>
|
||||
<module>bundles/org.eclipse.swt.gtk.linux.ppc64le</module>
|
||||
+ <module>bundles/org.eclipse.swt.gtk.linux.s390x</module>
|
||||
@ -195,28 +193,25 @@ index 7e1f520..734dd10 100644
|
||||
<module>bundles/org.eclipse.swt.win32.win32.x86</module>
|
||||
--- a/eclipse.platform.swt/bundles/org.eclipse.swt/META-INF/p2.inf 2017-04-21 10:15:34.857977599 +0100
|
||||
+++ b/eclipse.platform.swt/bundles/org.eclipse.swt/META-INF/p2.inf 2017-04-21 10:18:22.878025820 +0100
|
||||
@@ -49,4 +49,19 @@
|
||||
requires.10.namespace = org.eclipse.equinox.p2.iu
|
||||
requires.10.name = org.eclipse.swt.cocoa.macosx.x86_64
|
||||
requires.10.range = [$version$,$version$]
|
||||
-requires.10.filter = (&(osgi.os=macosx)(osgi.ws=cocoa)(osgi.arch=x86_64)(!(org.eclipse.swt.buildtime=true)))
|
||||
\ No newline at end of file
|
||||
+requires.10.filter = (&(osgi.os=macosx)(osgi.ws=cocoa)(osgi.arch=x86_64)(!(org.eclipse.swt.buildtime=true)))
|
||||
@@ -45,3 +45,18 @@
|
||||
requires.9.name = org.eclipse.swt.gtk.linux.ppc64le
|
||||
requires.9.range = [$version$,$version$]
|
||||
requires.9.filter = (&(osgi.os=linux)(osgi.ws=gtk)(osgi.arch=ppc64le)(!(org.eclipse.swt.buildtime=true)))
|
||||
+
|
||||
+requires.10.namespace = org.eclipse.equinox.p2.iu
|
||||
+requires.10.name = org.eclipse.swt.gtk.linux.arm
|
||||
+requires.10.range = [$version$,$version$]
|
||||
+requires.10.filter = (&(osgi.os=linux)(osgi.ws=gtk)(osgi.arch=arm)(!(org.eclipse.swt.buildtime=true)))
|
||||
+
|
||||
+requires.11.namespace = org.eclipse.equinox.p2.iu
|
||||
+requires.11.name = org.eclipse.swt.gtk.linux.arm
|
||||
+requires.11.name = org.eclipse.swt.gtk.linux.aarch64
|
||||
+requires.11.range = [$version$,$version$]
|
||||
+requires.11.filter = (&(osgi.os=linux)(osgi.ws=gtk)(osgi.arch=arm)(!(org.eclipse.swt.buildtime=true)))
|
||||
+requires.11.filter = (&(osgi.os=linux)(osgi.ws=gtk)(osgi.arch=aarch64)(!(org.eclipse.swt.buildtime=true)))
|
||||
+
|
||||
+requires.12.namespace = org.eclipse.equinox.p2.iu
|
||||
+requires.12.name = org.eclipse.swt.gtk.linux.aarch64
|
||||
+requires.12.name = org.eclipse.swt.gtk.linux.s390x
|
||||
+requires.12.range = [$version$,$version$]
|
||||
+requires.12.filter = (&(osgi.os=linux)(osgi.ws=gtk)(osgi.arch=aarch64)(!(org.eclipse.swt.buildtime=true)))
|
||||
+
|
||||
+requires.13.namespace = org.eclipse.equinox.p2.iu
|
||||
+requires.13.name = org.eclipse.swt.gtk.linux.s390x
|
||||
+requires.13.range = [$version$,$version$]
|
||||
+requires.13.filter = (&(osgi.os=linux)(osgi.ws=gtk)(osgi.arch=s390x)(!(org.eclipse.swt.buildtime=true)))
|
||||
+requires.12.filter = (&(osgi.os=linux)(osgi.ws=gtk)(osgi.arch=s390x)(!(org.eclipse.swt.buildtime=true)))
|
||||
--- a/rt.equinox.framework/features/org.eclipse.equinox.executable.feature/library/gtk/build.sh 2017-04-19 13:31:15.000000000 +0100
|
||||
+++ b/rt.equinox.framework/features/org.eclipse.equinox.executable.feature/library/gtk/build.sh 2017-04-23 16:58:34.022207885 +0100
|
||||
@@ -127,7 +127,7 @@
|
||||
|
23
eclipse.spec
23
eclipse.spec
@ -6,7 +6,7 @@
|
||||
Epoch: 1
|
||||
|
||||
%global eb_commit 8cc50cb75de7aa0d972af59c5dd74b34d793a74e
|
||||
%global eclipse_tag I20170426-2000
|
||||
%global eclipse_tag I20170505-2000
|
||||
|
||||
%global _jetty_version 9.4.3
|
||||
%global _lucene_version 6.1.0
|
||||
@ -38,7 +38,7 @@ Epoch: 1
|
||||
Summary: An open, extensible IDE
|
||||
Name: eclipse
|
||||
Version: 4.7.0
|
||||
Release: 0.8%{?dist}
|
||||
Release: 0.9%{?dist}
|
||||
License: EPL
|
||||
URL: http://www.eclipse.org/
|
||||
|
||||
@ -163,8 +163,9 @@ BuildRequires: apache-commons-logging
|
||||
BuildRequires: apache-commons-codec
|
||||
BuildRequires: apache-commons-jxpath
|
||||
BuildRequires: apache-commons-fileupload
|
||||
BuildRequires: osgi(org.apache.felix.gogo.shell)
|
||||
BuildRequires: osgi(org.apache.felix.gogo.command)
|
||||
BuildRequires: osgi(org.apache.felix.gogo.shell) >= 1.0.0
|
||||
BuildRequires: osgi(org.apache.felix.gogo.command) >= 1.0.2
|
||||
BuildRequires: osgi(org.apache.felix.gogo.runtime) >= 1.0.4
|
||||
BuildRequires: osgi(org.apache.felix.scr) >= 2.0.8
|
||||
BuildRequires: osgi(org.eclipse.jetty.util) >= %{_jetty_version}
|
||||
BuildRequires: osgi(org.eclipse.jetty.server) >= %{_jetty_version}
|
||||
@ -253,8 +254,9 @@ Requires: apache-commons-el >= 1.0-23
|
||||
Requires: apache-commons-logging
|
||||
Requires: apache-commons-codec
|
||||
Requires: apache-commons-jxpath
|
||||
Requires: osgi(org.apache.felix.gogo.shell)
|
||||
Requires: osgi(org.apache.felix.gogo.command)
|
||||
Requires: osgi(org.apache.felix.gogo.shell) >= 1.0.0
|
||||
Requires: osgi(org.apache.felix.gogo.command) >= 1.0.2
|
||||
Requires: osgi(org.apache.felix.gogo.runtime) >= 1.0.4
|
||||
Requires: osgi(org.apache.felix.scr) >= 2.0.8
|
||||
Requires: osgi(org.eclipse.jetty.util) >= %{_jetty_version}
|
||||
Requires: osgi(org.eclipse.jetty.server) >= %{_jetty_version}
|
||||
@ -578,7 +580,10 @@ sed -i '/javax\.servlet\.jsp/ s/2\.3/2\.4/' rt.equinox.bundles/bundles/org.eclip
|
||||
|
||||
# Use javax.servlet-api (Glassfish) instead of javax.servlet (Tomcat)
|
||||
find -name feature.xml | xargs sed -i -e 's|"javax.servlet"|"javax.servlet-api"|'
|
||||
sed -i -e "2iRequire-Bundle: javax.servlet-api" rt.equinox.bundles/bundles/org.eclipse.equinox.http.{jetty9,servlet}/META-INF/MANIFEST.MF
|
||||
sed -i -e "2iRequire-Bundle: javax.servlet-api" rt.equinox.bundles/bundles/org.eclipse.equinox.http.{jetty,servlet}/META-INF/MANIFEST.MF
|
||||
|
||||
# Fix constraint on gogo runtime
|
||||
sed -i -e '/org.apache.felix.service.command/s/;status=provisional//' rt.equinox.bundles/bundles/org.eclipse.equinox.console{,.ssh}/META-INF/MANIFEST.MF
|
||||
|
||||
# Pre-compiling JSPs does not currently work
|
||||
%pom_remove_plugin org.eclipse.jetty:jetty-jspc-maven-plugin eclipse.platform.ua/org.eclipse.help.webapp
|
||||
@ -1031,6 +1036,10 @@ fi
|
||||
%{_eclipsedir}/plugins/org.eclipse.osgi.util_*
|
||||
|
||||
%changelog
|
||||
* Sat May 06 2017 Mat Booth <mat.booth@redhat.com> - 1:4.7.0-0.9
|
||||
- Fix build against new felix-gogo
|
||||
- Update to latest I-build
|
||||
|
||||
* Wed May 03 2017 Mat Booth <mat.booth@redhat.com> - 1:4.7.0-0.8
|
||||
- Package missing PDE generic editor extension
|
||||
|
||||
|
@ -1,7 +1,7 @@
|
||||
#!/bin/bash
|
||||
set -e
|
||||
AGGREGATOR_PATH=git://git.eclipse.org/gitroot/platform/eclipse.platform.releng.aggregator.git
|
||||
TAG=I20170426-2000
|
||||
TAG=I20170505-2000
|
||||
|
||||
rm -rf R4_platform-aggregator-$TAG
|
||||
rm -rf R4_platform-aggregator-$TAG.tar.xz
|
||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (R4_platform-aggregator-I20170426-2000.tar.xz) = e79ae12e5b012c050b9fb87586c8ded234826b51052285f9d4ef5cc1953191ea79e70bb1a96871cf2827880c83b18e1665f76d5717dedea434b571ae1de89efc
|
||||
SHA512 (org.eclipse.linuxtools.eclipse-build-8cc50cb75de7aa0d972af59c5dd74b34d793a74e.tar.xz) = 39ea2659e6eb5b087dc68a7cfb586e928ef3d6e3085a514197a56c3bbce9909965891e88c9263ee87e2b914f87c2b0f3c2a751c3518dff9bbf2990d4eeef9251
|
||||
SHA512 (R4_platform-aggregator-I20170505-2000.tar.xz) = 26d02b349b4a8629d77c052d5fa44be5f956c38ccc8ebc775eace8e7c1e3091c92f75eb9260b7cdc587511b7a299726a7b5790a4dd8939c5baf30787ba0b8afa
|
||||
|
Loading…
Reference in New Issue
Block a user