update to upstream version 2.16.0

This commit is contained in:
Jos de Kloe 2020-02-08 17:37:51 +01:00
parent 92ffc13807
commit f2d8f69b5a
5 changed files with 27 additions and 13 deletions

1
.gitignore vendored
View File

@ -5,3 +5,4 @@
/eccodes-2.13.0-Source.tar.gz
/eccodes-2.14.1-Source.tar.gz
/eccodes-2.15.0-Source.tar.gz
/eccodes-2.16.0-Source.tar.gz

View File

@ -1,6 +1,6 @@
--- eccodes-2.14.1-Source.unchanged/src/grib_api_prototypes.h 2019-10-10 13:33:52.000000000 +0200
+++ eccodes-2.14.1-Source/src/grib_api_prototypes.h 2019-10-27 11:20:05.496702520 +0100
@@ -872,8 +872,8 @@ double grib_ieeefloat_error(double x);
--- eccodes-2.16.0-Source.unchanged/src/grib_api_prototypes.h 2020-01-14 10:53:35.000000000 +0100
+++ eccodes-2.16.0-Source/src/grib_api_prototypes.h 2020-02-08 16:14:04.100982991 +0100
@@ -873,8 +873,8 @@ double grib_ieeefloat_error(double x);
double grib_long_to_ieee(unsigned long x);
int grib_nearest_smaller_ieee_float(double a, double *x);
unsigned long grib_ieee_to_long(double x);
@ -11,8 +11,8 @@
int grib_ieee_decode_array(grib_context *c, unsigned char *buf, size_t nvals, int bytes, double *val);
int grib_ieee_decode_array(grib_context *c, unsigned char *buf, size_t nvals, int bytes, double *val);
int grib_ieee_encode_array(grib_context *c, double *val, size_t nvals, int bytes, unsigned char *buf);
--- eccodes-2.14.1-Source.unchanged/src/grib_ieeefloat.c 2019-10-10 13:33:52.000000000 +0200
+++ eccodes-2.14.1-Source/src/grib_ieeefloat.c 2019-10-27 11:20:05.497702497 +0100
--- eccodes-2.16.0-Source.unchanged/src/grib_ieeefloat.c 2020-01-14 10:53:35.000000000 +0100
+++ eccodes-2.16.0-Source/src/grib_ieeefloat.c 2020-02-08 16:14:04.104982891 +0100
@@ -392,14 +392,14 @@ unsigned long grib_ieee_to_long(double x
* grib_encode_unsigned_long.
*/

View File

@ -1,5 +1,5 @@
--- eccodes-2.15.0-Source.unchanged/fortran/CMakeLists.txt 2019-11-28 10:29:37.000000000 +0100
+++ eccodes-2.15.0-Source/fortran/CMakeLists.txt 2019-12-15 20:20:47.150657695 +0100
--- eccodes-2.16.0-Source.unchanged/fortran/CMakeLists.txt 2020-01-14 10:53:35.000000000 +0100
+++ eccodes-2.16.0-Source/fortran/CMakeLists.txt 2020-02-08 16:14:13.161755451 +0100
@@ -43,7 +43,9 @@ if( HAVE_FORTRAN )
ecbuild_add_library( TARGET eccodes_f90
SOURCES grib_fortran.c grib_f90.f90 eccodes_f90.f90 grib_kinds.h
@ -11,9 +11,9 @@
if( DEFINED ecbuild_VERSION AND NOT ${ecbuild_VERSION} VERSION_LESS 3.1 )
# Installed module directory is not in the PUBLIC INCLUDES!
target_include_directories( eccodes_f90 PUBLIC $<INSTALL_INTERFACE:${INSTALL_INCLUDE_DIR}> )
--- eccodes-2.15.0-Source.unchanged/src/CMakeLists.txt 2019-11-28 10:29:37.000000000 +0100
+++ eccodes-2.15.0-Source/src/CMakeLists.txt 2019-12-15 20:20:47.150657695 +0100
@@ -437,6 +437,7 @@ ecbuild_add_library(TARGET eccodes
--- eccodes-2.16.0-Source.unchanged/src/CMakeLists.txt 2020-01-14 10:53:35.000000000 +0100
+++ eccodes-2.16.0-Source/src/CMakeLists.txt 2020-02-08 16:14:13.169755250 +0100
@@ -438,6 +438,7 @@ ecbuild_add_library(TARGET eccodes
GENERATED grib_api_version.c
LIBS ${ECCODES_EXTRA_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT} ${CMATH_LIBRARIES}
TEMPLATES ${grib_api_extra_srcs}

View File

@ -1,6 +1,6 @@
Name: eccodes
Version: 2.15.0
Release: 2%{?dist}
Version: 2.16.0
Release: 1%{?dist}
Summary: WMO data format decoding and encoding
# force the shared libraries to have these so versions
@ -8,7 +8,7 @@ Summary: WMO data format decoding and encoding
%global so_version_f90 0.1
%global datapack_date 20181010
# latest rawhide grib_api version is 1.27.0-6
# latest rawhide grib_api version is 1.27.0-7
# but this version number is to be updated as soon as we know
# what the final release of grib_api by upstream will be.
# latest upstream grib_api release is 1.28.0 (05-Dec-2018)
@ -224,6 +224,14 @@ cd build
# the library so files get installed in /usr/lib in stead
# of /usr/lib64 on x86_64.
# Build with -fallow-argument-mismatch for gcc 10 compatibility
# otherwise the fortran interface fails to compile
# (thanks for the hint Orion)
# Reported upstream at https://jira.ecmwf.int/browse/SUP-3081
# note that setting FCFLAGS is not sufficient, i.e. this doesn't work:
# export FCFLAGS="%%{build_fflags} -fallow-argument-mismatch"
# defining the -DCMAKE_Fortran_FLAGS for camke is required to let it compile.
%cmake3 -DINSTALL_LIB_DIR=%{_lib} \
-DENABLE_ECCODES_OMP_THREADS=ON \
-DENABLE_EXTRA_TESTS=ON \
@ -234,6 +242,7 @@ cd build
-DCMAKE_SKIP_INSTALL_RPATH=TRUE \
-DECCODES_SOVERSION=%{so_version} \
-DECCODES_SOVERSION_F90=%{so_version_f90} \
-DCMAKE_Fortran_FLAGS="-fallow-argument-mismatch" \
-DENABLE_PYTHON=OFF \
..
@ -338,6 +347,9 @@ ctest3 -V %{?_smp_mflags}
%doc %{_datadir}/doc/%{name}/
%changelog
* Sat Feb 08 2020 Jos de Kloe <josdekloe@gmail.com> - 2.16.0-1
- Upgrade to upstream version 2.16.0
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.15.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

View File

@ -4,3 +4,4 @@ SHA512 (eccodes-2.12.5-Source.tar.gz) = ab1267dffdb3d0dbcdd65f23db2d77bc7bd8f324
SHA512 (eccodes-2.13.0-Source.tar.gz) = bbde1b7092caad20772b21cd06040938f99e763f77a6622820e3cc2fba5c0765178822be4b3c33b41a927757da85f311c0c4f057500ca58d257dde304e7eeca3
SHA512 (eccodes-2.14.1-Source.tar.gz) = 864b530642884baa0c3c56eee646a61af7d659e711c7ed4d08a5cc2d68812ecb96b8efabf40c4c9d5dcb3a0edeb1caddffea2ec3438571d3e90dc9cca1dabebe
SHA512 (eccodes-2.15.0-Source.tar.gz) = 1d906c5889773b4b6c5e9a967c2e20afb4ecc3ce8f4d496ad7b89417eec8783da9a0c8a9c14796f0c9c24b1f156b9d65408bb9a02a5e0c988a45478350aeae65
SHA512 (eccodes-2.16.0-Source.tar.gz) = 6e8768824152d8782c1457cfe79daed32114d1b4694d2843bd02a8aa63c42ccc435b53f7db6942239b3e56999fbaaba4ecef345d39fc5c5f7a5d20ceecf4422a