Upgrade to upstream version 2.12.5
This commit is contained in:
parent
968171903b
commit
9e2c1766c0
1
.gitignore
vendored
1
.gitignore
vendored
@ -7,3 +7,4 @@
|
||||
/eccodes_test_data_20181010.tar.gz
|
||||
/eccodes-2.9.2-Source.tar.gz
|
||||
/eccodes-2.12.0-Source.tar.gz
|
||||
/eccodes-2.12.5-Source.tar.gz
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- eccodes-2.12.0-Source.orig/src/grib_api_prototypes.h 2019-02-15 10:44:55.000000000 +0100
|
||||
+++ eccodes-2.12.0-Source/src/grib_api_prototypes.h 2019-02-17 17:16:20.867656748 +0100
|
||||
@@ -871,8 +871,8 @@ double grib_ieeefloat_error(double x);
|
||||
--- eccodes-2.12.5-Source.orig/src/grib_api_prototypes.h 2019-05-09 16:24:38.000000000 +0200
|
||||
+++ eccodes-2.12.5-Source/src/grib_api_prototypes.h 2019-05-09 20:11:02.977946707 +0200
|
||||
@@ -872,8 +872,8 @@ double grib_ieeefloat_error(double x);
|
||||
double grib_long_to_ieee(unsigned long x);
|
||||
int grib_nearest_smaller_ieee_float(double a, double *x);
|
||||
unsigned long grib_ieee_to_long(double x);
|
||||
@ -11,8 +11,8 @@
|
||||
int grib_ieee_decode_array(grib_context *c, unsigned char *buf, size_t nvals, int bytes, double *val);
|
||||
int grib_ieee_decode_array(grib_context *c, unsigned char *buf, size_t nvals, int bytes, double *val);
|
||||
int grib_ieee_encode_array(grib_context *c, double *val, size_t nvals, int bytes, unsigned char *buf);
|
||||
--- eccodes-2.12.0-Source.orig/src/grib_ieeefloat.c 2019-02-15 10:44:55.000000000 +0100
|
||||
+++ eccodes-2.12.0-Source/src/grib_ieeefloat.c 2019-02-17 17:16:20.868656722 +0100
|
||||
--- eccodes-2.12.5-Source.orig/src/grib_ieeefloat.c 2019-05-09 16:24:38.000000000 +0200
|
||||
+++ eccodes-2.12.5-Source/src/grib_ieeefloat.c 2019-05-09 20:11:02.978946681 +0200
|
||||
@@ -392,14 +392,14 @@ unsigned long grib_ieee_to_long(double x
|
||||
* grib_encode_unsigned_long.
|
||||
*/
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- eccodes-2.12.0-Source.orig/cmake/pkg-config.pc.in 2019-02-15 10:44:50.000000000 +0100
|
||||
+++ eccodes-2.12.0-Source/cmake/pkg-config.pc.in 2019-02-17 17:16:25.490537820 +0100
|
||||
--- eccodes-2.12.5-Source.orig/cmake/pkg-config.pc.in 2019-05-09 16:24:31.000000000 +0200
|
||||
+++ eccodes-2.12.5-Source/cmake/pkg-config.pc.in 2019-05-09 20:11:22.754434973 +0200
|
||||
@@ -14,9 +14,7 @@ CC=@CMAKE_C_COMPILER@
|
||||
CXX=@CMAKE_CXX_COMPILER@
|
||||
FC=@CMAKE_Fortran_COMPILER@
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- eccodes-2.12.0-Source.orig/fortran/CMakeLists.txt 2019-02-15 10:44:55.000000000 +0100
|
||||
+++ eccodes-2.12.0-Source/fortran/CMakeLists.txt 2019-02-17 17:16:23.108599099 +0100
|
||||
--- eccodes-2.12.5-Source.orig/fortran/CMakeLists.txt 2019-05-09 16:24:38.000000000 +0200
|
||||
+++ eccodes-2.12.5-Source/fortran/CMakeLists.txt 2019-05-09 20:11:14.481649037 +0200
|
||||
@@ -43,7 +43,8 @@ if( HAVE_FORTRAN )
|
||||
ecbuild_add_library( TARGET eccodes_f90
|
||||
SOURCES grib_fortran.c grib_f90.f90 eccodes_f90.f90 grib_kinds.h
|
||||
@ -10,8 +10,8 @@
|
||||
add_custom_command( TARGET eccodes_f90 POST_BUILD
|
||||
COMMAND ${CMAKE_COMMAND} -E make_directory ${CMAKE_BINARY_DIR}/include
|
||||
COMMAND ${CMAKE_COMMAND} -E copy ${CMAKE_Fortran_MODULE_DIRECTORY}/${CMAKE_CFG_INTDIR}/eccodes.mod ${CMAKE_BINARY_DIR}/include
|
||||
--- eccodes-2.12.0-Source.orig/src/CMakeLists.txt 2019-02-15 10:44:55.000000000 +0100
|
||||
+++ eccodes-2.12.0-Source/src/CMakeLists.txt 2019-02-17 17:16:23.109599073 +0100
|
||||
--- eccodes-2.12.5-Source.orig/src/CMakeLists.txt 2019-05-09 16:24:38.000000000 +0200
|
||||
+++ eccodes-2.12.5-Source/src/CMakeLists.txt 2019-05-09 20:11:14.481649037 +0200
|
||||
@@ -436,8 +436,8 @@ ecbuild_add_library(TARGET eccodes
|
||||
${grib_api_srcs}
|
||||
GENERATED grib_api_version.c
|
||||
|
@ -1,6 +1,6 @@
|
||||
Name: eccodes
|
||||
Version: 2.12.0
|
||||
Release: 3%{?dist}
|
||||
Version: 2.12.5
|
||||
Release: 1%{?dist}
|
||||
Summary: WMO data format decoding and encoding
|
||||
|
||||
# force the shared libraries to have these so versions
|
||||
@ -149,7 +149,7 @@ bufr_dump produces output in JSON format suitable for many web based
|
||||
applications.
|
||||
|
||||
(1) Note: the python3 interface is provided by upstream,
|
||||
but it fails unittesting, so it has been disabled for now.
|
||||
but it fails unit testing, so it has been disabled for now.
|
||||
As soon as this is fixed by upstream it will be added here.
|
||||
|
||||
#####################################################
|
||||
@ -372,6 +372,9 @@ ctest3 -V %{?_smp_mflags}
|
||||
%doc %{_datadir}/doc/%{name}/
|
||||
|
||||
%changelog
|
||||
* Thu May 09 2019 Jos de Kloe <josdekloe@gmail.com> - 2.12.5-1
|
||||
- Upgrade to upstream version 2.12.5
|
||||
|
||||
* Mon Mar 18 2019 Orion Poplawski <orion@nwra.com> - 2.12.0-3
|
||||
- Rebuild for netcdf 4.6.3
|
||||
|
||||
|
1
sources
1
sources
@ -1,2 +1,3 @@
|
||||
SHA512 (eccodes_test_data_20181010.tar.gz) = 24c24ec9e01d230cf542abe5c131f05b8e627dd9d170c666628bb5fd8f7b1a6aa11a35456b8d742c59f54c6aabac78658efd68b0c50779d466aba3d35b4a0231
|
||||
SHA512 (eccodes-2.12.0-Source.tar.gz) = 3dc876bde2a6c81a43bcc64ecb12969f28eae3cfbc8fed7da7797fc722dc8b446ac7be5178f55b7d395653e0718437b842296a7d4d11b372b8692404c76aa4ad
|
||||
SHA512 (eccodes-2.12.5-Source.tar.gz) = ab1267dffdb3d0dbcdd65f23db2d77bc7bd8f3241083374c75bc62ebf70b7d29d8af9f657d6da05a47e363151c8d995adfadca7bbf95ebb24a27303d80f081a4
|
||||
|
Loading…
Reference in New Issue
Block a user