Upgrade to upstream version 2.24.0

This commit is contained in:
Jos de Kloe 2021-12-09 10:42:26 +01:00
parent aa2a12089c
commit 9abde243ee
5 changed files with 16 additions and 40 deletions

1
.gitignore vendored
View File

@ -16,3 +16,4 @@
/eccodes-2.22.0-Source.tar.gz
/eccodes-2.22.1-Source.tar.gz
/eccodes-2.23.0-Source.tar.gz
/eccodes-2.24.0-Source.tar.gz

View File

@ -1,27 +1,5 @@
From 8cc6b5ee3ac27355ae95c4ce0d60d4e70ad9bbd6 Mon Sep 17 00:00:00 2001
From: Mamoru TASAKA <mtasaka@fedoraproject.org>
Date: Wed, 1 Dec 2021 20:23:31 +0900
Subject: [PATCH] grib_api_internal.h: reverse definition of FAST_BIG_ENDIAN
In grib_api_internal.h, currently on big endian system, FAST_BIG_ENDIAN is defined
if GRIB_MEM_ALIGN is *not* defined.
On the other hand, for example in src/grib_bits.c, when FAST_BIG_ENDIAN is defined
"grib_bits_fast_big_endian.c" is included, otherwise "grib_bits_any_endian.c" is
included.
As "grib_bits_any_endian.c" is used also in x86_64 system, it is reasonable to think that
the original intention is that "grib_bits_fast_big_endian.c" needs some alignment
condition, and uses such condition for optimization, otherwise "grib_bits_any_endian.c"
should be used, so it is natural to think that the condition on grib_api_internal.h
is opposite.
---
src/grib_api_internal.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/grib_api_internal.h b/src/grib_api_internal.h
index 3b8fae3c..0c8fcf17 100644
--- a/src/grib_api_internal.h
+++ b/src/grib_api_internal.h
--- eccodes-2.24.0-Source.unchanged/src/grib_api_internal.h 2021-12-07 12:03:44.000000000 +0100
+++ eccodes-2.24.0-Source/src/grib_api_internal.h 2021-12-09 10:02:54.686070864 +0100
@@ -40,9 +40,9 @@ extern "C" {
#if IS_BIG_ENDIAN
@ -34,6 +12,3 @@ index 3b8fae3c..0c8fcf17 100644
#endif
#endif
--
2.33.1

View File

@ -1,5 +1,5 @@
--- eccodes-2.23.0-Source.unchanged/fortran/CMakeLists.txt 2021-08-25 11:35:41.000000000 +0200
+++ eccodes-2.23.0-Source/fortran/CMakeLists.txt 2021-09-01 08:40:58.089840900 +0200
--- eccodes-2.24.0-Source.unchanged/fortran/CMakeLists.txt 2021-12-07 12:03:44.000000000 +0100
+++ eccodes-2.24.0-Source/fortran/CMakeLists.txt 2021-12-09 09:57:37.787105551 +0100
@@ -49,7 +49,8 @@ if( HAVE_FORTRAN )
GENERATED grib_f90.f90 eccodes_f90.f90
PUBLIC_INCLUDES $<BUILD_INTERFACE:${CMAKE_Fortran_MODULE_DIRECTORY}>
@ -10,8 +10,8 @@
if( DEFINED ecbuild_VERSION AND NOT ${ecbuild_VERSION} VERSION_LESS 3.1 )
# Installed module directory is not in the PUBLIC INCLUDES!
--- eccodes-2.23.0-Source.unchanged/src/CMakeLists.txt 2021-08-25 11:35:41.000000000 +0200
+++ eccodes-2.23.0-Source/src/CMakeLists.txt 2021-09-01 08:31:13.559364510 +0200
--- eccodes-2.24.0-Source.unchanged/src/CMakeLists.txt 2021-12-07 12:03:44.000000000 +0100
+++ eccodes-2.24.0-Source/src/CMakeLists.txt 2021-12-09 09:57:37.811104942 +0100
@@ -444,6 +444,7 @@ ecbuild_add_library( TARGET eccodes
PRIVATE_LIBS ${ECCODES_EXTRA_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT} ${AEC_LIBRARIES} ${PNG_LIBRARIES}
PUBLIC_LIBS ${CMATH_LIBRARIES} ${THREADS_LIBRARIES}

View File

@ -1,6 +1,6 @@
Name: eccodes
Version: 2.23.0
Release: 2%{?dist}
Version: 2.24.0
Release: 1%{?dist}
Summary: WMO data format decoding and encoding
# force the shared libraries to have these so versions
@ -8,7 +8,7 @@ Summary: WMO data format decoding and encoding
%global so_version_f90 0.1
%global datapack_date 20200626
# latest fedora-35 grib_api version is 1.27.0-12
# latest fedora-36 grib_api version is 1.27.0-12
# but this version number is to be updated as soon as we know
# what the final release of grib_api by upstream will be.
# latest upstream grib_api release is 1.28.0 (05-Dec-2018)
@ -43,18 +43,13 @@ Source1: http://download.ecmwf.org/test-data/eccodes/eccodes_test_data.ta
# https://software.ecmwf.int/issues/browse/SUP-1809
Patch1: eccodes-soversion.patch
# Disable versionNumberOfSuperblock checking, since the test expects 0 but
# on Fedora rawhide the code returns a value of 2.
# Issue reported upstream as: https://jira.ecmwf.int/browse/SUP-3497
Patch2: eccodes-test-grib_to_netcdf.patch
# note that the requests to make the other issues public are filed here:
# https://software.ecmwf.int/issues/browse/SUP-2073
# (and again, unfortunately this issue is not public)
# grib_api_internal.h: reverse definition of FAST_BIG_ENDIAN
# https://jira.ecmwf.int/browse/SUP-2410
Patch3: eccodes-grib_api_internal.h-reverse-definition-of-FAST_BIG_E.patch
Patch2: eccodes-grib_api_internal.h-reverse-definition-of-FAST_BIG_E.patch
BuildRequires: cmake3
BuildRequires: gcc
@ -352,6 +347,10 @@ ctest3 -V %{?_smp_mflags}
%doc %{_datadir}/doc/%{name}/
%changelog
* Thu Dec 09 2021 Jos de Kloe <josdekloe@gmail.com> - 2.24.0-1
- Upgrade to upstream version 2.24.0
- Remove no longer needed patch2 (grib_to_netcdf test fix)
* Wed Dec 1 2021 Mamoru TASAKA <mtasaka@fedoraproject.org> - 2.23.0-2
- Patch grib_api_internal.h for big endian test suite issue (upstream bug SUP-2410)

View File

@ -4,3 +4,4 @@ SHA512 (eccodes-2.21.0-Source.tar.gz) = f2ba8361b99800646a92f5f5beb7ec2facf2ee3b
SHA512 (eccodes-2.22.0-Source.tar.gz) = 488ff560cd9969c2d5c0dd0ce3e6b4433954893758ae1a2bd9177536d8b08a89f37aac4f6a175c271f528d5c838fd4ec7b090dfb1f691df5cfceb67508bdc470
SHA512 (eccodes-2.22.1-Source.tar.gz) = 86818604eca75a34c8ce0cf0540d255c0db2d92bf03970a65c972fb2a16b6c472f6dcebfd04bdac4b76b8db2fcf2ed4dfa8a70875eaf1353a775fc185e5de9a0
SHA512 (eccodes-2.23.0-Source.tar.gz) = df8e9f25396d91ae0adb1b1502cdb6c1473d80caf79ce3fe9318ecc63194fd1c7dc7424fccf44aabf8c06ea343d59093bb21e75f6e5466f21ce44cb514e07350
SHA512 (eccodes-2.24.0-Source.tar.gz) = cfd1989ff6d733c3053dae75d1951d6ba475dd6a388b6d747c3a87ade3de9a77da8a6954b6a6ea2eb8cfbd3e08aad7a8b12db1561893f8acc2a9041ce7718e24