update to upstream version 2.15.0 and disable ExcludeArch statements as test
This commit is contained in:
parent
78995fe03f
commit
81fa090637
@ -1,5 +1,5 @@
|
|||||||
--- eccodes-2.14.1-Source.unchanged/fortran/CMakeLists.txt 2019-10-10 13:33:52.000000000 +0200
|
--- eccodes-2.15.0-Source.unchanged/fortran/CMakeLists.txt 2019-11-28 10:29:37.000000000 +0100
|
||||||
+++ eccodes-2.14.1-Source/fortran/CMakeLists.txt 2019-10-27 11:25:48.269661718 +0100
|
+++ eccodes-2.15.0-Source/fortran/CMakeLists.txt 2019-12-15 20:20:47.150657695 +0100
|
||||||
@@ -43,7 +43,9 @@ if( HAVE_FORTRAN )
|
@@ -43,7 +43,9 @@ if( HAVE_FORTRAN )
|
||||||
ecbuild_add_library( TARGET eccodes_f90
|
ecbuild_add_library( TARGET eccodes_f90
|
||||||
SOURCES grib_fortran.c grib_f90.f90 eccodes_f90.f90 grib_kinds.h
|
SOURCES grib_fortran.c grib_f90.f90 eccodes_f90.f90 grib_kinds.h
|
||||||
@ -11,9 +11,9 @@
|
|||||||
if( DEFINED ecbuild_VERSION AND NOT ${ecbuild_VERSION} VERSION_LESS 3.1 )
|
if( DEFINED ecbuild_VERSION AND NOT ${ecbuild_VERSION} VERSION_LESS 3.1 )
|
||||||
# Installed module directory is not in the PUBLIC INCLUDES!
|
# Installed module directory is not in the PUBLIC INCLUDES!
|
||||||
target_include_directories( eccodes_f90 PUBLIC $<INSTALL_INTERFACE:${INSTALL_INCLUDE_DIR}> )
|
target_include_directories( eccodes_f90 PUBLIC $<INSTALL_INTERFACE:${INSTALL_INCLUDE_DIR}> )
|
||||||
--- eccodes-2.14.1-Source.unchanged/src/CMakeLists.txt 2019-10-10 13:33:52.000000000 +0200
|
--- eccodes-2.15.0-Source.unchanged/src/CMakeLists.txt 2019-11-28 10:29:37.000000000 +0100
|
||||||
+++ eccodes-2.14.1-Source/src/CMakeLists.txt 2019-10-27 11:27:56.115531419 +0100
|
+++ eccodes-2.15.0-Source/src/CMakeLists.txt 2019-12-15 20:20:47.150657695 +0100
|
||||||
@@ -438,6 +438,7 @@ ecbuild_add_library(TARGET eccodes
|
@@ -437,6 +437,7 @@ ecbuild_add_library(TARGET eccodes
|
||||||
GENERATED grib_api_version.c
|
GENERATED grib_api_version.c
|
||||||
LIBS ${ECCODES_EXTRA_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT} ${CMATH_LIBRARIES}
|
LIBS ${ECCODES_EXTRA_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT} ${CMATH_LIBRARIES}
|
||||||
TEMPLATES ${grib_api_extra_srcs}
|
TEMPLATES ${grib_api_extra_srcs}
|
||||||
|
30
eccodes.spec
30
eccodes.spec
@ -1,5 +1,5 @@
|
|||||||
Name: eccodes
|
Name: eccodes
|
||||||
Version: 2.14.1
|
Version: 2.15.0
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: WMO data format decoding and encoding
|
Summary: WMO data format decoding and encoding
|
||||||
|
|
||||||
@ -8,7 +8,7 @@ Summary: WMO data format decoding and encoding
|
|||||||
%global so_version_f90 0.1
|
%global so_version_f90 0.1
|
||||||
%global datapack_date 20181010
|
%global datapack_date 20181010
|
||||||
|
|
||||||
# latest rawhide grib_api version is 1.27.0-5
|
# latest rawhide grib_api version is 1.27.0-6
|
||||||
# but this version number is to be updated as soon as we know
|
# but this version number is to be updated as soon as we know
|
||||||
# what the final release of grib_api by upstream will be.
|
# what the final release of grib_api by upstream will be.
|
||||||
# latest upstream grib_api release is 1.28.0 (05-Dec-2018)
|
# latest upstream grib_api release is 1.28.0 (05-Dec-2018)
|
||||||
@ -87,25 +87,16 @@ Requires: %{name}-data = %{version}-%{release}
|
|||||||
|
|
||||||
%if 0%{obsolete_grib_api}
|
%if 0%{obsolete_grib_api}
|
||||||
# as stated in the note above, setting provides seems not correct here
|
# as stated in the note above, setting provides seems not correct here
|
||||||
# Provides: grib_api = %{final_grib_api_version}
|
# Provides: grib_api = %%{final_grib_api_version}
|
||||||
Obsoletes: grib_api < %{final_grib_api_version}
|
Obsoletes: grib_api < %{final_grib_api_version}
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
# as explained in bugzilla #1562066
|
# as explained in bugzilla #1562066
|
||||||
ExcludeArch: i686
|
#ExcludeArch: i686
|
||||||
# as explained in bugzilla #1562071
|
|
||||||
# note: this is no longer part of fc30/rawhide
|
|
||||||
# but the exclude is still needed for EPEL-7
|
|
||||||
#ExcludeArch: ppc64
|
|
||||||
# as explained in bugzilla #1562076
|
# as explained in bugzilla #1562076
|
||||||
ExcludeArch: s390x
|
#ExcludeArch: s390x
|
||||||
# as explained in bugzilla #1562084
|
# as explained in bugzilla #1562084
|
||||||
ExcludeArch: armv7hl
|
#ExcludeArch: armv7hl
|
||||||
|
|
||||||
%if 0%{?rhel} >= 7
|
|
||||||
# as explained in bugzilla #1629377
|
|
||||||
ExcludeArch: aarch64
|
|
||||||
%endif
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
ecCodes is a package developed by ECMWF which provides an application
|
ecCodes is a package developed by ECMWF which provides an application
|
||||||
@ -148,7 +139,7 @@ Requires: gcc-gfortran%{?_isa}
|
|||||||
Requires: jasper-devel%{?_isa}
|
Requires: jasper-devel%{?_isa}
|
||||||
|
|
||||||
%if 0%{obsolete_grib_api}
|
%if 0%{obsolete_grib_api}
|
||||||
# Provides: grib_api-devel = %{final_grib_api_version}
|
# Provides: grib_api-devel = %%{final_grib_api_version}
|
||||||
Obsoletes: grib_api-devel < %{final_grib_api_version}
|
Obsoletes: grib_api-devel < %{final_grib_api_version}
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
@ -245,10 +236,6 @@ cd build
|
|||||||
-DECCODES_SOVERSION_F90=%{so_version_f90} \
|
-DECCODES_SOVERSION_F90=%{so_version_f90} \
|
||||||
-DENABLE_PYTHON=OFF \
|
-DENABLE_PYTHON=OFF \
|
||||||
..
|
..
|
||||||
# note:
|
|
||||||
# with -DCMAKE_SKIP_RPATH=TRUE
|
|
||||||
# LD_LIBRARY_PATH and #LIBRARY_PATH need to be defined before running ctest.
|
|
||||||
# with -DCMAKE_SKIP_INSTALL_RPATH=TRUE this seems not needed
|
|
||||||
|
|
||||||
%make_build
|
%make_build
|
||||||
|
|
||||||
@ -351,6 +338,9 @@ ctest3 -V %{?_smp_mflags}
|
|||||||
%doc %{_datadir}/doc/%{name}/
|
%doc %{_datadir}/doc/%{name}/
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Dec 15 2019 Jos de Kloe <josdekloe@gmail.com> - 2.15.0-1
|
||||||
|
- Upgrade to upstream version 2.15.0
|
||||||
|
|
||||||
* Sun Oct 27 2019 Jos de Kloe <josdekloe@gmail.com> - 2.14.1-1
|
* Sun Oct 27 2019 Jos de Kloe <josdekloe@gmail.com> - 2.14.1-1
|
||||||
- Upgrade to upstream version 2.14.1
|
- Upgrade to upstream version 2.14.1
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user