update to new upstream version 2.8.2 and disable ExcludeArch to test what happens in a scratch build
This commit is contained in:
parent
44ae809acd
commit
76b0b8d3f8
@ -1,6 +1,6 @@
|
||||
--- eccodes-2.8.0-Source.orig/src/grib_api_prototypes.h 2018-06-12 13:50:54.000000000 +0200
|
||||
+++ eccodes-2.8.0-Source/src/grib_api_prototypes.h 2018-06-28 14:58:28.302344717 +0200
|
||||
@@ -869,8 +869,8 @@ double grib_ieeefloat_error(double x);
|
||||
--- eccodes-2.8.2-Source.orig/src/grib_api_prototypes.h 2018-08-06 11:45:33.000000000 +0200
|
||||
+++ eccodes-2.8.2-Source/src/grib_api_prototypes.h 2018-09-09 12:06:18.628509429 +0200
|
||||
@@ -871,8 +871,8 @@ double grib_ieeefloat_error(double x);
|
||||
double grib_long_to_ieee(unsigned long x);
|
||||
int grib_nearest_smaller_ieee_float(double a, double *x);
|
||||
unsigned long grib_ieee_to_long(double x);
|
||||
@ -11,8 +11,8 @@
|
||||
int grib_ieee_decode_array(grib_context *c, unsigned char *buf, size_t nvals, int bytes, double *val);
|
||||
int grib_ieee_decode_array(grib_context *c, unsigned char *buf, size_t nvals, int bytes, double *val);
|
||||
int grib_ieee_encode_array(grib_context *c, double *val, size_t nvals, int bytes, unsigned char *buf);
|
||||
--- eccodes-2.8.0-Source.orig/src/grib_ieeefloat.c 2018-06-12 13:50:54.000000000 +0200
|
||||
+++ eccodes-2.8.0-Source/src/grib_ieeefloat.c 2018-06-28 14:58:28.303344693 +0200
|
||||
--- eccodes-2.8.2-Source.orig/src/grib_ieeefloat.c 2018-08-06 11:45:33.000000000 +0200
|
||||
+++ eccodes-2.8.2-Source/src/grib_ieeefloat.c 2018-09-09 12:06:18.628509429 +0200
|
||||
@@ -392,14 +392,14 @@ unsigned long grib_ieee_to_long(double x
|
||||
* grib_encode_unsigned_long.
|
||||
*/
|
||||
|
27
eccodes.spec
27
eccodes.spec
@ -1,6 +1,6 @@
|
||||
Name: eccodes
|
||||
Version: 2.8.0
|
||||
Release: 3%{?dist}
|
||||
Version: 2.8.2
|
||||
Release: 1%{?dist}
|
||||
Summary: WMO data format decoding and encoding
|
||||
|
||||
# force the shared libraries to have these so versions
|
||||
@ -8,11 +8,11 @@ Summary: WMO data format decoding and encoding
|
||||
%global so_version_f90 0.1
|
||||
%global datapack_date 20180705
|
||||
|
||||
# latest rawhide grib_api version is 1.26.1-1
|
||||
# latest rawhide grib_api version is 1.27.0-1
|
||||
# but this version number is to be updated as soon as we know
|
||||
# what the final release of grib_api by upstream will be.
|
||||
# latest upstream grib_api release is 1.26.1 (08-May-2018)
|
||||
%global final_grib_api_version 1.26.1-1
|
||||
# latest upstream grib_api release is 1.27.0 (09-Sep-2018)
|
||||
%global final_grib_api_version 1.27.0-1
|
||||
|
||||
# license remarks:
|
||||
# most of eccodes is licensed ASL 2.0 but a special case must be noted.
|
||||
@ -30,7 +30,7 @@ Source0: https://software.ecmwf.int/wiki/download/attachments/45757960/ec
|
||||
# now and then. The current copy was downloaded 05-Jul-2018
|
||||
# todo: rename the datapack using the download date to make it versioned
|
||||
# in fedora and figure out how to insert this in this Source1 entry
|
||||
Source1: http://download.ecmwf.org/test-data/grib_api/eccodes_test_data.tar.gz
|
||||
Source1: http://download.ecmwf.org/test-data/eccodes/eccodes_test_data.tar.gz
|
||||
# Support 32-bit
|
||||
# https://software.ecmwf.int/issues/browse/SUP-1813
|
||||
# (unfortunately this issue is not public)
|
||||
@ -41,8 +41,7 @@ Patch2: eccodes-soversion.patch
|
||||
# remove rpath from cmake/pkg-config.pc.in
|
||||
Patch3: eccodes-rpath.patch
|
||||
# fix compile flags in fortran checks
|
||||
# https://software.ecmwf.int/issues/browse/SUP-1812
|
||||
# (unfortunately this issue is not public)
|
||||
# this is needed due to rpath removal
|
||||
Patch4: eccodes-fortran-check.patch
|
||||
|
||||
# note that the requests to make the other issues public are filed here:
|
||||
@ -90,13 +89,13 @@ Requires: %{name}-data = %{version}-%{release}
|
||||
Obsoletes: grib_api < %{final_grib_api_version}
|
||||
|
||||
# as explained in bugzilla #1562066
|
||||
ExcludeArch: i686
|
||||
#ExcludeArch: i686
|
||||
# as explained in bugzilla #1562071
|
||||
ExcludeArch: ppc64
|
||||
#ExcludeArch: ppc64
|
||||
# as explained in bugzilla #1562076
|
||||
ExcludeArch: s390x
|
||||
#ExcludeArch: s390x
|
||||
# as explained in bugzilla #1562084
|
||||
ExcludeArch: armv7hl
|
||||
#ExcludeArch: armv7hl
|
||||
|
||||
%description
|
||||
ecCodes is a package developed by ECMWF which provides an application
|
||||
@ -159,6 +158,7 @@ A python2 interface to ecCodes. Also a legacy interface to gribapi is provided.
|
||||
|
||||
#####################################################
|
||||
# note: python3 is not yet supported by eccodes
|
||||
# but upstream intents to make it available before the end of 2018
|
||||
|
||||
#####################################################
|
||||
%package data
|
||||
@ -344,6 +344,9 @@ ctest -V %{?_smp_mflags}
|
||||
|
||||
%changelog
|
||||
|
||||
* Sun Sep 9 2018 Jos de Kloe <josdekloe@gmail.com> - 2.8.2-1
|
||||
- Upgrade to version 2.8.2
|
||||
|
||||
* Fri Aug 17 2018 Jos de Kloe <josdekloe@gmail.com> - 2.8.0-3
|
||||
- rebuild with patch provided by Matthew Krupcale for f28
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user