update to version 2.23.0
This commit is contained in:
parent
0c8a1e15e5
commit
65f97a669b
1
.gitignore
vendored
1
.gitignore
vendored
@ -15,3 +15,4 @@
|
|||||||
/eccodes-2.21.0-Source.tar.gz
|
/eccodes-2.21.0-Source.tar.gz
|
||||||
/eccodes-2.22.0-Source.tar.gz
|
/eccodes-2.22.0-Source.tar.gz
|
||||||
/eccodes-2.22.1-Source.tar.gz
|
/eccodes-2.22.1-Source.tar.gz
|
||||||
|
/eccodes-2.23.0-Source.tar.gz
|
||||||
|
@ -1,18 +1,18 @@
|
|||||||
--- eccodes-2.22.0-Source.unchanged/fortran/CMakeLists.txt 2021-05-19 10:53:28.000000000 +0200
|
--- eccodes-2.23.0-Source.unchanged/fortran/CMakeLists.txt 2021-08-25 11:35:41.000000000 +0200
|
||||||
+++ eccodes-2.22.0-Source/fortran/CMakeLists.txt 2021-05-24 20:28:37.002735089 +0200
|
+++ eccodes-2.23.0-Source/fortran/CMakeLists.txt 2021-09-01 08:40:58.089840900 +0200
|
||||||
@@ -49,7 +49,8 @@ if( HAVE_FORTRAN )
|
@@ -49,7 +49,8 @@ if( HAVE_FORTRAN )
|
||||||
GENERATED grib_f90.f90 eccodes_f90.f90
|
GENERATED grib_f90.f90 eccodes_f90.f90
|
||||||
PUBLIC_INCLUDES $<BUILD_INTERFACE:${CMAKE_Fortran_MODULE_DIRECTORY}>
|
PUBLIC_INCLUDES $<BUILD_INTERFACE:${CMAKE_Fortran_MODULE_DIRECTORY}>
|
||||||
$<INSTALL_INTERFACE:${INSTALL_INCLUDE_DIR}>
|
$<INSTALL_INTERFACE:${INSTALL_INCLUDE_DIR}>
|
||||||
- PRIVATE_LIBS eccodes )
|
- PRIVATE_LIBS eccodes ${ECCODES_PTHREADS_LIBRARIES} )
|
||||||
+ PRIVATE_LIBS eccodes
|
+ PRIVATE_LIBS eccodes ${ECCODES_PTHREADS_LIBRARIES}
|
||||||
+ SOVERSION ${ECCODES_SOVERSION_F90})
|
+ SOVERSION ${ECCODES_SOVERSION_F90})
|
||||||
|
|
||||||
if( DEFINED ecbuild_VERSION AND NOT ${ecbuild_VERSION} VERSION_LESS 3.1 )
|
if( DEFINED ecbuild_VERSION AND NOT ${ecbuild_VERSION} VERSION_LESS 3.1 )
|
||||||
# Installed module directory is not in the PUBLIC INCLUDES!
|
# Installed module directory is not in the PUBLIC INCLUDES!
|
||||||
--- eccodes-2.22.0-Source.unchanged/src/CMakeLists.txt 2021-05-19 10:53:29.000000000 +0200
|
--- eccodes-2.23.0-Source.unchanged/src/CMakeLists.txt 2021-08-25 11:35:41.000000000 +0200
|
||||||
+++ eccodes-2.22.0-Source/src/CMakeLists.txt 2021-05-24 20:28:37.025734539 +0200
|
+++ eccodes-2.23.0-Source/src/CMakeLists.txt 2021-09-01 08:31:13.559364510 +0200
|
||||||
@@ -445,6 +445,7 @@ ecbuild_add_library( TARGET eccodes
|
@@ -444,6 +444,7 @@ ecbuild_add_library( TARGET eccodes
|
||||||
PRIVATE_LIBS ${ECCODES_EXTRA_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT} ${AEC_LIBRARIES} ${PNG_LIBRARIES}
|
PRIVATE_LIBS ${ECCODES_EXTRA_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT} ${AEC_LIBRARIES} ${PNG_LIBRARIES}
|
||||||
PUBLIC_LIBS ${CMATH_LIBRARIES} ${THREADS_LIBRARIES}
|
PUBLIC_LIBS ${CMATH_LIBRARIES} ${THREADS_LIBRARIES}
|
||||||
TEMPLATES ${grib_api_extra_srcs}
|
TEMPLATES ${grib_api_extra_srcs}
|
||||||
|
15
eccodes-test-grib_to_netcdf.patch
Normal file
15
eccodes-test-grib_to_netcdf.patch
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
--- eccodes-2.23.0-Source.unchanged/tests/grib_to_netcdf.sh 2021-08-25 11:35:41.000000000 +0200
|
||||||
|
+++ eccodes-2.23.0-Source/tests/grib_to_netcdf.sh 2021-09-02 10:31:33.417295119 +0200
|
||||||
|
@@ -64,8 +64,10 @@ if [ $ECCODES_ON_WINDOWS -eq 0 ]; then
|
||||||
|
set -e
|
||||||
|
if [ $stat -eq 0 ]; then
|
||||||
|
have_netcdf4=1
|
||||||
|
- res=`${tools_dir}/grib_get -TA -p identifier,versionNumberOfSuperblock $tempNetcdf`
|
||||||
|
- [ "$res" = "HDF5 0" ]
|
||||||
|
+# res=`${tools_dir}/grib_get -TA -p identifier,versionNumberOfSuperblock $tempNetcdf`
|
||||||
|
+# [ "$res" = "HDF5 0" ]
|
||||||
|
+ res=`${tools_dir}/grib_get -TA -p identifier $tempNetcdf`
|
||||||
|
+ [ "$res" = "HDF5" ]
|
||||||
|
fi
|
||||||
|
fi
|
||||||
|
|
29
eccodes.spec
29
eccodes.spec
@ -1,6 +1,6 @@
|
|||||||
Name: eccodes
|
Name: eccodes
|
||||||
Version: 2.22.1
|
Version: 2.23.0
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: WMO data format decoding and encoding
|
Summary: WMO data format decoding and encoding
|
||||||
|
|
||||||
# force the shared libraries to have these so versions
|
# force the shared libraries to have these so versions
|
||||||
@ -8,7 +8,7 @@ Summary: WMO data format decoding and encoding
|
|||||||
%global so_version_f90 0.1
|
%global so_version_f90 0.1
|
||||||
%global datapack_date 20200626
|
%global datapack_date 20200626
|
||||||
|
|
||||||
# latest fedora-34 grib_api version is 1.27.0-9
|
# latest fedora-35 grib_api version is 1.27.0-12
|
||||||
# but this version number is to be updated as soon as we know
|
# but this version number is to be updated as soon as we know
|
||||||
# what the final release of grib_api by upstream will be.
|
# what the final release of grib_api by upstream will be.
|
||||||
# latest upstream grib_api release is 1.28.0 (05-Dec-2018)
|
# latest upstream grib_api release is 1.28.0 (05-Dec-2018)
|
||||||
@ -43,6 +43,11 @@ Source1: http://download.ecmwf.org/test-data/eccodes/eccodes_test_data.ta
|
|||||||
# https://software.ecmwf.int/issues/browse/SUP-1809
|
# https://software.ecmwf.int/issues/browse/SUP-1809
|
||||||
Patch1: eccodes-soversion.patch
|
Patch1: eccodes-soversion.patch
|
||||||
|
|
||||||
|
# Disable versionNumberOfSuperblock checking, since the test expects 0 but
|
||||||
|
# on Fedora rawhide the code returns a value of 2.
|
||||||
|
# Issue reported upstream as: https://jira.ecmwf.int/browse/SUP-3497
|
||||||
|
Patch2: eccodes-test-grib_to_netcdf.patch
|
||||||
|
|
||||||
# note that the requests to make the other issues public are filed here:
|
# note that the requests to make the other issues public are filed here:
|
||||||
# https://software.ecmwf.int/issues/browse/SUP-2073
|
# https://software.ecmwf.int/issues/browse/SUP-2073
|
||||||
# (and again, unfortunately this issue is not public)
|
# (and again, unfortunately this issue is not public)
|
||||||
@ -222,14 +227,6 @@ chmod 644 AUTHORS LICENSE
|
|||||||
# the library so files get installed in /usr/lib in stead
|
# the library so files get installed in /usr/lib in stead
|
||||||
# of /usr/lib64 on x86_64.
|
# of /usr/lib64 on x86_64.
|
||||||
|
|
||||||
# Build with -fallow-argument-mismatch for gcc 10 compatibility
|
|
||||||
# otherwise the fortran interface fails to compile
|
|
||||||
# (thanks for the hint Orion)
|
|
||||||
# Reported upstream at https://jira.ecmwf.int/browse/SUP-3081
|
|
||||||
# note that setting FCFLAGS is not sufficient, i.e. this doesn't work:
|
|
||||||
# export FCFLAGS="%%{build_fflags} -fallow-argument-mismatch"
|
|
||||||
# defining the -DCMAKE_Fortran_FLAGS for camke is required to let it compile.
|
|
||||||
|
|
||||||
# added -DCMAKE_Fortran_FLAGS="-fPIC"
|
# added -DCMAKE_Fortran_FLAGS="-fPIC"
|
||||||
# because the koji build crashes with the error that it needs this setting
|
# because the koji build crashes with the error that it needs this setting
|
||||||
# when I try to build for armv7hl (other archs do not complain ......)
|
# when I try to build for armv7hl (other archs do not complain ......)
|
||||||
@ -246,10 +243,7 @@ chmod 644 AUTHORS LICENSE
|
|||||||
-DECCODES_SOVERSION=%{so_version} \
|
-DECCODES_SOVERSION=%{so_version} \
|
||||||
-DECCODES_SOVERSION_F90=%{so_version_f90} \
|
-DECCODES_SOVERSION_F90=%{so_version_f90} \
|
||||||
-DCMAKE_Fortran_FLAGS="-fPIC" \
|
-DCMAKE_Fortran_FLAGS="-fPIC" \
|
||||||
-DENABLE_PYTHON=OFF
|
-DENABLE_PYTHON2=OFF
|
||||||
|
|
||||||
# not needed anymore (solved in the cmake file now)
|
|
||||||
# -DCMAKE_Fortran_FLAGS="-fallow-argument-mismatch"
|
|
||||||
|
|
||||||
# note the final '..' is no longer needed to the cmake3 call.
|
# note the final '..' is no longer needed to the cmake3 call.
|
||||||
# this is now hidden in the %%cmake3 macro
|
# this is now hidden in the %%cmake3 macro
|
||||||
@ -356,6 +350,9 @@ ctest3 -V %{?_smp_mflags}
|
|||||||
%doc %{_datadir}/doc/%{name}/
|
%doc %{_datadir}/doc/%{name}/
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Sep 02 2021 Jos de Kloe <josdekloe@gmail.com> - 2.23.0-1
|
||||||
|
- Upgrade to upstream version 2.23.0
|
||||||
|
|
||||||
* Wed Aug 11 2021 Orion Poplawski <orion@nwra.com> - 2.22.1-4
|
* Wed Aug 11 2021 Orion Poplawski <orion@nwra.com> - 2.22.1-4
|
||||||
- Rebuild for netcdf 4.8.0
|
- Rebuild for netcdf 4.8.0
|
||||||
|
|
||||||
@ -488,7 +485,7 @@ ctest3 -V %{?_smp_mflags}
|
|||||||
- Implement so version because upstream refuses to do so
|
- Implement so version because upstream refuses to do so
|
||||||
- Add fix for test failure 184 and ldconfig_scriptlets
|
- Add fix for test failure 184 and ldconfig_scriptlets
|
||||||
and move unversioned so file to devel package
|
and move unversioned so file to devel package
|
||||||
as suggested by Robert-André Mauchin
|
as suggested by Robert-André Mauchin
|
||||||
- Add a documentation and a data sub-package
|
- Add a documentation and a data sub-package
|
||||||
- Change the license and add a note explaining why this was done
|
- Change the license and add a note explaining why this was done
|
||||||
|
|
||||||
|
1
sources
1
sources
@ -3,3 +3,4 @@ SHA512 (eccodes-2.20.0-Source.tar.gz) = ea2953987c4713b230e6d75ad5ae1dbbeea2633d
|
|||||||
SHA512 (eccodes-2.21.0-Source.tar.gz) = f2ba8361b99800646a92f5f5beb7ec2facf2ee3b8a3f7985d9681a23b2faae778004c8c688ebe4b3a8492e99c76422c66ecc8943d12d3342d5bc1d38362ccf06
|
SHA512 (eccodes-2.21.0-Source.tar.gz) = f2ba8361b99800646a92f5f5beb7ec2facf2ee3b8a3f7985d9681a23b2faae778004c8c688ebe4b3a8492e99c76422c66ecc8943d12d3342d5bc1d38362ccf06
|
||||||
SHA512 (eccodes-2.22.0-Source.tar.gz) = 488ff560cd9969c2d5c0dd0ce3e6b4433954893758ae1a2bd9177536d8b08a89f37aac4f6a175c271f528d5c838fd4ec7b090dfb1f691df5cfceb67508bdc470
|
SHA512 (eccodes-2.22.0-Source.tar.gz) = 488ff560cd9969c2d5c0dd0ce3e6b4433954893758ae1a2bd9177536d8b08a89f37aac4f6a175c271f528d5c838fd4ec7b090dfb1f691df5cfceb67508bdc470
|
||||||
SHA512 (eccodes-2.22.1-Source.tar.gz) = 86818604eca75a34c8ce0cf0540d255c0db2d92bf03970a65c972fb2a16b6c472f6dcebfd04bdac4b76b8db2fcf2ed4dfa8a70875eaf1353a775fc185e5de9a0
|
SHA512 (eccodes-2.22.1-Source.tar.gz) = 86818604eca75a34c8ce0cf0540d255c0db2d92bf03970a65c972fb2a16b6c472f6dcebfd04bdac4b76b8db2fcf2ed4dfa8a70875eaf1353a775fc185e5de9a0
|
||||||
|
SHA512 (eccodes-2.23.0-Source.tar.gz) = df8e9f25396d91ae0adb1b1502cdb6c1473d80caf79ce3fe9318ecc63194fd1c7dc7424fccf44aabf8c06ea343d59093bb21e75f6e5466f21ce44cb514e07350
|
||||||
|
Loading…
Reference in New Issue
Block a user