Merge branch 'f32' into f31 and undo gcc10 workaroundX
This commit is contained in:
commit
610c63d667
3
.gitignore
vendored
3
.gitignore
vendored
@ -6,3 +6,6 @@
|
||||
/eccodes-2.14.1-Source.tar.gz
|
||||
/eccodes-2.15.0-Source.tar.gz
|
||||
/eccodes-2.16.0-Source.tar.gz
|
||||
/eccodes-2.17.0-Source.tar.gz
|
||||
/eccodes-2.18.0-Source.tar.gz
|
||||
/eccodes_test_data_20200626.tar.gz
|
||||
|
@ -1,19 +1,19 @@
|
||||
--- eccodes-2.16.0-Source.unchanged/src/grib_api_prototypes.h 2020-01-14 10:53:35.000000000 +0100
|
||||
+++ eccodes-2.16.0-Source/src/grib_api_prototypes.h 2020-02-08 16:14:04.100982991 +0100
|
||||
@@ -873,8 +873,8 @@ double grib_ieeefloat_error(double x);
|
||||
--- eccodes-2.18.0-Source.unchanged/src/grib_api_prototypes.h 2020-06-24 11:11:27.000000000 +0200
|
||||
+++ eccodes-2.18.0-Source/src/grib_api_prototypes.h 2020-06-27 09:23:17.543758993 +0200
|
||||
@@ -860,8 +860,8 @@ double grib_ieeefloat_error(double x);
|
||||
double grib_long_to_ieee(unsigned long x);
|
||||
int grib_nearest_smaller_ieee_float(double a, double *x);
|
||||
int grib_nearest_smaller_ieee_float(double a, double* x);
|
||||
unsigned long grib_ieee_to_long(double x);
|
||||
-unsigned long grib_ieee64_to_long(double x);
|
||||
-double grib_long_to_ieee64(unsigned long x);
|
||||
+uint64_t grib_ieee64_to_long(double x);
|
||||
+double grib_long_to_ieee64(uint64_t x);
|
||||
int grib_ieee_decode_array(grib_context *c, unsigned char *buf, size_t nvals, int bytes, double *val);
|
||||
int grib_ieee_decode_array(grib_context *c, unsigned char *buf, size_t nvals, int bytes, double *val);
|
||||
int grib_ieee_encode_array(grib_context *c, double *val, size_t nvals, int bytes, unsigned char *buf);
|
||||
--- eccodes-2.16.0-Source.unchanged/src/grib_ieeefloat.c 2020-01-14 10:53:35.000000000 +0100
|
||||
+++ eccodes-2.16.0-Source/src/grib_ieeefloat.c 2020-02-08 16:14:04.104982891 +0100
|
||||
@@ -392,14 +392,14 @@ unsigned long grib_ieee_to_long(double x
|
||||
int grib_ieee_decode_array(grib_context* c, unsigned char* buf, size_t nvals, int bytes, double* val);
|
||||
int grib_ieee_decode_array(grib_context* c, unsigned char* buf, size_t nvals, int bytes, double* val);
|
||||
int grib_ieee_encode_array(grib_context* c, double* val, size_t nvals, int bytes, unsigned char* buf);
|
||||
--- eccodes-2.18.0-Source.unchanged/src/grib_ieeefloat.c 2020-06-24 11:11:27.000000000 +0200
|
||||
+++ eccodes-2.18.0-Source/src/grib_ieeefloat.c 2020-06-27 09:23:17.545758944 +0200
|
||||
@@ -443,14 +443,14 @@ unsigned long grib_ieee_to_long(double x
|
||||
* grib_encode_unsigned_long.
|
||||
*/
|
||||
|
||||
@ -21,12 +21,12 @@
|
||||
+uint64_t grib_ieee64_to_long(double x)
|
||||
{
|
||||
unsigned long lval;
|
||||
memcpy(&lval,&x,8);
|
||||
memcpy(&lval, &x, 8);
|
||||
return lval;
|
||||
}
|
||||
|
||||
-double grib_long_to_ieee64 (unsigned long x)
|
||||
-double grib_long_to_ieee64(unsigned long x)
|
||||
+double grib_long_to_ieee64(uint64_t x)
|
||||
{
|
||||
double dval;
|
||||
memcpy(&dval,&x,8);
|
||||
memcpy(&dval, &x, 8);
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- eccodes-2.16.0-Source.unchanged/fortran/CMakeLists.txt 2020-01-14 10:53:35.000000000 +0100
|
||||
+++ eccodes-2.16.0-Source/fortran/CMakeLists.txt 2020-02-08 16:14:13.161755451 +0100
|
||||
@@ -43,7 +43,9 @@ if( HAVE_FORTRAN )
|
||||
--- eccodes-2.18.0-Source.unchanged/fortran/CMakeLists.txt 2020-06-24 11:11:27.000000000 +0200
|
||||
+++ eccodes-2.18.0-Source/fortran/CMakeLists.txt 2020-06-27 09:23:33.020376062 +0200
|
||||
@@ -45,7 +45,9 @@ if( HAVE_FORTRAN )
|
||||
ecbuild_add_library( TARGET eccodes_f90
|
||||
SOURCES grib_fortran.c grib_f90.f90 eccodes_f90.f90 grib_kinds.h
|
||||
GENERATED grib_f90.f90 eccodes_f90.f90
|
||||
@ -11,13 +11,13 @@
|
||||
if( DEFINED ecbuild_VERSION AND NOT ${ecbuild_VERSION} VERSION_LESS 3.1 )
|
||||
# Installed module directory is not in the PUBLIC INCLUDES!
|
||||
target_include_directories( eccodes_f90 PUBLIC $<INSTALL_INTERFACE:${INSTALL_INCLUDE_DIR}> )
|
||||
--- eccodes-2.16.0-Source.unchanged/src/CMakeLists.txt 2020-01-14 10:53:35.000000000 +0100
|
||||
+++ eccodes-2.16.0-Source/src/CMakeLists.txt 2020-02-08 16:14:13.169755250 +0100
|
||||
@@ -438,6 +438,7 @@ ecbuild_add_library(TARGET eccodes
|
||||
GENERATED grib_api_version.c
|
||||
LIBS ${ECCODES_EXTRA_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT} ${CMATH_LIBRARIES}
|
||||
TEMPLATES ${grib_api_extra_srcs}
|
||||
+ SOVERSION ${ECCODES_SOVERSION}
|
||||
INSTALL_HEADERS_LIST
|
||||
--- eccodes-2.18.0-Source.unchanged/src/CMakeLists.txt 2020-06-24 11:11:27.000000000 +0200
|
||||
+++ eccodes-2.18.0-Source/src/CMakeLists.txt 2020-06-27 09:27:13.845630950 +0200
|
||||
@@ -442,6 +442,7 @@ ecbuild_add_library( TARGET eccodes
|
||||
GENERATED grib_api_version.c
|
||||
LIBS ${ECCODES_EXTRA_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT} ${CMATH_LIBRARIES}
|
||||
TEMPLATES ${grib_api_extra_srcs}
|
||||
+ SOVERSION ${ECCODES_SOVERSION}
|
||||
INSTALL_HEADERS_LIST
|
||||
grib_api.h
|
||||
eccodes.h
|
||||
|
18
eccodes.spec
18
eccodes.spec
@ -1,14 +1,14 @@
|
||||
Name: eccodes
|
||||
Version: 2.16.0
|
||||
Release: 1%{?dist}
|
||||
Version: 2.18.0
|
||||
Release: 2%{?dist}
|
||||
Summary: WMO data format decoding and encoding
|
||||
|
||||
# force the shared libraries to have these so versions
|
||||
%global so_version 0.1
|
||||
%global so_version_f90 0.1
|
||||
%global datapack_date 20181010
|
||||
%global datapack_date 20200626
|
||||
|
||||
# latest rawhide grib_api version is 1.27.0-7
|
||||
# latest fedora-32 grib_api version is 1.27.0-7
|
||||
# but this version number is to be updated as soon as we know
|
||||
# what the final release of grib_api by upstream will be.
|
||||
# latest upstream grib_api release is 1.28.0 (05-Dec-2018)
|
||||
@ -62,6 +62,7 @@ BuildRequires: openjpeg2-devel
|
||||
# For tests
|
||||
BuildRequires: perl(Getopt::Long)
|
||||
BuildRequires: perl(Test::More)
|
||||
BuildRequires: perl(File::Compare)
|
||||
|
||||
# the data is needed by the library and all tools provided in the main package
|
||||
# the other way around, the data package could be installed without
|
||||
@ -338,6 +339,15 @@ ctest3 -V %{?_smp_mflags}
|
||||
%doc %{_datadir}/doc/%{name}/
|
||||
|
||||
%changelog
|
||||
* Sat Jun 27 2020 Jos de Kloe <josdekloe@gmail.com> - 2.18.0-2
|
||||
- Rebuild after fixing mistake in ExcludeArch statements
|
||||
|
||||
* Sat Jun 27 2020 Jos de Kloe <josdekloe@gmail.com> - 2.18.0-1
|
||||
- Upgrade to upstream version 2.18.0
|
||||
|
||||
* Sun Mar 15 2020 Jos de Kloe <josdekloe@gmail.com> - 2.17.0-1
|
||||
- Upgrade to upstream version 2.17.0
|
||||
|
||||
* Sun Feb 09 2020 Jos de Kloe <josdekloe@gmail.com> - 2.16.0-1
|
||||
- Upgrade to upstream version 2.16.0
|
||||
|
||||
|
3
sources
3
sources
@ -5,3 +5,6 @@ SHA512 (eccodes-2.13.0-Source.tar.gz) = bbde1b7092caad20772b21cd06040938f99e763f
|
||||
SHA512 (eccodes-2.14.1-Source.tar.gz) = 864b530642884baa0c3c56eee646a61af7d659e711c7ed4d08a5cc2d68812ecb96b8efabf40c4c9d5dcb3a0edeb1caddffea2ec3438571d3e90dc9cca1dabebe
|
||||
SHA512 (eccodes-2.15.0-Source.tar.gz) = 1d906c5889773b4b6c5e9a967c2e20afb4ecc3ce8f4d496ad7b89417eec8783da9a0c8a9c14796f0c9c24b1f156b9d65408bb9a02a5e0c988a45478350aeae65
|
||||
SHA512 (eccodes-2.16.0-Source.tar.gz) = 6e8768824152d8782c1457cfe79daed32114d1b4694d2843bd02a8aa63c42ccc435b53f7db6942239b3e56999fbaaba4ecef345d39fc5c5f7a5d20ceecf4422a
|
||||
SHA512 (eccodes-2.17.0-Source.tar.gz) = 362c6ae23c23326a3a969c6ba109bdf96ba449cba899030a69efb03e53870f6c90e3f6dbf9d0d2f94febf3a661e607390e8b16d58e64066c4fa941af554ebee7
|
||||
SHA512 (eccodes-2.18.0-Source.tar.gz) = 8daf7f2e1aed055ca6402881f5473e4ae90ba24cc779005f57f99adc7468da459c7539e64f455e2122dd83df29992fd7a6dad2700c8331c4083226e091fbb629
|
||||
SHA512 (eccodes_test_data_20200626.tar.gz) = 553eb69f3664c2f847c5ee7a84066e814ef03b3148ae2c13d845891038336daca815673650f1d06efee4f4a1ddaa4326f2ddfbe81d29382e3f25608b249b8d9e
|
||||
|
Loading…
Reference in New Issue
Block a user