Merge branch 'master' into f29

This commit is contained in:
Jos de Kloe 2019-05-14 20:20:45 +02:00
commit 425cdef690
7 changed files with 69 additions and 32 deletions

2
.gitignore vendored
View File

@ -6,3 +6,5 @@
/eccodes-2.9.0-Source.tar.gz
/eccodes_test_data_20181010.tar.gz
/eccodes-2.9.2-Source.tar.gz
/eccodes-2.12.0-Source.tar.gz
/eccodes-2.12.5-Source.tar.gz

View File

@ -1,3 +1,14 @@
# eccodes
The eccodes package
The eccodes package.
EcCodes is a package developed by ECMWF which provides an application
programming interface and a set of tools for decoding and encoding
messages in the following formats:
* WMO FM-92 GRIB edition 1 and edition 2
* WMO FM-94 BUFR edition 3 and edition 4
* WMO GTS abbreviated header (only decoding).
For further details see:
https://confluence.ecmwf.int/display/ECC/What+is+ecCodes

View File

@ -1,6 +1,6 @@
--- eccodes-2.9.2-Source.orig/src/grib_api_prototypes.h 2018-11-09 15:55:26.000000000 +0100
+++ eccodes-2.9.2-Source/src/grib_api_prototypes.h 2018-11-24 15:06:47.892920252 +0100
@@ -869,8 +869,8 @@ double grib_ieeefloat_error(double x);
--- eccodes-2.12.5-Source.orig/src/grib_api_prototypes.h 2019-05-09 16:24:38.000000000 +0200
+++ eccodes-2.12.5-Source/src/grib_api_prototypes.h 2019-05-09 20:11:02.977946707 +0200
@@ -872,8 +872,8 @@ double grib_ieeefloat_error(double x);
double grib_long_to_ieee(unsigned long x);
int grib_nearest_smaller_ieee_float(double a, double *x);
unsigned long grib_ieee_to_long(double x);
@ -11,8 +11,8 @@
int grib_ieee_decode_array(grib_context *c, unsigned char *buf, size_t nvals, int bytes, double *val);
int grib_ieee_decode_array(grib_context *c, unsigned char *buf, size_t nvals, int bytes, double *val);
int grib_ieee_encode_array(grib_context *c, double *val, size_t nvals, int bytes, unsigned char *buf);
--- eccodes-2.9.2-Source.orig/src/grib_ieeefloat.c 2018-11-09 15:55:26.000000000 +0100
+++ eccodes-2.9.2-Source/src/grib_ieeefloat.c 2018-11-24 15:06:47.892920252 +0100
--- eccodes-2.12.5-Source.orig/src/grib_ieeefloat.c 2019-05-09 16:24:38.000000000 +0200
+++ eccodes-2.12.5-Source/src/grib_ieeefloat.c 2019-05-09 20:11:02.978946681 +0200
@@ -392,14 +392,14 @@ unsigned long grib_ieee_to_long(double x
* grib_encode_unsigned_long.
*/

View File

@ -1,5 +1,5 @@
--- eccodes-2.7.0-Source.orig/cmake/pkg-config.pc.in 2018-03-02 10:52:15.000000000 +0100
+++ eccodes-2.7.0-Source/cmake/pkg-config.pc.in 2018-03-10 10:16:43.852822378 +0100
--- eccodes-2.12.5-Source.orig/cmake/pkg-config.pc.in 2019-05-09 16:24:31.000000000 +0200
+++ eccodes-2.12.5-Source/cmake/pkg-config.pc.in 2019-05-09 20:11:22.754434973 +0200
@@ -14,9 +14,7 @@ CC=@CMAKE_C_COMPILER@
CXX=@CMAKE_CXX_COMPILER@
FC=@CMAKE_Fortran_COMPILER@

View File

@ -1,5 +1,5 @@
--- eccodes-2.7.0-Source.orig/fortran/CMakeLists.txt 2018-03-02 10:52:20.000000000 +0100
+++ eccodes-2.7.0-Source/fortran/CMakeLists.txt 2018-03-10 10:16:43.847822505 +0100
--- eccodes-2.12.5-Source.orig/fortran/CMakeLists.txt 2019-05-09 16:24:38.000000000 +0200
+++ eccodes-2.12.5-Source/fortran/CMakeLists.txt 2019-05-09 20:11:14.481649037 +0200
@@ -43,7 +43,8 @@ if( HAVE_FORTRAN )
ecbuild_add_library( TARGET eccodes_f90
SOURCES grib_fortran.c grib_f90.f90 eccodes_f90.f90 grib_kinds.h
@ -10,9 +10,9 @@
add_custom_command( TARGET eccodes_f90 POST_BUILD
COMMAND ${CMAKE_COMMAND} -E make_directory ${CMAKE_BINARY_DIR}/include
COMMAND ${CMAKE_COMMAND} -E copy ${CMAKE_Fortran_MODULE_DIRECTORY}/${CMAKE_CFG_INTDIR}/eccodes.mod ${CMAKE_BINARY_DIR}/include
--- eccodes-2.7.0-Source.orig/src/CMakeLists.txt 2018-03-02 10:52:20.000000000 +0100
+++ eccodes-2.7.0-Source/src/CMakeLists.txt 2018-03-10 10:16:43.848822480 +0100
@@ -435,8 +435,8 @@ ecbuild_add_library(TARGET eccodes
--- eccodes-2.12.5-Source.orig/src/CMakeLists.txt 2019-05-09 16:24:38.000000000 +0200
+++ eccodes-2.12.5-Source/src/CMakeLists.txt 2019-05-09 20:11:14.481649037 +0200
@@ -436,8 +436,8 @@ ecbuild_add_library(TARGET eccodes
${grib_api_srcs}
GENERATED grib_api_version.c
LIBS ${ECCODES_EXTRA_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT} ${CMATH_LIBRARIES}

View File

@ -1,5 +1,5 @@
Name: eccodes
Version: 2.9.2
Version: 2.12.5
Release: 1%{?dist}
Summary: WMO data format decoding and encoding
@ -8,11 +8,17 @@ Summary: WMO data format decoding and encoding
%global so_version_f90 0.1
%global datapack_date 20181010
# latest rawhide grib_api version is 1.27.0-2
# latest rawhide grib_api version is 1.27.0-3
# but this version number is to be updated as soon as we know
# what the final release of grib_api by upstream will be.
# latest upstream grib_api release is 1.27.0 (09-Sep-2018)
%global final_grib_api_version 1.27.0-2
%global final_grib_api_version 1.27.1-1%{?dist}
%ifarch i686 ppc64 s390x armv7hl
%global obsolete_grib_api 0
%else
%global obsolete_grib_api 1
%endif
# license remarks:
# most of eccodes is licensed ASL 2.0 but a special case must be noted.
@ -39,9 +45,11 @@ Patch1: eccodes-32bit.patch
Patch2: eccodes-soversion.patch
# remove rpath from cmake/pkg-config.pc.in
Patch3: eccodes-rpath.patch
# disabled
# fix compile flags in fortran checks
# this is needed due to rpath removal
Patch4: eccodes-fortran-check.patch
#Patch4: eccodes-fortran-check.patch
# note that the requests to make the other issues public are filed here:
# https://software.ecmwf.int/issues/browse/SUP-2073
@ -85,7 +93,10 @@ Requires: %{name}-data = %{version}-%{release}
# "Please note that GRIB-API support is being discontinued at the end of 2018."
# So the old grib_api will need to be obsoleted.
%if 0%{obsolete_grib_api}
Provides: grib_api = %{final_grib_api_version}
Obsoletes: grib_api < %{final_grib_api_version}
%endif
# as explained in bugzilla #1562066
ExcludeArch: i686
@ -137,11 +148,9 @@ and behaviour. A significant difference compared with GRIB-API tools is that
bufr_dump produces output in JSON format suitable for many web based
applications.
(1) Note: for now only a python2 interface is provided by upstream,
and since Fedora is phasing out python2 this interface has
been removed from this package starting with Fedora 30.
As soon as upstream provides a python3 interface that one will
be added here.
(1) Note: the python3 interface is provided by upstream,
but it fails unit testing, so it has been disabled for now.
As soon as this is fixed by upstream it will be added here.
#####################################################
%package devel
@ -150,7 +159,10 @@ Requires: %{name}%{?_isa} = %{version}-%{release}
Requires: gcc-gfortran%{?_isa}
Requires: jasper-devel%{?_isa}
%if 0%{obsolete_grib_api}
Provides: grib_api-devel = %{final_grib_api_version}
Obsoletes: grib_api-devel < %{final_grib_api_version}
%endif
%description devel
Header files and libraries for ecCodes.
@ -196,11 +208,9 @@ This package contains the html documentation for ecCodes
and a fair number of example programs and scripts to use it
in C, Fortran 90, and Python (1).
(1) Note: for now only a python2 interface is provided by upstream,
and since Fedora is phasing out python2 this interface has
been removed from this package starting with Fedora 30.
As soon as upstream provides a python3 interface that one will
be added here.
(1) Note: the python3 interface is provided by upstream,
but it fails unittesting, so it has been disabled for now.
As soon as this is fixed by upstream it will be added here.
#####################################################
%prep
@ -333,7 +343,7 @@ ctest3 -V %{?_smp_mflags}
%files
%license LICENSE
%doc README ChangeLog AUTHORS
%doc README.md ChangeLog AUTHORS NEWS NOTICE
%{_bindir}/*
%{_libdir}/*.so.*
@ -362,6 +372,22 @@ ctest3 -V %{?_smp_mflags}
%doc %{_datadir}/doc/%{name}/
%changelog
* Thu May 09 2019 Jos de Kloe <josdekloe@gmail.com> - 2.12.5-1
- Upgrade to upstream version 2.12.5
* Mon Mar 18 2019 Orion Poplawski <orion@nwra.com> - 2.12.0-3
- Rebuild for netcdf 4.6.3
* Thu Feb 21 2019 Jos de Kloe <josdekloe@gmail.com> - 2.12.0-2
- bump final_grib_api_version global variable to 1.27.1, so just above the
actual final version, to prevent the obsoletes to be disabled if the release
gets bumped. See BZ #1677968
* Sun Feb 17 2019 Jos de Kloe <josdekloe@gmail.com> - 2.12.0-1
- Upgrade to upstream version 2.12.0
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.9.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Sat Nov 24 2018 Jos de Kloe <josdekloe@gmail.com> - 2.9.2-1
- Upgrade to upstream version 2.9.2

View File

@ -1,5 +1,3 @@
SHA512 (eccodes-2.8.2-Source.tar.gz) = 942de24390df9de64a768e2f351c9acef5b0550a59695016b9753b22fbff260f8a6f9780240dbb2402bec372ee4c8224a68f3d70699a5df42b23c0a4c073114d
SHA512 (eccodes_test_data.tar.gz) = 0f13137584525f12e184068501cc13a58fb8bb16ada680ca7f1575c6066fd2bc5995ec7afffb175c38958e71d991cea4b3972ad01402b54d2550e442241ffc7b
SHA512 (eccodes-2.9.0-Source.tar.gz) = c485255d85d78600fbb4828d9d6eaf2e03a425b7eb8fe5cb1a5f5f822df8b830eddeaa06013327ca1f7247b0012e1ee78814a164a5ccf4b1e90c1a62a35431ea
SHA512 (eccodes_test_data_20181010.tar.gz) = 24c24ec9e01d230cf542abe5c131f05b8e627dd9d170c666628bb5fd8f7b1a6aa11a35456b8d742c59f54c6aabac78658efd68b0c50779d466aba3d35b4a0231
SHA512 (eccodes-2.9.2-Source.tar.gz) = 94d077bb0f348c4d64883a4f0877439c123786c73d2b64e4bdfb3f7eb28e445ff1e0eeb57140261906b8aef8e22fd3d614528f1821877ebe6bcb9d38393921d9
SHA512 (eccodes-2.12.0-Source.tar.gz) = 3dc876bde2a6c81a43bcc64ecb12969f28eae3cfbc8fed7da7797fc722dc8b446ac7be5178f55b7d395653e0718437b842296a7d4d11b372b8692404c76aa4ad
SHA512 (eccodes-2.12.5-Source.tar.gz) = ab1267dffdb3d0dbcdd65f23db2d77bc7bd8f3241083374c75bc62ebf70b7d29d8af9f657d6da05a47e363151c8d995adfadca7bbf95ebb24a27303d80f081a4