Upgrade to upstream version 2.25.0; Add new BR libaec-devel

This commit is contained in:
Jos de Kloe 2022-03-06 17:17:56 +01:00
parent a086e5e7b2
commit 285b274271
4 changed files with 16 additions and 30 deletions

View File

@ -1,14 +0,0 @@
--- eccodes-2.24.0-Source.unchanged/src/grib_api_internal.h 2021-12-07 12:03:44.000000000 +0100
+++ eccodes-2.24.0-Source/src/grib_api_internal.h 2021-12-09 10:02:54.686070864 +0100
@@ -40,9 +40,9 @@ extern "C" {
#if IS_BIG_ENDIAN
#if GRIB_MEM_ALIGN
-#define FAST_BIG_ENDIAN 0
-#else
#define FAST_BIG_ENDIAN 1
+#else
+#define FAST_BIG_ENDIAN 0
#endif
#endif

View File

@ -1,6 +1,5 @@
diff -urp -x '*~' -x redhat-linux-build -x '*.list' -x '.package_note*' eccodes-2.24.0-Source/src/grib_jasper_encoding.c eccodes-2.24.0-Source.new/src/grib_jasper_encoding.c --- eccodes-2.25.0-Source.unchanged/src/grib_jasper_encoding.c 2022-03-03 15:40:43.000000000 +0100
--- eccodes-2.24.0-Source/src/grib_jasper_encoding.c 2021-12-07 20:03:44.000000000 +0900 +++ eccodes-2.25.0-Source/src/grib_jasper_encoding.c 2022-03-06 16:18:43.875617700 +0100
+++ eccodes-2.24.0-Source.new/src/grib_jasper_encoding.c 2022-02-14 23:35:10.954255326 +0900
@@ -30,7 +30,7 @@ int grib_jasper_decode(grib_context* c, @@ -30,7 +30,7 @@ int grib_jasper_decode(grib_context* c,
jas_matrix_t* matrix = NULL; jas_matrix_t* matrix = NULL;
jas_image_cmpt_t* p; jas_image_cmpt_t* p;

View File

@ -1,5 +1,5 @@
--- eccodes-2.24.0-Source.unchanged/fortran/CMakeLists.txt 2021-12-07 12:03:44.000000000 +0100 --- eccodes-2.25.0-Source.unchanged/fortran/CMakeLists.txt 2022-03-03 15:40:42.000000000 +0100
+++ eccodes-2.24.0-Source/fortran/CMakeLists.txt 2021-12-09 09:57:37.787105551 +0100 +++ eccodes-2.25.0-Source/fortran/CMakeLists.txt 2022-03-06 15:40:01.323606416 +0100
@@ -49,7 +49,8 @@ if( HAVE_FORTRAN ) @@ -49,7 +49,8 @@ if( HAVE_FORTRAN )
GENERATED grib_f90.f90 eccodes_f90.f90 GENERATED grib_f90.f90 eccodes_f90.f90
PUBLIC_INCLUDES $<BUILD_INTERFACE:${CMAKE_Fortran_MODULE_DIRECTORY}> PUBLIC_INCLUDES $<BUILD_INTERFACE:${CMAKE_Fortran_MODULE_DIRECTORY}>
@ -10,9 +10,9 @@
if( DEFINED ecbuild_VERSION AND NOT ${ecbuild_VERSION} VERSION_LESS 3.1 ) if( DEFINED ecbuild_VERSION AND NOT ${ecbuild_VERSION} VERSION_LESS 3.1 )
# Installed module directory is not in the PUBLIC INCLUDES! # Installed module directory is not in the PUBLIC INCLUDES!
--- eccodes-2.24.0-Source.unchanged/src/CMakeLists.txt 2021-12-07 12:03:44.000000000 +0100 --- eccodes-2.25.0-Source.unchanged/src/CMakeLists.txt 2022-03-03 15:40:42.000000000 +0100
+++ eccodes-2.24.0-Source/src/CMakeLists.txt 2021-12-09 09:57:37.811104942 +0100 +++ eccodes-2.25.0-Source/src/CMakeLists.txt 2022-03-06 15:40:01.324606392 +0100
@@ -444,6 +444,7 @@ ecbuild_add_library( TARGET eccodes @@ -437,6 +437,7 @@ ecbuild_add_library( TARGET eccodes
PRIVATE_LIBS ${ECCODES_EXTRA_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT} ${AEC_LIBRARIES} ${PNG_LIBRARIES} PRIVATE_LIBS ${ECCODES_EXTRA_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT} ${AEC_LIBRARIES} ${PNG_LIBRARIES}
PUBLIC_LIBS ${CMATH_LIBRARIES} ${THREADS_LIBRARIES} PUBLIC_LIBS ${CMATH_LIBRARIES} ${THREADS_LIBRARIES}
TEMPLATES ${grib_api_extra_srcs} TEMPLATES ${grib_api_extra_srcs}

View File

@ -1,6 +1,6 @@
Name: eccodes Name: eccodes
Version: 2.24.0 Version: 2.25.0
Release: 4%{?dist} Release: 1%{?dist}
Summary: WMO data format decoding and encoding Summary: WMO data format decoding and encoding
# force the shared libraries to have these so versions # force the shared libraries to have these so versions
@ -32,7 +32,7 @@ Summary: WMO data format decoding and encoding
License: ASL 2.0 License: ASL 2.0
URL: https://software.ecmwf.int/wiki/display/ECC/ecCodes+Home URL: https://confluence.ecmwf.int/display/ECC/ecCodes+Home
Source0: https://software.ecmwf.int/wiki/download/attachments/45757960/eccodes-%{version}-Source.tar.gz Source0: https://software.ecmwf.int/wiki/download/attachments/45757960/eccodes-%{version}-Source.tar.gz
# note: this data package is unversioned upstream but still it is updated # note: this data package is unversioned upstream but still it is updated
# now and then so rename the datapack using the download date # now and then so rename the datapack using the download date
@ -47,15 +47,11 @@ Patch1: eccodes-soversion.patch
# https://software.ecmwf.int/issues/browse/SUP-2073 # https://software.ecmwf.int/issues/browse/SUP-2073
# (and again, unfortunately this issue is not public) # (and again, unfortunately this issue is not public)
# grib_api_internal.h: reverse definition of FAST_BIG_ENDIAN
# https://jira.ecmwf.int/browse/SUP-2410
Patch2: eccodes-grib_api_internal.h-reverse-definition-of-FAST_BIG_E.patch
# jasper3 now hides internal encoder / decoder. Use wrapper entry point # jasper3 now hides internal encoder / decoder. Use wrapper entry point
# c.f. https://github.com/jasper-software/jasper/commit/5fe57ac5829ec31396e7eaab59a688da014660af # c.f. https://github.com/jasper-software/jasper/commit/5fe57ac5829ec31396e7eaab59a688da014660af
# Also, now with jasper3, calling jas_stream_memopen (for example) always needs jasper # Also, now with jasper3, calling jas_stream_memopen (for example) always needs jasper
# library initialization # library initialization
Patch3: eccodes-2.24.0-jasper3-use-wrapper-entry-point.patch Patch2: eccodes-jasper3-use-wrapper-entry-point.patch
BuildRequires: cmake3 BuildRequires: cmake3
@ -67,6 +63,7 @@ BuildRequires: libjpeg-devel
BuildRequires: libpng-devel BuildRequires: libpng-devel
BuildRequires: netcdf-devel BuildRequires: netcdf-devel
BuildRequires: openjpeg2-devel BuildRequires: openjpeg2-devel
BuildRequires: libaec-devel
# For tests # For tests
BuildRequires: perl(Getopt::Long) BuildRequires: perl(Getopt::Long)
@ -354,6 +351,10 @@ ctest3 -V %{?_smp_mflags}
%doc %{_datadir}/doc/%{name}/ %doc %{_datadir}/doc/%{name}/
%changelog %changelog
* Sun Mar 06 2022 Jos de Kloe <josdekloe@gmail.com> - 2.25.0-1
- Upgrade to upstream version 2.25.0
- Add new BR libaec-devel
* Mon Feb 14 2022 Mamoru TASAKA <mtasaka@fedoraproject.org> - 2.24.0-4 * Mon Feb 14 2022 Mamoru TASAKA <mtasaka@fedoraproject.org> - 2.24.0-4
- jasper3: use wrapper entry point for jpeg2000 decoder - jasper3: use wrapper entry point for jpeg2000 decoder