update to new upstream version, and disable architecture exceptions for testing

This commit is contained in:
Jos de Kloe 2019-10-27 13:05:28 +01:00
parent 549447a985
commit 1b5923d046
5 changed files with 42 additions and 46 deletions

1
.gitignore vendored
View File

@ -3,3 +3,4 @@
/eccodes-2.12.0-Source.tar.gz
/eccodes-2.12.5-Source.tar.gz
/eccodes-2.13.0-Source.tar.gz
/eccodes-2.14.1-Source.tar.gz

View File

@ -1,5 +1,5 @@
--- eccodes-2.13.0-Source.orig/src/grib_api_prototypes.h 2019-07-08 14:06:45.000000000 +0200
+++ eccodes-2.13.0-Source/src/grib_api_prototypes.h 2019-07-25 12:58:22.124808129 +0200
--- eccodes-2.14.1-Source.unchanged/src/grib_api_prototypes.h 2019-10-10 13:33:52.000000000 +0200
+++ eccodes-2.14.1-Source/src/grib_api_prototypes.h 2019-10-27 11:20:05.496702520 +0100
@@ -872,8 +872,8 @@ double grib_ieeefloat_error(double x);
double grib_long_to_ieee(unsigned long x);
int grib_nearest_smaller_ieee_float(double a, double *x);
@ -11,8 +11,8 @@
int grib_ieee_decode_array(grib_context *c, unsigned char *buf, size_t nvals, int bytes, double *val);
int grib_ieee_decode_array(grib_context *c, unsigned char *buf, size_t nvals, int bytes, double *val);
int grib_ieee_encode_array(grib_context *c, double *val, size_t nvals, int bytes, unsigned char *buf);
--- eccodes-2.13.0-Source.orig/src/grib_ieeefloat.c 2019-07-08 14:06:45.000000000 +0200
+++ eccodes-2.13.0-Source/src/grib_ieeefloat.c 2019-07-25 12:58:22.125808103 +0200
--- eccodes-2.14.1-Source.unchanged/src/grib_ieeefloat.c 2019-10-10 13:33:52.000000000 +0200
+++ eccodes-2.14.1-Source/src/grib_ieeefloat.c 2019-10-27 11:20:05.497702497 +0100
@@ -392,14 +392,14 @@ unsigned long grib_ieee_to_long(double x
* grib_encode_unsigned_long.
*/

View File

@ -1,25 +1,23 @@
--- eccodes-2.13.0-Source.orig/fortran/CMakeLists.txt 2019-07-08 14:06:44.000000000 +0200
+++ eccodes-2.13.0-Source/fortran/CMakeLists.txt 2019-07-25 12:58:27.343673693 +0200
@@ -43,7 +43,8 @@ if( HAVE_FORTRAN )
--- eccodes-2.14.1-Source.unchanged/fortran/CMakeLists.txt 2019-10-10 13:33:52.000000000 +0200
+++ eccodes-2.14.1-Source/fortran/CMakeLists.txt 2019-10-27 11:25:48.269661718 +0100
@@ -43,7 +43,9 @@ if( HAVE_FORTRAN )
ecbuild_add_library( TARGET eccodes_f90
SOURCES grib_fortran.c grib_f90.f90 eccodes_f90.f90 grib_kinds.h
GENERATED grib_f90.f90 eccodes_f90.f90
- LIBS eccodes )
+ LIBS eccodes
+ SOVERSION ${ECCODES_SOVERSION_F90})
add_custom_command( TARGET eccodes_f90 POST_BUILD
COMMAND ${CMAKE_COMMAND} -E make_directory ${CMAKE_BINARY_DIR}/include
COMMAND ${CMAKE_COMMAND} -E copy ${CMAKE_Fortran_MODULE_DIRECTORY}/${CMAKE_CFG_INTDIR}/eccodes.mod ${CMAKE_BINARY_DIR}/include
--- eccodes-2.13.0-Source.orig/src/CMakeLists.txt 2019-07-08 14:06:45.000000000 +0200
+++ eccodes-2.13.0-Source/src/CMakeLists.txt 2019-07-25 12:58:27.343673693 +0200
@@ -437,8 +437,8 @@ ecbuild_add_library(TARGET eccodes
${grib_api_srcs}
+
if( DEFINED ecbuild_VERSION AND NOT ${ecbuild_VERSION} VERSION_LESS 3.1 )
# Installed module directory is not in the PUBLIC INCLUDES!
target_include_directories( eccodes_f90 PUBLIC $<INSTALL_INTERFACE:${INSTALL_INCLUDE_DIR}> )
--- eccodes-2.14.1-Source.unchanged/src/CMakeLists.txt 2019-10-10 13:33:52.000000000 +0200
+++ eccodes-2.14.1-Source/src/CMakeLists.txt 2019-10-27 11:27:56.115531419 +0100
@@ -438,6 +438,7 @@ ecbuild_add_library(TARGET eccodes
GENERATED grib_api_version.c
LIBS ${ECCODES_EXTRA_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT} ${CMATH_LIBRARIES}
- TEMPLATES ${grib_api_extra_srcs})
-
+ TEMPLATES ${grib_api_extra_srcs}
+ SOVERSION ${ECCODES_SOVERSION})
install( FILES grib_api.h eccodes.h eccodes_windef.h DESTINATION ${INSTALL_INCLUDE_DIR} )
install( FILES ${CMAKE_CURRENT_BINARY_DIR}/eccodes_version.h DESTINATION ${INSTALL_INCLUDE_DIR} )
TEMPLATES ${grib_api_extra_srcs}
+ SOVERSION ${ECCODES_SOVERSION}
INSTALL_HEADERS_LIST
grib_api.h
eccodes.h

View File

@ -1,6 +1,6 @@
Name: eccodes
Version: 2.13.0
Release: 2%{?dist}
Version: 2.14.1
Release: 1%{?dist}
Summary: WMO data format decoding and encoding
# force the shared libraries to have these so versions
@ -8,7 +8,7 @@ Summary: WMO data format decoding and encoding
%global so_version_f90 0.1
%global datapack_date 20181010
# latest rawhide grib_api version is 1.27.0-4
# latest rawhide grib_api version is 1.27.0-5
# but this version number is to be updated as soon as we know
# what the final release of grib_api by upstream will be.
# latest upstream grib_api release is 1.28.0 (05-Dec-2018)
@ -91,15 +91,15 @@ Obsoletes: grib_api < %{final_grib_api_version}
%endif
# as explained in bugzilla #1562066
ExcludeArch: i686
#ExcludeArch: i686
# as explained in bugzilla #1562071
# note: this is no longer part of fc30/rawhide
# but the exclude is still needed for EPEL-7
#ExcludeArch: ppc64
# as explained in bugzilla #1562076
ExcludeArch: s390x
#ExcludeArch: s390x
# as explained in bugzilla #1562084
ExcludeArch: armv7hl
#ExcludeArch: armv7hl
%if 0%{?rhel} >= 7
# as explained in bugzilla #1629377
@ -286,14 +286,16 @@ cp examples/C/*.c %{buildroot}%{_datadir}/doc/%{name}/examples/C
mkdir -p %{buildroot}%{_datadir}/doc/%{name}/examples/F90
cp examples/F90/*.f90 %{buildroot}%{_datadir}/doc/%{name}/examples/F90
%ifarch i686 armv7hl
# pass (nothing to do)
%else
# it seems pkgconfig files end up in lib in stead of lib64 now
# so move them to the right place
mv %{buildroot}/%{_usr}/lib/pkgconfig/ \
%{buildroot}/%{_libdir}/pkgconfig/
%endif
# also not needed for x86_64
# maybe they fixed it for all archs?
#%%ifarch i686 armv7hl
# # pass (nothing to do)
#%%else
# # it seems pkgconfig files end up in lib in stead of lib64 now
# # so move them to the right place
# mv %%{buildroot}/%%{_usr}/lib/pkgconfig/ \
# %%{buildroot}/%%{_libdir}/pkgconfig/
#%%endif
# It seems the cmake options
# -DCMAKE_SKIP_RPATH=TRUE
@ -317,18 +319,9 @@ cd build
# 'eccodes_t_bufr_dump_(de|en)code_C' tests run.
# These tests compile on the fly generated C code, and
# without this setting the loader does not find the libraries.
#
# These fail due to build flag issues, i.e. the test script does a
# test build of some on the fly generated fortran code, but cannot
# find the necessary *.mod fortran module definition files.
# There is no easy way to define this as environment setting,
# so a patch has been added to solve this for now.
# See: https://software.ecmwf.int/issues/browse/SUP-1812
# (unfortunately this issue is not public)
#LD_LIBRARY_PATH=%%{buildroot}/%%{_libdir} \
#LIBRARY_PATH=%%{buildroot}/%%{_libdir} \
LD_LIBRARY_PATH=%{buildroot}/%{_libdir} \
LIBRARY_PATH=%{buildroot}/%{_libdir} \
ctest3 -V %{?_smp_mflags}
%files
@ -357,6 +350,9 @@ ctest3 -V %{?_smp_mflags}
%doc %{_datadir}/doc/%{name}/
%changelog
* Sun Oct 27 2019 Jos de Kloe <josdekloe@gmail.com> - 2.14.1-1
- Upgrade to upstream version 2.14.1
* Sat Aug 10 2019 Jos de Kloe <josdekloe@gmail.com> - 2.13.0-2
- apply bugfix to pc files contribuited by Emanuele Di Giacomo

View File

@ -2,3 +2,4 @@ SHA512 (eccodes_test_data_20181010.tar.gz) = 24c24ec9e01d230cf542abe5c131f05b8e6
SHA512 (eccodes-2.12.0-Source.tar.gz) = 3dc876bde2a6c81a43bcc64ecb12969f28eae3cfbc8fed7da7797fc722dc8b446ac7be5178f55b7d395653e0718437b842296a7d4d11b372b8692404c76aa4ad
SHA512 (eccodes-2.12.5-Source.tar.gz) = ab1267dffdb3d0dbcdd65f23db2d77bc7bd8f3241083374c75bc62ebf70b7d29d8af9f657d6da05a47e363151c8d995adfadca7bbf95ebb24a27303d80f081a4
SHA512 (eccodes-2.13.0-Source.tar.gz) = bbde1b7092caad20772b21cd06040938f99e763f77a6622820e3cc2fba5c0765178822be4b3c33b41a927757da85f311c0c4f057500ca58d257dde304e7eeca3
SHA512 (eccodes-2.14.1-Source.tar.gz) = 864b530642884baa0c3c56eee646a61af7d659e711c7ed4d08a5cc2d68812ecb96b8efabf40c4c9d5dcb3a0edeb1caddffea2ec3438571d3e90dc9cca1dabebe