2.0.9 for EL5
This commit is contained in:
parent
7a37a6dc56
commit
4ffed1cb0c
12
ebtables-2.0.8-buildid.patch
Normal file
12
ebtables-2.0.8-buildid.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up ebtables-v2.0.8-1/Makefile.BAD ebtables-v2.0.8-1/Makefile
|
||||
--- ebtables-v2.0.8-1/Makefile.BAD 2007-08-23 09:57:40.000000000 -0400
|
||||
+++ ebtables-v2.0.8-1/Makefile 2007-08-23 09:58:11.000000000 -0400
|
||||
@@ -94,7 +94,7 @@ ebtables-standalone.o: ebtables-standalo
|
||||
|
||||
.PHONY: libebtc
|
||||
libebtc: $(OBJECTS2)
|
||||
- $(LD) -shared -soname libebtc.so -o libebtc.so -lc $(OBJECTS2)
|
||||
+ $(LD) --build-id -shared -soname libebtc.so -o libebtc.so -lc $(OBJECTS2)
|
||||
|
||||
ebtables: $(OBJECTS) ebtables-standalone.o libebtc
|
||||
$(CC) $(CFLAGS) $(CFLAGS_SH_LIB) -o $@ ebtables-standalone.o -I$(KERNEL_INCLUDES) -L. -Lextensions -lebtc $(EXT_LIBSI) \
|
19
ebtables-2.0.8-cflags.patch
Normal file
19
ebtables-2.0.8-cflags.patch
Normal file
@ -0,0 +1,19 @@
|
||||
diff -up ebtables-v2.0.8-1/extensions/Makefile.BAD ebtables-v2.0.8-1/extensions/Makefile
|
||||
--- ebtables-v2.0.8-1/extensions/Makefile.BAD 2007-08-23 09:52:37.000000000 -0400
|
||||
+++ ebtables-v2.0.8-1/extensions/Makefile 2007-08-23 09:52:50.000000000 -0400
|
||||
@@ -11,13 +11,13 @@ EXT_LIBSI+=$(foreach T,$(EXT_FUNC), -leb
|
||||
EXT_LIBSI+=$(foreach T,$(EXT_TABLES), -lebtable_$(T))
|
||||
|
||||
extensions/ebt_%.so: extensions/ebt_%.o
|
||||
- $(CC) -shared -o $@ -lc $< -nostartfiles
|
||||
+ $(CC) $(CFLAGS) -shared -o $@ -lc $< -nostartfiles
|
||||
|
||||
extensions/libebt_%.so: extensions/ebt_%.so
|
||||
mv $< $@
|
||||
|
||||
extensions/ebtable_%.so: extensions/ebtable_%.o
|
||||
- $(CC) -shared -o $@ -lc $< -nostartfiles
|
||||
+ $(CC) $(CFLAGS) -shared -o $@ -lc $< -nostartfiles
|
||||
|
||||
extensions/libebtable_%.so: extensions/ebtable_%.so
|
||||
mv $< $@
|
63
ebtables-2.0.8-norootinst.patch
Normal file
63
ebtables-2.0.8-norootinst.patch
Normal file
@ -0,0 +1,63 @@
|
||||
diff -up ebtables-v2.0.8-2/Makefile.orig ebtables-v2.0.8-2/Makefile
|
||||
--- ebtables-v2.0.8-2/Makefile.orig 2007-09-21 13:27:20.000000000 -0400
|
||||
+++ ebtables-v2.0.8-2/Makefile 2007-10-28 15:09:01.000000000 -0400
|
||||
@@ -154,28 +154,28 @@ tmp3:=$(shell printf $(PIPE) | sed 's/\/
|
||||
.PHONY: scripts
|
||||
scripts: ebtables-save ebtables.sysv ebtables-config
|
||||
cat ebtables-save | sed 's/__EXEC_PATH__/$(tmp1)/g' > ebtables-save_
|
||||
- install -m 0755 -o root -g root ebtables-save_ $(DESTDIR)$(BINDIR)/ebtables-save
|
||||
+ install -m 0755 ebtables-save_ $(DESTDIR)$(BINDIR)/ebtables-save
|
||||
cat ebtables.sysv | sed 's/__EXEC_PATH__/$(tmp1)/g' | sed 's/__SYSCONFIG__/$(tmp2)/g' > ebtables.sysv_
|
||||
- install -m 0755 -o root -g root ebtables.sysv_ $(DESTDIR)$(INITDIR)/ebtables
|
||||
+ install -m 0755 ebtables.sysv_ $(DESTDIR)$(INITDIR)/ebtables
|
||||
cat ebtables-config | sed 's/__SYSCONFIG__/$(tmp2)/g' > ebtables-config_
|
||||
- install -m 0600 -o root -g root ebtables-config_ $(DESTDIR)$(SYSCONFIGDIR)/ebtables-config
|
||||
+ install -m 0600 ebtables-config_ $(DESTDIR)$(SYSCONFIGDIR)/ebtables-config
|
||||
rm -f ebtables-save_ ebtables.sysv_ ebtables-config_
|
||||
|
||||
$(MANDIR)/man8/ebtables.8: ebtables.8
|
||||
mkdir -p $(DESTDIR)$(@D)
|
||||
sed 's/$$(VERSION)/$(PROGVERSION)/' ebtables.8 | sed 's/$$(DATE)/$(PROGDATE)/' > ebtables.8_
|
||||
- install -m 0644 -o root -g root ebtables.8_ $(DESTDIR)$@
|
||||
+ install -m 0644 ebtables.8_ $(DESTDIR)$@
|
||||
rm -f ebtables.8_
|
||||
|
||||
$(ETHERTYPESFILE): ethertypes
|
||||
mkdir -p $(DESTDIR)$(@D)
|
||||
- install -m 0644 -o root -g root $< $(DESTDIR)$@
|
||||
+ install -m 0644 $< $(DESTDIR)$@
|
||||
|
||||
.PHONY: exec
|
||||
exec: ebtables ebtables-restore
|
||||
mkdir -p $(DESTDIR)$(BINDIR)
|
||||
- install -m 0755 -o root -g root $(PROGNAME) $(DESTDIR)$(BINDIR)/$(PROGNAME)
|
||||
- install -m 0755 -o root -g root ebtables-restore $(DESTDIR)$(BINDIR)/ebtables-restore
|
||||
+ install -m 0755 $(PROGNAME) $(DESTDIR)$(BINDIR)/$(PROGNAME)
|
||||
+ install -m 0755 ebtables-restore $(DESTDIR)$(BINDIR)/ebtables-restore
|
||||
|
||||
.PHONY: install
|
||||
install: $(MANDIR)/man8/ebtables.8 $(ETHERTYPESFILE) exec scripts
|
||||
@@ -199,18 +199,18 @@ release:
|
||||
rm -f extensions/ebt_inat.c
|
||||
rm -rf $(CVSDIRS)
|
||||
mkdir -p include/linux/netfilter_bridge
|
||||
- install -m 0644 -o root -g root \
|
||||
+ install -m 0644 \
|
||||
$(KERNEL_INCLUDES)/linux/netfilter_bridge.h include/linux/
|
||||
# To keep possible compile error complaints about undefined ETH_P_8021Q
|
||||
# off my back
|
||||
- install -m 0644 -o root -g root \
|
||||
+ install -m 0644 \
|
||||
$(KERNEL_INCLUDES)/linux/if_ether.h include/linux/
|
||||
- install -m 0644 -o root -g root \
|
||||
+ install -m 0644 \
|
||||
$(KERNEL_INCLUDES)/linux/types.h include/linux/
|
||||
- install -m 0644 -o root -g root \
|
||||
+ install -m 0644 \
|
||||
$(KERNEL_INCLUDES)/linux/netfilter_bridge/*.h \
|
||||
include/linux/netfilter_bridge/
|
||||
- install -m 0644 -o root -g root \
|
||||
+ install -m 0644 \
|
||||
include/ebtables.h include/linux/netfilter_bridge/
|
||||
make clean
|
||||
touch *
|
@ -1,15 +1,17 @@
|
||||
Name: ebtables
|
||||
Version: 2.0.8
|
||||
Release: 1%{?dist}
|
||||
Summary: Ethernet Bridge frame table administration tool
|
||||
License: GPLv2+
|
||||
Group: System Environment/Base
|
||||
URL: http://ebtables.sourceforge.net/
|
||||
Source0: http://dl.sf.net/ebtables/ebtables-v%{version}-1.tar.gz
|
||||
Source1: ebtables.sysv
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
PreReq: /sbin/chkconfig
|
||||
PreReq: /sbin/service
|
||||
Name: ebtables
|
||||
Version: 2.0.9
|
||||
Release: 1%{?dist}
|
||||
Summary: Ethernet Bridge frame table administration tool
|
||||
License: GPLv2+
|
||||
Group: System Environment/Base
|
||||
URL: http://ebtables.sourceforge.net/
|
||||
Source0: http://dl.sf.net/ebtables/ebtables-v%{version}-1.tar.gz
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Requires(pre): /sbin/chkconfig
|
||||
Requires(postun): /sbin/service
|
||||
Patch0: ebtables-2.0.8-norootinst.patch
|
||||
Patch1: ebtables-2.0.8-cflags.patch
|
||||
Patch2: ebtables-2.0.8-buildid.patch
|
||||
|
||||
%description
|
||||
Ethernet bridge tables is a firewalling tool to transparently filter network
|
||||
@ -17,30 +19,32 @@ traffic passing a bridge. The filtering possibilities are limited to link
|
||||
layer filtering and some basic filtering on higher network layers.
|
||||
|
||||
This tool is the userspace control for the bridge and ebtables kernel
|
||||
components (built by default in Fedora Core kernels).
|
||||
components (built by default in Fedora kernels).
|
||||
|
||||
The ebtables tool can be used together with the other Linux filtering tools,
|
||||
like iptables. There are no known incompatibility issues.
|
||||
|
||||
%prep
|
||||
%setup -q -n ebtables-v%{version}-1
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
|
||||
# Convert to UTF-8
|
||||
f=THANKS; iconv -f iso-8859-1 -t utf-8 $f -o $f.utf8 ; mv $f.utf8 $f
|
||||
|
||||
%build
|
||||
MY_CFLAGS=`echo $RPM_OPT_FLAGS -fPIC | sed -e 's/-fstack-protector//g'`
|
||||
make %{?_smp_mflags} CFLAGS="$MY_CFLAGS"
|
||||
make %{?_smp_mflags} CFLAGS="$MY_CFLAGS" LIBDIR="%{_libdir}/ebtables" BINDIR="/sbin" MANDIR="%{_mandir}"
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
mkdir -p $RPM_BUILD_ROOT%{_libdir}
|
||||
install -m0755 extensions/*.so $RPM_BUILD_ROOT%{_libdir}
|
||||
install -m0755 *.so $RPM_BUILD_ROOT%{_libdir}
|
||||
install -D -m0755 ebtables $RPM_BUILD_ROOT/sbin/ebtables
|
||||
install -D -m0755 %{SOURCE1} $RPM_BUILD_ROOT%{_initrddir}/ebtables
|
||||
install -D -m0644 ethertypes $RPM_BUILD_ROOT%{_sysconfdir}/ethertypes
|
||||
install -D -m0644 ebtables.8 $RPM_BUILD_ROOT%{_mandir}/man8/ebtables.8
|
||||
touch $RPM_BUILD_ROOT%{_sysconfdir}/ebtables.filter
|
||||
touch $RPM_BUILD_ROOT%{_sysconfdir}/ebtables.nat
|
||||
touch $RPM_BUILD_ROOT%{_sysconfdir}/ebtables.broute
|
||||
mkdir -p $RPM_BUILD_ROOT%{_initrddir}
|
||||
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
|
||||
make DESTDIR="$RPM_BUILD_ROOT" LIBDIR="%{_libdir}/ebtables" BINDIR="/sbin" MANDIR="%{_mandir}" install
|
||||
touch $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/ebtables.filter
|
||||
touch $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/ebtables.nat
|
||||
touch $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/ebtables.broute
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
@ -66,14 +70,42 @@ fi
|
||||
%doc ChangeLog COPYING THANKS
|
||||
%doc %{_mandir}/man8/ebtables.8*
|
||||
%config(noreplace) %{_sysconfdir}/ethertypes
|
||||
%config(noreplace) %{_sysconfdir}/sysconfig/ebtables-config
|
||||
%{_initrddir}/ebtables
|
||||
%{_libdir}/libebt*.so
|
||||
/sbin/ebtables
|
||||
%ghost %{_sysconfdir}/ebtables.filter
|
||||
%ghost %{_sysconfdir}/ebtables.nat
|
||||
%ghost %{_sysconfdir}/ebtables.broute
|
||||
%{_libdir}/ebtables/
|
||||
/sbin/ebtables*
|
||||
%ghost %{_sysconfdir}/sysconfig/ebtables.filter
|
||||
%ghost %{_sysconfdir}/sysconfig/ebtables.nat
|
||||
%ghost %{_sysconfdir}/sysconfig/ebtables.broute
|
||||
|
||||
%changelog
|
||||
* Mon Jul 27 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 2.0.9-1
|
||||
- update to 2.0.9
|
||||
|
||||
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.8-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.8-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.0.8-5
|
||||
- Autorebuild for GCC 4.3
|
||||
|
||||
* Sun Oct 28 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2.0.8-4
|
||||
- bump to 2.0.8-2 from upstream
|
||||
- keep _libdir/ebtables, even though upstream just moved away from it.
|
||||
|
||||
* Thu Aug 23 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2.0.8-3
|
||||
- use _libdir/ebtables to match upstream RPATH (bugzilla 248865)
|
||||
- correct license tag
|
||||
- use upstream init script
|
||||
- enable build-id
|
||||
- use cflags for all compiles
|
||||
- be sane with DESTDIR
|
||||
|
||||
* Mon Jul 9 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2.0.8-2
|
||||
- remove "Fedora Core" reference in spec
|
||||
|
||||
* Mon Jul 2 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2.0.8-1
|
||||
- final 2.0.8 release
|
||||
|
||||
@ -125,9 +157,9 @@ fi
|
||||
* Fri Jul 1 2005 Tom "spot" Callaway <tcallawa@redhat.com> 2.0.6-4
|
||||
- remove INSTALL file
|
||||
- add some text to description, correct typos
|
||||
- fix %postun
|
||||
- fix %%postun
|
||||
- add PreReqs
|
||||
- add %ghost config files
|
||||
- add %%ghost config files
|
||||
|
||||
* Tue May 31 2005 Tom "spot" Callaway <tcallawa@redhat.com> 2.0.6-3
|
||||
- reworked for Fedora Extras
|
||||
|
Loading…
Reference in New Issue
Block a user