Update to 0.11.3 with bug fixes

Signed-off-by: Jonathan Dieter <jdieter@gmail.com>
This commit is contained in:
Jonathan Dieter 2021-09-08 17:24:26 +01:00
parent 7cee002684
commit f937ad6283
5 changed files with 8 additions and 84 deletions

1
.gitignore vendored
View File

@ -1,2 +1,3 @@
/duperemove-0.11.tar.gz
/duperemove-0.11.1.tar.gz
/duperemove-0.11.3.tar.gz

View File

@ -1,77 +0,0 @@
diff -urb duperemove-0.11a/csum-xxhash.c duperemove-0.11b/csum-xxhash.c
--- duperemove-0.11a/csum-xxhash.c 2018-05-15 20:47:26.000000000 +0100
+++ duperemove-0.11b/csum-xxhash.c 2018-09-10 11:11:17.768921930 +0100
@@ -43,7 +43,7 @@
}
struct xxhash_running_checksum {
- XXH64_state_t td64;
+ XXH64_state_t *td64;
};
DECLARE_RUNNING_CSUM_CAST_FUNCS(xxhash_running_checksum);
@@ -51,7 +51,8 @@
{
struct xxhash_running_checksum *c =
calloc(1, sizeof(struct xxhash_running_checksum));
- XXH64_reset(&c->td64, 0);
+ c->td64 = XXH64_createState();
+ XXH64_reset(c->td64, 0);
return priv_to_rc(c);
}
@@ -59,7 +60,7 @@
unsigned int len, unsigned char *buf)
{
struct xxhash_running_checksum *c = rc_to_priv(_c);
- XXH64_update(&c->td64, buf, len);
+ XXH64_update(c->td64, buf, len);
}
static void xxhash_finish_running_checksum(struct running_checksum *_c,
@@ -68,7 +69,8 @@
struct xxhash_running_checksum *c = rc_to_priv(_c);
unsigned long long *hash = (unsigned long long*)digest;
- *hash = XXH64_digest(&c->td64);
+ *hash = XXH64_digest(c->td64);
+ XXH64_freeState(c->td64);
free(c);
}
diff -urb duperemove-0.11a/Makefile duperemove-0.11b/Makefile
--- duperemove-0.11a/Makefile 2018-05-15 20:47:26.000000000 +0100
+++ duperemove-0.11b/Makefile 2018-09-10 11:09:11.808519081 +0100
@@ -8,13 +8,13 @@
HEADERS=csum.h hash-tree.h results-tree.h kernel.h list.h rbtree.h dedupe.h \
btrfs-ioctl.h filerec.h btrfs-util.h debug.h util.h \
- memstats.h file_scan.h find_dupes.h run_dedupe.h xxhash.h \
+ memstats.h file_scan.h find_dupes.h run_dedupe.h \
bswap.h dbfile.h interval_tree.h interval_tree_generic.h \
rbtree_augmented.h list_sort.h stats.h
CFILES=duperemove.c hash-tree.c results-tree.c rbtree.c dedupe.c filerec.c \
btrfs-util.c util.c memstats.c file_scan.c find_dupes.c run_dedupe.c \
csum.c dbfile.c interval_tree.c list_sort.c stats.c debug.c
-hash_CFILES=csum-xxhash.c xxhash.c csum-murmur3.c
+hash_CFILES=csum-xxhash.c csum-murmur3.c
CFILES += $(hash_CFILES)
@@ -24,7 +24,7 @@
DIST_CFILES:=$(CFILES) $(hashstats_CFILES) $(btrfs_extent_same_CFILES) \
$(csum_test_CFILES)
-DIST_SOURCES:=$(DIST_CFILES) $(HEADERS) LICENSE LICENSE.xxhash Makefile \
+DIST_SOURCES:=$(DIST_CFILES) $(HEADERS) LICENSE Makefile \
rbtree.txt README.md $(MANPAGES) SubmittingPatches docs/duperemove.html
DIST=duperemove-$(VER)
DIST_TARBALL=$(RELEASE).tar.gz
@@ -45,6 +45,7 @@
glib_LIBS=$(shell pkg-config --libs glib-2.0)
sqlite_CFLAGS=$(shell pkg-config --cflags sqlite3)
sqlite_LIBS=$(shell pkg-config --libs sqlite3)
+hash_LIBS=-lxxhash
ifdef DEBUG
DEBUG_FLAGS = -ggdb3 -fsanitize=address -fno-omit-frame-pointer \

View File

@ -1,13 +1,12 @@
%define _legacy_common_support 1
Name: duperemove
Version: 0.11.1
Release: 6%{?dist}
Version: 0.11.3
Release: 1%{?dist}
Summary: Tools for deduping file systems
License: GPLv2
URL: https://github.com/markfasheh/%{name}
Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
Patch1: duperemove-use-system-xxhash.patch
BuildRequires: pkgconfig(glib-2.0)
BuildRequires: pkgconfig(sqlite3)
BuildRequires: libgcrypt-devel
@ -31,7 +30,6 @@ deduplication using the btrfs-extent-same ioctl.
%prep
%autosetup
rm -f xxhash.c xxhash.h
%build
%set_build_flags
@ -56,6 +54,10 @@ rm -f xxhash.c xxhash.h
%{_sbindir}/show-shared-extents
%changelog
* Wed Sep 8 2021 Jonathan Dieter <jdieter@gmail.com> - 0.11.3-1
- Update to 0.11.3 with bug fixes
- Remove patch to use system xxhash since upstream does that by default now
* Wed Jul 21 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.11.1-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild

View File

@ -1,2 +0,0 @@
[koji]
targets = epel8 epel8-playground

View File

@ -1 +1 @@
SHA512 (duperemove-0.11.1.tar.gz) = 3c344b00b8fb58a259840aea977ba2e5123b651bb58ec84177bdfd8337a377361984b85c6325271b7d3e4ea216017fa6fda793136c83e9837a13ec041df326b9
SHA512 (duperemove-0.11.3.tar.gz) = 0669cbb8a08082b9c2b62aff26759951e3e2c1b2236676ac6d79b9639027f775e4e5a218d1c7930b33ad7cca39726764cce5ac3063dc7d2049eb65fc4431af89