add upstream patch to fix 32 bit FTBFS
This commit is contained in:
parent
9e2d82e64e
commit
be7c0cb469
41
checks-Use-proper-format-modifier-for-size_t.patch
Normal file
41
checks-Use-proper-format-modifier-for-size_t.patch
Normal file
@ -0,0 +1,41 @@
|
|||||||
|
From 497432fd2131967f349e69dc5d259072151cc4b4 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Thierry Reding <treding@nvidia.com>
|
||||||
|
Date: Wed, 27 Sep 2017 15:04:09 +0200
|
||||||
|
Subject: [PATCH 1/3] checks: Use proper format modifier for size_t
|
||||||
|
|
||||||
|
The size of size_t can vary between architectures, so using %ld isn't
|
||||||
|
going to work on 32-bit builds. Use the %zu modifier to make sure it is
|
||||||
|
always correct.
|
||||||
|
|
||||||
|
Signed-off-by: Thierry Reding <treding@nvidia.com>
|
||||||
|
Acked-by: Rob Herring <robh@kernel.org>
|
||||||
|
Signed-off-by: David Gibson <david@gibson.dropbear.id.au>
|
||||||
|
---
|
||||||
|
checks.c | 4 ++--
|
||||||
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/checks.c b/checks.c
|
||||||
|
index 902f2e3..08a3a29 100644
|
||||||
|
--- a/checks.c
|
||||||
|
+++ b/checks.c
|
||||||
|
@@ -972,7 +972,7 @@ static void check_property_phandle_args(struct check *c,
|
||||||
|
int cell, cellsize = 0;
|
||||||
|
|
||||||
|
if (prop->val.len % sizeof(cell_t)) {
|
||||||
|
- FAIL(c, dti, "property '%s' size (%d) is invalid, expected multiple of %ld in node %s",
|
||||||
|
+ FAIL(c, dti, "property '%s' size (%d) is invalid, expected multiple of %zu in node %s",
|
||||||
|
prop->name, prop->val.len, sizeof(cell_t), node->fullpath);
|
||||||
|
return;
|
||||||
|
}
|
||||||
|
@@ -1163,7 +1163,7 @@ static void check_interrupts_property(struct check *c,
|
||||||
|
return;
|
||||||
|
|
||||||
|
if (irq_prop->val.len % sizeof(cell_t))
|
||||||
|
- FAIL(c, dti, "property '%s' size (%d) is invalid, expected multiple of %ld in node %s",
|
||||||
|
+ FAIL(c, dti, "property '%s' size (%d) is invalid, expected multiple of %zu in node %s",
|
||||||
|
irq_prop->name, irq_prop->val.len, sizeof(cell_t),
|
||||||
|
node->fullpath);
|
||||||
|
|
||||||
|
--
|
||||||
|
2.13.5
|
||||||
|
|
2
dtc.spec
2
dtc.spec
@ -7,6 +7,7 @@ URL: https://devicetree.org/
|
|||||||
|
|
||||||
Source: https://ftp.kernel.org/pub/software/utils/%{name}/%{name}-%{version}.tar.xz
|
Source: https://ftp.kernel.org/pub/software/utils/%{name}/%{name}-%{version}.tar.xz
|
||||||
Patch1: use-tx-as-the-type-specifier-instead-of-zx.patch
|
Patch1: use-tx-as-the-type-specifier-instead-of-zx.patch
|
||||||
|
Patch2: checks-Use-proper-format-modifier-for-size_t.patch
|
||||||
|
|
||||||
BuildRequires: flex bison swig
|
BuildRequires: flex bison swig
|
||||||
BuildRequires: python2-devel python2-setuptools
|
BuildRequires: python2-devel python2-setuptools
|
||||||
@ -44,6 +45,7 @@ This package provides python2 bindings for libfdt
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
make %{?_smp_mflags} V=1
|
make %{?_smp_mflags} V=1
|
||||||
|
Loading…
Reference in New Issue
Block a user