Update to new snapshot

This commit is contained in:
jwboyer 2007-07-04 02:42:54 +00:00
parent 1338fb3b8c
commit b0ece1598a
4 changed files with 11 additions and 40 deletions

View File

@ -1 +1 @@
dtc-20070628.tar.gz dtc-20070703.tar.gz

View File

@ -1,30 +0,0 @@
Add a minimal install target
Signed-off-by: Josh Boyer <jwboyer@linux.vnet.ibm.com>
---
Makefile | 9 +++++++++
1 file changed, 9 insertions(+)
--- dtc.orig/Makefile
+++ dtc/Makefile
@@ -4,6 +4,10 @@ LDFLAGS = -Llibfdt
BISON = bison
+INSTALL = /usr/bin/install
+DESTDIR =
+BINDIR = /usr/bin
+
#
# Overall rules
#
@@ -113,3 +117,8 @@ endif
#
TESTS_PREFIX=tests/
include tests/Makefile.tests
+
+install: dtc ftdump
+ $(INSTALL) -d $(DESTDIR)$(BINDIR)
+ $(INSTALL) -m 755 dtc $(DESTDIR)$(BINDIR)
+ $(INSTALL) -m 755 ftdump $(DESTDIR)$(BINDIR)

View File

@ -1,6 +1,6 @@
Name: dtc Name: dtc
Version: 0 Version: 0
Release: 0.2.20070628gitd9d679fb9%{?dist} Release: 0.3.20070703%{?dist}
Summary: Device Tree Compiler Summary: Device Tree Compiler
Group: Development/Tools Group: Development/Tools
@ -9,22 +9,19 @@ URL: http://dtc.ozlabs.org/
# The source for this package was pulled from upstream's vcs. Use the # The source for this package was pulled from upstream's vcs. Use the
# following commands to generate the tarball: # following commands to generate the tarball:
# git clone git://www.jdl.com/software/dtc.git; cd dtc; # git clone git://www.jdl.com/software/dtc.git; cd dtc;
# git checkout d9d679fb9; rm -rf .git; cd ..; mv dtc dtc-20070628; # git checkout 8cd4196ee; rm -rf .git; cd ..; mv dtc dtc-20070703;
# tar -czvf dtc-20070628.tar.gz dtc-20070628; # tar -czvf dtc-20070703.tar.gz dtc-20070703;
Source: dtc-20070628.tar.gz Source: dtc-20070703.tar.gz
Patch0: dtc-add-install.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: flex, bison BuildRequires: flex, bison
#Requires:
%description %description
The Device Tree Compiler generates flattened Open Firmware style device trees The Device Tree Compiler generates flattened Open Firmware style device trees
for use with PowerPC machines that lack an Open Firmware implementation for use with PowerPC machines that lack an Open Firmware implementation
%prep %prep
%setup -q -n dtc-20070628 %setup -q -n dtc-20070703
%patch0 -p1
%build %build
make %{?_smp_mflags} make %{?_smp_mflags}
@ -42,6 +39,10 @@ rm -rf $RPM_BUILD_ROOT
%{_bindir}/* %{_bindir}/*
%changelog %changelog
* Tue Jul 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org>
- Update to new snapshot
- Drop upstreamed install patch
* Fri Jun 29 2007 Josh Boyer <jwboyer@jdub.homelinux.org> * Fri Jun 29 2007 Josh Boyer <jwboyer@jdub.homelinux.org>
- Fix packaging errors - Fix packaging errors

View File

@ -1 +1 @@
b7e66374dee746786976f8e8a1a9875e dtc-20070628.tar.gz 53e848947b475302d1b6b2d1bcf8d194 dtc-20070703.tar.gz