Initial dtc commit

This commit is contained in:
jwboyer 2007-07-04 02:33:47 +00:00
parent e57bcf21ce
commit 1338fb3b8c
4 changed files with 81 additions and 0 deletions

View File

@ -0,0 +1 @@
dtc-20070628.tar.gz

30
dtc-add-install.patch Normal file
View File

@ -0,0 +1,30 @@
Add a minimal install target
Signed-off-by: Josh Boyer <jwboyer@linux.vnet.ibm.com>
---
Makefile | 9 +++++++++
1 file changed, 9 insertions(+)
--- dtc.orig/Makefile
+++ dtc/Makefile
@@ -4,6 +4,10 @@ LDFLAGS = -Llibfdt
BISON = bison
+INSTALL = /usr/bin/install
+DESTDIR =
+BINDIR = /usr/bin
+
#
# Overall rules
#
@@ -113,3 +117,8 @@ endif
#
TESTS_PREFIX=tests/
include tests/Makefile.tests
+
+install: dtc ftdump
+ $(INSTALL) -d $(DESTDIR)$(BINDIR)
+ $(INSTALL) -m 755 dtc $(DESTDIR)$(BINDIR)
+ $(INSTALL) -m 755 ftdump $(DESTDIR)$(BINDIR)

49
dtc.spec Normal file
View File

@ -0,0 +1,49 @@
Name: dtc
Version: 0
Release: 0.2.20070628gitd9d679fb9%{?dist}
Summary: Device Tree Compiler
Group: Development/Tools
License: GPL
URL: http://dtc.ozlabs.org/
# The source for this package was pulled from upstream's vcs. Use the
# following commands to generate the tarball:
# git clone git://www.jdl.com/software/dtc.git; cd dtc;
# git checkout d9d679fb9; rm -rf .git; cd ..; mv dtc dtc-20070628;
# tar -czvf dtc-20070628.tar.gz dtc-20070628;
Source: dtc-20070628.tar.gz
Patch0: dtc-add-install.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: flex, bison
#Requires:
%description
The Device Tree Compiler generates flattened Open Firmware style device trees
for use with PowerPC machines that lack an Open Firmware implementation
%prep
%setup -q -n dtc-20070628
%patch0 -p1
%build
make %{?_smp_mflags}
%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT
%clean
rm -rf $RPM_BUILD_ROOT
%files
%defattr(-,root,root,-)
%doc GPL
%{_bindir}/*
%changelog
* Fri Jun 29 2007 Josh Boyer <jwboyer@jdub.homelinux.org>
- Fix packaging errors
* Thu Jun 28 2007 Josh Boyer <jwboyer@jdub.homelinux.org>
- Initial packaging

View File

@ -0,0 +1 @@
b7e66374dee746786976f8e8a1a9875e dtc-20070628.tar.gz