Ensure libmissing.a exists before dsniff for parallelized builds

This commit is contained in:
Robert Scheck 2018-07-14 03:16:33 +02:00
parent 16e3285a65
commit 479de47f11
3 changed files with 20 additions and 3 deletions

View File

@ -16,7 +16,7 @@ support in glibc has been deprecated for a long time.
@@ -93,7 +93,7 @@
$(RANLIB) $@
dsniff: $(HDRS) $(SRCS) $(OBJS)
dsniff: $(HDRS) $(SRCS) $(OBJS) libmissing.a
- $(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBS) $(NIDSLIB) $(PCAPLIB) $(LNETLIB) $(DBLIB) $(SSLLIB)
+ $(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBS) $(NIDSLIB) $(PCAPLIB) $(LNETLIB) $(DBLIB) $(SSLLIB) -ltirpc

View File

@ -0,0 +1,15 @@
Patch by Robert Scheck <robert@fedoraproject.org> for dsniff >= 2.4b1 which
ensures when building using %{?_smp_mflags} that libmissing.a is built when
its being used for linking.
--- dsniff-2.4/Makefile.in 2018-07-14 02:54:20.405095355 +0200
+++ dsniff-2.4/Makefile.in.smp_mflags 2018-07-14 02:54:44.973245128 +0200
@@ -92,7 +92,7 @@
ar -cr $@ $(LIBOBJS)
$(RANLIB) $@
-dsniff: $(HDRS) $(SRCS) $(OBJS)
+dsniff: $(HDRS) $(SRCS) $(OBJS) libmissing.a
$(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBS) $(NIDSLIB) $(PCAPLIB) $(LNETLIB) $(DBLIB) $(SSLLIB)
arpspoof: arpspoof.o arp.o

View File

@ -38,7 +38,8 @@ Patch28: dsniff-2.4-pntohl_shift.patch
Patch29: dsniff-2.4-rpc_segfault.patch
Patch30: dsniff-2.4-openssl_110.patch
Patch31: dsniff-2.4-remote_typo.patch
Patch32: dsniff-2.4-libtirpc.patch
Patch32: dsniff-2.4-smp_mflags.patch
Patch33: dsniff-2.4-libtirpc.patch
BuildRequires: gcc
BuildRequires: libnet-devel
BuildRequires: openssl-devel
@ -100,8 +101,9 @@ by exploiting weak bindings in ad-hoc PKI.
%patch29 -p1 -b .rpc_segfault
%patch30 -p1 -b .openssl_110
%patch31 -p1 -b .remote_typo
%patch32 -p1 -b .smp_mflags
%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
%patch32 -p1 -b .libtirpc
%patch33 -p1 -b .libtirpc
%endif
%build