dracut/0151-Makefile-create-rpms-in-DESTDIR-for-target-rpm.patch
Harald Hoyer 53404a5fc7 dracut-044-176
- git snapshot
2016-12-08 17:57:25 +01:00

23 lines
935 B
Diff

From 5d274f93654f85b9c52aae02e733f901ff69b97f Mon Sep 17 00:00:00 2001
From: Harald Hoyer <harald@redhat.com>
Date: Mon, 7 Nov 2016 13:14:49 +0100
Subject: [PATCH] Makefile: create rpms in DESTDIR for target rpm
---
Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index d28e4cf..4cab7d5 100644
--- a/Makefile
+++ b/Makefile
@@ -211,7 +211,7 @@ rpm: dracut-$(VERSION).tar.xz syncheck
rpmbuild --define "_topdir $$PWD" --define "_sourcedir $$PWD" \
--define "_specdir $$PWD" --define "_srcrpmdir $$PWD" \
--define "_rpmdir $$PWD" -ba dracut.spec; ) && \
- ( mv "$$rpmbuild"/$$(arch)/*.rpm .; mv "$$rpmbuild"/*.src.rpm .;rm -fr -- "$$rpmbuild"; ls *.rpm )
+ ( mv "$$rpmbuild"/$$(arch)/*.rpm $(DESTDIR)/.; mv "$$rpmbuild"/*.src.rpm $(DESTDIR)/.;rm -fr -- "$$rpmbuild"; ls $(DESTDIR)/*.rpm )
syncheck:
@ret=0;for i in dracut-initramfs-restore.sh modules.d/*/*.sh; do \