dracut/0021-Makefile-do-not-install-systemd-service-in-reboot.patch
Harald Hoyer 953eb612d1 dracut-018-22.git20120418
- new upstream version
2012-04-18 13:18:08 +02:00

27 lines
1015 B
Diff

From 817ddcf053f8d068a6bf6089e25059f171cd8493 Mon Sep 17 00:00:00 2001
From: Harald Hoyer <harald@redhat.com>
Date: Wed, 18 Apr 2012 13:14:55 +0200
Subject: [PATCH] Makefile: do not install systemd service in reboot
shutdown is enough. It is pulled in on reboot.
---
Makefile | 3 ---
1 file changed, 3 deletions(-)
diff --git a/Makefile b/Makefile
index c62aae1..5ce1778 100644
--- a/Makefile
+++ b/Makefile
@@ -57,11 +57,8 @@ install: doc
if [ -n "$(systemdsystemunitdir)" ]; then \
mkdir -p $(DESTDIR)$(systemdsystemunitdir); \
install -m 0644 dracut-shutdown.service $(DESTDIR)$(systemdsystemunitdir); \
- mkdir -p $(DESTDIR)$(systemdsystemunitdir)/reboot.target.wants; \
mkdir -p $(DESTDIR)$(systemdsystemunitdir)/shutdown.target.wants; \
ln -s ../dracut-shutdown.service \
- $(DESTDIR)$(systemdsystemunitdir)/reboot.target.wants/dracut-shutdown.service; \
- ln -s ../dracut-shutdown.service \
$(DESTDIR)$(systemdsystemunitdir)/shutdown.target.wants/dracut-shutdown.service; \
fi