dracut - 046-8

- support for AMD CPU early microcode
This commit is contained in:
Harald Hoyer 2018-01-05 10:12:17 +01:00
parent ce66396e60
commit dc9c173dbb
8 changed files with 91 additions and 17 deletions

View File

@ -1,4 +1,4 @@
From 0344c2be134fbdf1019052eb314b76b7e3251d52 Mon Sep 17 00:00:00 2001
From 517bf10afb5daf4f64e9488603ce9d931fca5733 Mon Sep 17 00:00:00 2001
From: Harald Hoyer <harald@redhat.com>
Date: Fri, 11 Aug 2017 14:11:32 +0200
Subject: [PATCH] dracut.spec: add support for builds without dist-tag
@ -7,6 +7,8 @@ In the module-build-service, we have pieces of dracut provided by different
modules ("base-runtime" provides most functionality, but we need
dracut-network in "installer". Since these two modules build with separate
dist-tags, we need to reduce this strict requirement to ignore the dist-tag.
(cherry picked from commit 0344c2be134fbdf1019052eb314b76b7e3251d52)
---
dracut.spec | 17 ++++++++++++++++-
git2spec.pl | 4 ++--
@ -73,3 +75,4 @@ index 4b03a95c..0c5f3b9e 100755
}
elsif ((/^Source0:/) || (/^Source:/)) {
print $_;

View File

@ -1,19 +1,21 @@
From 791d80168994f4784569c8ea47b7bff554102f5e Mon Sep 17 00:00:00 2001
From c17ad59c49fcc953e65f18c4d7567f001ff8e904 Mon Sep 17 00:00:00 2001
From: Harald Hoyer <harald@redhat.com>
Date: Tue, 10 Oct 2017 10:30:44 +0200
Subject: [PATCH] dracut.sh: if /boot/vmlinuz-$version exists use /boot/ as
output dir
Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1475565
(cherry picked from commit 791d80168994f4784569c8ea47b7bff554102f5e)
---
dracut.sh | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/dracut.sh b/dracut.sh
index 5ad0f464..995d983e 100755
index 3a136d46..88a4de2b 100755
--- a/dracut.sh
+++ b/dracut.sh
@@ -773,7 +773,9 @@ if ! [[ $outfile ]]; then
@@ -761,7 +761,9 @@ if ! [[ $outfile ]]; then
mkdir -p "$efidir/Linux"
outfile="$efidir/Linux/linux-$kernel${MACHINE_ID:+-${MACHINE_ID}}${BUILD_ID:+-${BUILD_ID}}.efi"
else
@ -24,3 +26,4 @@ index 5ad0f464..995d983e 100755
outfile="/boot/${MACHINE_ID}/$kernel/initrd"
else
outfile="/boot/initramfs-$kernel.img"

View File

@ -1,4 +1,4 @@
From 28401778c4c95b3750e73675dd4a4867303402d5 Mon Sep 17 00:00:00 2001
From c63da4085b473152804f40e30327f802ed1171c5 Mon Sep 17 00:00:00 2001
From: Michal Sekletar <msekleta@redhat.com>
Date: Wed, 27 Sep 2017 13:27:42 +0200
Subject: [PATCH] systemd: fix setting of timeouts for device units
@ -13,6 +13,8 @@ i.e. disabling running state timeout disables generic timeout. But doing
it this way we would create implicit dependency on fairly new
systemd-234. However, by setting both options we don't create dependency
on specific systemd version.
(cherry picked from commit 28401778c4c95b3750e73675dd4a4867303402d5)
---
modules.d/90dmsquash-live/dmsquash-generator.sh | 1 +
modules.d/90livenet/livenet-generator.sh | 1 +

View File

@ -1,4 +1,4 @@
From 82651e9ef3c4c799281ba006f6ef46902e13086f Mon Sep 17 00:00:00 2001
From 4ebfa8e4de990ddc6803f999432c8dbc4b15506d Mon Sep 17 00:00:00 2001
From: Peter Robinson <pbrobinson@gmail.com>
Date: Thu, 12 Oct 2017 12:17:41 +0100
Subject: [PATCH] Add rpmsg, hwspinlock and usb/misc for ARM
@ -8,12 +8,13 @@ process to start, and these to the initrd, and pull in usb/misc because
apparently non standard usb hubs are a thing.
Signed-off-by: Peter Robinson <pbrobinson@gmail.com>
(cherry picked from commit 82651e9ef3c4c799281ba006f6ef46902e13086f)
---
modules.d/90kernel-modules/module-setup.sh | 3 +++
1 file changed, 3 insertions(+)
diff --git a/modules.d/90kernel-modules/module-setup.sh b/modules.d/90kernel-modules/module-setup.sh
index c6405e95..076f1e8a 100755
index 462b5417..40ab6c5f 100755
--- a/modules.d/90kernel-modules/module-setup.sh
+++ b/modules.d/90kernel-modules/module-setup.sh
@@ -32,17 +32,20 @@ installkernel() {
@ -37,6 +38,4 @@ index c6405e95..076f1e8a 100755
"=drivers/usb/musb" \
"=drivers/usb/phy" \
"=drivers/scsi/hisi_sas" \
--
2.14.2

View File

@ -1,4 +1,4 @@
From 38ff9dfbe5d134347638e61bd265065a0c97c0c5 Mon Sep 17 00:00:00 2001
From 6d2453754e26b7da04623c689c187dba38a2759a Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
Date: Thu, 2 Nov 2017 17:04:49 +0100
Subject: [PATCH] dmsquash-generator.sh: properly escape backslash in path
@ -6,6 +6,7 @@ Subject: [PATCH] dmsquash-generator.sh: properly escape backslash in path
We need an actual bashslash in the filename on disk.
https://bugzilla.redhat.com/show_bug.cgi?id=1508794
(cherry picked from commit 38ff9dfbe5d134347638e61bd265065a0c97c0c5)
---
modules.d/90dmsquash-live/dmsquash-generator.sh | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
@ -23,3 +24,4 @@ index d47cf14a..fe190012 100755
fi
} > "$GENERATOR_DIR"/sysroot.mount

29
0006.patch Normal file
View File

@ -0,0 +1,29 @@
From 910c9fd4c2cedc4cbfc9beabeb9324781144d745 Mon Sep 17 00:00:00 2001
From: Daniel Molkentin <dmolkentin@suse.com>
Date: Tue, 12 Dec 2017 17:48:36 +0100
Subject: [PATCH] Support Microcode Updates for AMD CPU Family 0x17
Original-Patch-By: Tom Lendacky <thomas.lendacky@amd.com>
(cherry picked from commit 215fe583240ae886c2096d502a96e44798b84163)
---
dracut-functions.sh | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/dracut-functions.sh b/dracut-functions.sh
index 112b2434..377d9202 100755
--- a/dracut-functions.sh
+++ b/dracut-functions.sh
@@ -661,8 +661,10 @@ get_ucode_file ()
local stepping=`grep -E "stepping" /proc/cpuinfo | head -1 | sed s/.*:\ //`
if [[ "$(get_cpu_vendor)" == "AMD" ]]; then
- # If family greater than or equal to 0x16
- if [[ $family -ge 22 ]]; then
+ # If family greater than or equal to 0x17
+ if [[ $family -ge 23 ]]; then
+ printf "microcode_amd_fam17h.bin"
+ elif [[ $family -eq 22 ]]; then
printf "microcode_amd_fam16h.bin"
elif [[ $family -eq 21 ]]; then
printf "microcode_amd_fam15h.bin"

32
0007.patch Normal file
View File

@ -0,0 +1,32 @@
From e465b5b36eed332f51a3c7217f076558fa7a3193 Mon Sep 17 00:00:00 2001
From: Daniel Molkentin <dmolkentin@suse.com>
Date: Thu, 14 Dec 2017 12:24:53 +0100
Subject: [PATCH] Simplify microcode lookup for for AMD CPUs
Suggested by Tom Lendacky <thomas.lendacky@amd.com>
(cherry picked from commit 19453dc8744e6a59725c43b61b2e3db01cb4c57c)
---
dracut-functions.sh | 9 ++-------
1 file changed, 2 insertions(+), 7 deletions(-)
diff --git a/dracut-functions.sh b/dracut-functions.sh
index 377d9202..d7fc5303 100755
--- a/dracut-functions.sh
+++ b/dracut-functions.sh
@@ -661,13 +661,8 @@ get_ucode_file ()
local stepping=`grep -E "stepping" /proc/cpuinfo | head -1 | sed s/.*:\ //`
if [[ "$(get_cpu_vendor)" == "AMD" ]]; then
- # If family greater than or equal to 0x17
- if [[ $family -ge 23 ]]; then
- printf "microcode_amd_fam17h.bin"
- elif [[ $family -eq 22 ]]; then
- printf "microcode_amd_fam16h.bin"
- elif [[ $family -eq 21 ]]; then
- printf "microcode_amd_fam15h.bin"
+ if [[ $family -ge 21 ]]; then
+ printf "microcode_amd_fam%xh.bin" $family
else
printf "microcode_amd.bin"
fi

View File

@ -14,7 +14,7 @@
%define with_nbd 0
%endif
%define dist_free_release 5
%define dist_free_release 8.git20180105
Name: dracut
Version: 046
@ -37,13 +37,14 @@ URL: https://dracut.wiki.kernel.org/
# Source can be generated by
# http://git.kernel.org/?p=boot/dracut/dracut.git;a=snapshot;h=%%{version};sf=tgz
Source0: http://www.kernel.org/pub/linux/utils/boot/dracut/dracut-%{version}.tar.xz
# Patches from https://github.com/haraldh/dracut/tree/Fedora27
Patch1: 0001.patch
Patch2: grubby.patch
Patch3: timeout.patch
Patch4: arm-sbc-fixes.patch
# https://github.com/dracutdevs/dracut/pull/302
Patch5: 302.patch
Patch2: 0002.patch
Patch3: 0003.patch
Patch4: 0004.patch
Patch5: 0005.patch
Patch6: 0006.patch
Patch7: 0007.patch
Source1: https://www.gnu.org/licenses/lgpl-2.1.txt
@ -523,6 +524,9 @@ rm -rf -- $RPM_BUILD_ROOT
%endif
%changelog
* Fri Jan 05 2018 Harald Hoyer <harald@redhat.com> - 046-8
- support for AMD CPU early microcode
* Thu Nov 02 2017 Adam Williamson <awilliam@redhat.com> - 046-5
- Backport upstream fix for RHBZ #1508794 (media check timeout)