dracut-026-54.git20130316

- fix for squashfs
Resolves: rhbz#922248
- documentation fixes
- sosreport, mkdir /run/initramfs
This commit is contained in:
Harald Hoyer 2013-03-16 10:36:46 +01:00
parent 61c4978036
commit 8d2be9b2e4
7 changed files with 154 additions and 1 deletions

View File

@ -0,0 +1,22 @@
From 7e9bfdde14e64b959f5ae24aa8e6d91e56d09ec6 Mon Sep 17 00:00:00 2001
From: Harald Hoyer <harald@redhat.com>
Date: Fri, 15 Mar 2013 10:41:41 +0100
Subject: [PATCH] sosreport.sh: use -o short-monotonic for the journal output
---
modules.d/99base/sosreport.sh | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/modules.d/99base/sosreport.sh b/modules.d/99base/sosreport.sh
index 2aded6b..0b4ccdc 100755
--- a/modules.d/99base/sosreport.sh
+++ b/modules.d/99base/sosreport.sh
@@ -41,7 +41,7 @@ command -v dmsetup >/dev/null 2>/dev/null && dmsetup ls --tree
cat /proc/mdstat
if command -v journalctl >/dev/null 2>/dev/null; then
- journalctl -ab --no-pager
+ journalctl -ab --no-pager -o short-monotonic
else
dmesg
[ -f /run/initramfs/init.log ] && cat /run/initramfs/init.log

View File

@ -0,0 +1,24 @@
From fb05f9876ac18b64c8b9e07f9eb2e451e818b46e Mon Sep 17 00:00:00 2001
From: Harald Hoyer <harald@redhat.com>
Date: Fri, 15 Mar 2013 10:42:18 +0100
Subject: [PATCH] dracut-bash-completion.sh: add --kver kernel version
completion
---
dracut-bash-completion.sh | 3 +++
1 file changed, 3 insertions(+)
diff --git a/dracut-bash-completion.sh b/dracut-bash-completion.sh
index 38e2ebd..322e630 100644
--- a/dracut-bash-completion.sh
+++ b/dracut-bash-completion.sh
@@ -51,6 +51,9 @@ _dracut() {
-a|-m|-o|--add|--modules|--omit)
comps=$(dracut --list-modules 2>/dev/null)
;;
+ --kver)
+ comps=$(cd /lib/modules; echo *)
+ ;;
*)
return 0
;;

View File

@ -0,0 +1,22 @@
From 11fbde445440c4de1b99eb03b930c9191b3181b9 Mon Sep 17 00:00:00 2001
From: Harald Hoyer <harald@redhat.com>
Date: Fri, 15 Mar 2013 14:41:11 +0100
Subject: [PATCH] TEST-16-DMSQUASH: use current releasever
---
test/TEST-16-DMSQUASH/livecd-fedora-minimal.ks | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/test/TEST-16-DMSQUASH/livecd-fedora-minimal.ks b/test/TEST-16-DMSQUASH/livecd-fedora-minimal.ks
index 88637ae..6310f78 100644
--- a/test/TEST-16-DMSQUASH/livecd-fedora-minimal.ks
+++ b/test/TEST-16-DMSQUASH/livecd-fedora-minimal.ks
@@ -6,7 +6,7 @@ selinux --enforcing
firewall --disabled
part / --size 1024
-repo --name=fedora --mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-16&arch=$basearch
+repo --name=fedora --mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-$version&arch=$basearch
%packages
@core

View File

@ -0,0 +1,24 @@
From ee2321c91e52c4de2a3a9e41c0469cf76447db41 Mon Sep 17 00:00:00 2001
From: Harald Hoyer <harald@redhat.com>
Date: Fri, 15 Mar 2013 16:54:38 +0100
Subject: [PATCH] dracut.conf.5.asc: remove duplicated install_items
---
dracut.conf.5.asc | 4 ----
1 file changed, 4 deletions(-)
diff --git a/dracut.conf.5.asc b/dracut.conf.5.asc
index dbaa2e5..df876cc 100644
--- a/dracut.conf.5.asc
+++ b/dracut.conf.5.asc
@@ -51,10 +51,6 @@ Configuration files must have the extension .conf; other extensions are ignored.
Specify a space-separated list of kernel modules not to add to the
initramfs. The kernel modules have to be specified without the ".ko" suffix.
-*install_items+=*" __<kernel modules>__ "::
- Specify a space-separated list of files, which are added to the initramfs
- image.
-
*filesystems+=*" __<filesystem names>__ "::
Specify a space-separated list of kernel filesystem modules to exclusively
include in the generic initramfs.

View File

@ -0,0 +1,27 @@
From 85804a9197790d461dfa1458883f84a9da9ae589 Mon Sep 17 00:00:00 2001
From: Harald Hoyer <harald@redhat.com>
Date: Sat, 16 Mar 2013 10:31:37 +0100
Subject: [PATCH] dmsquash-live: force load squashfs kernel module
https://bugzilla.redhat.com/show_bug.cgi?id=922248
---
modules.d/90dmsquash-live/dmsquash-live-root.sh | 3 +++
1 file changed, 3 insertions(+)
diff --git a/modules.d/90dmsquash-live/dmsquash-live-root.sh b/modules.d/90dmsquash-live/dmsquash-live-root.sh
index 0b1ed20..a79b0d9 100755
--- a/modules.d/90dmsquash-live/dmsquash-live-root.sh
+++ b/modules.d/90dmsquash-live/dmsquash-live-root.sh
@@ -49,9 +49,12 @@ ln -s $livedev /run/initramfs/livedev
# determine filesystem type for a filesystem image
det_img_fs() {
+ udevadm settle
blkid -s TYPE -u noraid -o value "$1"
}
+modprobe squashfs
+
for arg in $CMDLINE; do case $arg in ro|rw) liverw=$arg ;; esac; done
# mount the backing of the live image first
mkdir -m 0755 -p /run/initramfs/live

View File

@ -0,0 +1,22 @@
From e42c7a980ca3852781ee2ddd2b1633e482cf58d0 Mon Sep 17 00:00:00 2001
From: Harald Hoyer <harald@redhat.com>
Date: Sat, 16 Mar 2013 10:34:20 +0100
Subject: [PATCH] sosreport: mkdir /run/initramfs, if it does not exist yet
---
modules.d/99base/sosreport.sh | 2 ++
1 file changed, 2 insertions(+)
diff --git a/modules.d/99base/sosreport.sh b/modules.d/99base/sosreport.sh
index 0b4ccdc..eb1ba80 100755
--- a/modules.d/99base/sosreport.sh
+++ b/modules.d/99base/sosreport.sh
@@ -2,6 +2,8 @@
echo 'Generating "/run/initramfs/sosreport.txt"'
+[ -d /run/initramfs ] || mkdir -p /run/initramfs
+
exec >/run/initramfs/sosreport.txt 2>&1
set -x

View File

@ -10,7 +10,7 @@
Name: dracut
Version: 026
Release: 48.git20130315%{?dist}
Release: 54.git20130316%{?dist}
Summary: Initramfs generator using udev
%if 0%{?fedora} || 0%{?rhel}
@ -76,6 +76,12 @@ Patch44: 0044-systemd-do-not-use-systemd-version-until-fixed.patch
Patch45: 0045-fix-typo-in-dracut.conf.5.asc.patch
Patch46: 0046-fixed-testsuite.patch
Patch47: 0047-dracut.spec-bump-systemd-version-requirement.patch
Patch48: 0048-sosreport.sh-use-o-short-monotonic-for-the-journal-o.patch
Patch49: 0049-dracut-bash-completion.sh-add-kver-kernel-version-co.patch
Patch50: 0050-TEST-16-DMSQUASH-use-current-releasever.patch
Patch51: 0051-dracut.conf.5.asc-remove-duplicated-install_items.patch
Patch52: 0052-dmsquash-live-force-load-squashfs-kernel-module.patch
Patch53: 0053-sosreport-mkdir-run-initramfs-if-it-does-not-exist-y.patch
BuildRequires: dash bash git
@ -465,6 +471,12 @@ rm -rf $RPM_BUILD_ROOT
%{dracutlibdir}/dracut.conf.d/02-norescue.conf
%changelog
* Sat Mar 16 2013 Harald Hoyer <harald@redhat.com> 026-54.git20130316
- fix for squashfs
Resolves: rhbz#922248
- documentation fixes
- sosreport, mkdir /run/initramfs
* Fri Mar 15 2013 Harald Hoyer <harald@redhat.com> 026-48.git20130315
- use new initrd.target from systemd
- fixed rescue generation