update to latest git

This commit is contained in:
Harald Hoyer 2011-10-20 13:18:57 +02:00
parent 55891eb212
commit 8a80334789
9 changed files with 438 additions and 86 deletions

View File

@ -0,0 +1,29 @@
From 6f000443170614db0972fe6fb848560d9285bc8b Mon Sep 17 00:00:00 2001
From: Harald Hoyer <harald@redhat.com>
Date: Thu, 20 Oct 2011 12:13:25 +0200
Subject: [PATCH] 95udev-rules/module-setup.sh: correctly create udevd symlink
---
modules.d/95udev-rules/module-setup.sh | 9 +++++++--
1 files changed, 7 insertions(+), 2 deletions(-)
diff --git a/modules.d/95udev-rules/module-setup.sh b/modules.d/95udev-rules/module-setup.sh
index 915c1fc..5f8bae8 100755
--- a/modules.d/95udev-rules/module-setup.sh
+++ b/modules.d/95udev-rules/module-setup.sh
@@ -63,8 +63,13 @@ install() {
[ -e /usr/lib/udev/$_i ] && dracut_install /usr/lib/udev/$_i
done
- [ -x /lib/udev/udevd ] && ln -s ../lib/udev/udevd "$initdir/sbin/udevd"
- [ -x /usr/lib/udev/udevd ] && ln -s ../usr/lib/udev/udevd "$initdir/sbin/udevd"
+ if ! [ -e "$initdir/sbin/udevd" ]; then
+ if [ -x /usr/lib/udev/udevd ]; then
+ ln -s /usr/lib/udev/udevd "$initdir/sbin/udevd"
+ elif [ -x /lib/udev/udevd ]; then
+ ln -s /lib/udev/udevd "$initdir/sbin/udevd"
+ fi
+ fi
[ -f /etc/arch-release ] && \
inst "$moddir/load-modules.sh" /lib/udev/load-modules.sh

View File

@ -0,0 +1,60 @@
From e2d92b5adf710bacaea14e3fbca936997c6b9469 Mon Sep 17 00:00:00 2001
From: Harald Hoyer <harald@redhat.com>
Date: Thu, 20 Oct 2011 12:13:50 +0200
Subject: [PATCH] */module-setup.sh: turn off debugging for module search
turn off debugging for module search, because it clutters the debug log
---
modules.d/40network/module-setup.sh | 2 ++
modules.d/90kernel-modules/module-setup.sh | 2 ++
modules.d/90multipath/module-setup.sh | 2 ++
3 files changed, 6 insertions(+), 0 deletions(-)
diff --git a/modules.d/40network/module-setup.sh b/modules.d/40network/module-setup.sh
index eb7ef9b..fbf6f34 100755
--- a/modules.d/40network/module-setup.sh
+++ b/modules.d/40network/module-setup.sh
@@ -52,7 +52,9 @@ installkernel() {
done | nmf1 1>&${_merge}
}
# Use two parallel streams to filter alternating modules.
+ set +x
eval "( ( rotor ) ${_side2}>&1 | nmf1 ) ${_merge}>&1"
+ [[ $debug ]] && set -x
}
find_kernel_modules_by_path drivers/net | net_module_filter | instmods
diff --git a/modules.d/90kernel-modules/module-setup.sh b/modules.d/90kernel-modules/module-setup.sh
index 6e3a918..db4b276 100755
--- a/modules.d/90kernel-modules/module-setup.sh
+++ b/modules.d/90kernel-modules/module-setup.sh
@@ -31,7 +31,9 @@ installkernel() {
done | bmf1 1>&${_merge}
}
# Use two parallel streams to filter alternating modules.
+ set +x
eval "( ( rotor ) ${_side2}>&1 | bmf1 ) ${_merge}>&1"
+ [[ $debug ]] && set -x
}
hostonly='' instmods sr_mod sd_mod scsi_dh scsi_dh_rdac scsi_dh_emc
hostonly='' instmods pcmcia firewire-ohci
diff --git a/modules.d/90multipath/module-setup.sh b/modules.d/90multipath/module-setup.sh
index f68b58d..43f0a3d 100755
--- a/modules.d/90multipath/module-setup.sh
+++ b/modules.d/90multipath/module-setup.sh
@@ -33,6 +33,7 @@ depends() {
}
installkernel() {
+ set +x
mp_mod_filter() {
local _mpfuncs='scsi_register_device_handler|dm_dirty_log_type_register|dm_register_path_selector|dm_register_target'
local _f
@@ -45,6 +46,7 @@ installkernel() {
( find_kernel_modules_by_path drivers/scsi;
find_kernel_modules_by_path drivers/md ) | mp_mod_filter | instmods
+ [[ $debug ]] && set -x
}
install() {

View File

@ -0,0 +1,22 @@
From 15a5dc5b89facd084eaa400630510ca551b52afd Mon Sep 17 00:00:00 2001
From: Harald Hoyer <harald@redhat.com>
Date: Thu, 20 Oct 2011 11:13:34 +0200
Subject: [PATCH] 99base/init: fix check for in kernel polling
---
modules.d/99base/init | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/modules.d/99base/init b/modules.d/99base/init
index 556ac68..36b2152 100755
--- a/modules.d/99base/init
+++ b/modules.d/99base/init
@@ -243,7 +243,7 @@ while :; do
# no more udev jobs and queues empty.
sleep 0.5
- if [ ! -e /sys/module/block/parameters/uevent ]; then
+ if [ ! -e /sys/module/block/parameters/events_dfl_poll_msecs ]; then
# if the kernel does not support autopolling
# then we have to do a
# dirty hack for some cdrom drives,

View File

@ -0,0 +1,59 @@
From c2801d093829e3b87ec4c6d7054b43bad4bd59ad Mon Sep 17 00:00:00 2001
From: Harald Hoyer <harald@redhat.com>
Date: Thu, 20 Oct 2011 11:14:10 +0200
Subject: [PATCH] 99base/dracut-lib.sh: add /etc/cmdline/*.conf parsing
modules and overlay images can set default kernel command line
parameters in /etc/cmdline/*.conf in the initramfs.
---
dracut.kernel.7.xml | 8 ++++++++
modules.d/99base/dracut-lib.sh | 9 ++++++++-
2 files changed, 16 insertions(+), 1 deletions(-)
diff --git a/dracut.kernel.7.xml b/dracut.kernel.7.xml
index 8d50d94..2ba0570 100644
--- a/dracut.kernel.7.xml
+++ b/dracut.kernel.7.xml
@@ -1268,6 +1268,14 @@ set in the configuration files.</para>
<para>Can contain additional command line options.</para>
</listitem>
</varlistentry>
+ <varlistentry>
+ <term>
+ <filename>/etc/cmdline.d/*.conf</filename>
+ </term>
+ <listitem>
+ <para>Can contain additional command line options.</para>
+ </listitem>
+ </varlistentry>
</variablelist>
</refsect1>
<refsect1>
diff --git a/modules.d/99base/dracut-lib.sh b/modules.d/99base/dracut-lib.sh
index 2cfaf93..8d294ee 100755
--- a/modules.d/99base/dracut-lib.sh
+++ b/modules.d/99base/dracut-lib.sh
@@ -32,6 +32,7 @@ str_replace() {
_getcmdline() {
local _line
+ local _i
unset _line
if [ -z "$CMDLINE" ]; then
if [ -e /etc/cmdline ]; then
@@ -39,8 +40,14 @@ _getcmdline() {
CMDLINE_ETC="$CMDLINE_ETC $_line";
done </etc/cmdline;
fi
+ for _i in /etc/cmdline.d/*.conf; do
+ [ -e "$_i" ] || continue
+ while read -r _line; do
+ CMDLINE_ETC_D="$CMDLINE_ETC_D $_line";
+ done <"$_i";
+ done
read -r CMDLINE </proc/cmdline;
- CMDLINE="$CMDLINE $CMDLINE_ETC"
+ CMDLINE="$CMDLINE_ETC_D $CMDLINE_ETC $CMDLINE"
fi
}

38
0089-minor-changes.patch Normal file
View File

@ -0,0 +1,38 @@
From 5259da1043323e5bc74a8f1c3db18d112c312b03 Mon Sep 17 00:00:00 2001
From: Michal Soltys <soltys@ziu.info>
Date: Tue, 18 Oct 2011 20:33:19 +0200
Subject: [PATCH] minor changes
- in 10i18n - do stty -iutf8 on non-utf8 consoles, for consistency with
iutf8 on utf8 ones
- vim modeline in xml file
Signed-off-by: Michal Soltys <soltys@ziu.info>
---
dracut.kernel.7.xml | 1 +
modules.d/10i18n/console_init | 1 +
2 files changed, 2 insertions(+), 0 deletions(-)
diff --git a/dracut.kernel.7.xml b/dracut.kernel.7.xml
index 2ba0570..7cd7b81 100644
--- a/dracut.kernel.7.xml
+++ b/dracut.kernel.7.xml
@@ -1,5 +1,6 @@
<?xml version='1.0' encoding='UTF-8'?>
<!-- This document was created with Syntext Serna Free. --><!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN" "http://www.oasis-open.org/docbook/xml/4.3/docbookx.dtd" []>
+<!-- vim: set ts=8 sts=2 sw=2 et: -->
<refentry id="dracutkernel7">
<refentryinfo>
<title>dracut.kernel</title>
diff --git a/modules.d/10i18n/console_init b/modules.d/10i18n/console_init
index 110cb0a..b46046b 100755
--- a/modules.d/10i18n/console_init
+++ b/modules.d/10i18n/console_init
@@ -22,6 +22,7 @@ set_terminal() {
stty -F ${dev} iutf8
else
printf '\033%%@' >&7
+ stty -F ${dev} -iutf8
fi
}

View File

@ -0,0 +1,21 @@
From d73bbd57ee901b8470d9e42f5e004e240e00af62 Mon Sep 17 00:00:00 2001
From: Harald Hoyer <harald@redhat.com>
Date: Thu, 20 Oct 2011 12:33:33 +0200
Subject: [PATCH] 90livenet: check() for wget
---
modules.d/90livenet/module-setup.sh | 1 +
1 files changed, 1 insertions(+), 0 deletions(-)
diff --git a/modules.d/90livenet/module-setup.sh b/modules.d/90livenet/module-setup.sh
index b166859..3ee7521 100755
--- a/modules.d/90livenet/module-setup.sh
+++ b/modules.d/90livenet/module-setup.sh
@@ -4,6 +4,7 @@
check() {
# a live, host-only image doesn't really make a lot of sense
[[ $hostonly ]] && return 1
+ command -v wget || return 1
return 0
}

View File

@ -0,0 +1,75 @@
From 44cef0d5637f5f6982612d22c92f6d299ec316f9 Mon Sep 17 00:00:00 2001
From: Harald Hoyer <harald@redhat.com>
Date: Thu, 20 Oct 2011 13:04:10 +0200
Subject: [PATCH] dracut-logger: re-set debugging
---
dracut-logger | 8 +++++++-
1 files changed, 7 insertions(+), 1 deletions(-)
diff --git a/dracut-logger b/dracut-logger
index ce28208..f1b3a7e 100755
--- a/dracut-logger
+++ b/dracut-logger
@@ -313,7 +313,6 @@ dlog() {
_do_dlog "$1" "$line"
done
fi
- [ -n "$debug" ] && set -x || :
}
## @brief Logs message at TRACE level (6)
@@ -323,6 +322,7 @@ dlog() {
dtrace() {
set +x
dlog 6 "$@"
+ [ -n "$debug" ] && set -x || :
}
## @brief Logs message at DEBUG level (5)
@@ -332,6 +332,7 @@ dtrace() {
ddebug() {
set +x
dlog 5 "$@"
+ [ -n "$debug" ] && set -x || :
}
## @brief Logs message at INFO level (4)
@@ -341,6 +342,7 @@ ddebug() {
dinfo() {
set +x
dlog 4 "$@"
+ [ -n "$debug" ] && set -x || :
}
## @brief Logs message at WARN level (3)
@@ -350,6 +352,7 @@ dinfo() {
dwarn() {
set +x
dlog 3 "$@"
+ [ -n "$debug" ] && set -x || :
}
## @brief It's an alias to dwarn() function.
@@ -359,6 +362,7 @@ dwarn() {
dwarning() {
set +x
dwarn "$@"
+ [ -n "$debug" ] && set -x || :
}
## @brief Logs message at ERROR level (2)
@@ -368,6 +372,7 @@ dwarning() {
derror() {
set +x
dlog 2 "$@"
+ [ -n "$debug" ] && set -x || :
}
## @brief Logs message at FATAL level (1)
@@ -377,4 +382,5 @@ derror() {
dfatal() {
set +x
dlog 1 "$@"
+ [ -n "$debug" ] && set -x || :
}

View File

@ -0,0 +1,30 @@
From b01885338bb0b3daa087f71cfbf895e999e90b9f Mon Sep 17 00:00:00 2001
From: Harald Hoyer <harald@redhat.com>
Date: Thu, 20 Oct 2011 13:04:30 +0200
Subject: [PATCH] dracut-functions: inst_dir() handle relative symlinks
---
dracut-functions | 8 ++++----
1 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/dracut-functions b/dracut-functions
index 1ef5269..70a467b 100755
--- a/dracut-functions
+++ b/dracut-functions
@@ -290,12 +290,12 @@ inst_dir() {
inst_dir "$target"
inst_symlink "$_file"
else
- [[ -h ${initdir}$_file ]] && _file=$(readlink "${initdir}$_file")
+ [[ -h ${initdir}/$_file ]] && _file=$(readlink "${initdir}/$_file")
# create directory
- mkdir -m 0755 -p "${initdir}$_file" || return 1
+ [[ -e "${initdir}/$_file" ]] || mkdir -m 0755 -p "${initdir}/$_file" || return 1
if [[ -d "$_file" ]]; then
- chmod --reference="$_file" "${initdir}$_file"
- chmod u+w "${initdir}$_file"
+ chmod --reference="$_file" "${initdir}/$_file"
+ chmod u+w "${initdir}/$_file"
fi
fi
done

View File

@ -8,7 +8,7 @@
Name: dracut
Version: 013
Release: 85.git20111019%{?dist}
Release: 93.git20111020%{?dist}
Summary: Initramfs generator using udev
%if 0%{?fedora} || 0%{?rhel} > 6
@ -22,90 +22,98 @@ URL: https://dracut.wiki.kernel.org/
# Source can be generated by
# http://git.kernel.org/?p=boot/dracut/dracut.git;a=snapshot;h=%{version};sf=tgz
Source0: http://www.kernel.org/pub/linux/utils/boot/dracut/dracut-%{version}.tar.bz2
Patch1: 0002-90dmsquash-live-dmsquash-live-root-include-fs_lib.sh.patch
Patch2: 0003-fix-live-crash-with-livenet-installed.patch
Patch3: 0004-profile.py-parse-the-output-of-dracut-profile-for-pr.patch
Patch4: 0005-add-TEST-16-DMSQUASH.patch
Patch5: 0006-dracut-functions-s-emergency-shutdown-shutdown-emerg.patch
Patch6: 0007-dracut-unset-LD_LIBRARY_PATH.patch
Patch7: 0008-build-initramfs-prelink-undo-sbin.patch
Patch8: 0009-dracut-functions-speed-up-inst_dir.patch
Patch9: 0010-90crypt-ask_for_password-pings-plymouthd.patch
Patch10: 0011-99base-whitespace-fix.patch
Patch11: 0012-dracut-functions-new-function-inst_any-d-dest-f1-f2-.patch
Patch12: 0013-livenet-take-into-account-other-ca-bundle-paths-use-.patch
Patch13: 0014-luks-key-on-ext-dev-wait-for-luks.patch
Patch14: 0015-crypt-changed-cmdline-arg-name-from-rd.luks.tout-to-.patch
Patch15: 0016-luks-key-on-ext-dev-wait-for-luks.patch
Patch16: 0017-dracut-functions-fix-inst_dir-for-non-absolute-dirs.patch
Patch17: 0018-90mdraid-65-md-incremental-imsm.rules-incremental-ru.patch
Patch18: 0019-dracut.spec-fixed-rhel-fedora-version-checks.patch
Patch19: 0020-50plymouth-add-plymouth.enable-kernel-command-line-o.patch
Patch20: 0021-99base-init-only-poll-cdroms-if-the-kernel-does-supp.patch
Patch21: 0022-build-initramfs-unclear-_mpargs-in-instmods.patch
Patch22: 0023-90crypt-parse-crypt.sh-also-accept-the-beginning-of-.patch
Patch23: 0024-99base-init-save-and-restore-environment-given-from-.patch
Patch24: 0025-99base-init-move-switch_root-breakpoint-to-a-later-p.patch
Patch25: 0026-dracut-functions-hmac-checksum-files-can-be-symlinks.patch
Patch26: 0027-95udev-rules-add-input_id.patch
Patch27: 0028-inst_simple-inst_dir-make-fast-case-faster.patch
Patch28: 0029-filter_kernel_modules-is-a-specialized-filter_kernel.patch
Patch29: 0030-install_kmod_with_fw-make-fast-case-faster.patch
Patch30: 0031-instmods-get-filenames-from-stdin-if-no-args-use-it.patch
Patch31: 0032-instmods-sanity-for-_mpargs.patch
Patch32: 0033-instmods-factor-out-egrep-of-FATAL-Module-.-not-foun.patch
Patch33: 0034-99base-init-do-not-fail-when-importing-the-original-.patch
Patch34: 0035-dracut-cp-with-sparse.patch
Patch35: 0036-99base-init-removed-cdrom-polling-reset-code.patch
Patch36: 0037-dmsquash-live-root-use-blkid-to-determine-fstype-of-.patch
Patch37: 0038-dmsquash-live-root-load-filesystem-modules-before-mo.patch
Patch38: 0039-90dmsquash-live-do-not-symlink-to-dev-live.patch
Patch39: 0040-99base-init-remove-dev-root-helper-symlink.patch
Patch40: 0041-Do-not-use-run-udev-rules.d-for-udev-rules.patch
Patch41: 0042-99base-init-mount-securityfs-with-source-securityfs-.patch
Patch42: 0043-mount-securityfs-in-a-seperate-dracut-module.patch
Patch43: 0044-mount-securityfs-in-a-seperate-dracut-module.patch
Patch44: 0045-90mdraid-adjust-stock-mdadm-udev-rules.patch
Patch45: 0046-90mdraid-containers-are-not-runnable.patch
Patch46: 0047-90mdraid-fix-adjust-mdraid-cleanup.patch
Patch47: 0048-90mdraid-fix-adjust-force-run-script.patch
Patch48: 0049-90-md-dm-raid-recognize-ddf-container.patch
Patch49: 0050-90mdraid-fix-adjust-65-md-rules-and-related-scripts.patch
Patch50: 0051-TEST-40-NBD-relaxed-check-on-ext3-filesystem-options.patch
Patch51: 0052-99fs-lib-fs-lib.sh-fsck-btrfs-via-mounting-like-xfs.patch
Patch52: 0053-dracut-functions-inst_rules-do-not-check-std-dirs-fo.patch
Patch53: 0054-str_replace-fix.patch
Patch54: 0055-dracut-logger-bail-out-early-if-we-don-t-have-to-log.patch
Patch55: 0056-dracut-create-dev-besides-proc-sys-and-so.patch
Patch56: 0057-99fs-lib-export-FSTAB_FILE-before-fsck-call.patch
Patch57: 0058-dracut-functions-inst_rules-add-missing.patch
Patch58: 0059-90mdraid-check-precisely-for-supported-contaiers.patch
Patch59: 0060-90mdraid-more-thorough-64-md-raid.rules-edit.patch
Patch60: 0061-90mdraid-adjust-dev-md-loops.patch
Patch61: 0062-dracut-PATCH-Parameter-expansion-occurs-before-comma.patch
Patch62: 0063-dracut-PATCH-es-parallelize-block_module-filter-and-.patch
Patch63: 0064-order-mdadm-and-lvm-timeout-operations.patch
Patch64: 0065-90mdraid-mdraid_start.sh-fix-path-to-md-sysfs.patch
Patch65: 0066-90mdraid-module-setup.sh-fixed-sed-arguments.patch
Patch66: 0067-95udev-rules-module-setup.sh-also-search-in-lib-udev.patch
Patch67: 0068-update-the-documentation-of-no-prefix.patch
Patch68: 0069-dracut-check-mktemp-return-value.patch
Patch69: 0070-convert_abs_rel-fixups.patch
Patch70: 0071-dracut.8-add-missing-lvmconf-info.patch
Patch71: 0072-fs-lib-add-ability-to-choose-fsck-tools.patch
Patch72: 0073-manuals-add-info-about-fs-lib-fsck-configuration.patch
Patch73: 0074-dracut-functions-conv-normalize-minor-corrections.patch
Patch74: 0075-dracut.-.xml-s-exisiting-existing-g.patch
Patch75: 0076-95udev-rules-module-setup.s-fixed-symlink-for-udevd-.patch
Patch76: 0077-dracut.conf.5.xml-tag-mismatch-fix.patch
Patch77: 0078-bash3-compat-patch.patch
Patch78: 0079-explicitly-verify-bash-version.patch
Patch79: 0080-dracut-remove-duplicate-options.patch
Patch80: 0081-dracut-lib.sh-fix-dropped-backslashes-in-CMDLINE.patch
Patch81: 0082-dmsquash-live-fix-log-message-about-root-liveroot.patch
Patch82: 0083-check-root-candidates-more-carefully.patch
Patch83: 0084-netroot-do-not-die-if-arping-failed.patch
Patch2: 0002-90dmsquash-live-dmsquash-live-root-include-fs_lib.sh.patch
Patch3: 0003-fix-live-crash-with-livenet-installed.patch
Patch4: 0004-profile.py-parse-the-output-of-dracut-profile-for-pr.patch
Patch5: 0005-add-TEST-16-DMSQUASH.patch
Patch6: 0006-dracut-functions-s-emergency-shutdown-shutdown-emerg.patch
Patch7: 0007-dracut-unset-LD_LIBRARY_PATH.patch
Patch8: 0008-build-initramfs-prelink-undo-sbin.patch
Patch9: 0009-dracut-functions-speed-up-inst_dir.patch
Patch10: 0010-90crypt-ask_for_password-pings-plymouthd.patch
Patch11: 0011-99base-whitespace-fix.patch
Patch12: 0012-dracut-functions-new-function-inst_any-d-dest-f1-f2-.patch
Patch13: 0013-livenet-take-into-account-other-ca-bundle-paths-use-.patch
Patch14: 0014-luks-key-on-ext-dev-wait-for-luks.patch
Patch15: 0015-crypt-changed-cmdline-arg-name-from-rd.luks.tout-to-.patch
Patch16: 0016-luks-key-on-ext-dev-wait-for-luks.patch
Patch17: 0017-dracut-functions-fix-inst_dir-for-non-absolute-dirs.patch
Patch18: 0018-90mdraid-65-md-incremental-imsm.rules-incremental-ru.patch
Patch19: 0019-dracut.spec-fixed-rhel-fedora-version-checks.patch
Patch20: 0020-50plymouth-add-plymouth.enable-kernel-command-line-o.patch
Patch21: 0021-99base-init-only-poll-cdroms-if-the-kernel-does-supp.patch
Patch22: 0022-build-initramfs-unclear-_mpargs-in-instmods.patch
Patch23: 0023-90crypt-parse-crypt.sh-also-accept-the-beginning-of-.patch
Patch24: 0024-99base-init-save-and-restore-environment-given-from-.patch
Patch25: 0025-99base-init-move-switch_root-breakpoint-to-a-later-p.patch
Patch26: 0026-dracut-functions-hmac-checksum-files-can-be-symlinks.patch
Patch27: 0027-95udev-rules-add-input_id.patch
Patch28: 0028-inst_simple-inst_dir-make-fast-case-faster.patch
Patch29: 0029-filter_kernel_modules-is-a-specialized-filter_kernel.patch
Patch30: 0030-install_kmod_with_fw-make-fast-case-faster.patch
Patch31: 0031-instmods-get-filenames-from-stdin-if-no-args-use-it.patch
Patch32: 0032-instmods-sanity-for-_mpargs.patch
Patch33: 0033-instmods-factor-out-egrep-of-FATAL-Module-.-not-foun.patch
Patch34: 0034-99base-init-do-not-fail-when-importing-the-original-.patch
Patch35: 0035-dracut-cp-with-sparse.patch
Patch36: 0036-99base-init-removed-cdrom-polling-reset-code.patch
Patch37: 0037-dmsquash-live-root-use-blkid-to-determine-fstype-of-.patch
Patch38: 0038-dmsquash-live-root-load-filesystem-modules-before-mo.patch
Patch39: 0039-90dmsquash-live-do-not-symlink-to-dev-live.patch
Patch40: 0040-99base-init-remove-dev-root-helper-symlink.patch
Patch41: 0041-Do-not-use-run-udev-rules.d-for-udev-rules.patch
Patch42: 0042-99base-init-mount-securityfs-with-source-securityfs-.patch
Patch43: 0043-mount-securityfs-in-a-seperate-dracut-module.patch
Patch44: 0044-mount-securityfs-in-a-seperate-dracut-module.patch
Patch45: 0045-90mdraid-adjust-stock-mdadm-udev-rules.patch
Patch46: 0046-90mdraid-containers-are-not-runnable.patch
Patch47: 0047-90mdraid-fix-adjust-mdraid-cleanup.patch
Patch48: 0048-90mdraid-fix-adjust-force-run-script.patch
Patch49: 0049-90-md-dm-raid-recognize-ddf-container.patch
Patch50: 0050-90mdraid-fix-adjust-65-md-rules-and-related-scripts.patch
Patch51: 0051-TEST-40-NBD-relaxed-check-on-ext3-filesystem-options.patch
Patch52: 0052-99fs-lib-fs-lib.sh-fsck-btrfs-via-mounting-like-xfs.patch
Patch53: 0053-dracut-functions-inst_rules-do-not-check-std-dirs-fo.patch
Patch54: 0054-str_replace-fix.patch
Patch55: 0055-dracut-logger-bail-out-early-if-we-don-t-have-to-log.patch
Patch56: 0056-dracut-create-dev-besides-proc-sys-and-so.patch
Patch57: 0057-99fs-lib-export-FSTAB_FILE-before-fsck-call.patch
Patch58: 0058-dracut-functions-inst_rules-add-missing.patch
Patch59: 0059-90mdraid-check-precisely-for-supported-contaiers.patch
Patch60: 0060-90mdraid-more-thorough-64-md-raid.rules-edit.patch
Patch61: 0061-90mdraid-adjust-dev-md-loops.patch
Patch62: 0062-dracut-PATCH-Parameter-expansion-occurs-before-comma.patch
Patch63: 0063-dracut-PATCH-es-parallelize-block_module-filter-and-.patch
Patch64: 0064-order-mdadm-and-lvm-timeout-operations.patch
Patch65: 0065-90mdraid-mdraid_start.sh-fix-path-to-md-sysfs.patch
Patch66: 0066-90mdraid-module-setup.sh-fixed-sed-arguments.patch
Patch67: 0067-95udev-rules-module-setup.sh-also-search-in-lib-udev.patch
Patch68: 0068-update-the-documentation-of-no-prefix.patch
Patch69: 0069-dracut-check-mktemp-return-value.patch
Patch70: 0070-convert_abs_rel-fixups.patch
Patch71: 0071-dracut.8-add-missing-lvmconf-info.patch
Patch72: 0072-fs-lib-add-ability-to-choose-fsck-tools.patch
Patch73: 0073-manuals-add-info-about-fs-lib-fsck-configuration.patch
Patch74: 0074-dracut-functions-conv-normalize-minor-corrections.patch
Patch75: 0075-dracut.-.xml-s-exisiting-existing-g.patch
Patch76: 0076-95udev-rules-module-setup.s-fixed-symlink-for-udevd-.patch
Patch77: 0077-dracut.conf.5.xml-tag-mismatch-fix.patch
Patch78: 0078-bash3-compat-patch.patch
Patch79: 0079-explicitly-verify-bash-version.patch
Patch80: 0080-dracut-remove-duplicate-options.patch
Patch81: 0081-dracut-lib.sh-fix-dropped-backslashes-in-CMDLINE.patch
Patch82: 0082-dmsquash-live-fix-log-message-about-root-liveroot.patch
Patch83: 0083-check-root-candidates-more-carefully.patch
Patch84: 0084-netroot-do-not-die-if-arping-failed.patch
Patch85: 0085-95udev-rules-module-setup.sh-correctly-create-udevd-.patch
Patch86: 0086-module-setup.sh-turn-off-debugging-for-module-search.patch
Patch87: 0087-99base-init-fix-check-for-in-kernel-polling.patch
Patch88: 0088-99base-dracut-lib.sh-add-etc-cmdline-.conf-parsing.patch
Patch89: 0089-minor-changes.patch
Patch90: 0090-90livenet-check-for-wget.patch
Patch91: 0091-dracut-logger-re-set-debugging.patch
Patch92: 0092-dracut-functions-inst_dir-handle-relative-symlinks.patch
BuildArch: noarch
BuildRequires: dash bash
@ -239,7 +247,6 @@ This package contains tools to assemble the local initrd and host configuration.
%prep
%setup -q -n %{name}-%{version}
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
@ -322,7 +329,15 @@ This package contains tools to assemble the local initrd and host configuration.
%patch81 -p1
%patch82 -p1
%patch83 -p1
%patch84 -p1
%patch85 -p1
%patch86 -p1
%patch87 -p1
%patch88 -p1
%patch89 -p1
%patch90 -p1
%patch91 -p1
%patch92 -p1
%build
make
@ -462,6 +477,9 @@ rm -rf $RPM_BUILD_ROOT
%dir /var/lib/dracut/overlay
%changelog
* Thu Oct 20 2011 Harald Hoyer <harald@redhat.com> 013-93.git20111020
- update to latest git
* Wed Oct 19 2011 Harald Hoyer <harald@redhat.com> 013-85.git20111019
- update to latest git