- version 009

This commit is contained in:
Harald Hoyer 2011-03-28 21:37:46 +02:00
parent 1f95645686
commit 689683ca90
17 changed files with 5 additions and 655 deletions

View File

@ -1,23 +0,0 @@
From 52889453c13258b3fd036bbb7a8b37df132505e3 Mon Sep 17 00:00:00 2001
From: Harald Hoyer <harald@redhat.com>
Date: Tue, 8 Feb 2011 17:59:48 +0100
Subject: [PATCH] dracut-functions: write to $HOME/dracut.log instead of /tmp/dracut.log
---
dracut-functions | 3 +--
1 files changed, 1 insertions(+), 2 deletions(-)
diff --git a/dracut-functions b/dracut-functions
index e80a638..9ac0bba 100755
--- a/dracut-functions
+++ b/dracut-functions
@@ -65,8 +65,7 @@ is_func() {
if ! [[ $dracutlogfile ]]; then
[[ $dracutbasedir = /usr/share/dracut ]] && \
dracutlogfile=/var/log/dracut.log || \
- dracutlogfile=/tmp/dracut.log
-# [[ -w $dracutlogfile ]] || dracutlogfile=/tmp/dracut.log
+ dracutlogfile=$HOME/dracut.log
if [[ -w $dracutlogfile ]]; then
>"$dracutlogfile"
fi

View File

@ -1,22 +0,0 @@
From c965ed2db4062044ba43e78b28376f572878e2bf Mon Sep 17 00:00:00 2001
From: Harald Hoyer <harald@redhat.com>
Date: Tue, 8 Feb 2011 18:06:25 +0100
Subject: [PATCH] dracut.8.xml: corrected typo
---
dracut.8.xml | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/dracut.8.xml b/dracut.8.xml
index 34b3986..26e575b 100644
--- a/dracut.8.xml
+++ b/dracut.8.xml
@@ -298,7 +298,7 @@ Default:
<para>activates the local mode. dracut will use modules from the current working
directory instead of the system-wide installed modules in
<filename>/usr/share/dracut/modules.d</filename>.
-Thsi is useful when running dracut from a git checkout.</para>
+This is useful when running dracut from a git checkout.</para>
</listitem>
</varlistentry>
<varlistentry>

View File

@ -1,24 +0,0 @@
From 1cedde068192af7536479ff5fb159c75fc7d7ed6 Mon Sep 17 00:00:00 2001
From: Harald Hoyer <harald@redhat.com>
Date: Wed, 9 Feb 2011 13:22:49 +0100
Subject: [PATCH] plymouth: touch /dev/.systemd/plymouth
until plymouth does it itsself, touch /dev/.systemd/plymouth
https://bugzilla.redhat.com/show_bug.cgi?id=676302
---
modules.d/50plymouth/plymouth-pretrigger.sh | 2 ++
1 files changed, 2 insertions(+), 0 deletions(-)
diff --git a/modules.d/50plymouth/plymouth-pretrigger.sh b/modules.d/50plymouth/plymouth-pretrigger.sh
index 0800dbc..c224875 100755
--- a/modules.d/50plymouth/plymouth-pretrigger.sh
+++ b/modules.d/50plymouth/plymouth-pretrigger.sh
@@ -18,6 +18,8 @@ if getargbool 1 rd.plymouth -n rd_NO_PLYMOUTH; then
info "Starting plymouth daemon"
[ -x /bin/plymouthd ] && /bin/plymouthd --attach-to-session
+ mkdir -m 0755 /dev/.systemd >/dev/null 2>&1
+ >/dev/.systemd/plymouth
/lib/udev/console_init tty0
/bin/plymouth --show-splash 2>&1 | vinfo
fi

View File

@ -1,45 +0,0 @@
From f63c30d89bf4831723cd54b8e39be8c20f278591 Mon Sep 17 00:00:00 2001
From: maximilian attems <max@stro.at>
Date: Wed, 16 Feb 2011 14:56:07 +0100
Subject: [PATCH] dracut: Don't suppress the modprobe error output.
It happens that either due to newer modprobe or missing depmod
module-init-tools cries.
Suppressing the error ensures for a funny debug search for the user.
Resulting initramfs is generally unbootable due to missing module deps.
Better use the quiet option of modprobe itself.
It makes it less chatty, but doesn't suppress "fatal" errors.
Signed-off-by: maximilian attems <max@stro.at>
---
dracut-functions | 2 +-
dracut-gencmdline | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/dracut-functions b/dracut-functions
index 9ac0bba..eef8f1e 100755
--- a/dracut-functions
+++ b/dracut-functions
@@ -670,7 +670,7 @@ install_kmod_with_fw() {
for_each_kmod_dep() {
local func=$1 kmod=$2 cmd modpapth options
shift 2
- modprobe "$@" --ignore-install --show-depends $kmod 2>/dev/null | \
+ modprobe "$@" --ignore-install --quiet --show-depends $kmod | \
while read cmd modpath options; do
[[ $cmd = insmod ]] || continue
$func $modpath
diff --git a/dracut-gencmdline b/dracut-gencmdline
index 76c91ac..90e4906 100755
--- a/dracut-gencmdline
+++ b/dracut-gencmdline
@@ -72,7 +72,7 @@ moduledep() {
fi
vecho -n "Looking for deps of module $1"
deps=""
- deps=$(modprobe $MPARGS --set-version $kernel --show-depends $1 2>/dev/null| awk '/^insmod / { print gensub(".*/","","g",$2) }' | while read foo ; do [ "${foo%%.ko}" != "$1" ] && echo -n "${foo%%.ko} " ; done)
+ deps=$(modprobe $MPARGS --set-version $kernel --quiet --show-depends $1 | awk '/^insmod / { print gensub(".*/","","g",$2) }' | while read foo ; do [ "${foo%%.ko}" != "$1" ] && echo -n "${foo%%.ko} " ; done)
[ -n "$deps" ] && vecho ": $deps" || vecho
}

View File

@ -1,27 +0,0 @@
From 81c6e7fb69a0b7ef5169d13f8b4a4025db923ead Mon Sep 17 00:00:00 2001
From: Harald Hoyer <harald@redhat.com>
Date: Thu, 17 Feb 2011 10:48:35 +0100
Subject: [PATCH] dracut-functions: handle shared objects in find_binary w/o the exec flag
---
dracut-functions | 7 ++++++-
1 files changed, 6 insertions(+), 1 deletions(-)
diff --git a/dracut-functions b/dracut-functions
index eef8f1e..ebcb7d8 100755
--- a/dracut-functions
+++ b/dracut-functions
@@ -320,7 +320,12 @@ inst_library() {
# search in the usual places to find the binary.
find_binary() {
local binpath="/bin /sbin /usr/bin /usr/sbin" p
- [[ -z ${1##/*} && -x $1 ]] && { echo $1; return 0; }
+ if [[ -z ${1##/*} ]]; then
+ if [[ -x $1 ]] || ldd $1 &>/dev/null; then
+ echo $1
+ return 0
+ fi
+ fi
for p in $binpath; do
[[ -x $p/$1 ]] && { echo "$p/$1"; return 0; }
done

View File

@ -1,34 +0,0 @@
From 172d85b9c949b321771d63dbd5f06ecf19cf94f0 Mon Sep 17 00:00:00 2001
From: Jon Ander Hernandez <jonan.h@gmail.com>
Date: Thu, 17 Feb 2011 10:35:27 +0100
Subject: [PATCH] dracut-functions: fixed installing libraries which links to another directory
$ ldd `which bash` | grep ld
/lib64/ld-linux-x86-64.so.2 (0x00007fa1cc3ff000)
$ readlink -f /lib64/ld-linux-x86-64.so.2
/lib/ld-2.12.1.so
So inst_library /lib64/ld-linux-x86-64.so.2 was doing :
(cd "/tmp/initramfs.4uaeD9/lib64" && ln -s "/lib/ld-2.12.1.so"
"ld-linux-x86-64.so.2")
But, /tmp/initramfs.4uaeD9/lib64 -> /lib... :-S
---
dracut-functions | 2 ++
1 files changed, 2 insertions(+), 0 deletions(-)
diff --git a/dracut-functions b/dracut-functions
index ebcb7d8..1cb43e7 100755
--- a/dracut-functions
+++ b/dracut-functions
@@ -302,6 +302,8 @@ inst_library() {
lib=${src##*/}
inst_simple "$reallib" "$reallib"
inst_dir "${dest%/*}"
+ [[ -L ${initdir}${dest%/*} ]] && \
+ dest=$(readlink -f ${initdir}${dest%/*})/
(cd "${initdir}${dest%/*}" && ln -s "$reallib" "$lib")
else
inst_simple "$src" "$dest"

View File

@ -1,27 +0,0 @@
From ebaed7d51f61d331d128037e0b37130c58e957e3 Mon Sep 17 00:00:00 2001
From: Harald Hoyer <harald@redhat.com>
Date: Fri, 18 Feb 2011 09:33:06 +0100
Subject: [PATCH] i18n: fixed config file parsing in hostonly mode
I accidently removed some parenthesis.
---
modules.d/10i18n/module-setup.sh | 4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/modules.d/10i18n/module-setup.sh b/modules.d/10i18n/module-setup.sh
index a524d2d..57a0f9a 100755
--- a/modules.d/10i18n/module-setup.sh
+++ b/modules.d/10i18n/module-setup.sh
@@ -68,10 +68,10 @@ install() {
for item in $@
do
- item=${item/:/ }
+ item=(${item/:/ })
for map in ${item[1]//,/ }
do
- map=${map//-/ }
+ map=(${map//-/ })
value=$(grep "^${map[0]}=" "${item[0]}")
value=${value#*=}
echo "${map[1]:-${map[0]}}=${value}"

View File

@ -1,46 +0,0 @@
From c0a82e271e2730159f042ee7d7fc4aca2e08d28a Mon Sep 17 00:00:00 2001
From: Harald Hoyer <harald@redhat.com>
Date: Fri, 18 Feb 2011 09:37:11 +0100
Subject: [PATCH] i18n: default to vconsole.font.unicode=1
---
modules.d/10i18n/parse-i18n.sh | 16 ++++++++++------
1 files changed, 10 insertions(+), 6 deletions(-)
diff --git a/modules.d/10i18n/parse-i18n.sh b/modules.d/10i18n/parse-i18n.sh
index 860b0ae..61280c0 100755
--- a/modules.d/10i18n/parse-i18n.sh
+++ b/modules.d/10i18n/parse-i18n.sh
@@ -5,9 +5,13 @@
inst_key_val() {
local _value
local _file
+ local _default
+ _default=$1
+ shift
_file=$1
shift
_value=$(getarg $@)
+ [ -z "${_value}" ] && _value=$_default
if [ -n "${_value}" ]; then
printf '%s="%s"\n' $1 ${_value} >> $_file
fi
@@ -15,12 +19,12 @@ inst_key_val() {
unset _value
}
-inst_key_val /etc/vconsole.conf KEYMAP vconsole.keymap KEYTABLE
-inst_key_val /etc/vconsole.conf FONT vconsole.font SYSFONT
-inst_key_val /etc/vconsole.conf FONT_MAP vconsole.font.map CONTRANS
-inst_key_val /etc/vconsole.conf FONT_UNIMAP vconsole.font.unimap UNIMAP
-inst_key_val /etc/vconsole.conf UNICODE vconsole.font.unicode
-inst_key_val /etc/vconsole.conf EXT_KEYMAP vconsole.keymap.ext
+inst_key_val /etc/vconsole.conf '' KEYMAP vconsole.keymap KEYTABLE
+inst_key_val /etc/vconsole.conf '' FONT vconsole.font SYSFONT
+inst_key_val /etc/vconsole.conf '' FONT_MAP vconsole.font.map CONTRANS
+inst_key_val /etc/vconsole.conf '' FONT_UNIMAP vconsole.font.unimap UNIMAP
+inst_key_val /etc/vconsole.conf 1 UNICODE vconsole.font.unicode
+inst_key_val /etc/vconsole.conf '' EXT_KEYMAP vconsole.keymap.ext
inst_key_val /etc/locale.conf LANG locale.LANG
inst_key_val /etc/locale.conf LC_ALL locale.LC_ALL

View File

@ -1,41 +0,0 @@
From 0ce274f02b7391dfa5ab34f26ec3fbc6deff3269 Mon Sep 17 00:00:00 2001
From: Harald Hoyer <harald@redhat.com>
Date: Fri, 18 Feb 2011 09:44:47 +0100
Subject: [PATCH] selinux: turn off selinux by default
In Fedora selinux is now handled by systemd. If you want to enable
selinux by default, just add it to your /etc/dracut.conf.d/01-dist.conf
with:
add_dracutmodules+=" selinux "
---
dracut.conf.d/suse.conf.example | 3 ---
modules.d/98selinux/module-setup.sh | 6 +-----
2 files changed, 1 insertions(+), 8 deletions(-)
diff --git a/dracut.conf.d/suse.conf.example b/dracut.conf.d/suse.conf.example
index 9afda04..f25ab01 100644
--- a/dracut.conf.d/suse.conf.example
+++ b/dracut.conf.d/suse.conf.example
@@ -1,5 +1,2 @@
i18n_vars="/etc/sysconfig/language:RC_LANG-LANG,RC_LC_ALL-LC_ALL /etc/sysconfig/console:CONSOLE_UNICODEMAP-FONT_UNIMAP,CONSOLE_FONT-FONT,CONSOLE_SCREENMAP-FONT_MAP /etc/sysconfig/keyboard:KEYTABLE-KEYMAP"
-omit_dracutmodules+=" selinux "
-
-
diff --git a/modules.d/98selinux/module-setup.sh b/modules.d/98selinux/module-setup.sh
index 483e42f..316b552 100755
--- a/modules.d/98selinux/module-setup.sh
+++ b/modules.d/98selinux/module-setup.sh
@@ -3,11 +3,7 @@
# ex: ts=8 sw=4 sts=4 et filetype=sh
check() {
- [[ $hostonly ]] && {
- [ -x "/usr/sbin/load_policy" -o -x "/sbin/load_policy" ] || return 1
- return 0
- }
- return 0
+ return 255
}
depends() {

View File

@ -1,92 +0,0 @@
From b282107fa947817f1fc0bce6ae88b0a83c275847 Mon Sep 17 00:00:00 2001
From: Harald Hoyer <harald@redhat.com>
Date: Fri, 18 Feb 2011 10:58:39 +0100
Subject: [PATCH] lvm: use --sysinit, if lvm version >= v2.02.65
---
modules.d/90lvm/lvm_scan.sh | 50 +++++++++++++++++++++++++++++-------------
1 files changed, 34 insertions(+), 16 deletions(-)
diff --git a/modules.d/90lvm/lvm_scan.sh b/modules.d/90lvm/lvm_scan.sh
index e705d39..7d56fce 100755
--- a/modules.d/90lvm/lvm_scan.sh
+++ b/modules.d/90lvm/lvm_scan.sh
@@ -45,30 +45,40 @@ if [ ! -e /etc/lvm/lvm.conf ]; then
fi
check_lvm_ver() {
+ maj=$1; shift;
+ min=$1; shift;
+ ver=$1; shift;
# --poll is supported since 2.2.57
- [ $1 -lt 2 ] && return 1
- [ $1 -gt 2 ] && return 0
- # major is 2
- [ $2 -lt 2 ] && return 1
- [ $2 -gt 2 ] && return 0
- # minor is 2, check for
- # greater or equal 57
- [ $3 -ge 57 ] && return 0
+ [ $1 -lt $maj ] && return 1
+ [ $1 -gt $maj ] && return 0
+ [ $2 -lt $min ] && return 1
+ [ $2 -gt $min ] && return 0
+ [ $3 -ge $ver ] && return 0
return 1
}
+lvm version 2>/dev/null | ( \
+ IFS=. read maj min sub;
+ maj=${maj##*:};
+ sub=${sub%% *}; sub=${sub%%\(*};
+ ) 2>/dev/null
+
nopoll=$(
# hopefully this output format will never change, e.g.:
# LVM version: 2.02.53(1) (2009-09-25)
- lvm version 2>/dev/null | ( \
- IFS=. read maj min sub;
- maj=${maj##*:};
- sub=${sub%% *}; sub=${sub%%\(*};
- check_lvm_ver $maj $min $sub && \
+ check_lvm_ver 2 2 57 $maj $min $sub && \
echo " --poll n ";
- ) 2>/dev/null
)
+sysinit=$(
+ # hopefully this output format will never change, e.g.:
+ # LVM version: 2.02.53(1) (2009-09-25)
+ check_lvm_ver 2 2 65 $maj $min $sub && \
+ echo " --sysinit ";
+)
+
+export LVM_SUPPRESS_LOCKING_FAILURE_MESSAGES=1
+
if [ -n "$SNAPSHOT" ] ; then
# HACK - this should probably be done elsewhere or turned into a function
# Enable read-write LVM locking
@@ -94,13 +104,21 @@ fi
if [ -n "$LVS" ] ; then
info "Scanning devices $lvmdevs for LVM logical volumes $LVS"
lvm lvscan --ignorelockingfailure 2>&1 | vinfo
- lvm lvchange -ay --ignorelockingfailure $nopoll --ignoremonitoring $LVS 2>&1 | vinfo
+ if [ -z "$sysinit" ]; then
+ lvm lvchange -ay --ignorelockingfailure $nopoll --ignoremonitoring $LVS 2>&1 | vinfo
+ else
+ lvm lvchange -ay $sysinit $LVS 2>&1 | vinfo
+ fi
fi
if [ -z "$LVS" -o -n "$VGS" ]; then
info "Scanning devices $lvmdevs for LVM volume groups $VGS"
lvm vgscan --ignorelockingfailure 2>&1 | vinfo
- lvm vgchange -ay --ignorelockingfailure $nopoll --ignoremonitoring $VGS 2>&1 | vinfo
+ if [ -z "$sysinit" ]; then
+ lvm vgchange -ay --ignorelockingfailure $nopoll --ignoremonitoring $VGS 2>&1 | vinfo
+ else
+ lvm vgchange -ay $sysinit $VGS 2>&1 | vinfo
+ fi
fi
if [ "$lvmwritten" ]; then

View File

@ -1,22 +0,0 @@
From 440a4cc2475ff9ed1fc7b52b965dded8a36c9a2d Mon Sep 17 00:00:00 2001
From: Harald Hoyer <harald@redhat.com>
Date: Fri, 18 Feb 2011 13:11:53 +0100
Subject: [PATCH] Makefile: do not dash syntax check module-setup.sh
module-setup.sh is bash syntax, so dash complains about bash contructs
---
Makefile | 1 +
1 files changed, 1 insertions(+), 0 deletions(-)
diff --git a/Makefile b/Makefile
index 9dbe981..ab69c16 100644
--- a/Makefile
+++ b/Makefile
@@ -95,6 +95,7 @@ gitrpm: dracut-$(VERSION)-$(GITVERSION).tar.bz2
check: all
@ret=0;for i in modules.d/99base/init modules.d/*/*.sh; do \
+ [ "$${i##*/}" = "module-setup.sh" ] && continue; \
dash -n "$$i" ; ret=$$(($$ret+$$?)); \
done;exit $$ret
$(MAKE) -C test check

View File

@ -1,54 +0,0 @@
From 9edf1b206b69a9f6d6d038d333d8b855145ed4d6 Mon Sep 17 00:00:00 2001
From: Harald Hoyer <harald@redhat.com>
Date: Fri, 18 Feb 2011 13:27:31 +0100
Subject: [PATCH] init: set cdrom polling in kernel
and reset to -1 after we are done.
---
modules.d/99base/init | 22 +++++++++++++++++-----
1 files changed, 17 insertions(+), 5 deletions(-)
diff --git a/modules.d/99base/init b/modules.d/99base/init
index 0a05e91..b49c87a 100755
--- a/modules.d/99base/init
+++ b/modules.d/99base/init
@@ -203,15 +203,19 @@ while :; do
# dirty hack for some cdrom drives,
# which report no medium for quiet
# some time.
- if [ ! -e /sys/module/block/parameters/events_dfl_poll_msecs ]; then
- for cdrom in /sys/block/sr*; do
- [ -e "$cdrom" ] || continue
+ for cdrom in /sys/block/sr*; do
+ [ -e "$cdrom" ] || continue
+ if [ -e "$cdrom"/events_poll_msecs ]; then
+ msecs=$(while read a; do echo $a;done < "$cdrom"/events_poll_msecs)
+ [ "$msecs" = "-1" ] && \
+ echo 1000 > "$cdrom"/events_poll_msecs
+ else
# skip, if cdrom medium was already found
strstr "$(udevadm info --query=env --path=${cdrom##/sys})" \
ID_CDROM_MEDIA && continue
echo change > "$cdrom/uevent"
- done
- fi
+ fi
+ done
i=$(($i+1))
[ $i -gt $RDRETRY ] \
@@ -220,6 +224,14 @@ done
unset job
unset queuetriggered
+# reset cdrom polling
+for cdrom in /sys/block/sr*; do
+ [ -e "$cdrom" ] || continue
+ if [ -e "$cdrom"/events_poll_msecs ]; then
+ echo -1 > "$cdrom"/events_poll_msecs
+ fi
+done
+
# pre-mount happens before we try to mount the root filesystem,
# and happens once.
getarg 'rd.break=pre-mount' 'rdbreak=pre-mount' && emergency_shell -n pre-mount "Break pre-mount"

View File

@ -1,45 +0,0 @@
From 06e07df001e196a47041bcea65b23f3039e005fa Mon Sep 17 00:00:00 2001
From: Andrey Borzenkov <arvidjaar@gmail.com>
Date: Sat, 19 Feb 2011 09:57:55 +0300
Subject: [PATCH] fix c0a82e271e2730159f042ee7d7fc4aca2e08d28a
Let inst_key_val usage agree with above patch :)
Also UNICODE is rather global console property, not font specific
(and if anything, is rather keyboard specific). Let it be just
vconsole.unicode
Signed-off-by: Andrey Borzenkov <arvidjaar@gmail.com>
Cc: initramfs@vger.kernel.org
---
modules.d/10i18n/parse-i18n.sh | 16 ++++++++--------
1 files changed, 8 insertions(+), 8 deletions(-)
diff --git a/modules.d/10i18n/parse-i18n.sh b/modules.d/10i18n/parse-i18n.sh
index 61280c0..73dff6e 100755
--- a/modules.d/10i18n/parse-i18n.sh
+++ b/modules.d/10i18n/parse-i18n.sh
@@ -19,15 +19,15 @@ inst_key_val() {
unset _value
}
-inst_key_val /etc/vconsole.conf '' KEYMAP vconsole.keymap KEYTABLE
-inst_key_val /etc/vconsole.conf '' FONT vconsole.font SYSFONT
-inst_key_val /etc/vconsole.conf '' FONT_MAP vconsole.font.map CONTRANS
-inst_key_val /etc/vconsole.conf '' FONT_UNIMAP vconsole.font.unimap UNIMAP
-inst_key_val /etc/vconsole.conf 1 UNICODE vconsole.font.unicode
-inst_key_val /etc/vconsole.conf '' EXT_KEYMAP vconsole.keymap.ext
+inst_key_val '' /etc/vconsole.conf KEYMAP vconsole.keymap KEYTABLE
+inst_key_val '' /etc/vconsole.conf FONT vconsole.font SYSFONT
+inst_key_val '' /etc/vconsole.conf FONT_MAP vconsole.font.map CONTRANS
+inst_key_val '' /etc/vconsole.conf FONT_UNIMAP vconsole.font.unimap UNIMAP
+inst_key_val 1 /etc/vconsole.conf UNICODE vconsole.unicode
+inst_key_val '' /etc/vconsole.conf EXT_KEYMAP vconsole.keymap.ext
-inst_key_val /etc/locale.conf LANG locale.LANG
-inst_key_val /etc/locale.conf LC_ALL locale.LC_ALL
+inst_key_val '' /etc/locale.conf LANG locale.LANG
+inst_key_val '' /etc/locale.conf LC_ALL locale.LC_ALL
if [ -f /etc/locale.conf ]; then
. /etc/locale.conf

View File

@ -1,45 +0,0 @@
From 94cce410aaa7f4363c0fa48869c81f769ecd1289 Mon Sep 17 00:00:00 2001
From: Harald Hoyer <harald@redhat.com>
Date: Mon, 21 Feb 2011 09:23:27 +0100
Subject: [PATCH] vconsole.font.unicode -> vconsole.unicode
---
dracut.kernel.7.xml | 4 ++--
modules.d/10i18n/parse-i18n.sh | 2 +-
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/dracut.kernel.7.xml b/dracut.kernel.7.xml
index 21cfecd..aad27e2 100644
--- a/dracut.kernel.7.xml
+++ b/dracut.kernel.7.xml
@@ -193,7 +193,7 @@ This parameter can be specified multiple times.</para>
</varlistentry>
<varlistentry>
<term>
- <envar>vconsole.font.unicode=</envar><replaceable>&lt;1|0&gt;</replaceable>
+ <envar>vconsole.unicode=</envar><replaceable>&lt;1|0&gt;</replaceable>
</term>
<listitem>
<para>boolean, indicating UTF-8 mode; will be written as <envar>UNICODE</envar> to <filename>/etc/vconsole.conf</filename> in the initramfs</para>
@@ -1168,7 +1168,7 @@ rd.znet=ctc,0.0.0600,0.0.0601,0.0.0602,protocol=bar</programlisting></para>
<envar>UNICODE</envar>
</term>
<listitem>
- <para><envar>vconsole.font.unicode</envar></para>
+ <para><envar>vconsole.unicode</envar></para>
</listitem>
</varlistentry>
<varlistentry>
diff --git a/modules.d/10i18n/parse-i18n.sh b/modules.d/10i18n/parse-i18n.sh
index 73dff6e..9f47326 100755
--- a/modules.d/10i18n/parse-i18n.sh
+++ b/modules.d/10i18n/parse-i18n.sh
@@ -23,7 +23,7 @@ inst_key_val '' /etc/vconsole.conf KEYMAP vconsole.keymap KEYTABLE
inst_key_val '' /etc/vconsole.conf FONT vconsole.font SYSFONT
inst_key_val '' /etc/vconsole.conf FONT_MAP vconsole.font.map CONTRANS
inst_key_val '' /etc/vconsole.conf FONT_UNIMAP vconsole.font.unimap UNIMAP
-inst_key_val 1 /etc/vconsole.conf UNICODE vconsole.unicode
+inst_key_val 1 /etc/vconsole.conf UNICODE vconsole.unicode vconsole.font.unicode
inst_key_val '' /etc/vconsole.conf EXT_KEYMAP vconsole.keymap.ext
inst_key_val '' /etc/locale.conf LANG locale.LANG

View File

@ -1,76 +0,0 @@
From 53570e16c3c83c3975ff789303ce175027673795 Mon Sep 17 00:00:00 2001
From: Harald Hoyer <harald@redhat.com>
Date: Tue, 22 Feb 2011 17:45:11 +0100
Subject: [PATCH] 90lvm/lvm_scan.sh: fixed lvm version parsing
---
modules.d/90lvm/lvm_scan.sh | 48 ++++++++++++++++++++----------------------
1 files changed, 23 insertions(+), 25 deletions(-)
diff --git a/modules.d/90lvm/lvm_scan.sh b/modules.d/90lvm/lvm_scan.sh
index 7d56fce..9f9ce92 100755
--- a/modules.d/90lvm/lvm_scan.sh
+++ b/modules.d/90lvm/lvm_scan.sh
@@ -45,37 +45,35 @@ if [ ! -e /etc/lvm/lvm.conf ]; then
fi
check_lvm_ver() {
- maj=$1; shift;
- min=$1; shift;
- ver=$1; shift;
+ maj=$1
+ min=$2
+ ver=$3
# --poll is supported since 2.2.57
- [ $1 -lt $maj ] && return 1
- [ $1 -gt $maj ] && return 0
- [ $2 -lt $min ] && return 1
- [ $2 -gt $min ] && return 0
- [ $3 -ge $ver ] && return 0
+ [ $4 -lt $maj ] && return 1
+ [ $4 -gt $maj ] && return 0
+ [ $5 -lt $min ] && return 1
+ [ $5 -gt $min ] && return 0
+ [ $6 -ge $ver ] && return 0
return 1
}
-lvm version 2>/dev/null | ( \
- IFS=. read maj min sub;
- maj=${maj##*:};
- sub=${sub%% *}; sub=${sub%%\(*};
- ) 2>/dev/null
-
-nopoll=$(
- # hopefully this output format will never change, e.g.:
- # LVM version: 2.02.53(1) (2009-09-25)
- check_lvm_ver 2 2 57 $maj $min $sub && \
- echo " --poll n ";
-)
-
-sysinit=$(
- # hopefully this output format will never change, e.g.:
- # LVM version: 2.02.53(1) (2009-09-25)
- check_lvm_ver 2 2 65 $maj $min $sub && \
- echo " --sysinit ";
-)
+# hopefully this output format will never change, e.g.:
+# LVM version: 2.02.53(1) (2009-09-25)
+OLDIFS=$IFS
+IFS=.
+set $(lvm version 2>/dev/null)
+IFS=$OLDIFS
+maj min sub
+maj=${1##*:}
+min=$2
+sub=${3%% *}
+sub=${sub%%\(*};
+
+check_lvm_ver 2 2 57 $maj $min $sub && \
+ nopoll="--poll n"
+
+check_lvm_ver 2 2 65 $maj $min $sub && \
+ sysinit=" --sysinit "
export LVM_SUPPRESS_LOCKING_FAILURE_MESSAGES=1

View File

@ -1,21 +0,0 @@
From 2826a877afe74eef6e5ba35e78eddf77107c3d01 Mon Sep 17 00:00:00 2001
From: Harald Hoyer <harald@redhat.com>
Date: Tue, 22 Feb 2011 18:40:40 +0100
Subject: [PATCH] 90lvm/lvm_scan.sh: removed garbage line
---
modules.d/90lvm/lvm_scan.sh | 1 -
1 files changed, 0 insertions(+), 1 deletions(-)
diff --git a/modules.d/90lvm/lvm_scan.sh b/modules.d/90lvm/lvm_scan.sh
index 9f9ce92..7573615 100755
--- a/modules.d/90lvm/lvm_scan.sh
+++ b/modules.d/90lvm/lvm_scan.sh
@@ -63,7 +63,6 @@ OLDIFS=$IFS
IFS=.
set $(lvm version 2>/dev/null)
IFS=$OLDIFS
-maj min sub
maj=${1##*:}
min=$2
sub=${3%% *}

View File

@ -1,4 +1,3 @@
%define gittag 519d339
# Variables must be defined
%define with_nbd 1
@ -7,17 +6,9 @@
%define with_nbd 0
%endif
%if %{defined gittag}
%define rdist .git%{gittag}%{?dist}
%define dashgittag -%{gittag}
%else
%define rdist %{?dist}
%endif
Name: dracut
Version: 009
%define release_prefix 0.1%{?rdist}
Release: %{release_prefix}
Release: 1
Summary: Initramfs generator using udev
%if 0%{?fedora}
@ -29,7 +20,7 @@ Group: System/Base
License: GPLv2+
URL: https://dracut.wiki.kernel.org/
# Source can be generated by
# http://git.kernel.org/?p=boot/dracut/dracut.git;a=snapshot;h=%{?gittag};sf=tgz
# http://git.kernel.org/?p=boot/dracut/dracut.git;a=snapshot;h=009;sf=tgz
Source0: dracut-%{version}%{?dashgittag}.tar.bz2
BuildArch: noarch
@ -299,6 +290,9 @@ rm -rf $RPM_BUILD_ROOT
%dir /var/lib/dracut/overlay
%changelog
* Mon Mar 28 2011 Harald Hoyer <harald@redhat.com> 009-1
- version 009
* Thu Mar 17 2011 Harald Hoyer <harald@redhat.com> 009-0.1
- version 009 prerelease