update to 1.8.9.1

drop multilib patch. uppstream has a fix, it's not needed anymore
This commit is contained in:
Than Ngo 2015-01-21 16:49:06 +01:00
parent 78ad620e0e
commit f293e096b2
6 changed files with 30 additions and 71 deletions

1
.gitignore vendored
View File

@ -41,3 +41,4 @@ doxygen-1.7.1.src.tar.gz
/doxygen-1.8.6.src.tar.gz
/doxygen-1.8.7.src.tar.gz
/doxygen-1.8.8.src.tar.gz
/doxygen-1.8.9.1.src.tar.gz

View File

@ -1,43 +0,0 @@
diff -up doxygen-1.8.3/src/htmlgen.cpp.multilib doxygen-1.8.3/src/htmlgen.cpp
--- doxygen-1.8.3/src/htmlgen.cpp.multilib 2012-12-25 11:27:52.000000000 +0100
+++ doxygen-1.8.3/src/htmlgen.cpp 2013-01-02 17:08:57.559028518 +0100
@@ -125,6 +125,17 @@ static unsigned char tab_b_png[36] =
205, 207, 209, 211, 213, 217, 219, 206, 188
};
+static unsigned char nav_g_png[95] = {
+0x89, 0x50, 0x4e, 0x47, 0x0d, 0x0a, 0x1a, 0x0a, 0x00, 0x00, 0x00, 0x0d,
+0x49, 0x48, 0x44, 0x52, 0x00, 0x00, 0x00, 0x01, 0x00, 0x00, 0x00, 0x06,
+0x08, 0x06, 0x00, 0x00, 0x00, 0x02, 0x10, 0xf4, 0x31, 0x00, 0x00, 0x00,
+0x26, 0x49, 0x44, 0x41, 0x54, 0x78, 0x01, 0xed, 0xdd, 0x31, 0x0d, 0x00,
+0x00, 0x08, 0x03, 0xc1, 0x4f, 0x48, 0x17, 0x66, 0x84, 0xe1, 0x5f, 0x0d,
+0x2d, 0x3e, 0x7e, 0xb8, 0xe5, 0x4d, 0x20, 0x69, 0xcb, 0x4d, 0xe8, 0xc0,
+0x83, 0x07, 0x07, 0x0f, 0x53, 0x00, 0xbd, 0xfc, 0x82, 0x3c, 0x05, 0x00,
+0x00, 0x00, 0x00, 0x49, 0x45, 0x4e, 0x44, 0xae, 0x42, 0x60, 0x82,
+};
+
// hovering tab background luma
static unsigned char tab_h_png[36] =
{
@@ -824,6 +835,7 @@ static ColoredImgDataItem colored_tab_da
{ "tab_s.png", 1, 36, tab_s_png, 0 },
{ "nav_h.png", 1, 12, header_png, 0 },
{ "nav_f.png", 1, 56, func_header_png, 0 },
+ { "nav_g.png", 1, 6, nav_g_png, 0 },
{ "bc_s.png", 8, 30, bc_s_png, bc_s_a_png },
{ "doxygen.png", 104,31, doxygen_png, doxygen_a_png },
{ "closed.png", 9, 9, closed_png, closed_a_png },
@@ -1502,13 +1514,6 @@ void HtmlGenerator::writeTabData()
Doxygen::indexList->addStyleSheetFile("tabs.css");
QCString dname=Config_getString("HTML_OUTPUT");
writeColoredImgData(dname,colored_tab_data);
-
- {
- unsigned char shadow[6] = { 5, 5, 5, 5, 5, 5 };
- unsigned char shadow_alpha[6] = { 80, 60, 40, 20, 10, 0 };
- ColoredImage img(1,6,shadow,shadow_alpha,0,0,100);
- img.save(dname+"/nav_g.png");
- }
}
void HtmlGenerator::writeSearchData(const char *dir)

View File

@ -1,6 +1,6 @@
diff -up doxygen-1.8.6/addon/doxywizard/Makefile.in.config doxygen-1.8.6/addon/doxywizard/Makefile.in
--- doxygen-1.8.6/addon/doxywizard/Makefile.in.config 2013-12-26 12:17:57.281368574 -0700
+++ doxygen-1.8.6/addon/doxywizard/Makefile.in 2013-12-26 12:20:44.673513404 -0700
diff -up doxygen-1.8.9.1/addon/doxywizard/Makefile.in.config doxygen-1.8.9.1/addon/doxywizard/Makefile.in
--- doxygen-1.8.9.1/addon/doxywizard/Makefile.in.config 2014-10-19 16:39:17.000000000 +0200
+++ doxygen-1.8.9.1/addon/doxywizard/Makefile.in 2015-01-21 16:27:20.207772693 +0100
@@ -10,7 +10,6 @@
# See the GNU General Public License for more details.
#
@ -9,10 +9,10 @@ diff -up doxygen-1.8.6/addon/doxywizard/Makefile.in.config doxygen-1.8.6/addon/d
INCBUFSIZE=$(PYTHON) ../../src/increasebuffer.py
all: Makefile.doxywizard
diff -up doxygen-1.8.6/configure.config doxygen-1.8.6/configure
--- doxygen-1.8.6/configure.config 2013-12-24 09:14:46.000000000 -0700
+++ doxygen-1.8.6/configure 2013-12-26 12:20:20.542636493 -0700
@@ -326,9 +326,10 @@ if test "$f_wizard" = YES; then
diff -up doxygen-1.8.9.1/configure.config doxygen-1.8.9.1/configure
--- doxygen-1.8.9.1/configure.config 2015-01-04 12:00:55.000000000 +0100
+++ doxygen-1.8.9.1/configure 2015-01-21 16:27:20.207772693 +0100
@@ -362,9 +362,10 @@ if test "$f_wizard" = YES; then
if test -z "$QTDIR"; then
echo " QTDIR environment variable not set!"
printf " Checking for Qt..."
@ -24,7 +24,7 @@ diff -up doxygen-1.8.6/configure.config doxygen-1.8.6/configure
break 2
fi
done
@@ -704,6 +705,8 @@ INSTTOOL = $f_insttool
@@ -771,6 +772,8 @@ INSTTOOL = $f_insttool
DOXYDOCS = ..
DOCDIR = $f_docdir
QTDIR = $QTDIR
@ -33,10 +33,10 @@ diff -up doxygen-1.8.6/configure.config doxygen-1.8.6/configure
EOF
if test "$f_dot" != NO; then
diff -up doxygen-1.8.6/Makefile.in.config doxygen-1.8.6/Makefile.in
--- doxygen-1.8.6/Makefile.in.config 2013-12-26 12:17:57.283368564 -0700
+++ doxygen-1.8.6/Makefile.in 2013-12-26 12:19:17.796956667 -0700
@@ -78,8 +78,6 @@ realclean: clean
diff -up doxygen-1.8.9.1/Makefile.in.config doxygen-1.8.9.1/Makefile.in
--- doxygen-1.8.9.1/Makefile.in.config 2014-11-13 21:22:20.000000000 +0100
+++ doxygen-1.8.9.1/Makefile.in 2015-01-21 16:27:20.208772683 +0100
@@ -73,8 +73,6 @@ distclean: clean
DATE=$(shell date "+%B %Y")
@ -45,14 +45,14 @@ diff -up doxygen-1.8.6/Makefile.in.config doxygen-1.8.6/Makefile.in
install: doxywizard_install doxysearch_install
$(INSTTOOL) -d $(DESTDIR)$(INSTALL)/bin
$(INSTTOOL) -m 755 bin/doxygen $(DESTDIR)$(INSTALL)/bin
diff -up doxygen-1.8.6/tmake/lib/linux-g++/tmake.conf.config doxygen-1.8.6/tmake/lib/linux-g++/tmake.conf
--- doxygen-1.8.6/tmake/lib/linux-g++/tmake.conf.config 2013-11-02 08:18:53.000000000 -0600
+++ doxygen-1.8.6/tmake/lib/linux-g++/tmake.conf 2013-12-26 12:18:38.268158455 -0700
diff -up doxygen-1.8.9.1/tmake/lib/linux-g++/tmake.conf.config doxygen-1.8.9.1/tmake/lib/linux-g++/tmake.conf
--- doxygen-1.8.9.1/tmake/lib/linux-g++/tmake.conf.config 2014-10-24 11:51:54.000000000 +0200
+++ doxygen-1.8.9.1/tmake/lib/linux-g++/tmake.conf 2015-01-21 16:28:28.488140021 +0100
@@ -11,7 +11,7 @@ TMAKE_CC = gcc
TMAKE_CFLAGS = -pipe -fsigned-char
TMAKE_CFLAGS_WARN_ON = -Wall -W
TMAKE_CFLAGS_WARN_OFF =
-TMAKE_CFLAGS_RELEASE = -O2
-TMAKE_CFLAGS_RELEASE = -O3
+TMAKE_CFLAGS_RELEASE = $(RPM_OPT_FLAGS)
TMAKE_CFLAGS_DEBUG = -g
TMAKE_CFLAGS_SHLIB = -fPIC

View File

@ -1,7 +1,7 @@
diff -up doxygen-1.8.7/src/config.xml.than doxygen-1.8.7/src/config.xml
--- doxygen-1.8.7/src/config.xml.than 2014-05-12 13:54:38.000000000 +0200
+++ doxygen-1.8.7/src/config.xml 2014-05-12 13:56:31.000000000 +0200
@@ -1617,7 +1617,7 @@ to disable this feature.
diff -up doxygen-1.8.9.1/src/config.xml.html_timestamp_default_false doxygen-1.8.9.1/src/config.xml
--- doxygen-1.8.9.1/src/config.xml.html_timestamp_default_false 2014-12-25 13:43:29.000000000 +0100
+++ doxygen-1.8.9.1/src/config.xml 2015-01-21 16:31:37.221391259 +0100
@@ -1624,7 +1624,7 @@ to disable this feature.
</option>
</group>
<group name='HTML' docs='Configuration options related to the HTML output'>
@ -9,8 +9,8 @@ diff -up doxygen-1.8.7/src/config.xml.than doxygen-1.8.7/src/config.xml
+ <option type='bool' id='GENERATE_HTML' defval='0'>
<docs>
<![CDATA[
If the \c GENERATE_HTML tag is set to \c YES doxygen will
@@ -1878,7 +1878,7 @@ hr.footer {
If the \c GENERATE_HTML tag is set to \c YES, doxygen will
@@ -1887,7 +1887,7 @@ hr.footer {
]]>
</docs>
</option>

View File

@ -1,7 +1,7 @@
Summary: A documentation system for C/C++
Name: doxygen
Epoch: 1
Version: 1.8.8
Version: 1.8.9.1
Release: 1%{?dist}
# No version is specified.
@ -12,9 +12,8 @@ Source0: ftp://ftp.stack.nl/pub/users/dimitri/%{name}-%{version}.src.tar.gz
Source1: doxywizard.png
Source2: doxywizard.desktop
Patch1: doxygen-1.8.6-config.patch
Patch2: doxygen-1.8.7-html_timestamp_default_false.patch
Patch3: doxygen-1.8.3-multilib.patch
Patch1: doxygen-1.8.9.1-config.patch
Patch2: doxygen-1.8.9.1-html_timestamp_default_false.patch
BuildRequires: perl
BuildRequires: tex(dvips)
@ -64,7 +63,6 @@ Requires: texlive-epstopdf-bin
%patch1 -p1 -b .config
%patch2 -p1 -b .html_timestamp_default_false
%patch3 -p1 -b .multilib
# convert into utf-8
iconv --from=ISO-8859-1 --to=UTF-8 LANGUAGE.HOWTO > LANGUAGE.HOWTO.new
@ -120,6 +118,9 @@ desktop-file-install \
%changelog
* Wed Jan 21 2015 Than Ngo <than@redhat.com> 1.8.9.1-1
- update to 1.8.9.1
* Mon Aug 25 2014 Than Ngo <than@redhat.com> - 1:1.8.8-1
- 1.8.8

View File

@ -1,2 +1,2 @@
1a84da877450422c5fc49e525c546cd4 doxywizard.png
0cbe6912fcac302a984bfcfb9231fec9 doxygen-1.8.8.src.tar.gz
3d1a5c26bef358c10a3894f356a69fbc doxygen-1.8.9.1.src.tar.gz